Presentation

[image]

AMIgo Controls documentation
Presentation
See Also Send Feedback

This section intoduces the AMIgo controls for .NET

What is AMIgo

AMIgo is a suite of .NET Components and User Controls that offers a high level access to the Asterisk® open source PBX software system's Manager Interface (AMI).

AMIgo offers a high level access to the AMI and allows to remotely monitor, control and setup any Asterisk® open source PBX software system, version 1.2 and up (1.4 for setup functions), for which a manager access is available.

Application can be written in any of the .NET supported languages (C#, C++, Visual Basic ...) and run on Windows XP SP2 and up.

Monitor and Interact: AMIgo offers an extensive set of visual controls which supports drag and drop and offers context menus to display and interact with extensions / trunks, active channels, active calls, queues, queues members, queues calls, agents, conferences and conferences users. and conferences users.

Setup and configure: AMIgo also offers a set of visual controls to create, delete and edit Users, Agents, Queues, Conferences as well as a configuration file and dialplan editors.

See: Components for a description of the Controls and Components in the AMIgo suite.

See: Features for a description of features offered by the AMIgo suite.

See: Using AMIgo for simple applications examples.

AMIgo Controls

See Also

Other Resources

Components
Features
Using AMIgo
Asterisk WebSite
Asterisk Manager Documentation
Asterisk Manager Interface description

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


Features

[image]

AMIgo Controls documentation
Features
Send Feedback

AMIgo features

Monitoring / Control

Real time visual status display for extensions, channels, calls, queues, agents and conferences with drag and drop support. AMIgo offers 10 ListViews based Users Controls that allows to visually monitor the status of the PBX and to interact with the PBX items by draging and droping objects and / or using context sensitive menus.

  • Extensions / Trunks: Display the status of extensions and trunks in real time
  • Channels / Calls: Display the active channel and calls allows to transfer callers to extensions, queues, conferences or applications by drag and drop and/or context menus.
  • Queues: Display the queues and statistics and allow to create / delete / edit queues and add / remove queues members by drag and drop and/or context menus
  • Queues Members: Display the queues members and status and allow to logoff agents by drag and drop and/or context menus
  • Agents: Display the Agents and status and allows to create / delete / edit, login and logoff, add / remove agents to/from queues.
  • Conferences: Display the conferences and status and allows to lock / unlock an ongoing conference.
  • Conferences users: Display the conferences users and their status and allows to mute / unmute or kick out a participant.

Setup / Configure

  • Config File Editor: Allow to edit and update any .conf file present in the asterisk config directory
  • DialPlan Editor: Display the dialplan and allow to add / edit and update sections to the dialplan
  • Queues Creation / Edition: Allows to create / delete / edit call queues.
  • Agents / Local Channel Agents: Allows to create / delete edit Agents and local agents.
  • Conferences: Allows to create / delete / edit conferences.

Local channel 'Agents'

Local channel agents are an alternative to the standard Asterisk's Agent Channel which offers more versatility and can be used as a replacement for the now deprecated Agent Callback feature, and more...

This approach uses 'local channels' with dialplan support and the Asterisk DB, which allows more versatility while retaining all the functionnality of the Agent Channels.

Some features of AMIgo's 'Local Channel Agents':

  • Supports the AgentCallBack feature for local extension OR external phone number.

    Supports 'Off Premise' agents. Allows the creation of a decentralized call center. Local agents can be setup with an external phone number and optionally, a different outgoing context which allows, for instance, to assign a group of lines to be used for off premise agents.

  • Can be assigned a default location (extension OR external phone number) and can be preset as member of one or more queue which allows for quick and easy login and logoff procedure. The default location can also be left blank to allow for agent 'hot-desking'. Queue specific login and logoff is also supported.
  • Optional Local Agent login / logoff authentication.
  • Maintains all of the queue log functionality, including Sessions (Login / logoff).
  • Integration of Local / channel Agent in an unified interface. You can use a combination of both, if wanted.
  • Single click Dial Plan support installation.

    Dial Plan support for local agent can be easily added with a single method call. The default dialplan support can be customised by using user defined templates.


Applications

[image]

AMIgo Controls documentation
Applications
Send Feedback

AMIgo Applications

Operator Control Panel

Build your own, full featured operator control panel, and customize to your needs.

Custom Call Center / ACD/ Conferencing

Build call center management application. Manage queues and agents and monitor in real time. collect stats on agents etc ...

Custom applications

Build custom call center / conferencing applications.

Build programs to setup and monitor sytems remotely.

Integration of telephony function in your applications

You can use AMIgo to integrate telephony functions into your applications. Some examples:

  • Click to call from a database of clients, vendors etc.
  • Caller Identification and link to DB.
  • Conferences setup and control.
  • Etc ...


Components

[image]

AMIgo Controls documentation
Components
Send Feedback

A description of the AMIgo's components and controls

Components and Controls

  • AMI_Client

    The Asterisk Manager Interface Client which is the main central component, implements an Asterisk® Manager Interface (AMI) client in a Thread. The AMI Client's main functions are to handle the communication between the application and the AMI, to parse all of the messages into synchronised lists and to provide high level synchronised events (that can be safely used to update UI element's, from the main application's thread) for the events and messages sent by the AMI.

    The AMI_Client, effectively maintains a complete 'picture' of the connected system, lines, channels, queues, agents, conferences etc. into syncronized list. These are used to update the AMIgo user interface elements and to provide synchronize events, which greatly simplify the task of updating the user interface from events occuring in the AMI_Client thread.

    The AMI_Client supports almost all of the available AMI command (From V1.2 to 1.8) and also provides numerous higher level methods to send commands to the AMI server, modify the configuration and get informations on the connected system.

    In addition to the AMI_Client component, the AMIgo suite offers a list of high level user interface elements to display, monitor, interact and setup the extensions, channels, agents, queues, conferences, etc on any asterisk system, local or remote, for which a manager access is available.

    Note
    See: AMI_Client Members for a list of methods, events and properties offered by the AMI_Client component.

  • AMIgo ListViews:

    The AMIgo ListViews controls display the PBX elements in a multi layout Listview display, similar to the one used in the Windows' File explorer. These provide a visual real time display of the status and activity of the PBX system. The AMIgo ListViews also support drag and drop which allows, for instance, to transfer calls, by dragging the channel icon to a selected target, which can be an extension, a queue, a conference, a voice menu or an application. The AMIgo LisViews displays also offer a context menu, which is accessible by right clicking on an item.

    See: ListViewLines, ListViewChannels, ListViewCalls, ListViewQueues, ListViewQueueMembers, ListViewQueueEntries, ListViewAgents, ListViewAgentsCalls, ListViewConferences, ListViewConferenceUsers

  • AMIgo DataGridViews:

    The AMIgo DataGridViews display the PBX elements in a tabular format. The AMIgo DataGridViews content, is a reflexions of the Synchronised list that contains the information collected on the various items of the system.

    The AMIgo DataGridView displays offer a context menu, wich is accessible by right clicking on a table line

    See: DataGridViewLines, DataGridViewChannels, DataGridViewQueues, DataGridViewQueueMembers, DataGridViewQueuesEntries, DataGridViewAgents, DataGridViewAgentsEntries

  • AMIgoCommandPanel

    The AMIgoCommandPanel is made of a toolbar which give access to the AMIgoSitesManager and to the AMIgoDropTarget and displays the current connection information and status. It also offers a low access level to the Asterisk Manager Interface through a collapsible command panel which offers the following commands:

    • CLI commands: Displays a list of CLI commands available on the currently connected system, and allows to send commands with parameters.
    • Modules: Displays a list of the loaded modules and allows to reload, or load / unload modules.
    • Configuration: Displays a list of configuration files and allows to load them in the AMIgoConfigEditorForm.
    • AstDB: Display the content of the AstDB and offer an interface to add, edit or delete entries.
    • Originate: Offers an interface to send originate extension or originate application commands with full control of the parameters.

  • AMIgoSitesManager

    The AMIgo Sites Manager control implements a XML database of AMI hosts containing host and login information for a quick and easy, single click access to a list of asterisk manager sites. This component creates and allows to edit the XML database.

  • AMIgoConfigEditorForm

    The AMIgoConfigEditorForm allows to edit and update the asterisk configuration files.

    See: AMIgoConfigEditorPanel

  • AMIgoDropTarget

    The AMIGO Drop target form displays a list of extensions, queues, conferences, voice menus and applications that are defined on the system and allows to originate or transfer calls to selected destination by draging and droping items from the ListView displays (extensions, active, channels, calls and agents).

  • AMIgo Setup Panels and Forms.

    The setup controls allow to create, edit or delete, users, lines, agents, queues, conferences etc.

    See: AMIgoSetupPanel, AMIgoSetupAgentForm, AMIgoSetupConferenceForm, AMIgoSetupQueueForm


Requirements

[image]

AMIgo Controls documentation
Requirements
Send Feedback

This section gives details about AMIgo requirements

AMIgo requirements

AMIgo requires the .NET framework V2.0 and up. It can be installed on Windows XP SP2 and up. Windows Vista installation requires the .NET framework 3.5 SP1 an up

The installation program will consider 3.5 SP1 as a prerequisite and install it if needed.


Installation

[image]

AMIgo Controls documentation
Installation
Send Feedback

This section explains how to install the AMIgo controls into the development environment and to setup an asterisk system's Manager Interface for access.

Adding the AMIgo Controls to Visual Studio Toolbox

To add AMIgo components and controls to the Visual Studio Toolbox, follow this procedure

  • Create a new Windows Form Application
  • In the project manager, double click the main form to open it in design mode.
  • Open the toolbox if not already opened. (Menu View | Toolbox or CTRL+W, X)
  • Right click on the Toolbox and select Add Tab, and name the new Tab AMIgo
  • Right click in the new AMIgo Tab and select 'Choose Items...'
  • Click on the Browse button, and browse and select the AMIgo.dll file. (Default \Program Files\TELE DATA Inc\AMIgo)
  • Select all controls and component that are part of the AMIgo Namespace (you can sort the list by namspace for easier selection)
  • Once completed the AMIgo Tab of the toolbox should contains all of the AMIgo controls.

Adding a reference to AMIgo.dll to a project

To add a reference to AMIgo.dll to a Windows Form Application, follow this procedure

  • Create a new Windows Form Application
  • In the Solution Manager, right click on the 'References' directory and select 'Add reference ...'
  • Select the 'Browse' tab and browse to and select the AMIgo.dll file from the installation directory.

Note

The default installation directory is "\Program Files\TELE DATA Inc\AMIgo"

Setting up an Asterisk system to access the manager interface.

The manager is a client/server model over TCP. With the manager interface, you'll be able to control the PBX, originate calls, check mailbox status, monitor channels and queues as well as execute Asterisk commands. AMI is the standard management interface into your Asterisk server. You configure AMI in manager.conf. By default, AMI is available on TCP port 5038 if you enable it in manager.conf.

AMI receive commands, called "actions". These generate a "response" from Asterisk. Asterisk will also send "Events" containing various information messages about changes within Asterisk. Some actions generate an initial response and data in the form list of events. This format is created to make sure that extensive reports do not block the manager interface fully.

Management users are configured in the configuration file manager.conf and are given permissions for read and write, where write represents their ability to perform this class of "action", and read represents their ability to receive this class of "event".

Here an example of a manager.conf file with a single account for the user 'admin'

CopyC#
 1[general]
 2enabled = yes        ; Enable the AMI
 3webenabled = yes    ; Enable HTTP access (used by Asterisk GUI)
 4port = 5038        ; Use the default port
 5bindaddr = 0.0.0.0    ; Listen for all IP address
 6displayconnects = yes    ; display connections (In CLI))
 7timestampevents = yes    ; Add a unix timestamp to event messages.
 8
 9; Define an account for username 'admin' with password 'mypwd'
10[admin]
11secret = mypwd
12read = system,call,log,verbose,command,agent,user,config
13write = system,call,log,verbose,command,agent,user,config

Note

If the Asterisk system uses the Asterisk GUI, there will be a manager account already configured on the system, with default username 'admin'. You can use this account to connect with the AMI_Client if desired.


License

[image]

AMIgo Controls documentation
License
Send Feedback

AMIgo License

AMIgo Trial

AMIgo offers a 30 days trial period. This trial period also applies to any application built with the unlicenced controls.

Design Time license

The design time license removes all limitations and allows to build and distribute an unlimited numbers of applications built using the AMIgo suite. Once the registration key has been entered , applications built with the licenced component will automatically be licensed.

Note

You have to rebuild any application built with the unlicensed controls to transfer the license.

Design time license with source code

You can also buy the full source code for the complete AMIgo suite of components and controls. This includes well over 10 000 lines of C# code with inline XML documentation used to build the AMIgo namespace help (see TOC).

Buying a license

To buy a license, go to the following Web site: http://teledata.qc.ca/AMIgo


Using AMIgo

[image]

AMIgo Controls documentation
Using AMIgo
Send Feedback

This section show how the AMIgo controls suite can be used.


The AMI_Client component

[image]

AMIgo Controls documentation
The AMI_Client component
Send Feedback

This section gives details on the AMI_Client component.

Description

The AMI_Client component is the central component of the AMIgo suite. This component creates a new thread and manage the communication with the AMI server and parse all of the received message. It maintains a complete state of the PBX, accessible as read only properties and offers several methods and events that can be used by the application to monitor, control / interact or configure an Asterisk PBX system through a Manager Interface connection.

Using the AMI_Client

The simplest way to use the AMI_Client component is to drop a AMI_Client component in a Windows Form Application, created with Visual Studio.

AMI_Client State

The AMI_Client can be in one of these state:

  • IDLE: Initial state after creation or the application is run.
  • RUNNING: After Start(Control) has been called.
  • CONNECTING: After Connect() has been called.
  • CONNECTED: After successfull connection has been established
  • LOGGING: After connection and Login() method called.
  • LOGGED: After successfull Login. Commands can be sent.
  • READY: After successfull AutoStartAutoLogin. 'One shot' event to signal ready state revert to LOGGED.
  • LOGGING_OFF: After Logoff() has been called.
  • DISCONNECTING: After Logoff and Disconnect() has been called
  • STOPPING: After Stop() has been called.

The state of the AMI_Client can be accessed with the AMI_Client State property or by setting up an event handler for the StateChangeEvent

AutoStart / AutoLogin / AutoGetConfig

The behavior on startup vary according to how these public properties are set. The default is true.

  • AutoStart: Auto Start the AMI_Client thread after object creation. If set to false you must explicitly call the Start()()()() method.
  • AutoLogin: Call the Connect()()()() and Login()()()() method on startup. If set to false you must call these function explicitly. The Host Port UserName and Password properties must be setup for the AutoLogin to be attempted.
  • AutoGetConfig: Auto get the system configuration on startup after a successfull connect and login. If set to false methods to get the extensions / trunks, channels, queues, agents etc must be called explicitly or by calling the DoAutoGetConfig()()()() method.

Example

This example show how to use AMI_Client StateChangeEvent to wait for the READY state and then send an Originate command from an extension to an external phone number.

CopyC#
 1private void StateChangeEventHandler(object Sender, AMIgo.StateChangeEventArgs ev)
 2{
 3  // If auto login just wait for the READY state
 4  if (AMI_Client1.AutoLogin == true)
 5  {
 6    if (ev.state == AMI_Client.AMI_ClientState.READY)
 7      AMI_Client1.OriginateExtension("SIP/200", "DLPN_DialPlan1", "95555551212, "1", "");
 8  }
 9  else // else call Start and do things 'manually'
10  {
11    if (ev.state == AMI_Client.AMI_ClientState.RUNNING)
12      AMI_Client1.Connect();
13    else if (ev.state == AMI_Client.AMI_ClientState.CONNECTED)
14      AMI_Client1.Login();
15    else if (ev.state == AMI_Client.AMI_ClientState.READY)
16      AMI_Client1.OriginateExtension("SIP/200", "DLPN_DialPlan1", "95555551212, "1", "");
17  }
18}


System Objects and Real Time Status

[image]

AMIgo Controls documentation
System Objects and Real Time Status
Send Feedback

This section exposes the data structures which contains the information about the currently connected system.

Systems Objects

The AMI_Client collects and maintains information on the elements and status of the connected system in objects Lists that are accessible as read only properties.

These list are built either automatically after connection, by setting the AutoGetConfig to true or by sending individual AMI commands using the AMI_Client methods. The status is updated in realtime as status messages are received from the connected system and parsed by the AMI_Client.

The AMIgo ListViews and DataGridView controls display these lists in real time.

  • AstUsersObjectsList: This property gives read only access to the Users Objects List. This is a list of AstUsersObject which contains the SIP / IAX / Zap/DAHDI peers, users and registrations defined on the connected system and allows to get the real time status of the object.
  • AstChannelsList: This is a list of AstChannel which contains the currently active channels and their status.
  • AstCallsList: This is a list of AstCall which contains the currently active calls and their status.
  • AstQueuesList: This is a list of AstQueue which contains the queues defined on the connected system and and statistics.
  • AstQueuesMembersList: This is a list of AstQueueMember which reflects the queue members, that is agents that have been added as queue memebers.
  • AstQueuesEntriesList: This is a list of AstQueueEntry which contains the calls that are currently waiting in the queues.
  • AstConferencesList: This is a list of AstConference which contains the conferences defined on the connected system.
  • AstConferenceUsersList: This is a list of AstConferenceUser which contains the currently active conferences users.

Extensions Status and configuration

Asterisk can report real time status for SIP and IAX2 types extensions, but some configuration is needed. In order for Asterisk to report the status of SIP or IAX2 extensions, a 'hint' priority must be set in the dialplan. For example, this line in the 'default' context define a hint priority for extension 200 and specify a SIP extension type.

CopyC#
1[default]
2exten => 200,hint,SIP/200
Note

If your system define the users in 'users.conf' the 'hints' are set dynamically by asterisk at startup

"In Asterisk 1.4 the inner workings of the hint functionality have slightly changed. It is now imperative that you set a call-limit (even if it's an arbitrarily-high value like 100) and/or the new limitonpeers value in sip.conf."

CopyC#
1In sip.conf
2
3[general]
4limitonpeers = yes
5
6[200]
7call-limit = 100

Using the objects Lists

You can use these List as with any other generic lists :
CopyC#
1foreach (AstAgent agent in AstAgentsList)
2{
3  if (agent.Status == "0") // Test if agent busy
4  {
5    string ph_no = GetNextPhoneNo(); // Get next no (From db ..., list etc )
6    // Originate a call from agent extension to phone number
7    AMI_Client1.OriginateExtension(agent.Agent, "default", 9 + ph_no, "1", "");
8  }
9}


Setup and configuration

[image]

AMIgo Controls documentation
Setup and configuration
Send Feedback

This section gives information about the setup and configuration features of the AMIgo controls.

Setup and Configuration controls and methods

AMIgo offers several high level controls that allows to retrieve, edit and update the configuration files used by Asterisk. These controls are named with prefix AMIgoSetup. The AMIgoSetupPanel control group most setup controls into a tab control to form a full featured setup / configuration panel.

A Configuration file and a DialPlan editor controls are also available.

The AMI_Client component offers several methods to get and update configuration files and higher level methods to create / update users, queues, agents, conferences etc.

Note
See: AMI_Client Members for the list.

Configuration model and the Asterisk GUI

AMIgo uses and supports the configuration model introduced by the Asterisk GUI, which allocates a ranges of extensions for the different PBX elements and store these in the guipreferences.conf configuration file.

The Asterisk GUI assigns extensions range for: Users (Extensions), Queues, Conferences, Ring Groups and Voicemail groups. AMIgo adds two new items to this: Agents and Applications. These extensions range will be used to write the dialplan instructions. Each element is written in a different context and these context are include in the 'default' context.

If the guipreferences.conf file exists this will be used. Otherwise a default extension range will be proposed. You can edit and save this from the 'General' tab of the Setup panel. The extension can be set to a size of 3 or 4 digits.

Caution

Make sure that the extensions range do not overlap.

Using the Dictionaries

AMIgo uses generic Lists of Dictionary to store and manipulate the configuration information that is retrieved from the Asterisk configuration files:

public List<Dictionary<string, string>>

This is a list of Dictionary which contains the configuration information in the form of key / Value pair. Each section or context in a given configuration file is contained in a dictionary in the list. Each of these dictionary has a "FileName" and a "Category" keys which identify the file and context / section.

These dictionary lists are available as AMI_Client public fields. See:

AMI_Client Fields, See also: _AgentsConfigList, _AgentsConfigList, _ConferencesConfigList, _ExtensionsConfigList, _QueuesConfigList, _UsersConfigList

Use the GetDicoIndexInList(List<(Of <<'(Dictionary<(Of <<'(String, String>)>>)>)>>), String) method to get the index of a given category / context from a Dictionary List.

Use the GetValueFromDictionaryList(List<(Of <<'(Dictionary<(Of <<'(String, String>)>>)>)>>), String, String, String%) method to get the value of a given category / context and Key name from a Dictionary List.

You can use the foreach keyword and KeyValuePair object to read the key / values from the dictionary

CopyC#
1if ((index = GetDicoIndexInList(_ExtensionsConfigList, "default")) != -1)
2{
3  string key = "", value = "";
4  foreach (KeyValuePair<string, string> kvp in _ExtensionsConfigList[index])
5  {
6    key = kvp.Key;
7    value = kvp.Value
8  }
9}

Getting the config files

Several method with name starting with ConfigGet allows to retreive and parse various configuration file into the Dictionary Lists used internally by AMIgo.

These method will generate a ConfigFileReadEvent after the config file has been received and parsed. The Dictionary List is then available through the public fields.

If the AutoGetConfig property is set to true (default), the configuration for the users, queues, agents and conferences will be retreived after login and the Dictionary Lists will contains the configuration information for the currently connected system

Configuration file editor

The AMIgoConfigEditor Panel and Form controls allows to display, edit and update the configuration file.

Use the ConfigGetFile(String) method to retrieve a file. Once the file has been read a GetConfigEvent will be triggered and the GetConfigEventArgs will contains the FileName and the content of the config file as an array of strings.

The example below show how to get a file and open it in the AMIgo editor control in a form.

CopyC#
 1private void buttonGetConfig_Click(object sender, EventArgs e)
 2{
 3  if (AMI_ClientInstance != null)
 4    AMI_ClientInstance.ConfigGetFile("asterisk.conf");
 5}
 6public void GetConfigEventHandler(object sender, GetConfigEventArgs ev)
 7{
 8  if (AMI_ClientInstance != null)
 9    AMI_ClientInstance.ConfigOpenEditor(ev.filename, ev.strings);
10}

DialPlan Editor

The AMIgo dialplan editor allows to display and edit the dialplan. It display a list of the current contexts in a panel which allows to select fthe context for display and edition. This editor allows to insert lines anywhere in a context.

To use the dialplan editor, drop a AMIgoConfigEditorPanel in a container or create a new AMIgoConfigEditorForm.


Using Local Channel Agents

[image]

AMIgo Controls documentation
Using Local Channel Agents
Send Feedback

This section introduces and explains how to use AMIgo implementation of the local channels agents.

What are 'Local Channel Agents'

Local channel agents are an alternative to the standard Asterisk's Agent Channel which offers more versatility and can be used as a replacement for the now deprecated Agent Callback feature, and more...

The name 'local channel agent' refer to the fact that this approach does not use the agent channel driver, but local channels which branch in the dialplan and use dialplan logic to process the call. The agents definitions are stored in the Asterisk DB so that they are easily accessible to the dialplan and to the AMI.

Using local channels allows for more versatility while retaining all the functionnality of the Agent Channels. Local channel agent behave in a very similar way than the agent channel except for a few details which are mostly hidden by AMIgo. The two types can even be used in a same system if desired or required.

Note

1 - The agent channel with callback feature has been deprecated and is is not supported by Asterisk version 1.6 and up. You must use local channel agent if you want the callback feature.

2 - The local channel agent doest not suppot agent login (without callback) where a agent calls in to login and stay on line with MOH to wait for call. Use 'channel agent' if you want this mode of operation.

Agent definition / AstDB

The agent definition are made up of 5 fields separated by a ! character and are stored in the AstDB. The AstDB allows to store data grouped in families and identified with a key that is unique within the family. Agents definitions are stored under a Key named 'Local' and the Family is the Agent Number / Extension.

The agent definitions fields are as follow:

  • Current Callback Location: This is the callback location or external phone number (including trunk access dial prefix), with optional context or "n/a" if not logged in
  • Login time: as a Unix timestamp or '0' if not logged in. This is used to calculate loogedin time at the end of the session. It is filled by the dialplan and or AMIgo controls when loggin in.
  • Default Location: If blank, ask callback location to agent on login. Used for quick loging/logoff. Leave the default extension blank if you want 'hot-desking' for this agent.
  • Default queues membership: A list of coma separated queues. If this is left blank, the agent should then use the queue specific login procedure for login / logof.
  • Agent Group Number (currently not used/reserved for future)

Here are a few example of local channel agents definition as stored in the AstDB:

  • /Local/6700 : n/a!0!6001!6500,6501!
  • /Local/6701 : 95555551212@DLPN_DialPlan2!1297263232!95555551212@DLPN_DialPlan2!6500,6501!1
  • /Local/6702 : 6001!1297786374!6002@DLPN_DialPlan1!6502!2

In the first example the agent no. 6700 is currently not loged in, it's default location is extension 6001 (at default context), this agent will be logged in for the queues extensions 6500 and 6501 and no group number is defined.

In the second example the agent no. 6701 is currently logged in with an external number callback location, it's default location. The system will call the agent using the DLPN_DialPlan2 context, which can contains instruction to dial the external agent using a specific trunk group, for instance. This default queues for this agent are extensions 6500 and 6501. The group number is '1'.

In the third example the agent no. 6702 is currently logged in with a local extension callback location, it's not it's default location. This agent is logged in for the queue extension 6500 and has a group number of '2'.

AMIgo Agent Editor

Note

You can display and edit the content of the AstDB by using the AMIgoCommandPanel control.

Dialplan support

This section contains the following subsections.

  • Adding Dialplan support for local channel agents
  • Agents Callback Login with default values
  • Queue specific Login/Logoff
  • Quick Login/Logoff

In order to support the use of local channels as agents, some dial plan support is required. The local channel agent dialplan support provided by AMIgo offers functions to Login / Logoff for the Local (or regular Agent channel) agent and instruction to call back the local agent.

When the system call a local channel agent, the local agent number is actually used in the dialplan as a key to lookup the information for the agent that is located in the AstDB. This information is used to place the call to the agent.

An extension is defined by the system manager for agents Login / logout and another one for agent callback login / logoff. By default, the two last extension in the range reserved for agent are used for this purpose. These entry point extension can be changed if desired. For example assuming the range reserved for agent is 6500 - 6999, the extension 6998 will be assigned for Channel agent login (not callback), and 6999 will be assigne for Local and Channels agent login with callback.

Note

These extensions are stored in the general context of the agents.conf configuration file under the keys loginexten and cbloginexten.

Adding Dialplan support for local channel agents

Support for local agent can easily be added to the dialplan with a single method call, with the ConfigAddAgentSupportToDialplan(String, String, Int32) method. This will add a new agents context to the dialplan and two new macros: queues-login and queue-logoff.

Agents Callback Login with default values

Local channel agents (and regular agents) can login and logoff by calling the extension that is defined in the AMIgo setup (see note above). The dialplan logic will ask the agent number, and optionally, a password. If the agent is already logged in he will be logged off from all the queues defined in it's default membership list. If logged off and a default location is not defined a new location will be requested, and the agent will be logged in to all queues defined in it's default membership list. If hot desking is required, the agent's default location must be left blank, so that the location will be asked and used for callback.

Queue specific Login/Logoff

An agent can login / logof to / from a specific queue number by dialing its agent number followed by the desired queue number folowed by a '1' to login or a '0' to logoff. This login method can be used to overide the default location and queue.

For example agent 6700 can login to queue 6500 by dialing 6700 6500 1 and loggof from the same queue by calling 6700 6500 0.

Quick Login/Logoff

The quick loging procedure can be used when the agent login from the location that is defined as it's default location. In this case, the agent can login / logoff just by calling it's own agent number. For instance, suppose local agent number 6700 has it's default extension defined as 6000. Then he can simply call it's agent number, that is 6700 from it's default location extension (6000) to login / Logoff. If already logged in, calling 6700 (from default extension 6000) will logoff the agent. This quick login/logoff method can be used when hot desking is not required, or when agents have fixed assigned extensions.


Adding a reference to AMIgo to a Windows Form Application

[image]

AMIgo Controls documentation
Adding a reference to AMIgo to a Windows Form Application
Send Feedback

This explains how to add a reference to AMIgo.dll to a Windows Form Application

Adding a reference to AMIgo.dll to a project

To add a reference to AMIgo.dll to a Windows Form Application, follow this procedure

  • Create a new Windows Form Application
  • In the Solution Manager, right click on the 'References' directory and select 'Add reference ...'
  • Select the 'Browse' tab and browse to and select the AMIgo.dll file from the installation directory.

Note

The default installation directory is "\Program Files\TELE DATA Inc\AMIgo"


Using the AMI_Client component in an ASP.NET application

[image]

AMIgo Controls documentation
Using the AMI_Client component in an ASP.NET application
Send Feedback

This sections explains how to use the AMI_Client component in an ASP.NET application.

AMI_Client component in an ASP.NET application

The AMI_Client component can also be used in an ASP.NET Web application to provide a Web based interface to an Asterisk system.

In order to use the AMI_Client in an ASP.NET Web Application, it must be created and initialized when the Web Application starts. This is done by writing an event handler for the Application_Start application level event. In ASP.NET the application and session level event handler are contained in the application file: Global.asax.cs (Or Global.asax.vb).

The example below show a Global.asax.cs file with application level event handlers. The first is for Application_Start global event which is invoqued only once when the application starts. This handlers creates dynamically a new AMI_Client object initialize it and call the Start method to connect and login to the given Asterisk system. It also sets an HttpApplicationState variable with the AMI_Client object so it can be accessed from individual sessions. And it sets a global event handler for the AMI_Client's NewCallEvent event. Finally a handler for the Application_Stop global event is used to call the AMI_Client Stop method when the Web Application is stopped.

CopyC#
 1using System;
 2using AMIgo;
 3
 4namespace WebApplication1
 5{
 6
 7    public class Global : System.Web.HttpApplication
 8    {
 9        //+=====================================================+
10    // This global event is called when the application starts
11        void Application_Start(object sender, EventArgs e)
12        {
13          // Create a new instance of the AMI_Client
14          AMI_Client AMI_Client1 = new AMI_Client();
15          // Set the AMI Host to connect to.
16          AMI_Client1.AstMngrSiteName = "EdgePBX";
17          AMI_Client1.AstMngrHost = "192.168.1.10";
18          AMI_Client1.AstMngrPort = 5038;
19          AMI_Client1.AstMngrUserName = "admin";
20          AMI_Client1.AstMngrPassword = "noelbou";
21          // Set a global event handler for the NewCallEvent
22          AMI_Client1.NewCallEvent += new AMIgo.NewCallEventHandler(AMI_Client1_NewCallEvent);
23          AMI_Client1.Start();
24          // An HttpApplicationState object is set so that the AMI_Client object can be accessed from sessions.
25          Application["AMI_Client"] = AMI_Client1;
26        }
27        //+=====================================================+
28        void Application_End(object sender, EventArgs e)
29        {
30            //  This code is executed when the application stops.
31          AMI_Client AMI_ClientL = (AMI_Client)Application["AMI_Client"];
32          if (AMI_ClientL != null)
33            AMI_ClientL.Stop();
34        }
35        //+=====================================================+
36        // Handler for the NewCallEvent.
37        void AMI_Client1_NewCallEvent(object sender, AMIgo.NewCallEventArgs ev)
38        {
39          CallType ct = ev.call_type;
40          string phone_no = "";
41
42          if (ev.call_type == CallType.Outbound)
43          {
44            phone_no = ev.dst_caller_id;
45            if ((phone_no.Length > 0) && (phone_no[0] == '9'))
46              phone_no = phone_no.Substring(1);
47          }
48          else if (ev.call_type == CallType.Inbound)
49          {
50            phone_no = ev.src_caller_id;
51            if ((phone_no.Length > 0) && (phone_no[0] == '1'))
52              phone_no = phone_no.Substring(1);
53          }
54          else if (ev.call_type == CallType.Internal)
55          {
56          }
57          // ... Do something with the phone number. Ex. Db Lookup
58        }
59        //+=====================================================+
60    }
61}

The next code excerpt show how to retreive and use the AMI_Client from with a session. Here we have a button and a textBox which contains the full number to dial, including the trunk access prefix (usually '9'). A reference to the global AMI_Client object is retreived by using the intrinsinc 'Application' object.

Excerpt from ASP.NET doc.: A single instance of an HttpApplicationState class is created the first time a client requests any URL resource from within a particular ASP.NET application virtual directory. A separate single instance is created for each ASP.NET application on a Web server. A reference to each instance is then exposed via the intrinsic Application object.

CopyC#
 1protected void ButtonCall_Click(object sender, EventArgs e)
 2{
 3  // Get the AMI_Client instance from this HttpApplicationState instance through the 'Application' intrinsic object.
 4  // The returned object need to be typecast to the AMI_Client type
 5  AMI_Client AClient = (AMI_Client)Application["AMI_Client"];
 6  // To keep this example simple, the user contains the extension number. Ex 6000
 7  string tech = null, user = Context.User.Identity.Name;
 8  if (AClient != null)
 9  {
10    if (user == null) //
11      LabelResultMsg.Text = "Please login with extension as user name first.";
12    else
13    {
14      // Find the extension tech. from AMI_Client's AstUsersObjectsList
15      for (int i = 0; i < AClient.AstUsersObjectsList.Count; i++)
16      {
17        if (AClient.AstUsersObjectsList[i].ObjName == user)
18          tech = AClient.AstUsersObjectsList[i].ChannelType;
19      }
20      if (tech == null)
21        LabelResultMsg.Text = "Extension not found. Please login with extension as user name first.";
22      else
23      {
24        // We can now use the AMI_Client object to originate a call from the user's extension to the given phone number
25        // Asterisk will call the extension, and then go to the dialplan context to dial the given number
26        AClient.OriginateExtension(tech + "/" + user, "DLPN_DialPlan2", TextBoxPhoneNo.Text, "1", "");
27        LabelResultMsg.Text = "Calling extension: " + tech + "/" + user + " for PhoneNo: " + TextBoxPhoneNo.Text;
28      }
29    }
30  }
31}


AMIgo Demo
Send Feedback

This section gives details on the AMIgo Demo program

AMIgo Demo

Note

The source code and project file for this example can be found in the

[InstallDir]\Examples\AMIgoDemo directory

This AMIgo Demo is a more elaborated application that make uses of most of the controls and components offered by the suite.

The display is divided in five sections accessible trough a tab control:

  • The Main display allows to monitor and interract with the extensions, lines, channels and calls through ListView display with drag and drop support and context menu.
  • The Agent/Queue tab displays the status of the queues, agents and queues member and allows to setup, and create, edit, manage and monitor agents and queues.
  • The Conferences tab show the conferences and their users and allows setup, and create, edit, manage conferences.
  • The Setup Tab allows to create edit and manage users, queues, agents and conferences. It also offers a dialplan editor.
  • The Message Tab display the raw messages received from the AMI server.


Simple Applications

[image]

AMIgo Controls documentation
Simple Applications
Send Feedback

This section explains how to use the AMIgo suite to build simple applications.

Simple Applications examples

See: Hello AMIgo World. How to build the simple "Hello AMIgo World" application within MS Visual Studio.

See: PBX functions integration. Using the AMIgo suite to integrate PBX functions into your application.

See: Call Database Lookup How to do a database lookup on new calls using the CallerID number or Caller Name.

See: Without Visual Studio. Building the "Hello AMIgo world" application using the command line compiler.

Caution

If you build these examples from the given source code, you will need to update the reference to the AMIgo dll in the projects. Click on the project's reference directory and delete the reference to AMIgo.dll. Right click and select 'Add reference' and then click on Browse and select the AMIgo.dll file from the installation directory.

Compiling the example Applications

Compiling the examples and Demo applications Some simple example applications and a more elaborated demo app. are available in the [Install dir]\Examples directory. These include source code and project files for Visual Studio 2010. NOTE: To build these examples, you will need to change the reference to the AMIgo.dll assembly to the one installed on your system. You need to do this before opening the Forms in design mode: - In solution explorer, open the reference directory and right click on AMIgo.dll and select 'Remove'. - Select the 'Reference' directory right click and select 'Add a reference'. - Browse to the AMIgo.dll file installed on your system (default: \Program Files\TELE DATA Inc\AMIgo) and select AMIgo.dll.


Hello AMIgo World
Send Feedback

Building the "Hello AMIgo World" demo application

Hello AMIgo World

This section explains how to build the simple "Hello AMIgo World" application within MS Visual Studio.

Note

The source code for this example can be found in the Examples\Example1 directory

Caution

If you build this example from the given source code, you will need to change the reference to the AMIgo dll. Click on the project reference directory and delete the reference to AMIgo.dll and then click on Browse and select the AMIgo.dll file from the installation directory.

  • Create a new Windows Form Application in the .NET language of your choice(File | New | Project | C# / VB / C++ | Windows) and name it as you like.
  • Add a reference to the AMIgo.dll assembly. (Right click in the Solution Explorer and select 'Add Reference')
  • Open the AMIgo tab in the Toolbox Windows and drag an AMI_Client object on your project's main form.
  • Drag an AMIgoCommandPanel on the form and set it's 'Dock' property to 'Top'.
  • Drag an AMIgoStatusStrip on the form and set it's 'Dock' property to 'Bottom'.
  • From the Toolbox' Containers tab, drag a SplitContainer and set it's Orientation property to 'Horizontal' and the 'Dock' property to 'Fill'.
  • From the Tollbox' AMIgo tab, drag a ListViewLines object in the top panel of the Split Container and set it's 'Dock' property to 'Fill'.
  • From the Tollbox' AMIgo tab, drag a ListViewChannels object in the bottom panel of the Split Container and set it's 'Dock' property to 'Fill'.
  • Click on the AMI_Client and select the Event Tab from the properties windows, then double click on the PeerDetailsEvent then on ChannelDetailsEvent.
  • Edit Form1.cs to add the lines shown below to the two events handlers.
  • Build the application and run it.

CopyC#
 1using System.Windows.Forms;
 2using AMIgo;
 3
 4namespace AMIgoExample1
 5{
 6  public partial class Form1 : Form
 7  {
 8    public Form1()
 9    {
10      InitializeComponent();
11    }
12    //+===========================================================+
13    private void AMI_Client_PeerDetailsEvent(object sender, AMIgo.StringMsgEventArgs ev)
14    {
15      AMIgoDisplayForm df = new  AMIgoDisplayForm("Peer Details", ev.string_msg);
16      df.Show();
17    }
18    //+===========================================================+
19    private void AMI_Client_ChannelDetailsEvent(object sender, StringMsgEventArgs ev)
20    {
21      AMIgoDisplayForm df = new AMIgoDisplayForm("Channel Details", ev.string_msg);
22      df.Show();
23    }
24    //+===========================================================+
25  }
26}

You can now click on the Connection button in the Command Panel toolbar and enter a new Asterisk site definition. You must enter the Host name (or IP address) the port (default 5038), the Asterisk Manager UserName and Password. Then click the save button and finally the connect button or double click on the first column of the new site.

Once connected and logged in, the AMI client will retreive the PBX objects status and display the extensions and trunks and any active channel in the ListView displays.

Tip

You can also fill the AMI_Client AstMngrHost, AstMngrPort, AstMngrUserName and AstMngrPassword and leave the AutoStart and AutoLogin properties to the default of 'true' to have the AMI_Client connect and loggin to the given Asterisk system Manager on startup.


PBX functions integration

[image]

AMIgo Controls documentation
PBX functions integration
Send Feedback

This example is a simple demonstration on how to integrate PBX functions in an application

Integration of PBX functions in your applications

Note

The source code for this example can be found in the Examples\Example3 directory

Caution

If you build this example from the given source code, you will need to change the reference to the AMIgo dll. Click on the project reference directory and delete the reference to AMIgo.dll and then click on Browse and select the AMIgo.dll file from the installation directory.

Here we have a simple Windows form application with textboxes to enter an Asterisk site and login information. and textbox to enter a source extension and a destination, which can be an external phone number or an extension, or a Local extension to btranch into the dialplan. The context is set to default

Note

This demonstrate how to create an AMI_Client object by programming. You could also just drop an AMI_Client on your form project.

CopyC#
 1using System;
 2using System.Windows.Forms;
 3using AMIgo;
 4
 5namespace Example3
 6{
 7  public partial class Form1 : Form
 8  {
 9    private AMI_Client AMI_Client1;
10    private AMIgoMsgDisplayForm DisplayForm;
11    //+=================================================+
12    public Form1()
13    {
14      InitializeComponent();
15    }
16    //+=================================================+
17    private void AMI_ErrorEventHandler(object sender, StringMsgEventArgs ev)
18    {
19      MessageBox.Show(ev.string_msg, "AMIgo Error");
20      AMI_Client1.Stop();
21    }
22    //+=================================================+
23    private void StateChangeEventHandler(object Sender, AMIgo.StateChangeEventArgs ev)
24    {
25      // If auto login just wait for the READY state
26      if (AMI_Client1.AutoLogin == true)
27      {
28        if (ev.state == AMI_Client.AMI_ClientState.READY)
29          //
30          AMI_Client1.OriginateExtension(textBoxTechData.Text, textBoxContext.Text, textBoxPhoneNo.Text, "1", "");
31      }
32      else // else call Start and do things 'manually'
33      {
34        if (ev.state == AMI_Client.AMI_ClientState.RUNNING)
35          AMI_Client1.Connect();
36        else if (ev.state == AMI_Client.AMI_ClientState.CONNECTED)
37          AMI_Client1.Login();
38        else if (ev.state == AMI_Client.AMI_ClientState.LOGGED)
39          AMI_Client1.OriginateExtension(textBoxTechData.Text, textBoxContext.Text, textBoxPhoneNo.Text, "1", "");
40      }
41
42      if (ev.state == AMI_Client.AMI_ClientState.IDLE)
43        AMI_Client1.Dispose();
44    }
45    //+=================================================+
46    private void HangupEventHandler(object sender, AstChannelEventArgs ev)
47    {
48      AMI_Client1.Stop();
49    }
50    //+=================================================+
51    private void buttonOrig_Click(object sender, EventArgs e)
52    {
53      AstSite aSite = new AstSite("UnNamed", textBoxHost.Text, textBoxPort.Text, textBoxUserName.Text, textBoxPassword.Text, false);
54      AMI_Client1 = new AMI_Client(this, aSite);
55      // Try setting these properties to false;
56      AMI_Client1.AutoStart = true;
57      AMI_Client1.AutoLogin = true;
58      // We dont need to get the site whole config ...
59      AMI_Client1.AutoGetConfig = false;
60      // Setup a few Event handlers
61      AMI_Client1.StateChangeEvent += new AMIgo.StateChangeEventHandler(StateChangeEventHandler);
62      AMI_Client1.HangupEvent += new AstChannelEventHandler(HangupEventHandler);
63      AMI_Client1.ErrorEvent += new ErrorEventHandler(AMI_ErrorEventHandler);
64      // Create the raw manager message display form and show it.
65      DisplayForm = new AMIgoMsgDisplayForm(AMI_Client1);
66      DisplayForm.Show();
67      // If AutoStart is false we need to call Start();
68      if (AMI_Client1.AutoStart == false)
69        AMI_Client1.Start();
70    }
71  }
72}

Note

This example shows how to use both automated connection and login:

  • Leaving the default AutoStart and AutoLogin properties to true. Setup a StateChangeEvent handler and wait for the AST_READY before proceeding to send commands to the AMI.
  • Seting AutoStart and AutoLogin to false and using Start, Connect and Login method in the StateChangeEvent handler.


Caller Database Lookup

[image]

AMIgo Controls documentation
Caller Database Lookup
Send Feedback

This is a simple caller database lookup application

Caller Db Lookup

This section show how to do a database lookup on the telephone number of a caller or callee.

Note

The source code for this example can be found in the Examples\DbLookup directory

Caution

If you build this example from the given source code, you will need to change the reference to the AMIgo dll. Click on the project reference directory and delete the reference to AMIgo.dll and then click on Browse and select the AMIgo.dll file from the installation directory.

  • Create a new Windows Form Application in the .NET language of your choice(File | New | Project | C# / VB / C++ | Windows) and name it as you like.
  • Add a reference to the AMIgo.dll assembly. (Right click in the Solution Explorer and select 'Add Reference')
  • Open the AMIgo tab in the Toolbox Windows and drag an AMI_Client object on your project's main form.
  • Set the AMI_Client AstMngrHost, AstMngrPort, AstMngrUserName and AstMngrPassword for the desired Asterisk manager target site.
  • Set the AMI_Client AutoGetConfig property to false.
  • Drag an AMIgoStatusStrip on the form and set it's 'Dock' property to 'Bottom'.
  • From the Tollbox' AMIgo tab, drag a ListViewChannels object in the bottom panel of the Split Container and set it's 'Dock' property to 'Fill'.
  • Click on the AMI_Client and select the Event Tab from the properties windows, then double click on the NewCallEvent.
  • Edit Form1.cs to add the lines shown below to the events handlers and the DoDbLookup method.
  • Modify the connection strin to connect to the Nortwind or your own database.
  • Build the application and run it.

When the application is run, it will attempt to connect and login to the given site. The State shown in the status bar should be 'Logged'. From then on new inbound or oubound call will generate a NewCallEvent and the EventArgs will contains the CallerId number / Name which you can use to do the database lookup.

CopyC#
 1using System;
 2using System.Configuration;
 3using System.Data.SqlClient;
 4using System.Windows.Forms;
 5
 6namespace AMIgoDbLookup
 7{
 8  public partial class Form1 : Form
 9  {
10    /// <summary>A SQL Connection for our DB</summary>
11    SqlConnection sqlConnection;
12    /// <summary>A command object used to send SQL command to the SQLite DB</summary>
13    SqlCommand sqlCommand;
14    /// <summary>A SqlDataReader to get the Db record"</summary>
15    SqlDataReader reader;
16    //+====================================================+
17    public Form1()
18    {
19      InitializeComponent();
20    }
21    //+====================================================+
22    private void Form1_Load(object sender, EventArgs e)
23    {
24      string connection_str = "server=(local);integrated security=SSPI; database=Northwind";
25      //string connection_str = GetConnectionStrings();
26      sqlConnection = new SqlConnection(connection_str);
27    }
28    //+====================================================+
29    private string GetConnectionStrings()
30    { // This method returns the connection string set in the app.config file
31      ConnectionStringSettingsCollection settings =  ConfigurationManager.ConnectionStrings;
32      return (settings[0].ConnectionString);
33    }
34    //+====================================================+
35    // This is the AMI_Client NewCall event handler.
36    private void AMI_Client1_NewCallEvent(object sender, AMIgo.NewCallEventArgs ev)
37    {
38      if ((ev.src_caller_id.Length >= 10) && (ev.dst_caller_id.Length <= 4))
39      {
40        // Inbound Call
41        DoDbLookup(ev.src_caller_id, true);
42      }
43      else if ((ev.src_caller_id.Length <= 4) && (ev.dst_caller_id.Length >= 10))
44      {
45        // Outbound call
46        DoDbLookup(ev.dst_caller_id, true);
47      }
48    }
49    //+====================================================+
50    // Do a Db lookup on the PhoneNumber
51    private void DoDbLookup(string PhoneNo, bool IsInbound)
52    {
53      string sql_cmd = "SELECT * from Customers WHERE Phone = '" + PhoneNo + "'";
54      sqlCommand = new SqlCommand(sql_cmd, sqlConnection);
55      try
56      {
57        sqlConnection.Open();
58        reader = sqlCommand.ExecuteReader();
59        while (reader.Read())
60        {
61          string cust_id = (string)reader[0];
62          string address = (string)reader[4];
63          string city = (string)reader[5];
64          string phone = (string)reader[9];
65          // Do something with the record data.
66          // Ex. Create an HTML page, on an intranet HTTP Server ... etc
67        }
68      }
69      catch (Exception ex)
70      {
71        MessageBox.Show(ex.Message, "DbLookup Error", MessageBoxButtons.OK, MessageBoxIcon.Error);
72      }
73      finally
74      {
75        sqlConnection.Close();
76      }
77    }
78    //+====================================================+
79  }
80}


Without Visual Studio
Send Feedback

This section explains how to use the command line compiler to build a simple application

Without Visual Studio

Note

The source code for this example can be found in the Examples\Example2 directory

You can also use the command line compiler (csc) to compile an application.

Copy the code below and paste in a new file named HelloAMIgoWorld.cs.

Then type: csc /t:winexe HelloAMIgoWorld.cs /r:[path]AMIgo.dll to build the program. This is an exact equivalent of the Hello AMIgo World.

CopyC#
  1using System;
  2using System.Drawing;
  3using System.Windows.Forms;
  4using AMIgo;
  5
  6// A simple AMIgo application to be used with the command line compiler
  7public class Form1 : System.Windows.Forms.Form
  8{
  9    private AMI_Client AMI_Cli; // The AMI_Client object
 10    private AstSite ASite; // A site definition object
 11    private AMIgoCommandPanel ACmdPanel; // AMIgo Command panel
 12    private AMIgoStatusStrip AStatusStrip; // AMIgo Status Strip
 13    private ListViewLines ALinesListView; // AMIgo Lines ListView display
 14    private ListViewChannels AChannelsListView; // AMIgo Channels ListView display
 15    private SplitContainer splitContainer1; // For the two list view
 16    //+============================================================+
 17    public Form1()
 18    {
 19        //this.Load += new EventHandler(Form1_Load);
 20        SetupLayout();
 21    }
 22    //+============================================================+
 23    private void Form1_Load(System.Object sender, System.EventArgs e)
 24    {
 25      SetupLayout();
 26      //if (AMI_Cli.AutoStart == false)
 27      //  AMI_Cli.Start(this);
 28    }
 29    //+============================================================+
 30    private void SetupLayout()
 31    {
 32      this.Size = new Size(800, 600); // Set the main form size
 33      // Create a new AstSite object with Host and manager account info. for the target system.
 34      ASite = new AstSite("Site Name", "Host or domain", "5038", "MyUserName", "MyPassword", false);
 35      // Create a new AMI_Client object with a reference to the main form (this) and the AstSite object
 36      //AMI_Cli = new AMI_Client(this, ASite);
 37      // Or start and use the Connection button to connect
 38      // NOTE: The 'this' parameter which represents the main form will be used to
 39      // synchronize the events with the main thread.
 40      AMI_Cli = new AMI_Client(this);
 41      // If you use the next constructor, the events will not be synchronised to the main thread.
 42      // You will need to call Invoke for any update to the User Interface.
 43      //AMI_Cli = new AMI_Client();
 44
 45      // Setup events handlers for the peers and channels details events.
 46      AMI_Cli.PeerDetailsEvent += new StatusEventHandler(AMI_Cli_PeerDetailsEventHandler);
 47      AMI_Cli.ChannelDetailsEvent += new StatusEventHandler(AMI_Cli_ChannelDetailsEventHandler);
 48      // Create a new AMIgo command panel and set it to dock to the top of the form.
 49      ACmdPanel = new AMIgoCommandPanel(AMI_Cli);
 50      ACmdPanel.Dock = DockStyle.Top;
 51      // Create a new AMIgo Status strip  and set it to dock to the bottom of the form.
 52      AStatusStrip = new AMIgoStatusStrip(AMI_Cli);
 53      AStatusStrip.Dock = DockStyle.Bottom;
 54      // Create a split container, with horizontal splitter and blue background
 55      this.splitContainer1 = new System.Windows.Forms.SplitContainer();
 56      this.splitContainer1.Location = new System.Drawing.Point(0, 30);
 57      this.splitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal;
 58      this.splitContainer1.BackColor = System.Drawing.SystemColors.ActiveCaption;
 59      // Set is to fill the remaining space on the form.
 60      this.splitContainer1.Dock = DockStyle.Fill;
 61
 62      // Create an AMIgo ListViewLines and set it to fill it's container
 63      ALinesListView = new ListViewLines(AMI_Cli);
 64      //this.ALinesListView.Location = new System.Drawing.Point(0, 0);
 65      ALinesListView.Dock = DockStyle.Fill;
 66
 67      // Create an AMIgo ListViewChannels and set it to fill it's container
 68      AChannelsListView = new ListViewChannels(AMI_Cli);
 69      //this.ALinesListView.Location = new System.Drawing.Point(0, 0);
 70      AChannelsListView.Dock = DockStyle.Fill;
 71      // Set the ListViewLines in the top panel and the ListViewChannels in the bottom panel
 72      // of the split container
 73      this.splitContainer1.Panel1.Controls.Add(this.ALinesListView);
 74      this.splitContainer1.Panel2.Controls.Add(this.AChannelsListView);
 75
 76      // Add the Command Panel, Status strip and splitcontainer to the form.
 77      this.Controls.Add(this.splitContainer1);
 78      this.Controls.Add(this.AStatusStrip);
 79      this.Controls.Add(this.ACmdPanel);
 80    }
 81    //+============================================================+
 82    // This event is triggered in the AMI_Client thread but synchronised to the main form's thread.
 83    // So it is safe to update UI elements from within this event handler.
 84    private void AMI_Cli_PeerDetailsEventHandler(object sender, StringMsgEventArgs ev)
 85    {
 86      AMIgoDisplayForm df = new AMIgoDisplayForm("Peer Details", ev.string_msg);
 87      df.Show();
 88    }
 89    //+============================================================+
 90    private void AMI_Cli_ChannelDetailsEventHandler(object sender, StringMsgEventArgs ev)
 91    {
 92      AMIgoDisplayForm df = new AMIgoDisplayForm("Channel Details", ev.string_msg);
 93      df.Show();
 94    }
 95    //+============================================================+
 96    [STAThreadAttribute()]
 97    static void Main()
 98    {
 99      Form1 app = null;
100      try
101      {
102        app = new Form1();
103        Application.EnableVisualStyles();
104        Application.Run(app);
105      }
106      catch (Exception ex)
107      {
108        MessageBox.Show(ex.Message, "Exception", MessageBoxButtons.OK, MessageBoxIcon.Error);
109      }
110    }
111}


AMIgo Namespace

[image]

AMIgo Controls documentation
AMIgo Namespace
Send Feedback
AMIgo: A suite of high level .NET Components and User Controls for the Asterisk® PBX Manager Interface, that allows to remotely monitor, control and setup an Asterisk® VoIP PBX system.

See: T:AMIgo.AMI_Client

Classes

 | Class | Description
Public class | AgentCallEventArgs | Custom EventArgs used for Agents calls
Public class | AgentSessionEventArgs | Custom EventArgs used for Agents Sessions
Public class | AgentsEventArgs | Custom EventArgs used for Agents events
Public class | AMI_Client | The Asterisk Manager Client Interface (AMI) is the main component required for all applications.
Public class | AMIgoCommandPanel | The Command Panel class ...
Public class | AMIgoConfigControl | This is the base control from which most config / setips controls inherits
Public class | AMIgoConfigEditorForm | The asterisk config file editor Form class
Public class | AMIgoConfigEditorPanel | The asterisk config file editor Panel.
Public class | AMIgoControl | This is the base control from which inherit most of the AMIgo controls
Public class | AMIgoDialplanEditorPanel | This control is used to edit the dial plan (extensions.conf).
Public class | AMIgoDisplayForm | This is a form descendant used to display elements details
Public class | AMIgoDropTarget | This class inherited from Form is a form that lists drop targets on which ListView items can be dropped to originate calls or to redirect active channels / calls.
Public class | AMIgoListViewControl | This is the base class from which all of the AMIgo ListView controls inherit
Public class | AMIgoMsgDisplayForm | This Form is used as a container for a AmigoMsgDisplayPanel to display raw manager message in a Form.
Public class | AmigoMsgDisplayPanel | This controls is used to display the 'raw' AMI message.
Public class | AMIgoSetupAgentForm | This Form descendant allows to create / edit agents definitions.
Public class | AMIgoSetupAgentPanel | This control is used to edit and create new agents.
Public class | AMIgoSetupConferenceForm | This Form descendant allows to create / edit conferences definitions.
Public class | AMIgoSetupConferencePanel | This control is used to edit and create new conferences.
Public class | AMIgoSetupPanel | This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc
Public class | AMIgoSetupPanel..::..AgentConfig | This holds the information for an agent (from agents.conf) or from the AstDB
Public class | AMIgoSetupPanel..::..ConferenceConfig | This contains the information for a conference
Public class | AMIgoSetupPanel..::..QueueConfig | This contains a Queue configuration parameters
Public class | AMIgoSetupPanel..::..UserConfig | This class hold the information for a user contained in the users.conf config file.
Public class | AMIgoSetupQueueForm | This Form descendant allows to create / edit queues definitions.
Public class | AMIgoSetupQueuePanel | This control is used to edit and create new queues.
Public class | AMIgoSitesManager | This Controls implements a DataBase of Asterisk sites and provides an easy and quick way to connect and login to a selected site.
Public class | AMIgoStatusStrip | This is the AMIgo status strip class, used to display status message .
Public class | AstAgent | This class is the base for the Agents list. See: AstAgentsList
Public class | AstAgentCall | This class is the base for the Agents Calls list. See: AstAgentsCallsList
Public class | AstAgentSession | This class is the base for the Agents sessions DB record.
Public class | AstCall | This class is the base for the ongoing calls list
Public class | AstChannel | This is the base class for the AstChannelsList SyncList, which contains the definition of sip / iax / zap objects present in the connected system.
Public class | AstChannelEventArgs | Custom EventArgs used for Channels events
Public class | AstConference | This class is the base for the conferences list. See: AstConferencesList
Public class | AstConferenceUser | This class is the base for the conferences users records. See: AstConferenceUsersList
Public class | AstQueue | This class is the base for the Queues list. See AstQueuesList
Public class | AstQueueEntry | This class is the base for the Queues entries list (users waiting in queues) AstQueuesEntriesList
Public class | AstQueueMember | This class is the base for the Queues members list (extension defined to handle the calls in the queues) See: AstQueuesMembersList
Public class | AstSite | This class hold the sites location and manager login information for a list of asterisk installations.
Public class | AstUsersObject | This is the base class for the AstUsersObjectsList SyncList, which contains the definition of sip / iax / zap objects present in the connected system.
Public class | AstUsersObjectEventArgs | Custom EventArgs used for AstUsersObjects (Extensions, trunks, registrations) events
Public class | AstVoicemail | This class is used a a template for a voice Mailbox definition
Public class | CDR | This class is the base for the AstCall details report record
Public class | CDR_EventArgs | Custom EventArgs used for Calls Details Report sent after a call is completed.
Public class | CmdResultEventArgs | Custom EventArgs used for Commands results events
Public class | ConferenceEventArgs | Custom EventArgs used for Conferences events
Public class | ConferenceUserEventArgs | Custom EventArgs used for AstConferenceUser events
Public class | ConfigFileReadEventArgs | Custom EventArgs used for Config File read events.
Public class | DataGridViewAgents | This control display a tabular list of agents and their state.
Public class | DataGridViewAgentsEntries | This control display a tabular list of agents calls and their state.
Public class | DataGridViewChannels | This control display a tabular list of currently active channels on the connected system.
Public class | DataGridViewLines | This control display a tabular list of SIP / IAX2 peers / registration and Zap/DAHDI channela present on the connected system.
Public class | DataGridViewQueueMembers | This control display a tabular list current queues members and status infos. on the connected system.
Public class | DataGridViewQueues | This control display a tabular list of defined queues and some status infos. on the connected system.
Public class | DataGridViewQueuesEntries | This control display a tabular list of queneue entries (call waiting in queue)
Public class | DBEventArgs | Custom EventArgs used for Ast Database events
Public class | FormLicense | A form for lincense display and input
Public class | GetChannelVarEventArgs | Custom EventArgs used to for 'ChannelGetVar' events
Public class | GetConfigEventArgs | Custom EventArgs used for ConfigGetFile events
Public class | ListViewAgents | This class implement a ListView control to display defined agents and their state.
Public class | ListViewAgentsCalls | This class implement a ListView control to display the calls that have been received by the agents.
Public class | ListViewCalls | A UserControl used to display and interact with the active calls.
Public class | ListViewChannels | A UserControl used to display and interact with the channels objects that are active on the connected system.
Public class | ListViewConferences | This control implements a ListView that display the defined conferences.
Public class | ListViewConferenceUsers | This controls implements a ListView that display users of the conferences.
Public class | ListViewLines | A UserControl used to display and interact with the 'lines' objects that are defined on the system.
Public class | ListViewQueueEntries | This class implement a ListView control to display the current calls waiting in the queues.
Public class | ListViewQueueMembers | This class implement a ListView control to display queue members and their state.
Public class | ListViewQueues | This class implement a ListView control to display the defined Queues details
Public class | MbxCountEventArgs | Custom EventArgs used for Mailbox Count events
Public class | NewCallEventArgs | Custom EventArgs used for Calls events
Public class | OriginateEventArgs | Custom EventArgs used for the originate response.
Public class | OriginateResponse | This class is the base for the originate response message
Public class | QueueEntryEventArgs | Custom EventArgs used for Queue Entries
Public class | QueueMemberEventArgs | Custom EventArgs used for Queue Members events
Public class | QueueParamsEventArgs | Custom EventArgs used for Queue events
Public class | RawMngrMsgEventArgs | Custom EventArgs used to for 'raw message' events (send the message as received from the AMI)
Public class | ShutdownEventArgs | Custom EventArgs used for Shutdown events
Public class | StateChangeEventArgs | Custom EventArgs used for State Changes events
Public class | StringMsgEventArgs | Customs EventArgs for a few events
Public class | SyncList<(Of <(<'T>)>)> | A 'synchronized' descendant of BindingList used to insure that ListView and other UI AMIgo objects are updated from the Main application's thread.
Public class | VersionEventArgs | Custom EventArgs used for VersionEvent
Public class | VisibleChangeEventArgs | A custom EventArgs to use for the Hide Event

Delegates

 | Delegate | Description
Public delegate | AgentCallEventHandler | delegate for the AgentCall Event Handler
Public delegate | AgentEventHandler | delegate for the Agent Event Handler
Public delegate | AgentSessionEventHandler | delegate for the AgentSession Event Handler
Public delegate | AstChannelEventHandler | delegate for the AstChannel Event Handler
Public delegate | AstUsersObjectEventHandler | delegate for the AstUsersObjects Event Handler
Public delegate | CDR_EventHandler | delegate for the AstCall Details Report Event Handler
Public delegate | CmdResultHandler | delegate for the CmdResult Event Handler
Public delegate | ConferenceEventHandler | delegate for the AstConference Event Handler
Public delegate | ConferenceUserEventHandler | delegate for the AstConference User Event Handler
Public delegate | ConfigFileReadEventHandler | delegate for the ConfigFileRead Event Handler
Public delegate | ConfigUpdateEventHandler | delegate for the ConfigUpdate Event Handler
Public delegate | DBEventHandler | delegate for the Data Base Events Handler
Public delegate | ErrorEventHandler | delegate for the Error Event Handler
Public delegate | GetChannelVarEventHandler | delegate for the ChannelGetVar command
Public delegate | GetConfigEventHandler | delegate for the ConfigGetFile Event Handler
Public delegate | HideEventHandler | delegate for the Hide Event Handler
Public delegate | ListViewUpdateHandler | delegate for the List View Event Handler
Public delegate | ManagerCommandListHandler | delegate for the Manage Command List Event Handler
Public delegate | MbxCountHandler | delegate for the MailboxCount Event Handler
Public delegate | NewCallEventHandler | delegate for the NewCall Event Handler
Public delegate | OriginateResultEventHandler | delegate for the Originate response Event Handler
Public delegate | QueueEntryEventHandler | delegate for the Queue Entry Event Handler
Public delegate | QueueMemberEventHandler | delegate for the Queue Member Handler
Public delegate | QueueParamsEventHandler | delegate for the Queue Params Handler
Public delegate | RawMngrMsgHandler | delegate for the 'raw message' Event Handler
Public delegate | ShutdownEventHandler | delegate for the ShutDown Event Handler
Public delegate | StateChangeEventHandler | delegate for the StateChange Event Handler
Public delegate | StatusEventHandler | delegate for the Status Event Handler
Public delegate | TransferEventHandler | delegate for the Transfer Event Handler
Public delegate | UserEventHandler | delegate for the User Event Handler
Public delegate | VersionEventHandler | delegate for the Version Event Handler

Enumerations

 | Enumeration | Description
Public enumeration | AgentTypes | Types of Agents that can be added as queue members
Public enumeration | AMI_Client..::..AMI_ClientState | Asterisk Manager Interface Client states
Public enumeration | CallType | Enum the direction / source / dest of calls
Public enumeration | ObjectType | Enums for Object type. Used to define the type of objects in ListViews etc ...
Public enumeration | QueueMemberStatus | Statuses of queue members


AgentCallEventArgs Class

[image]

AMIgo Controls documentation
AgentCallEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Agents calls

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AgentCallEventArgs : EventArgs
Visual Basic
Public Class AgentCallEventArgs _
    Inherits EventArgs
Visual C++
public ref class AgentCallEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..AgentCallEventArgs

See Also

AgentCallEventArgs Members
AMIgo Namespace


AgentCallEventArgs Members

[image] [image]

AMIgo Controls documentation
AgentCallEventArgs Members
AgentCallEventArgs Class Constructors Fields See Also Send Feedback

The AgentCallEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AgentCallEventArgs | Initializes a new instance of the AgentCallEventArgs class.

Fields

 | Name | Description
Public field | agent_call | An AstAgentCall struct containing the call information.
Public field | event_strs | The raw event strings

See Also

AgentCallEventArgs Class


AgentCallEventArgs Constructor

[image]

AMIgo Controls documentation
AgentCallEventArgs Constructor
AgentCallEventArgs Class See Also Send Feedback
Initializes a new instance of the AgentCallEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentCallEventArgs(
    string[] EventStrs,
    AstAgentCall AgentCall
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    AgentCall As AstAgentCall _
)
Visual C++
public:
AgentCallEventArgs(
    array<String^>^ EventStrs,
    AstAgentCall^ AgentCall
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event strings.
AgentCall
Type: AMIgo..::..AstAgentCall
an AstAgentCall struct

See Also

AgentCallEventArgs Class


AgentCallEventArgs Fields

[image] [image]

AMIgo Controls documentation
AgentCallEventArgs Fields
AgentCallEventArgs Class See Also Send Feedback

The AgentCallEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | agent_call | An AstAgentCall struct containing the call information.
Public field | event_strs | The raw event strings

See Also

AgentCallEventArgs Class


agent_call Field

[image]

AMIgo Controls documentation
AgentCallEventArgs..::..agent_call Field
AgentCallEventArgs Class See Also Send Feedback
An AstAgentCall struct containing the call information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgentCall agent_call
Visual Basic
Public agent_call As AstAgentCall
Visual C++
public:
AstAgentCall^ agent_call

See Also

AgentCallEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
AgentCallEventArgs..::..event_strs Field
AgentCallEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

AgentCallEventArgs Class


AgentCallEventHandler Delegate

[image]

AMIgo Controls documentation
AgentCallEventHandler Delegate
See Also Send Feedback
delegate for the AgentCall Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void AgentCallEventHandler(
    Object sender,
    AgentCallEventArgs ev
)
Visual Basic
Public Delegate Sub AgentCallEventHandler ( _
    sender As Object, _
    ev As AgentCallEventArgs _
)
Visual C++
public delegate void AgentCallEventHandler(
    Object^ sender,
    AgentCallEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..AgentCallEventArgs
The AgentCallEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AgentEventHandler Delegate

[image]

AMIgo Controls documentation
AgentEventHandler Delegate
See Also Send Feedback
delegate for the Agent Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void AgentEventHandler(
    Object sender,
    AgentsEventArgs ev
)
Visual Basic
Public Delegate Sub AgentEventHandler ( _
    sender As Object, _
    ev As AgentsEventArgs _
)
Visual C++
public delegate void AgentEventHandler(
    Object^ sender,
    AgentsEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..AgentsEventArgs
The AgentsEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AgentSessionEventArgs Class

[image]

AMIgo Controls documentation
AgentSessionEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Agents Sessions

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AgentSessionEventArgs : EventArgs
Visual Basic
Public Class AgentSessionEventArgs _
    Inherits EventArgs
Visual C++
public ref class AgentSessionEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..AgentSessionEventArgs

See Also

AgentSessionEventArgs Members


AgentSessionEventArgs Members

[image] [image]

AMIgo Controls documentation
AgentSessionEventArgs Members
AgentSessionEventArgs Class Constructors Fields See Also Send Feedback

The AgentSessionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AgentSessionEventArgs | Initializes a new instance of the AgentSessionEventArgs class.

Fields

 | Name | Description
Public field | agent_session | An AstAgentSession struct containing the agent session information.
Public field | event_strs | The raw event strings

See Also

AgentSessionEventArgs Class


AgentSessionEventArgs Constructor

[image]

AMIgo Controls documentation
AgentSessionEventArgs Constructor
AgentSessionEventArgs Class See Also Send Feedback
Initializes a new instance of the AgentSessionEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentSessionEventArgs(
    string[] EventStrs,
    AstAgentSession AgentSession
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    AgentSession As AstAgentSession _
)
Visual C++
public:
AgentSessionEventArgs(
    array<String^>^ EventStrs,
    AstAgentSession^ AgentSession
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
AgentSession
Type: AMIgo..::..AstAgentSession
The agent session.

See Also

AgentSessionEventArgs Class


AgentSessionEventArgs Fields

[image] [image]

AMIgo Controls documentation
AgentSessionEventArgs Fields
AgentSessionEventArgs Class See Also Send Feedback

The AgentSessionEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | agent_session | An AstAgentSession struct containing the agent session information.
Public field | event_strs | The raw event strings

See Also

AgentSessionEventArgs Class


agent_session Field

[image]

AMIgo Controls documentation
AgentSessionEventArgs..::..agent_session Field
AgentSessionEventArgs Class See Also Send Feedback
An AstAgentSession struct containing the agent session information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgentSession agent_session
Visual Basic
Public agent_session As AstAgentSession
Visual C++
public:
AstAgentSession^ agent_session

See Also

AgentSessionEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
AgentSessionEventArgs..::..event_strs Field
AgentSessionEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

AgentSessionEventArgs Class


AgentSessionEventHandler Delegate

[image]

AMIgo Controls documentation
AgentSessionEventHandler Delegate
See Also Send Feedback
delegate for the AgentSession Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void AgentSessionEventHandler(
    Object sender,
    AgentSessionEventArgs ev
)
Visual Basic
Public Delegate Sub AgentSessionEventHandler ( _
    sender As Object, _
    ev As AgentSessionEventArgs _
)
Visual C++
public delegate void AgentSessionEventHandler(
    Object^ sender,
    AgentSessionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..AgentSessionEventArgs
The AgentSessionEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AgentsEventArgs Class

[image]

AMIgo Controls documentation
AgentsEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Agents events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AgentsEventArgs : EventArgs
Visual Basic
Public Class AgentsEventArgs _
    Inherits EventArgs
Visual C++
public ref class AgentsEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..AgentsEventArgs

See Also

AgentsEventArgs Members


AgentsEventArgs Members

[image] [image]

AMIgo Controls documentation
AgentsEventArgs Members
AgentsEventArgs Class Constructors Fields See Also Send Feedback

The AgentsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AgentsEventArgs | Initializes a new instance of the AgentsEventArgs class.

Fields

 | Name | Description
Public field | agent | An AstAgent struc containing the agent's info.
Public field | event_strs | The raw event strings

See Also

AgentsEventArgs Class


AgentsEventArgs Constructor

[image]

AMIgo Controls documentation
AgentsEventArgs Constructor
AgentsEventArgs Class See Also Send Feedback
Initializes a new instance of the AgentsEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentsEventArgs(
    string[] EventStrs,
    AstAgent Agent
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Agent As AstAgent _
)
Visual C++
public:
AgentsEventArgs(
    array<String^>^ EventStrs,
    AstAgent^ Agent
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Agent
Type: AMIgo..::..AstAgent
The agent.

See Also

AgentsEventArgs Class


AgentsEventArgs Fields

[image] [image]

AMIgo Controls documentation
AgentsEventArgs Fields
AgentsEventArgs Class See Also Send Feedback

The AgentsEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | agent | An AstAgent struc containing the agent's info.
Public field | event_strs | The raw event strings

See Also

AgentsEventArgs Class


agent Field

[image]

AMIgo Controls documentation
AgentsEventArgs..::..agent Field
AgentsEventArgs Class See Also Send Feedback
An AstAgent struc containing the agent's info.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgent agent
Visual Basic
Public agent As AstAgent
Visual C++
public:
AstAgent^ agent

See Also

AgentsEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
AgentsEventArgs..::..event_strs Field
AgentsEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

AgentsEventArgs Class


AgentTypes Enumeration

[image]

AMIgo Controls documentation
AgentTypes Enumeration
See Also Send Feedback
Types of Agents that can be added as queue members

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public enum AgentTypes
Visual Basic
Public Enumeration AgentTypes
Visual C++
public enum class AgentTypes

Members

Member name | Value | Description
Channel | 0 | A 'Channel Agents' defined in agents.conf
Local | 1 | Local agents are defined in the AstDB and use Local channels and support the agent callback feature by using dialplan application and the AST DB
Phone | 2 | An extension used as Agent

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AMI_Client Class

[image]

AMIgo Controls documentation
AMI_Client Class
Members See Also Send Feedback
The Asterisk Manager Client Interface (AMI) is the main component required for all applications.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMI_Client : Component
Visual Basic
Public Class AMI_Client _
    Inherits Component
Visual C++
public ref class AMI_Client : public Component

Remarks

The Asterisk Manager Client AMI_Client is the main central component which implement an Asterisk Manager Interface (AMI) client in a Thread and takes care of the communication between your application and the AMI server.

Its main function is to handle the communication between the application and the AMI and to parse all of the message into synchronised lists and to provide high level synchronised events (that can be safely used from the main application's thread) for the events and messages sent by the AMI. It also provides numerous high level methods to send commands to the AMI server.

In order to simplify usage, the AMI_Client handles the initialisation of all AMIgo controls used in an application. Just drop any of the control on a form with an AMI_Client component.

For more control and/or custom applications, the AMI_Client provides a wide range of low and high level methods and events, for which you can provide your own handlers.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
AMIgo..::..AMI_Client

See Also

AMI_Client Members
AMIgo Namespace
AMIgo..::..AMI_Client..::..AMI_ClientState
AMI_Client..::..Start(Control)
AMI_Client..::..Connect()()()()
AMI_Client..::..Login()()()()
AMI_Client..::..AutoStart
AMI_Client..::..AutoLogin


AMI_Client Members

[image] [image]

AMIgo Controls documentation
AMI_Client Members
AMI_Client Class Constructors Methods Fields Properties Events See Also Send Feedback

The AMI_Client type exposes the following members.

Constructors

 | Name | Description
Public method | AMI_Client()()()() | This constructor can be used when no display object are used
Public method | AMI_Client(IContainer) | This constructor is the one that will be used when the AMI_Client is used in the Visual Development environment. (Visual Studio ...). See Start()()()()
Public method | AMI_Client(Control) | This constructor should be used when using the AstMngr DataGrid and ListView controls.
Public method | AMI_Client(AstSite) | This constructor can be used to specify a Site to connect to on startup.
Public method | AMI_Client(Control, AstSite) | This constructor can be used to specify a Site to connect to on startup.
Public method | AMI_Client(String, String, Int32, String, String) | This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.
Public method | AMI_Client(Control, String, String, Int32, String, String) | This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.

Methods

 | Name | Description
Public method | AgentCallbackLogin | Log in an agent with Callback. NOTE: Not available in asterisk 1.6 and up.
Public method | AgentLogoff | Logoff a 'Channel' Agent (Not for local agents)
Public method | AgentsClearList | Clears the Agents SyncList
Public method | AgentsGetStatus | Gets the agents status.
Public method | AgentsRefreshList | Refreshes the _astAgentsList
Public method | ApplicationsBuildList()()()() | Returns a string list of defined applications.
Public method | ApplicationsBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined applications.
Public method | ChannelAbsoluteTimeout | Set an absolute Timeout on the given active Channel.
Public method | ChannelAtxfer | Attended Transfer: Allow to talk to the destination extension before doing the Transfer. (V1.6 and up only)
Public method | ChannelBridge | ChannelBridge together two channels already in the PBX. (V1.6 and up only)
Public method | ChannelGetDetails | Get details on an active channel.
Public method | ChannelGetVar | Retreive a Channel variable from the given active channel.(Asterisk 1.6 and up)
Public method | ChannelHangup | Hangup a given active channel
Public method | ChannelParkCall | Parks a given channel and announce the parking extension to the parking channel. An optional Timeout parameter can be given.
Public method | ChannelRedirect | ChannelRedirect an active channel
Public method | ChannelsBuildList(String) | Returns a string list of active channels
Public method | ChannelsBuildList(ComboBox..::..ObjectCollection, String) | Fills the given ComboBox items with a list of active channels
Public method | ChannelSetVar | Sets a Channel variable on the given active channel. (Asterisk 1.6 and up)
Public method | ChannelsGetStatus | Get the active channels statuses and update the AstChannelsList
Public method | ChannelsGetTypes | Gets a list of currently loaded channel drivers types.
Public method | ChannelsRefresh | Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.
Public method | CLI_CommandsGetList | Get a list of the CLI commands available on the currently connected system
Public method | CLI_SendCommand | Send a CLI command.
Public method | ConferencesBuildList()()()() | Returns a string list of defined conferences.
Public method | ConferencesBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined conferences.
Public method | ConfigAddAgentSupportToDialplan | Add agent support to dialplan.
Public method | ConfigAddAMIgoCommandsToDialplan | Add commands to the dialplan to send 'system' command to the target.
Public method | ConfigAddExtensionsToDialplan | Dynamically add an extension to the dialplan (not written to extensions.conf)
Public method | ConfigAppendCategory | Append a new category (context) in a given config file
Public method | ConfigCreateAgent | Create a new agent definition.
Public method | ConfigCreateAgentMailbox | Create a voice mailbox for an agent.
Public method | ConfigCreateConference | Create a new conference definition in meetme.conf
Public method | ConfigCreateMailbox | Create a new voicemail mailbox.
Public method | ConfigCreateNewFile | Create a new configuration file. V1.6 and up
Public method | ConfigCreateQueue | Create a new queue definition in queues.conf
Public method | ConfigCreateUser | Create a new user definition in users.conf
Public method | ConfigDeleteAgent | Delete an agent.
Public method | ConfigDeleteAgentMailbox | Delete an agent mailbox from voicemail.conf.
Public method | ConfigDeleteCategory | Deletes a whole category (context) in a given config file
Public method | ConfigDeleteConference | Delete a conference from meetme.conf.
Public method | ConfigDeleteQueue | Delete a queue definition from queues.conf
Public method | ConfigDeleteUser | Delete a user definition from users.conf.
Public method | ConfigGetAgents | This will fill the _AgentsConfigList dictionary lists with one Dictionary entry for each agent defined in the agents.conf file.
Public method | ConfigGetConferences | This will fill the _ConferencesConfigList dictionary list with one Dictionary entry for each conference (or room) defined in the meetme.conf file.
Public method | ConfigGetFile | Gets the given config file.
Public method | ConfigGetInfo |
Public method | ConfigGetPreferences | This will fill the _GuiPreferencesConfigList dictionary list with one Dictionary entry for each category defined in the guipreference.conf file.
Public method | ConfigGetQueues | This will fill the _QueuesConfigList dictionary list with one Dictionary entry for each queue defined in the queues.conf file.
Public method | ConfigGetUpdateCount | Returns the Update config. counter that keeps traks of the number of pending updates.
Public method | ConfigGetUsers | This will fill the _UsersConfigList dictionary lists with one Dictionary entry for each user defined in the users.conf file.
Public method | ConfigGetVoicemail | This will fill the _VoicemailConfigList dictionary lists with one Dictionary entry for each voicemail user defined in the voicemail.conf file.
Public method | ConfigListCategories | Gets the categories in the given config file. V1.6 and up only
Public method | ConfigOpenEditor | Opens the config editor. with given filename and content.
Public method | ConfigSaveAgentsAdminOptions | Save agents admin options to the agents.conf config file.
Public method | ConfigSaveConferenceAdminOptions | Save conference admin options to the meetme.conf file.
Public method | ConfigShowDialPlan | List a given Context / extension from the dialplan (extensions.conf). V1.6 and up only
Public method | ConfigUpdateAgent | Update an agent definition
Public method | ConfigUpdateCategory | Update category in a .conf file.
Public method | ConfigUpdateConference | Update a conference definition.
Public method | ConfigUpdateDefaultInclude | Test if the given context is in the list of includes in the 'default' context and update if needed.
Public method | ConfigUpdateExtensionCategory | Update a category in the dialplan (extensions.conf)
Public method | ConfigUpdateLine | Update a given configuration line in a given .conf file
Public method | ConfigUpdateLines | Update a given list of configuration lines in a givent .conf file
Public method | ConfigUpdateQueue | Update a queue definition.
Public method | ConfigUpdateUser | Update a User definition.
Public method | ConfigWriteAgentAdminDiaplan | Write the agent admin lines to the dialplan.
Public method | ConfigWriteDialplanQueuesList | Write the queues to the dialplan (extensions.conf)
Public method | ConfigWriteDiaplanConferencesAdminToList | Write the conferences admin lines to the dialplan. (extensions.conf)
Public method | ConfigWriteDiaplanConferencesToList | Write the conferences to the dialplan. (extensions.conf)
Public method | Connect()()()() | Connect to the Asterisk Manager server with given parameters set as properties. Change the control state to CONNECTED on success.
Public method | Connect(AstSite) | Connect to the Asterisk Manager server at location / login given by the AstSite parameter. Change the control state to CONNECTED on success.
 | ConvertFromUnixTimestamp | Converts from unix timestamp to DateTime
Public method | CoreSettings | Get asterisk core settings. (V1.6 and up only)
Public method | CoreStatus | Get asterisk core status. (V1.6 and up only)
Public method | DBDel | Delete a value from the AstDB.
Public method | DBDelTree | Delete a whole family tree from the AstDB. (V1.6 and up only)
Public method | DBGet | Gets a value from the Ast DB.
Public method | DBGetLocalAgent | Gets a value from the Ast DB.
Public method | DBPut | Set a value into the AstDB
Public method | DialPlanAddHint | Adds a 'hint' to the dialplan.
Public method | DialPlanBuildList | Scan the dialplan dico list and build defined Dialplan list.
Public method | DialPlanGetApplicationsList | This function reads the extensions.conf [applications] Context and parses the applications into a string list. See: _DialplanApplicationsList
Public method | DialPlanGetConferencesList | Gets the conferences list.
Public method | DialPlanGetQueuesList | Gets the queues list.
Public method | DialPlanGetVoiceMenusList | Gets the voice menus list.
Public method | Disconnect | Disconnect from the target system. A LogOff command should be issued first.
Protected method | Dispose | Clean up any resources being used. (Overrides Component..::..Dispose(Boolean).)
Public method | DoAutoGetConfig | Execute the auto login. Sends commands to get lines/trunks/registration, channels, queues, agents, voicemail, conference infos, etc and parse the result into AMIgo SyncLists AutoLogin
Public method | ExtensionCallChannelSpy | Originate a call to the given extension and starts 'spying' on SIP channels.
Public method | ExtensionGetState | Get the status of a given extension and update the AstUsersObjectsList.
Public method | ExtensionsBuildList(String, Boolean) | Returns a string list of available extensions.
Public method | ExtensionsBuildList(ComboBox..::..ObjectCollection, String, Boolean) | Fills the given ComboBox items with a list of available extensions.
Public method | ExtensionsGetStatus | Gets all of the defined extensions statuses and update the AstUsersObjectsList.
Public method | ExtractAgentNo | Extracts the agent no. from a full agent name (Ex: Agent/6007, Local/6000)
Public method | ExtractExtensionNo | Extracts the extension no. from the given tech/ext-no
Public method | ExtractFromMsg | Extracts the value for given parameter from a 'raw' manager message
Public method | ExtractZapAliasName | Extracts the name of the zap alias. (extension associated with Zap channel) from given string in the form Zap/1 (1234)
Public method | GetAsteriskVersion | Fills the _AsteriskVersion... public fields with the version given by the connected system.
Public method | GetDicoIndexInList | Gets the dico index in list of a given Category. returns -1 if not found
Public method | GetExtensionsConfig | This will fill the _ExtensionsConfigList dictionary list with one Dictionary entry for each category defined in the extensions.conf file.
Public method | GetLinesInfos | Gets the Lines (Extensions and trunks) information. This fills the AstUsersObjectsList with the SIP / IAX / ZAP/DAHDI peers and registrations.
Public method | GetOriginateDataFromItems | Translate extensions name if needed and parse dest strings for originate call.
Public method | GetSubItemTextByColumnName | Gets the name of the given ListView sub item text by column.
Public method | GetValueFromDictionaryList | Returns a string from a givent dictionary list
Public method | GetVoicemailInfos | Retreive and parse the voicemail users information. This will create a list accessible with the readonly property : AstVoicemailList.
Public method | IAX2_GetRegistry | Get the IAX2 registrations and parse into AstUsersObjectsList.
Public method | IAX2_PeersGetDef | Get the IAX2 peers and parse into the AstUsersObjectsList.
Public method | LinesRefresh | Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.
Public method | LocalAgentCallbackLogin | Login a Local agent with Callback. Add the agent in the given queue and sets the callback extension in the AstDB.
Public method | LocalAgentLogoff | Logs off a Local agent. Remove from queue and sets the extension into AstDB to 'n/a'
Public method | LocalAgentsGetStatus | Gets the local agents status from the AstDB.
Public method | Login | Called after connect to login to the asterisk manager server.
Public method | Logoff | Logoff from the currently connected asterisk manager server.
Public method | MailboxGetCount | Gets the numbers of voicemail in the given Mailbox
Public method | ManagerCommandsGetList | Fills the string list _ManagerCommandsList with the list of available manager commands
Public method | MeetmeKick | Kick a Meetme conference user out.
Public method | MeetmeList | List the meetme conferences
Public method | MeetmeLock | Lock a given conference. (does not accept any new user)
Public method | MeetmeMute | Mute a Meetme conference user
Public method | MeetmeUnlock | Unlock a given conference. (Accept new users)
Public method | MeetmeUnmute | Unmute a Meetme conference user
Public method | ModulesGetList | Get a list of the loaded modules on the currently connected system.
Protected method | OnAstChannelEvent | Raises the AstChannelEvent event.
Protected method | OnAstUsersObjectEvent | Raises the AstUsersObjectEvent event.
Protected method | OnStatusEvent | Raises the StatusEvent event.
Protected method | OnTransferEvent | Raises the TransferEvent event.
Public method | Originate | Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.
Public method | OriginateApplication | Generates a call to a given tech/data and execute an application.
Public method | OriginateExtension | Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.
Public method | Ping | Send a message to verify or maintains connection.
Public method | QueueAdd(String, String, String, String) | Add a Member to a queue
Public method | QueueAdd(String, String, String, String, String, String) | Add a Member to a queue. For Asterisk V1.6 and up only
Public method | QueueGetStatus | Gets the status of queues, queues members and queues entries
Public method | QueuePause | Set the Pause status of a queue member
Public method | QueueRemove | Remove a member from a queue
Public method | QueuesBuildList(Boolean) | Returns a string list of defined queues.
Public method | QueuesBuildList(ComboBox..::..ObjectCollection, Boolean) | Fills the given ComboBox items with a list of defined queues.
Public method | QueuesClearList | Clears the Queues SyncList
Public method | QueuesRefreshList | Refreshes the _queuesList SyncList
Public method | ReloadDialplan | Reloads the dialplan.
Public method | SendEventCommand | Select the manager events to receive
Public method | SIP_GetPeerDetails | Get detailed infos about a SIP peer.
Public method | SIP_GetRegistry | Get the SIP registrations and parse into AstUsersObjectsList.
Public method | SIP_PeersGetDef | Get the SIP peers and parse into the AstUsersObjectsList.
Public method | Start()()()() | Starts this instance with no Parent Control. (see others constructors) (Note: You must use Invoke to modify any UI element from an event handler)
Public method | Start(Control) | Start the AMC thread with the givent control (Usually the main form) as parent control
Public method | Start(Control, AstSite) | Start the AMC thread at a given site
Public method | Stop | Stop the AMI_Client thread. This function MUST (should) be called before exiting to stop the AMIClient thread.
Public method | TestLogged | Test if state is LOGGED. Return true / false
Public method | TestVersion | Test the given version against the one of the connected system
Public method | TimeNowToString | Returns a string with current date and time in ISO8601 format
 | TimeNowToUnixTimeStamp | Returns a timestamp string in the Unix EPOCH format (Nb secs. since 01/01/1970)
 | UnixTimestampToString | Convert a UNIX timestamp to Local time. Optionally output the TIME in ISO8601 format.
Public method | VoiceMenusBuildList()()()() | Returns a string list of defined voice menus.
Public method | VoiceMenusBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined voice menus.
Public method | ZAPorDAHDI_GetDef | Get the Zap/DAHDI channels and parse into AstUsersObjectsList.

Fields

 | Name | Description
Public field | _AgentsConfigList | A list of Dictionnary that contains one Dico for each 'channel' agent defined in agents.conf and each 'Local' agent defined in AstDB that holds the agents configuration information.
Public field | _AsteriskVersionFullString | This contains the full Asterisk version string. GetAsteriskVersion()()()()
Public field | _ConferencesConfigList | A list of Dictionnary that contains one Dico for each user defined in meetme.conf that holds the conferences configuration information.
Public field | _DefaultDialPlan | The default dial plan as set in guipreferences.conf, if any.
Public field | _DialplanApplicationsList | This is a list of applications found in the [applications] Context of the dialplan (extensions.conf)
Public field | _DialplanConferencesList | This is a list of applications conferences in the [conferences] Context of the dialplan (extensions.conf)
Public field | _DialplanQueuesList | This is a list of voice menus found in the [queues] Context of the dialplan (extensions.conf)
Public field | _DialplanVoiceMenusList | This is a list of voice menus found in the [voicemenus] Context of the dialplan (extensions.conf)
Public field | _ExtensionsConfigList | A list of Dictionnary that contains one Dico for each category in the dialplan (extensions.conf)
Public field | _GuiPreferencesConfigList | A list of Dictionnary that contains one Dico for each user defined in guipreferences.conf that holds the Asterisk GUI configuration information. This defines the ranges of extensions that are reserved for the queues, conferences, agents, applications etc etc
Public field | _HasAgent | true if Agent channel driver loaded
Public field | _HasDAHDI | true if DAHDI channel driver loaded
Public field | _HasIAX2 | true if IAX2 channel driver loaded
Public field | _HasLocal | true if Local channel driver loaded
Public field | _HasSIP | true if SIP channel driver loaded
Public field | _HasZAP | true if ZAP channel driver loaded
Public field | _ManagerCommandsList | This is a list of the available manager commands on the connected system
Public field | _ModulesList | This is a list of the loaded modules on the connected system
Public field | _QueuesConfigList | A list of Dictionnary that contains one Dico for each user defined in queues.conf that holds the queues configuration information
Public field | _UsersConfigList | A list of Dictionnary that contains one Dico for each user defined in users.conf that holds the users configuration information
Public field | _VoicemailConfigList | A list of Dictionnary that contains one Dico for each user defined in voicemail.conf that holds the voicemail configuration information.

Properties

 | Name | Description
Public property | AstAgentsCallsList | Ongoing agents call list. (read only).
Public property | AstAgentsList | Agents list. (read only). See: AstAgent
Public property | AstCallsList | Active call list (read only). See: AstCall
Public property | AstChannelsList | Active channels list (read only). See: AstChannel
Public property | AstConferencesList | Conferences list. (read only). See: AstConference
Public property | AstConferenceUsersList | Conferences Users list. (read only). See: AstConferenceUser
Public property | AsteriskVersion | Version of the currently connected Asterisk system (read only)
Public property | AstMngrHost | Asterisk manager HostName or IP address.
Public property | AstMngrPassword | Asterisk manager password (Secret). (As set in target system manager.conf file)
Public property | AstMngrPort | Asterisk manager port. (Usually 5038)
Public property | AstMngrSiteName | A name for this asterisk site
Public property | AstMngrUserName | Asterisk manager User Name. (As set in target system manager.conf file)
Public property | AstQueuesEntriesList | Ongoing calls in queues List. (read only). See: AstQueueEntry
Public property | AstQueuesList | Queues list. (read only). See: AstQueue
Public property | AstQueuesMembersList | Queues members list. (read only). See: AstQueueMember
Public property | AstUsersObjectsList | AstUsersObjects list. (read only). See: AstUsersObject and SyncList<(Of <(<'T>)>)>
Public property | AstVoicemailList | Voicemail list (read only).
Public property | AutoGetConfig | Gets or sets a value indicating whether to get system config on start. Default = true.
Public property | AutoLogin | AutoConnect and Login after Start. See: AutoStart. Default = true
Public property | AutoStart | AutoStart. Starts the AMI_Client thread on application startup. Default = true
Public property | DialPlanTemplate | Gets or sets the DialPlan template.
Public property | IsStopping | True if Stop() has been called
Public property | RegCode | Gets the license code.
Public property | RegKey | Gets the license key, if any
Public property | SendPingInterval | Gets or sets the send ping interval.
Public property | ShowNewExten | Show NewExten Events.
Public property | State | State of the AMI_Client control

Events

 | Name | Description
Public event | AgentCallEvent | Occurs when an agent is called, when the call is connected (answered) and at the end of agent's calls.
Public event | AgentEvent | Occurs on Agent Status, login / off, queue members and other events affecting the agents.
Public event | AgentSessionEvent | Occurs when an agent logs in or off.
Public event | AstChannelEvent | Occurs when a channel state change
Public event | AstUsersObjectEvent | Occurs when a AstUsersObject state change.
Public event | CDR_Event | Occurs when a call ends.
Public event | ChannelDetailsEvent | Occurs after a ChannelGetDetails(String) command
Public event | CmdResultEvent | Occurs after many commands.
Public event | CommandListEvent | Occurs after a CLI_CommandsGetList()()()() command
Public event | ConferenceEvent | Occurs when a new conference starts and when it ends
Public event | ConferenceUserEvent | Occurs when a new users join or leave a conference
Public event | ConfigFileListEvent | Occurs after a system command command. V1.6 and up only
Public event | ConfigFileReadEvent | Occurs after the config file has been received and parsed
Public event | ConfigUpdateBeginEvent | Occurs after an Config Update command. is sent
Public event | ConfigUpdateEvent | Occurs after an Config Update result.
Public event | DBEvent | Occurs after commands affecting the AstDB.
Public event | DialPlanCategsEvent | Occurs after a ConfigListCategories(String) command for the dialplan (extensions.conf)
Public event | ErrorEvent | Occurs after an error.
Public event | GetChannelVariableEvent | Occurs after a ChannelGetVar command.
Public event | GetConfigEvent | Occurs after a config file has been received.
Public event | HangupEvent | Occurs when a channel is hungup
Public event | ManagerCommandsListEvent | Occurs after a ManagerCommandsGetList()()()() command
Public event | MbxCountEvent | Occurs after a call to the MailboxGetCount(String) method.
Public event | ModuleListEvent | Occurs after a ModulesGetList()()()() command
Public event | NewCallEvent | Occurs after a new call is established.
Public event | NewExtenEvent | Occurs after each step in the dialplan if enabled. See: ShowNewExten
Public event | OriginateResultEvent | Occurs after an OriginateExtension(String, String, String, String, String) or OriginateApplication(String, String, String, String) command.
Public event | PeerDetailsEvent | Occurs in response to the SIP_GetPeerDetails(String) command
Public event | QueueEntryEvent | Occurs after a AstQueueEntry event is received. See: QueueGetStatus()()()()
Public event | QueueMemberEvent | Occurs after a QueueParam event is received. See: QueueGetStatus()()()()
Public event | QueueParamsEvent | Occurs after a QueueParam event is received. See: QueueGetStatus()()()()
Public event | RawMngrMsgEvent | Occurs after commands returning result a string array.
Public event | SetChannelVariableEvent | Occurs after the ChannelSetVar command.
Public event | ShutdownEvent | Occurs after a Shutdown event is received
Public event | StateChangeEvent | Occurs after a state change of the AMI_Client.
Public event | StatusEvent | Occurs after a status change of the AMI_Client.
Public event | TransferEvent | Occurs after the reception of a TransferEvent.
Public event | UserEventEvent | Occurs after the reception of a UserEvent.
Public event | VersionEvent | Occurs after the response to the GetAsteriskVersion()()()() command.
Public event | WriteErrorEvent | Occurs after a Write error. (disconnected ...)

See Also

AMI_Client Class


AMI_Client Constructor

[image] [image]

AMIgo Controls documentation
AMI_Client Constructor
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMI_Client()()()() | This constructor can be used when no display object are used
Public method | AMI_Client(IContainer) | This constructor is the one that will be used when the AMI_Client is used in the Visual Development environment. (Visual Studio ...). See Start()()()()
Public method | AMI_Client(Control) | This constructor should be used when using the AstMngr DataGrid and ListView controls.
Public method | AMI_Client(AstSite) | This constructor can be used to specify a Site to connect to on startup.
Public method | AMI_Client(Control, AstSite) | This constructor can be used to specify a Site to connect to on startup.
Public method | AMI_Client(String, String, Int32, String, String) | This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.
Public method | AMI_Client(Control, String, String, Int32, String, String) | This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.

See Also

AMI_Client Class
AMI_Client Members


AMI_Client Constructor

[image]

AMIgo Controls documentation
AMI_Client Constructor
AMI_Client Class See Also Send Feedback
This constructor can be used when no display object are used

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client()
Visual Basic
Public Sub New
Visual C++
public:
AMI_Client()

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (IContainer)

[image]

AMIgo Controls documentation
AMI_Client Constructor (IContainer)
AMI_Client Class See Also Send Feedback
This constructor is the one that will be used when the AMI_Client is used in the Visual Development environment. (Visual Studio ...). See Start()()()()

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    IContainer container
)
Visual Basic
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
AMI_Client(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::..IContainer
The container.

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (Control)

[image]

AMIgo Controls documentation
AMI_Client Constructor (Control)
AMI_Client Class See Also Send Feedback
This constructor should be used when using the AstMngr DataGrid and ListView controls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    Control ParentControl
)
Visual Basic
Public Sub New ( _
    ParentControl As Control _
)
Visual C++
public:
AMI_Client(
    Control^ ParentControl
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control. Used to synchonize events. Usually the projects main form.

Remarks

The control given as a param. which is usually the application Main Form, is used with Invoke() to insure that Event Handlers are executed in the Control's parent thread.

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (AstSite)

[image]

AMIgo Controls documentation
AMI_Client Constructor (AstSite)
AMI_Client Class See Also Send Feedback
This constructor can be used to specify a Site to connect to on startup.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    AstSite Site
)
Visual Basic
Public Sub New ( _
    Site As AstSite _
)
Visual C++
public:
AMI_Client(
    AstSite^ Site
)

Parameters

Site
Type: AMIgo..::..AstSite
The AstSite containing the Host and manager login infos

Remarks

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (Control, AstSite)

[image]

AMIgo Controls documentation
AMI_Client Constructor (Control, AstSite)
AMI_Client Class See Also Send Feedback
This constructor can be used to specify a Site to connect to on startup.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    Control ParentControl,
    AstSite Site
)
Visual Basic
Public Sub New ( _
    ParentControl As Control, _
    Site As AstSite _
)
Visual C++
public:
AMI_Client(
    Control^ ParentControl,
    AstSite^ Site
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control. Used to synchonize events. Usually the projects main form.
Site
Type: AMIgo..::..AstSite
The AstSite containing the Host and manager login infos

Remarks

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (String, String, Int32, String, String)

[image]

AMIgo Controls documentation
AMI_Client Constructor (String, String, Int32, String, String)
AMI_Client Class See Also Send Feedback
This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    string SiteName,
    string MngrHost,
    int MngrPort,
    string MngrUserName,
    string MngrSecret
)
Visual Basic
Public Sub New ( _
    SiteName As String, _
    MngrHost As String, _
    MngrPort As Integer, _
    MngrUserName As String, _
    MngrSecret As String _
)
Visual C++
public:
AMI_Client(
    String^ SiteName,
    String^ MngrHost,
    int MngrPort,
    String^ MngrUserName,
    String^ MngrSecret
)

Parameters

SiteName
Type: System..::..String
A name to identify the target asterisk system
MngrHost
Type: System..::..String
The domain or IP address of the target asterisk system
MngrPort
Type: System..::..Int32
Manager port. Default is 5038
MngrUserName
Type: System..::..String
The manager account UserName
MngrSecret
Type: System..::..String
The manager account password

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Constructor (Control, String, String, Int32, String, String)

[image]

AMIgo Controls documentation
AMI_Client Constructor (Control, String, String, Int32, String, String)
AMI_Client Class See Also Send Feedback
This constructor allows to specify a target system to connect to. If the AutoStart property is set to true, the connection will be attempted on startup. Otherwise you need to call the Start function.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client(
    Control ParentControl,
    string SiteName,
    string MngrHost,
    int MngrPort,
    string MngrUserName,
    string MngrSecret
)
Visual Basic
Public Sub New ( _
    ParentControl As Control, _
    SiteName As String, _
    MngrHost As String, _
    MngrPort As Integer, _
    MngrUserName As String, _
    MngrSecret As String _
)
Visual C++
public:
AMI_Client(
    Control^ ParentControl,
    String^ SiteName,
    String^ MngrHost,
    int MngrPort,
    String^ MngrUserName,
    String^ MngrSecret
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control. Used to synchonize events. Usually the projects main form.
SiteName
Type: System..::..String
A name to identify the target asterisk system
MngrHost
Type: System..::..String
The domain or IP address of the target asterisk system
MngrPort
Type: System..::..Int32
Manager port. Default is 5038
MngrUserName
Type: System..::..String
The manager account UserName
MngrSecret
Type: System..::..String
The manager account password

See Also

AMI_Client Class
AMI_Client Overload


AMI_Client Fields

[image] [image]

AMIgo Controls documentation
AMI_Client Fields
AMI_Client Class See Also Send Feedback

The AMI_Client type exposes the following members.

Fields

 | Name | Description
Public field | _AgentsConfigList | A list of Dictionnary that contains one Dico for each 'channel' agent defined in agents.conf and each 'Local' agent defined in AstDB that holds the agents configuration information.
Public field | _AsteriskVersionFullString | This contains the full Asterisk version string. GetAsteriskVersion()()()()
Public field | _ConferencesConfigList | A list of Dictionnary that contains one Dico for each user defined in meetme.conf that holds the conferences configuration information.
Public field | _DefaultDialPlan | The default dial plan as set in guipreferences.conf, if any.
Public field | _DialplanApplicationsList | This is a list of applications found in the [applications] Context of the dialplan (extensions.conf)
Public field | _DialplanConferencesList | This is a list of applications conferences in the [conferences] Context of the dialplan (extensions.conf)
Public field | _DialplanQueuesList | This is a list of voice menus found in the [queues] Context of the dialplan (extensions.conf)
Public field | _DialplanVoiceMenusList | This is a list of voice menus found in the [voicemenus] Context of the dialplan (extensions.conf)
Public field | _ExtensionsConfigList | A list of Dictionnary that contains one Dico for each category in the dialplan (extensions.conf)
Public field | _GuiPreferencesConfigList | A list of Dictionnary that contains one Dico for each user defined in guipreferences.conf that holds the Asterisk GUI configuration information. This defines the ranges of extensions that are reserved for the queues, conferences, agents, applications etc etc
Public field | _HasAgent | true if Agent channel driver loaded
Public field | _HasDAHDI | true if DAHDI channel driver loaded
Public field | _HasIAX2 | true if IAX2 channel driver loaded
Public field | _HasLocal | true if Local channel driver loaded
Public field | _HasSIP | true if SIP channel driver loaded
Public field | _HasZAP | true if ZAP channel driver loaded
Public field | _ManagerCommandsList | This is a list of the available manager commands on the connected system
Public field | _ModulesList | This is a list of the loaded modules on the connected system
Public field | _QueuesConfigList | A list of Dictionnary that contains one Dico for each user defined in queues.conf that holds the queues configuration information
Public field | _UsersConfigList | A list of Dictionnary that contains one Dico for each user defined in users.conf that holds the users configuration information
Public field | _VoicemailConfigList | A list of Dictionnary that contains one Dico for each user defined in voicemail.conf that holds the voicemail configuration information.

See Also

AMI_Client Class


_AgentsConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._AgentsConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each 'channel' agent defined in agents.conf and each 'Local' agent defined in AstDB that holds the agents configuration information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _AgentsConfigList
Visual Basic
Public _AgentsConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _AgentsConfigList

See Also

AMI_Client Class


_AsteriskVersionFullString Field

[image]

AMIgo Controls documentation
AMI_Client..::.._AsteriskVersionFullString Field
AMI_Client Class See Also Send Feedback
This contains the full Asterisk version string. GetAsteriskVersion()()()()

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string _AsteriskVersionFullString
Visual Basic
Public _AsteriskVersionFullString As String
Visual C++
public:
String^ _AsteriskVersionFullString

See Also

AMI_Client Class


_ConferencesConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._ConferencesConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each user defined in meetme.conf that holds the conferences configuration information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _ConferencesConfigList
Visual Basic
Public _ConferencesConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _ConferencesConfigList

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ConfigGetConferences()()()()


_DefaultDialPlan Field

[image]

AMIgo Controls documentation
AMI_Client..::.._DefaultDialPlan Field
AMI_Client Class See Also Send Feedback
The default dial plan as set in guipreferences.conf, if any.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string _DefaultDialPlan
Visual Basic
Public _DefaultDialPlan As String
Visual C++
public:
String^ _DefaultDialPlan

See Also

AMI_Client Class


_DialplanApplicationsList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._DialplanApplicationsList Field
AMI_Client Class See Also Send Feedback
This is a list of applications found in the [applications] Context of the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _DialplanApplicationsList
Visual Basic
Public _DialplanApplicationsList As List(Of String)
Visual C++
public:
List<String^>^ _DialplanApplicationsList

See Also

AMI_Client Class


_DialplanConferencesList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._DialplanConferencesList Field
AMI_Client Class See Also Send Feedback
This is a list of applications conferences in the [conferences] Context of the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _DialplanConferencesList
Visual Basic
Public _DialplanConferencesList As List(Of String)
Visual C++
public:
List<String^>^ _DialplanConferencesList

See Also

AMI_Client Class


_DialplanQueuesList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._DialplanQueuesList Field
AMI_Client Class See Also Send Feedback
This is a list of voice menus found in the [queues] Context of the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _DialplanQueuesList
Visual Basic
Public _DialplanQueuesList As List(Of String)
Visual C++
public:
List<String^>^ _DialplanQueuesList

See Also

AMI_Client Class


_DialplanVoiceMenusList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._DialplanVoiceMenusList Field
AMI_Client Class See Also Send Feedback
This is a list of voice menus found in the [voicemenus] Context of the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _DialplanVoiceMenusList
Visual Basic
Public _DialplanVoiceMenusList As List(Of String)
Visual C++
public:
List<String^>^ _DialplanVoiceMenusList

See Also

AMI_Client Class


_ExtensionsConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._ExtensionsConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each category in the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _ExtensionsConfigList
Visual Basic
Public _ExtensionsConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _ExtensionsConfigList

See Also

AMI_Client Class


_GuiPreferencesConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._GuiPreferencesConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each user defined in guipreferences.conf that holds the Asterisk GUI configuration information. This defines the ranges of extensions that are reserved for the queues, conferences, agents, applications etc etc

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _GuiPreferencesConfigList
Visual Basic
Public _GuiPreferencesConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _GuiPreferencesConfigList

See Also

AMI_Client Class


_HasAgent Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasAgent Field
AMI_Client Class See Also Send Feedback
true if Agent channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasAgent
Visual Basic
Public _HasAgent As Boolean
Visual C++
public:
bool _HasAgent

See Also

AMI_Client Class


_HasDAHDI Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasDAHDI Field
AMI_Client Class See Also Send Feedback
true if DAHDI channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasDAHDI
Visual Basic
Public _HasDAHDI As Boolean
Visual C++
public:
bool _HasDAHDI

See Also

AMI_Client Class


_HasIAX2 Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasIAX2 Field
AMI_Client Class See Also Send Feedback
true if IAX2 channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasIAX2
Visual Basic
Public _HasIAX2 As Boolean
Visual C++
public:
bool _HasIAX2

See Also

AMI_Client Class


_HasLocal Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasLocal Field
AMI_Client Class See Also Send Feedback
true if Local channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasLocal
Visual Basic
Public _HasLocal As Boolean
Visual C++
public:
bool _HasLocal

See Also

AMI_Client Class


_HasSIP Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasSIP Field
AMI_Client Class See Also Send Feedback
true if SIP channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasSIP
Visual Basic
Public _HasSIP As Boolean
Visual C++
public:
bool _HasSIP

See Also

AMI_Client Class


_HasZAP Field

[image]

AMIgo Controls documentation
AMI_Client..::.._HasZAP Field
AMI_Client Class See Also Send Feedback
true if ZAP channel driver loaded

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _HasZAP
Visual Basic
Public _HasZAP As Boolean
Visual C++
public:
bool _HasZAP

See Also

AMI_Client Class


_ManagerCommandsList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._ManagerCommandsList Field
AMI_Client Class See Also Send Feedback
This is a list of the available manager commands on the connected system

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _ManagerCommandsList
Visual Basic
Public _ManagerCommandsList As List(Of String)
Visual C++
public:
List<String^>^ _ManagerCommandsList

Remarks

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..CLI_CommandsGetList()()()()
AMI_Client..::..CommandListEvent


_ModulesList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._ModulesList Field
AMI_Client Class See Also Send Feedback
This is a list of the loaded modules on the connected system

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> _ModulesList
Visual Basic
Public _ModulesList As List(Of String)
Visual C++
public:
List<String^>^ _ModulesList

Remarks

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ModulesGetList()()()()
AMI_Client..::..ModuleListEvent


_QueuesConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._QueuesConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each user defined in queues.conf that holds the queues configuration information

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _QueuesConfigList
Visual Basic
Public _QueuesConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _QueuesConfigList

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ConfigGetQueues()()()()


_UsersConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._UsersConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each user defined in users.conf that holds the users configuration information

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _UsersConfigList
Visual Basic
Public _UsersConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _UsersConfigList

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ConfigGetUsers()()()()


_VoicemailConfigList Field

[image]

AMIgo Controls documentation
AMI_Client..::.._VoicemailConfigList Field
AMI_Client Class See Also Send Feedback
A list of Dictionnary that contains one Dico for each user defined in voicemail.conf that holds the voicemail configuration information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> _VoicemailConfigList
Visual Basic
Public _VoicemailConfigList As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ _VoicemailConfigList

See Also

AMI_Client Class


AMI_Client Methods

[image] [image]

AMIgo Controls documentation
AMI_Client Methods
AMI_Client Class See Also Send Feedback

The AMI_Client type exposes the following members.

Methods

 | Name | Description
Public method | AgentCallbackLogin | Log in an agent with Callback. NOTE: Not available in asterisk 1.6 and up.
Public method | AgentLogoff | Logoff a 'Channel' Agent (Not for local agents)
Public method | AgentsClearList | Clears the Agents SyncList
Public method | AgentsGetStatus | Gets the agents status.
Public method | AgentsRefreshList | Refreshes the _astAgentsList
Public method | ApplicationsBuildList()()()() | Returns a string list of defined applications.
Public method | ApplicationsBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined applications.
Public method | ChannelAbsoluteTimeout | Set an absolute Timeout on the given active Channel.
Public method | ChannelAtxfer | Attended Transfer: Allow to talk to the destination extension before doing the Transfer. (V1.6 and up only)
Public method | ChannelBridge | ChannelBridge together two channels already in the PBX. (V1.6 and up only)
Public method | ChannelGetDetails | Get details on an active channel.
Public method | ChannelGetVar | Retreive a Channel variable from the given active channel.(Asterisk 1.6 and up)
Public method | ChannelHangup | Hangup a given active channel
Public method | ChannelParkCall | Parks a given channel and announce the parking extension to the parking channel. An optional Timeout parameter can be given.
Public method | ChannelRedirect | ChannelRedirect an active channel
Public method | ChannelsBuildList(String) | Returns a string list of active channels
Public method | ChannelsBuildList(ComboBox..::..ObjectCollection, String) | Fills the given ComboBox items with a list of active channels
Public method | ChannelSetVar | Sets a Channel variable on the given active channel. (Asterisk 1.6 and up)
Public method | ChannelsGetStatus | Get the active channels statuses and update the AstChannelsList
Public method | ChannelsGetTypes | Gets a list of currently loaded channel drivers types.
Public method | ChannelsRefresh | Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.
Public method | CLI_CommandsGetList | Get a list of the CLI commands available on the currently connected system
Public method | CLI_SendCommand | Send a CLI command.
Public method | ConferencesBuildList()()()() | Returns a string list of defined conferences.
Public method | ConferencesBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined conferences.
Public method | ConfigAddAgentSupportToDialplan | Add agent support to dialplan.
Public method | ConfigAddAMIgoCommandsToDialplan | Add commands to the dialplan to send 'system' command to the target.
Public method | ConfigAddExtensionsToDialplan | Dynamically add an extension to the dialplan (not written to extensions.conf)
Public method | ConfigAppendCategory | Append a new category (context) in a given config file
Public method | ConfigCreateAgent | Create a new agent definition.
Public method | ConfigCreateAgentMailbox | Create a voice mailbox for an agent.
Public method | ConfigCreateConference | Create a new conference definition in meetme.conf
Public method | ConfigCreateMailbox | Create a new voicemail mailbox.
Public method | ConfigCreateNewFile | Create a new configuration file. V1.6 and up
Public method | ConfigCreateQueue | Create a new queue definition in queues.conf
Public method | ConfigCreateUser | Create a new user definition in users.conf
Public method | ConfigDeleteAgent | Delete an agent.
Public method | ConfigDeleteAgentMailbox | Delete an agent mailbox from voicemail.conf.
Public method | ConfigDeleteCategory | Deletes a whole category (context) in a given config file
Public method | ConfigDeleteConference | Delete a conference from meetme.conf.
Public method | ConfigDeleteQueue | Delete a queue definition from queues.conf
Public method | ConfigDeleteUser | Delete a user definition from users.conf.
Public method | ConfigGetAgents | This will fill the _AgentsConfigList dictionary lists with one Dictionary entry for each agent defined in the agents.conf file.
Public method | ConfigGetConferences | This will fill the _ConferencesConfigList dictionary list with one Dictionary entry for each conference (or room) defined in the meetme.conf file.
Public method | ConfigGetFile | Gets the given config file.
Public method | ConfigGetInfo |
Public method | ConfigGetPreferences | This will fill the _GuiPreferencesConfigList dictionary list with one Dictionary entry for each category defined in the guipreference.conf file.
Public method | ConfigGetQueues | This will fill the _QueuesConfigList dictionary list with one Dictionary entry for each queue defined in the queues.conf file.
Public method | ConfigGetUpdateCount | Returns the Update config. counter that keeps traks of the number of pending updates.
Public method | ConfigGetUsers | This will fill the _UsersConfigList dictionary lists with one Dictionary entry for each user defined in the users.conf file.
Public method | ConfigGetVoicemail | This will fill the _VoicemailConfigList dictionary lists with one Dictionary entry for each voicemail user defined in the voicemail.conf file.
Public method | ConfigListCategories | Gets the categories in the given config file. V1.6 and up only
Public method | ConfigOpenEditor | Opens the config editor. with given filename and content.
Public method | ConfigSaveAgentsAdminOptions | Save agents admin options to the agents.conf config file.
Public method | ConfigSaveConferenceAdminOptions | Save conference admin options to the meetme.conf file.
Public method | ConfigShowDialPlan | List a given Context / extension from the dialplan (extensions.conf). V1.6 and up only
Public method | ConfigUpdateAgent | Update an agent definition
Public method | ConfigUpdateCategory | Update category in a .conf file.
Public method | ConfigUpdateConference | Update a conference definition.
Public method | ConfigUpdateDefaultInclude | Test if the given context is in the list of includes in the 'default' context and update if needed.
Public method | ConfigUpdateExtensionCategory | Update a category in the dialplan (extensions.conf)
Public method | ConfigUpdateLine | Update a given configuration line in a given .conf file
Public method | ConfigUpdateLines | Update a given list of configuration lines in a givent .conf file
Public method | ConfigUpdateQueue | Update a queue definition.
Public method | ConfigUpdateUser | Update a User definition.
Public method | ConfigWriteAgentAdminDiaplan | Write the agent admin lines to the dialplan.
Public method | ConfigWriteDialplanQueuesList | Write the queues to the dialplan (extensions.conf)
Public method | ConfigWriteDiaplanConferencesAdminToList | Write the conferences admin lines to the dialplan. (extensions.conf)
Public method | ConfigWriteDiaplanConferencesToList | Write the conferences to the dialplan. (extensions.conf)
Public method | Connect()()()() | Connect to the Asterisk Manager server with given parameters set as properties. Change the control state to CONNECTED on success.
Public method | Connect(AstSite) | Connect to the Asterisk Manager server at location / login given by the AstSite parameter. Change the control state to CONNECTED on success.
 | ConvertFromUnixTimestamp | Converts from unix timestamp to DateTime
Public method | CoreSettings | Get asterisk core settings. (V1.6 and up only)
Public method | CoreStatus | Get asterisk core status. (V1.6 and up only)
Public method | DBDel | Delete a value from the AstDB.
Public method | DBDelTree | Delete a whole family tree from the AstDB. (V1.6 and up only)
Public method | DBGet | Gets a value from the Ast DB.
Public method | DBGetLocalAgent | Gets a value from the Ast DB.
Public method | DBPut | Set a value into the AstDB
Public method | DialPlanAddHint | Adds a 'hint' to the dialplan.
Public method | DialPlanBuildList | Scan the dialplan dico list and build defined Dialplan list.
Public method | DialPlanGetApplicationsList | This function reads the extensions.conf [applications] Context and parses the applications into a string list. See: _DialplanApplicationsList
Public method | DialPlanGetConferencesList | Gets the conferences list.
Public method | DialPlanGetQueuesList | Gets the queues list.
Public method | DialPlanGetVoiceMenusList | Gets the voice menus list.
Public method | Disconnect | Disconnect from the target system. A LogOff command should be issued first.
Protected method | Dispose | Clean up any resources being used. (Overrides Component..::..Dispose(Boolean).)
Public method | DoAutoGetConfig | Execute the auto login. Sends commands to get lines/trunks/registration, channels, queues, agents, voicemail, conference infos, etc and parse the result into AMIgo SyncLists AutoLogin
Public method | ExtensionCallChannelSpy | Originate a call to the given extension and starts 'spying' on SIP channels.
Public method | ExtensionGetState | Get the status of a given extension and update the AstUsersObjectsList.
Public method | ExtensionsBuildList(String, Boolean) | Returns a string list of available extensions.
Public method | ExtensionsBuildList(ComboBox..::..ObjectCollection, String, Boolean) | Fills the given ComboBox items with a list of available extensions.
Public method | ExtensionsGetStatus | Gets all of the defined extensions statuses and update the AstUsersObjectsList.
Public method | ExtractAgentNo | Extracts the agent no. from a full agent name (Ex: Agent/6007, Local/6000)
Public method | ExtractExtensionNo | Extracts the extension no. from the given tech/ext-no
Public method | ExtractFromMsg | Extracts the value for given parameter from a 'raw' manager message
Public method | ExtractZapAliasName | Extracts the name of the zap alias. (extension associated with Zap channel) from given string in the form Zap/1 (1234)
Public method | GetAsteriskVersion | Fills the _AsteriskVersion... public fields with the version given by the connected system.
Public method | GetDicoIndexInList | Gets the dico index in list of a given Category. returns -1 if not found
Public method | GetExtensionsConfig | This will fill the _ExtensionsConfigList dictionary list with one Dictionary entry for each category defined in the extensions.conf file.
Public method | GetLinesInfos | Gets the Lines (Extensions and trunks) information. This fills the AstUsersObjectsList with the SIP / IAX / ZAP/DAHDI peers and registrations.
Public method | GetOriginateDataFromItems | Translate extensions name if needed and parse dest strings for originate call.
Public method | GetSubItemTextByColumnName | Gets the name of the given ListView sub item text by column.
Public method | GetValueFromDictionaryList | Returns a string from a givent dictionary list
Public method | GetVoicemailInfos | Retreive and parse the voicemail users information. This will create a list accessible with the readonly property : AstVoicemailList.
Public method | IAX2_GetRegistry | Get the IAX2 registrations and parse into AstUsersObjectsList.
Public method | IAX2_PeersGetDef | Get the IAX2 peers and parse into the AstUsersObjectsList.
Public method | LinesRefresh | Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.
Public method | LocalAgentCallbackLogin | Login a Local agent with Callback. Add the agent in the given queue and sets the callback extension in the AstDB.
Public method | LocalAgentLogoff | Logs off a Local agent. Remove from queue and sets the extension into AstDB to 'n/a'
Public method | LocalAgentsGetStatus | Gets the local agents status from the AstDB.
Public method | Login | Called after connect to login to the asterisk manager server.
Public method | Logoff | Logoff from the currently connected asterisk manager server.
Public method | MailboxGetCount | Gets the numbers of voicemail in the given Mailbox
Public method | ManagerCommandsGetList | Fills the string list _ManagerCommandsList with the list of available manager commands
Public method | MeetmeKick | Kick a Meetme conference user out.
Public method | MeetmeList | List the meetme conferences
Public method | MeetmeLock | Lock a given conference. (does not accept any new user)
Public method | MeetmeMute | Mute a Meetme conference user
Public method | MeetmeUnlock | Unlock a given conference. (Accept new users)
Public method | MeetmeUnmute | Unmute a Meetme conference user
Public method | ModulesGetList | Get a list of the loaded modules on the currently connected system.
Protected method | OnAstChannelEvent | Raises the AstChannelEvent event.
Protected method | OnAstUsersObjectEvent | Raises the AstUsersObjectEvent event.
Protected method | OnStatusEvent | Raises the StatusEvent event.
Protected method | OnTransferEvent | Raises the TransferEvent event.
Public method | Originate | Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.
Public method | OriginateApplication | Generates a call to a given tech/data and execute an application.
Public method | OriginateExtension | Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.
Public method | Ping | Send a message to verify or maintains connection.
Public method | QueueAdd(String, String, String, String) | Add a Member to a queue
Public method | QueueAdd(String, String, String, String, String, String) | Add a Member to a queue. For Asterisk V1.6 and up only
Public method | QueueGetStatus | Gets the status of queues, queues members and queues entries
Public method | QueuePause | Set the Pause status of a queue member
Public method | QueueRemove | Remove a member from a queue
Public method | QueuesBuildList(Boolean) | Returns a string list of defined queues.
Public method | QueuesBuildList(ComboBox..::..ObjectCollection, Boolean) | Fills the given ComboBox items with a list of defined queues.
Public method | QueuesClearList | Clears the Queues SyncList
Public method | QueuesRefreshList | Refreshes the _queuesList SyncList
Public method | ReloadDialplan | Reloads the dialplan.
Public method | SendEventCommand | Select the manager events to receive
Public method | SIP_GetPeerDetails | Get detailed infos about a SIP peer.
Public method | SIP_GetRegistry | Get the SIP registrations and parse into AstUsersObjectsList.
Public method | SIP_PeersGetDef | Get the SIP peers and parse into the AstUsersObjectsList.
Public method | Start()()()() | Starts this instance with no Parent Control. (see others constructors) (Note: You must use Invoke to modify any UI element from an event handler)
Public method | Start(Control) | Start the AMC thread with the givent control (Usually the main form) as parent control
Public method | Start(Control, AstSite) | Start the AMC thread at a given site
Public method | Stop | Stop the AMI_Client thread. This function MUST (should) be called before exiting to stop the AMIClient thread.
Public method | TestLogged | Test if state is LOGGED. Return true / false
Public method | TestVersion | Test the given version against the one of the connected system
Public method | TimeNowToString | Returns a string with current date and time in ISO8601 format
 | TimeNowToUnixTimeStamp | Returns a timestamp string in the Unix EPOCH format (Nb secs. since 01/01/1970)
 | UnixTimestampToString | Convert a UNIX timestamp to Local time. Optionally output the TIME in ISO8601 format.
Public method | VoiceMenusBuildList()()()() | Returns a string list of defined voice menus.
Public method | VoiceMenusBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined voice menus.
Public method | ZAPorDAHDI_GetDef | Get the Zap/DAHDI channels and parse into AstUsersObjectsList.

See Also

AMI_Client Class


AgentCallbackLogin Method

[image]

AMIgo Controls documentation
AMI_Client..::..AgentCallbackLogin Method
AMI_Client Class See Also Send Feedback
Log in an agent with Callback. NOTE: Not available in asterisk 1.6 and up.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int AgentCallbackLogin(
    string Agent,
    string Exten,
    string Context
)
Visual Basic
Public Function AgentCallbackLogin ( _
    Agent As String, _
    Exten As String, _
    Context As String _
) As Integer
Visual C++
public:
int AgentCallbackLogin(
    String^ Agent,
    String^ Exten,
    String^ Context
)

Parameters

Agent
Type: System..::..String
The agent name. Ex: Agent/6700 Local/6500/n, SIP/200
Exten
Type: System..::..String
The exten to call back the agent. Ex: SIP/6000, Zap/1, DAHDI/2
Context
Type: System..::..String
The Context to call the agent.

Return Value

-1 if not logged or asterisk 1.6 and up, 0 otherwise

Remarks

NOTE: The Agent callback feature has been deprecated and is not available in asterisk 1.6 and up. You can get the AgentCallback functionality by using Local Agents instead of the Agents Channels.

EVENTS: This command will generate the following event: AgentEvent, AgentSessionEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstAgentSession


AgentLogoff Method

[image]

AMIgo Controls documentation
AMI_Client..::..AgentLogoff Method
AMI_Client Class See Also Send Feedback
Logoff a 'Channel' Agent (Not for local agents)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int AgentLogoff(
    string Agent
)
Visual Basic
Public Function AgentLogoff ( _
    Agent As String _
) As Integer
Visual C++
public:
int AgentLogoff(
    String^ Agent
)

Parameters

Agent
Type: System..::..String
The agent.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AgentEvent, AgentSessionEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstAgentSession


AgentsClearList Method

[image]

AMIgo Controls documentation
AMI_Client..::..AgentsClearList Method
AMI_Client Class See Also Send Feedback
Clears the Agents SyncList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void AgentsClearList()
Visual Basic
Public Sub AgentsClearList
Visual C++
public:
void AgentsClearList()

See Also

AMI_Client Class


AgentsGetStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..AgentsGetStatus Method
AMI_Client Class See Also Send Feedback
Gets the agents status.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int AgentsGetStatus()
Visual Basic
Public Function AgentsGetStatus As Integer
Visual C++
public:
int AgentsGetStatus()

Return Value

0 if logged in and command sent, -1 otherwise. An AgentEvent will occurs for each active channel

Remarks

EVENTS: An AgentEvent event will be generated for each agent defined in agents.conf. (channel agent). See: AgentEvent, AstAgent

See Also

AMI_Client Class


AgentsRefreshList Method

[image]

AMIgo Controls documentation
AMI_Client..::..AgentsRefreshList Method
AMI_Client Class See Also Send Feedback
Refreshes the _astAgentsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int AgentsRefreshList()
Visual Basic
Public Function AgentsRefreshList As Integer
Visual C++
public:
int AgentsRefreshList()

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


ApplicationsBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..ApplicationsBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplicationsBuildList()()()() | Returns a string list of defined applications.
Public method | ApplicationsBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined applications.

See Also

AMI_Client Class
AMI_Client Members


ApplicationsBuildList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ApplicationsBuildList Method
AMI_Client Class See Also Send Feedback
Returns a string list of defined applications.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> ApplicationsBuildList()
Visual Basic
Public Function ApplicationsBuildList As List(Of String)
Visual C++
public:
List<String^>^ ApplicationsBuildList()

Return Value

A string list of the applications defined on the system

Remarks

This lis is compiled from the dialplan [applications] Context

See Also

AMI_Client Class
ApplicationsBuildList Overload


ApplicationsBuildList Method (ComboBox.ObjectCollection)

[image]

AMIgo Controls documentation
AMI_Client..::..ApplicationsBuildList Method (ComboBox..::..ObjectCollection)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of defined applications.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ApplicationsBuildList(
    ComboBox..::..ObjectCollection Items
)
Visual Basic
Public Sub ApplicationsBuildList ( _
    Items As ComboBox..::..ObjectCollection _
)
Visual C++
public:
void ApplicationsBuildList(
    ComboBox..::..ObjectCollection^ Items
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan

Remarks

This lis is compiled from the dialplan [applications] Context

See Also

AMI_Client Class
ApplicationsBuildList Overload


ChannelAbsoluteTimeout Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelAbsoluteTimeout Method
AMI_Client Class See Also Send Feedback
Set an absolute Timeout on the given active Channel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelAbsoluteTimeout(
    string Channel,
    string Timeout
)
Visual Basic
Public Function ChannelAbsoluteTimeout ( _
    Channel As String, _
    Timeout As String _
) As Integer
Visual C++
public:
int ChannelAbsoluteTimeout(
    String^ Channel,
    String^ Timeout
)

Parameters

Channel
Type: System..::..String
The channel.
Timeout
Type: System..::..String
The Timeout (in secs).

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

This will terminate the call after the specified Timeout

See Also

AMI_Client Class


ChannelAtxfer Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelAtxfer Method
AMI_Client Class See Also Send Feedback
Attended Transfer: Allow to talk to the destination extension before doing the Transfer. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelAtxfer(
    string Channel,
    string Exten,
    string Context,
    string Priority
)
Visual Basic
Public Function ChannelAtxfer ( _
    Channel As String, _
    Exten As String, _
    Context As String, _
    Priority As String _
) As Integer
Visual C++
public:
int ChannelAtxfer(
    String^ Channel,
    String^ Exten,
    String^ Context,
    String^ Priority
)

Parameters

Channel
Type: System..::..String
Transferer's channel.
Exten
Type: System..::..String
Extension to Transfer to.
Context
Type: System..::..String
Context to Transfer to.
Priority
Type: System..::..String
Priority to Transfer to.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


ChannelBridge Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelBridge Method
AMI_Client Class See Also Send Feedback
ChannelBridge together two channels already in the PBX. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelBridge(
    string Channel1Name,
    string Channel2Name,
    bool Tone
)
Visual Basic
Public Function ChannelBridge ( _
    Channel1Name As String, _
    Channel2Name As String, _
    Tone As Boolean _
) As Integer
Visual C++
public:
int ChannelBridge(
    String^ Channel1Name,
    String^ Channel2Name,
    bool Tone
)

Parameters

Channel1Name
Type: System..::..String
Name of the channel1.
Channel2Name
Type: System..::..String
Name of the channel2.
Tone
Type: System..::..Boolean
if set to true plays a coutesy tone to Channel2.

Return Value

0 if Logged In, Version >= 1.6 and command sent, -1 otherwise

See Also

AMI_Client Class


ChannelGetDetails Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelGetDetails Method
AMI_Client Class See Also Send Feedback
Get details on an active channel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelGetDetails(
    string ChannelName
)
Visual Basic
Public Function ChannelGetDetails ( _
    ChannelName As String _
) As Integer
Visual C++
public:
int ChannelGetDetails(
    String^ ChannelName
)

Parameters

ChannelName
Type: System..::..String
The full active channel name. Ex: SIP/200-12345678

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: ChannelDetailsEvent

See Also

AMI_Client Class


ChannelGetVar Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelGetVar Method
AMI_Client Class See Also Send Feedback
Retreive a Channel variable from the given active channel.(Asterisk 1.6 and up)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelGetVar(
    string Channel,
    string Variable
)
Visual Basic
Public Function ChannelGetVar ( _
    Channel As String, _
    Variable As String _
) As Integer
Visual C++
public:
int ChannelGetVar(
    String^ Channel,
    String^ Variable
)

Parameters

Channel
Type: System..::..String
The channel.
Variable
Type: System..::..String
The variable.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

This command will generate a GetChannelVariableEvent event.

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..GetChannelVarEventArgs


ChannelHangup Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelHangup Method
AMI_Client Class See Also Send Feedback
Hangup a given active channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelHangup(
    string Channel
)
Visual Basic
Public Function ChannelHangup ( _
    Channel As String _
) As Integer
Visual C++
public:
int ChannelHangup(
    String^ Channel
)

Parameters

Channel
Type: System..::..String
The active channel full name. Ex: SIP/200-12345678

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstChannelEvent, AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstChannel


ChannelParkCall Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelParkCall Method
AMI_Client Class See Also Send Feedback
Parks a given channel and announce the parking extension to the parking channel. An optional Timeout parameter can be given.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelParkCall(
    string ChannelToPark,
    string ChannelParking,
    int Timeout
)
Visual Basic
Public Function ChannelParkCall ( _
    ChannelToPark As String, _
    ChannelParking As String, _
    Timeout As Integer _
) As Integer
Visual C++
public:
int ChannelParkCall(
    String^ ChannelToPark,
    String^ ChannelParking,
    int Timeout
)

Parameters

ChannelToPark
Type: System..::..String
Channel to park (Required)
ChannelParking
Type: System..::..String
Channel to announce park extension to. (Required)
Timeout
Type: System..::..Int32
Timeout (In milliseconds (!) after which the parked call returns to the parking channel(Optional)

Return Value

0 if logged in and command sent, -1 otherwise.

See Also

AMI_Client Class


ChannelRedirect Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelRedirect Method
AMI_Client Class See Also Send Feedback
ChannelRedirect an active channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelRedirect(
    string Channel,
    string Context,
    string Exten,
    string Priority
)
Visual Basic
Public Function ChannelRedirect ( _
    Channel As String, _
    Context As String, _
    Exten As String, _
    Priority As String _
) As Integer
Visual C++
public:
int ChannelRedirect(
    String^ Channel,
    String^ Context,
    String^ Exten,
    String^ Priority
)

Parameters

Channel
Type: System..::..String
The full active channel name Ex- Sip/200-12345678.
Context
Type: System..::..String
The Context /extension / priority to redirect the channel to.
Exten
Type: System..::..String
The exten.
Priority
Type: System..::..String
The priority.

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


ChannelsBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..ChannelsBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChannelsBuildList(String) | Returns a string list of active channels
Public method | ChannelsBuildList(ComboBox..::..ObjectCollection, String) | Fills the given ComboBox items with a list of active channels

See Also

AMI_Client Class
AMI_Client Members


ChannelsBuildList Method (String)

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelsBuildList Method (String)
AMI_Client Class See Also Send Feedback
Returns a string list of active channels

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> ChannelsBuildList(
    string SrcName
)
Visual Basic
Public Function ChannelsBuildList ( _
    SrcName As String _
) As List(Of String)
Visual C++
public:
List<String^>^ ChannelsBuildList(
    String^ SrcName
)

Parameters

SrcName
Type: System..::..String
Name of a channel to exclude from list

Return Value

A string list of the active channels

Remarks

This lis is compiled from the AstChannels list

See Also

AMI_Client Class
ChannelsBuildList Overload


ChannelsBuildList Method (ComboBox.ObjectCollection, String)

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelsBuildList Method (ComboBox..::..ObjectCollection, String)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of active channels

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ChannelsBuildList(
    ComboBox..::..ObjectCollection Items,
    string SrcName
)
Visual Basic
Public Sub ChannelsBuildList ( _
    Items As ComboBox..::..ObjectCollection, _
    SrcName As String _
)
Visual C++
public:
void ChannelsBuildList(
    ComboBox..::..ObjectCollection^ Items,
    String^ SrcName
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan
SrcName
Type: System..::..String
Name of the SRC.

Remarks

This lis is compiled from the AstChannels list

See Also

AMI_Client Class
ChannelsBuildList Overload


ChannelSetVar Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelSetVar Method
AMI_Client Class See Also Send Feedback
Sets a Channel variable on the given active channel. (Asterisk 1.6 and up)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelSetVar(
    string Channel,
    string Variable,
    string Value
)
Visual Basic
Public Function ChannelSetVar ( _
    Channel As String, _
    Variable As String, _
    Value As String _
) As Integer
Visual C++
public:
int ChannelSetVar(
    String^ Channel,
    String^ Variable,
    String^ Value
)

Parameters

Channel
Type: System..::..String
The channel.
Variable
Type: System..::..String
The variable.
Value
Type: System..::..String
The value.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a SetChannelVariableEvent event.

See Also

AMI_Client Class


ChannelsGetStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelsGetStatus Method
AMI_Client Class See Also Send Feedback
Get the active channels statuses and update the AstChannelsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelsGetStatus()
Visual Basic
Public Function ChannelsGetStatus As Integer
Visual C++
public:
int ChannelsGetStatus()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate a AstChannelEvent event for each active channel.

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstChannel


ChannelsGetTypes Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelsGetTypes Method
AMI_Client Class See Also Send Feedback
Gets a list of currently loaded channel drivers types.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelsGetTypes()
Visual Basic
Public Function ChannelsGetTypes As Integer
Visual C++
public:
int ChannelsGetTypes()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

If the AutoLogin property is set to true, a call to the GetLinesInfos()()()() method will be issued.

See Also

AMI_Client Class


ChannelsRefresh Method

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelsRefresh Method
AMI_Client Class See Also Send Feedback
Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ChannelsRefresh()
Visual Basic
Public Function ChannelsRefresh As Integer
Visual C++
public:
int ChannelsRefresh()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ChannelsGetStatus()()()()


CLI_CommandsGetList Method

[image]

AMIgo Controls documentation
AMI_Client..::..CLI_CommandsGetList Method
AMI_Client Class See Also Send Feedback
Get a list of the CLI commands available on the currently connected system

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int CLI_CommandsGetList()
Visual Basic
Public Function CLI_CommandsGetList As Integer
Visual C++
public:
int CLI_CommandsGetList()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: CommandListEvent and the _ManagerCommandsList will be filled with the list of available CLI commands. These command can be sent using the CLI_SendCommand(String) method

See Also

AMI_Client Class


CLI_SendCommand Method

[image]

AMIgo Controls documentation
AMI_Client..::..CLI_SendCommand Method
AMI_Client Class See Also Send Feedback
Send a CLI command.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int CLI_SendCommand(
    string Command
)
Visual Basic
Public Function CLI_SendCommand ( _
    Command As String _
) As Integer
Visual C++
public:
int CLI_SendCommand(
    String^ Command
)

Parameters

Command
Type: System..::..String
The CLI command to send.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command can generate several different event depending on the CLI command sent

See Also

AMI_Client Class


ConferencesBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..ConferencesBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConferencesBuildList()()()() | Returns a string list of defined conferences.
Public method | ConferencesBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined conferences.

See Also

AMI_Client Class
AMI_Client Members


ConferencesBuildList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConferencesBuildList Method
AMI_Client Class See Also Send Feedback
Returns a string list of defined conferences.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> ConferencesBuildList()
Visual Basic
Public Function ConferencesBuildList As List(Of String)
Visual C++
public:
List<String^>^ ConferencesBuildList()

Return Value

A string list of the conferences defined on the system

Remarks

This lis is compiled from the dialplan [conferences] Context

See Also

AMI_Client Class
ConferencesBuildList Overload


ConferencesBuildList Method (ComboBox.ObjectCollection)

[image]

AMIgo Controls documentation
AMI_Client..::..ConferencesBuildList Method (ComboBox..::..ObjectCollection)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of defined conferences.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConferencesBuildList(
    ComboBox..::..ObjectCollection Items
)
Visual Basic
Public Sub ConferencesBuildList ( _
    Items As ComboBox..::..ObjectCollection _
)
Visual C++
public:
void ConferencesBuildList(
    ComboBox..::..ObjectCollection^ Items
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan

Remarks

This lis is compiled from the dialplan [conferences] Context

See Also

AMI_Client Class
ConferencesBuildList Overload


ConfigAddAgentSupportToDialplan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigAddAgentSupportToDialplan Method
AMI_Client Class See Also Send Feedback
Add agent support to dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigAddAgentSupportToDialplan(
    string AgentExtRange,
    string QueueExtRange,
    int ExtSize
)
Visual Basic
Public Sub ConfigAddAgentSupportToDialplan ( _
    AgentExtRange As String, _
    QueueExtRange As String, _
    ExtSize As Integer _
)
Visual C++
public:
void ConfigAddAgentSupportToDialplan(
    String^ AgentExtRange,
    String^ QueueExtRange,
    int ExtSize
)

Parameters

AgentExtRange
Type: System..::..String
The agent ext range.
QueueExtRange
Type: System..::..String
The queue ext range.
ExtSize
Type: System..::..Int32
Size of the extensions (3 / 4).

See Also

AMI_Client Class


ConfigAddAMIgoCommandsToDialplan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigAddAMIgoCommandsToDialplan Method
AMI_Client Class See Also Send Feedback
Add commands to the dialplan to send 'system' command to the target.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigAddAMIgoCommandsToDialplan()
Visual Basic
Public Function ConfigAddAMIgoCommandsToDialplan As Integer
Visual C++
public:
int ConfigAddAMIgoCommandsToDialplan()

Return Value

0 if logged, version > 1.2 and command sent, -1 otherwise

See Also

AMI_Client Class


ConfigAddExtensionsToDialplan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigAddExtensionsToDialplan Method
AMI_Client Class See Also Send Feedback
Dynamically add an extension to the dialplan (not written to extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigAddExtensionsToDialplan(
    string Context,
    string Extension,
    string Priority,
    string App,
    string AppData
)
Visual Basic
Public Function ConfigAddExtensionsToDialplan ( _
    Context As String, _
    Extension As String, _
    Priority As String, _
    App As String, _
    AppData As String _
) As Integer
Visual C++
public:
int ConfigAddExtensionsToDialplan(
    String^ Context,
    String^ Extension,
    String^ Priority,
    String^ App,
    String^ AppData
)

Parameters

Context
Type: System..::..String
The context.
Extension
Type: System..::..String
The extension.
Priority
Type: System..::..String
The priority.
App
Type: System..::..String
The app.
AppData
Type: System..::..String
The app data.

Return Value

0 if logged and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigAppendCategory Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigAppendCategory Method
AMI_Client Class See Also Send Feedback
Append a new category (context) in a given config file

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigAppendCategory(
    string FileName,
    string Category,
    bool Reload
)
Visual Basic
Public Function ConfigAppendCategory ( _
    FileName As String, _
    Category As String, _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigAppendCategory(
    String^ FileName,
    String^ Category,
    bool Reload
)

Parameters

FileName
Type: System..::..String
Name of the file.
Category
Type: System..::..String
The category to append.
Reload
Type: System..::..Boolean
true to reload the conf file, otherwise false

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


ConfigCreateAgent Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateAgent Method
AMI_Client Class See Also Send Feedback
Create a new agent definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateAgent(
    AgentTypes AgentType,
    string AgentNo,
    string AgentPassword,
    string Name,
    string AgentEmail,
    string DefaultCallbackLocation,
    string MemberOf,
    string AgentGroupNo
)
Visual Basic
Public Function ConfigCreateAgent ( _
    AgentType As AgentTypes, _
    AgentNo As String, _
    AgentPassword As String, _
    Name As String, _
    AgentEmail As String, _
    DefaultCallbackLocation As String, _
    MemberOf As String, _
    AgentGroupNo As String _
) As Integer
Visual C++
public:
int ConfigCreateAgent(
    AgentTypes AgentType,
    String^ AgentNo,
    String^ AgentPassword,
    String^ Name,
    String^ AgentEmail,
    String^ DefaultCallbackLocation,
    String^ MemberOf,
    String^ AgentGroupNo
)

Parameters

AgentType
Type: AMIgo..::..AgentTypes
Type of the agent. (channel or Local)
AgentNo
Type: System..::..String
The agent no.
AgentPassword
Type: System..::..String
The agent password.
Name
Type: System..::..String
The name.
AgentEmail
Type: System..::..String
The agent email. (local agent only)
DefaultCallbackLocation
Type: System..::..String
The default callback location.(local agent only)
MemberOf
Type: System..::..String
The list of queues this agent is a member of. (coma separated list of queues extension(s).
AgentGroupNo
Type: System..::..String
The agent group no.

Return Value

0 if logged and command sent, -1 otherwise or Version < 1.4

See Also

AMI_Client Class


ConfigCreateAgentMailbox Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateAgentMailbox Method
AMI_Client Class See Also Send Feedback
Create a voice mailbox for an agent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateAgentMailbox(
    string AgentNo,
    string Password,
    string AgentName,
    string Email
)
Visual Basic
Public Function ConfigCreateAgentMailbox ( _
    AgentNo As String, _
    Password As String, _
    AgentName As String, _
    Email As String _
) As Integer
Visual C++
public:
int ConfigCreateAgentMailbox(
    String^ AgentNo,
    String^ Password,
    String^ AgentName,
    String^ Email
)

Parameters

AgentNo
Type: System..::..String
The agent no.
Password
Type: System..::..String
The password.
AgentName
Type: System..::..String
Name of the agent.
Email
Type: System..::..String
The email.

Return Value

0 if logged, version > 1.2, -1 otherwise

See Also

AMI_Client Class


ConfigCreateConference Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateConference Method
AMI_Client Class See Also Send Feedback
Create a new conference definition in meetme.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateConference(
    Dictionary<string, string> ConfDico,
    string ConfName,
    string ConfNo,
    string ConfPIN,
    string Options
)
Visual Basic
Public Function ConfigCreateConference ( _
    ConfDico As Dictionary(Of String, String), _
    ConfName As String, _
    ConfNo As String, _
    ConfPIN As String, _
    Options As String _
) As Integer
Visual C++
public:
int ConfigCreateConference(
    Dictionary<String^, String^>^ ConfDico,
    String^ ConfName,
    String^ ConfNo,
    String^ ConfPIN,
    String^ Options
)

Parameters

ConfDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The conf dictionary containing the conference definition.
ConfName
Type: System..::..String
A Name assigned to the conf.
ConfNo
Type: System..::..String
The conf no. / extension
ConfPIN
Type: System..::..String
The conf PIN. (optional)
Options
Type: System..::..String
The options.

Return Value

0 if logged, version > 1.2 and command sent, -1 otherwise

See Also

AMI_Client Class


ConfigCreateMailbox Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateMailbox Method
AMI_Client Class See Also Send Feedback
Create a new voicemail mailbox.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateMailbox(
    string MailboxNo,
    string Password,
    string Name,
    string Email
)
Visual Basic
Public Function ConfigCreateMailbox ( _
    MailboxNo As String, _
    Password As String, _
    Name As String, _
    Email As String _
) As Integer
Visual C++
public:
int ConfigCreateMailbox(
    String^ MailboxNo,
    String^ Password,
    String^ Name,
    String^ Email
)

Parameters

MailboxNo
Type: System..::..String
The mailbox no.
Password
Type: System..::..String
The password.
Name
Type: System..::..String
The name of the mailbox user.
Email
Type: System..::..String
The email of the mailbox user.

Return Value

0 if logged and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigCreateNewFile Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateNewFile Method
AMI_Client Class See Also Send Feedback
Create a new configuration file. V1.6 and up

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateNewFile(
    string NewFileName
)
Visual Basic
Public Function ConfigCreateNewFile ( _
    NewFileName As String _
) As Integer
Visual C++
public:
int ConfigCreateNewFile(
    String^ NewFileName
)

Parameters

NewFileName
Type: System..::..String
Name of the new config file.

Return Value

0 if logged and command sent and Version > 1.4, -1 otherwise

See Also

AMI_Client Class


ConfigCreateQueue Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateQueue Method
AMI_Client Class See Also Send Feedback
Create a new queue definition in queues.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateQueue(
    Dictionary<string, string> QueueDico,
    string QueueNumber
)
Visual Basic
Public Function ConfigCreateQueue ( _
    QueueDico As Dictionary(Of String, String), _
    QueueNumber As String _
) As Integer
Visual C++
public:
int ConfigCreateQueue(
    Dictionary<String^, String^>^ QueueDico,
    String^ QueueNumber
)

Parameters

QueueDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The queue dictionary containing the queue definition.
QueueNumber
Type: System..::..String
The queue number / extension.

Return Value

0 if logged and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigCreateUser Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigCreateUser Method
AMI_Client Class See Also Send Feedback
Create a new user definition in users.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigCreateUser(
    Dictionary<string, string> UserDico,
    string UserNumber
)
Visual Basic
Public Function ConfigCreateUser ( _
    UserDico As Dictionary(Of String, String), _
    UserNumber As String _
) As Integer
Visual C++
public:
int ConfigCreateUser(
    Dictionary<String^, String^>^ UserDico,
    String^ UserNumber
)

Parameters

UserDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The user dictionary containing the user configuration lines.
UserNumber
Type: System..::..String
The user number / extension.

Return Value

0 if logged and command sent, -1 otherwise or Version < 1.4

See Also

AMI_Client Class


ConfigDeleteAgent Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteAgent Method
AMI_Client Class See Also Send Feedback
Delete an agent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteAgent(
    AgentTypes AgentType,
    string AgentNo,
    bool Refresh
)
Visual Basic
Public Function ConfigDeleteAgent ( _
    AgentType As AgentTypes, _
    AgentNo As String, _
    Refresh As Boolean _
) As Integer
Visual C++
public:
int ConfigDeleteAgent(
    AgentTypes AgentType,
    String^ AgentNo,
    bool Refresh
)

Parameters

AgentType
Type: AMIgo..::..AgentTypes
Type of the agent. (channel / local)
AgentNo
Type: System..::..String
The agent no. / extension
Refresh
Type: System..::..Boolean
if set to true [refresh]. chan_agent and voicemail

Return Value

0 if logged and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigDeleteAgentMailbox Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteAgentMailbox Method
AMI_Client Class See Also Send Feedback
Delete an agent mailbox from voicemail.conf.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteAgentMailbox(
    string AgentNo
)
Visual Basic
Public Function ConfigDeleteAgentMailbox ( _
    AgentNo As String _
) As Integer
Visual C++
public:
int ConfigDeleteAgentMailbox(
    String^ AgentNo
)

Parameters

AgentNo
Type: System..::..String
The agent / mailbox no.

Return Value

0 if logged and command sent, -1 otherwise or Version < 1.4

See Also

AMI_Client Class


ConfigDeleteCategory Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteCategory Method
AMI_Client Class See Also Send Feedback
Deletes a whole category (context) in a given config file

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteCategory(
    string FileName,
    string Category,
    bool Reload
)
Visual Basic
Public Function ConfigDeleteCategory ( _
    FileName As String, _
    Category As String, _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigDeleteCategory(
    String^ FileName,
    String^ Category,
    bool Reload
)

Parameters

FileName
Type: System..::..String
Name of the file.
Category
Type: System..::..String
The category to delete.
Reload
Type: System..::..Boolean
If set to true, reload config file.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


ConfigDeleteConference Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteConference Method
AMI_Client Class See Also Send Feedback
Delete a conference from meetme.conf.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteConference(
    string ConfNo,
    bool UpdateLists
)
Visual Basic
Public Function ConfigDeleteConference ( _
    ConfNo As String, _
    UpdateLists As Boolean _
) As Integer
Visual C++
public:
int ConfigDeleteConference(
    String^ ConfNo,
    bool UpdateLists
)

Parameters

ConfNo
Type: System..::..String
The conf no. (extension)
UpdateLists
Type: System..::..Boolean
if set to true [update lists]. to reloas meetme.conf and dialplan

Return Value

0 if logged and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigDeleteQueue Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteQueue Method
AMI_Client Class See Also Send Feedback
Delete a queue definition from queues.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteQueue(
    string QueueExtension,
    bool Refresh
)
Visual Basic
Public Function ConfigDeleteQueue ( _
    QueueExtension As String, _
    Refresh As Boolean _
) As Integer
Visual C++
public:
int ConfigDeleteQueue(
    String^ QueueExtension,
    bool Refresh
)

Parameters

QueueExtension
Type: System..::..String
The queue number (extension).
Refresh
Type: System..::..Boolean
if set to true [refresh].

Return Value

0 if logged and command sent, -1 otherwise or Version < 1.4

See Also

AMI_Client Class


ConfigDeleteUser Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigDeleteUser Method
AMI_Client Class See Also Send Feedback
Delete a user definition from users.conf.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigDeleteUser(
    string UserExtension,
    bool Refresh
)
Visual Basic
Public Function ConfigDeleteUser ( _
    UserExtension As String, _
    Refresh As Boolean _
) As Integer
Visual C++
public:
int ConfigDeleteUser(
    String^ UserExtension,
    bool Refresh
)

Parameters

UserExtension
Type: System..::..String
The user extension.
Refresh
Type: System..::..Boolean
if set to true [refresh]. (reload users)

Return Value

0 if logged and command sent, -1 otherwise or Version < 1.4

See Also

AMI_Client Class


ConfigGetAgents Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetAgents Method
AMI_Client Class See Also Send Feedback
This will fill the _AgentsConfigList dictionary lists with one Dictionary entry for each agent defined in the agents.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetAgents()
Visual Basic
Public Sub ConfigGetAgents
Visual C++
public:
void ConfigGetAgents()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigGetConferences Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetConferences Method
AMI_Client Class See Also Send Feedback
This will fill the _ConferencesConfigList dictionary list with one Dictionary entry for each conference (or room) defined in the meetme.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetConferences()
Visual Basic
Public Sub ConfigGetConferences
Visual C++
public:
void ConfigGetConferences()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigGetFile Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetFile Method
AMI_Client Class See Also Send Feedback
Gets the given config file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigGetFile(
    string Filename
)
Visual Basic
Public Function ConfigGetFile ( _
    Filename As String _
) As Integer
Visual C++
public:
int ConfigGetFile(
    String^ Filename
)

Parameters

Filename
Type: System..::..String
The .conf filename to retreive.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a GetConfigEvent event

See Also

AMI_Client Class


ConfigGetInfo Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetInfo Method
AMI_Client Class See Also Send Feedback

[Missing <summary> documentation for "M:AMIgo.AMI_Client.ConfigGetInfo"]

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigGetInfo()
Visual Basic
Public Function ConfigGetInfo As Integer
Visual C++
public:
int ConfigGetInfo()

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

EVENTS: This command will generate several ConfigFileReadEvent events

See Also

AMI_Client Class


ConfigGetPreferences Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetPreferences Method
AMI_Client Class See Also Send Feedback
This will fill the _GuiPreferencesConfigList dictionary list with one Dictionary entry for each category defined in the guipreference.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetPreferences()
Visual Basic
Public Sub ConfigGetPreferences
Visual C++
public:
void ConfigGetPreferences()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigGetQueues Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetQueues Method
AMI_Client Class See Also Send Feedback
This will fill the _QueuesConfigList dictionary list with one Dictionary entry for each queue defined in the queues.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetQueues()
Visual Basic
Public Sub ConfigGetQueues
Visual C++
public:
void ConfigGetQueues()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigGetUpdateCount Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetUpdateCount Method
AMI_Client Class See Also Send Feedback
Returns the Update config. counter that keeps traks of the number of pending updates.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigGetUpdateCount()
Visual Basic
Public Function ConfigGetUpdateCount As Integer
Visual C++
public:
int ConfigGetUpdateCount()

Return Value

The value of _updateConfigCount

See Also

AMI_Client Class


ConfigGetUsers Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetUsers Method
AMI_Client Class See Also Send Feedback
This will fill the _UsersConfigList dictionary lists with one Dictionary entry for each user defined in the users.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetUsers()
Visual Basic
Public Sub ConfigGetUsers
Visual C++
public:
void ConfigGetUsers()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigGetVoicemail Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigGetVoicemail Method
AMI_Client Class See Also Send Feedback
This will fill the _VoicemailConfigList dictionary lists with one Dictionary entry for each voicemail user defined in the voicemail.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigGetVoicemail()
Visual Basic
Public Sub ConfigGetVoicemail
Visual C++
public:
void ConfigGetVoicemail()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


ConfigListCategories Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigListCategories Method
AMI_Client Class See Also Send Feedback
Gets the categories in the given config file. V1.6 and up only

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigListCategories(
    string Filename
)
Visual Basic
Public Function ConfigListCategories ( _
    Filename As String _
) As Integer
Visual C++
public:
int ConfigListCategories(
    String^ Filename
)

Parameters

Filename
Type: System..::..String
The .conf filename.

Return Value

0 if logged in, target asterisk >= V1.6 and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a RawMngrMsgEvent event

See Also

AMI_Client Class


ConfigOpenEditor Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigOpenEditor Method
AMI_Client Class See Also Send Feedback
Opens the config editor. with given filename and content.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigOpenEditor(
    string FileName,
    string[] Strings
)
Visual Basic
Public Sub ConfigOpenEditor ( _
    FileName As String, _
    Strings As String() _
)
Visual C++
public:
void ConfigOpenEditor(
    String^ FileName,
    array<String^>^ Strings
)

Parameters

FileName
Type: System..::..String
Name of the config file.
Strings
Type: array< System..::..String >[]()[][]
An array of strings with the content of the file

Remarks

This can be used in a GetConfigEvent event handler.

See Also

AMI_Client Class


ConfigSaveAgentsAdminOptions Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigSaveAgentsAdminOptions Method
AMI_Client Class See Also Send Feedback
Save agents admin options to the agents.conf config file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigSaveAgentsAdminOptions(
    string LoginExtension,
    string CBLoginExtension
)
Visual Basic
Public Sub ConfigSaveAgentsAdminOptions ( _
    LoginExtension As String, _
    CBLoginExtension As String _
)
Visual C++
public:
void ConfigSaveAgentsAdminOptions(
    String^ LoginExtension,
    String^ CBLoginExtension
)

Parameters

LoginExtension
Type: System..::..String
The agent login extension.
CBLoginExtension
Type: System..::..String
The agent callback login extension.

See Also

AMI_Client Class


ConfigSaveConferenceAdminOptions Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigSaveConferenceAdminOptions Method
AMI_Client Class See Also Send Feedback
Save conference admin options to the meetme.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigSaveConferenceAdminOptions(
    string AdminExtension,
    string FirstAvailable,
    string Dynamic
)
Visual Basic
Public Sub ConfigSaveConferenceAdminOptions ( _
    AdminExtension As String, _
    FirstAvailable As String, _
    Dynamic As String _
)
Visual C++
public:
void ConfigSaveConferenceAdminOptions(
    String^ AdminExtension,
    String^ FirstAvailable,
    String^ Dynamic
)

Parameters

AdminExtension
Type: System..::..String
Extension to access the conference as an administrator
FirstAvailable
Type: System..::..String
Extension to access 'first available' conference.
Dynamic
Type: System..::..String
Extension to access and creste a dynamic conference

See Also

AMI_Client Class


ConfigShowDialPlan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigShowDialPlan Method
AMI_Client Class See Also Send Feedback
List a given Context / extension from the dialplan (extensions.conf). V1.6 and up only

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigShowDialPlan(
    string Context,
    string Extension
)
Visual Basic
Public Function ConfigShowDialPlan ( _
    Context As String, _
    Extension As String _
) As Integer
Visual C++
public:
int ConfigShowDialPlan(
    String^ Context,
    String^ Extension
)

Parameters

Context
Type: System..::..String
(optional) The Context in the DialPlan
Extension
Type: System..::..String
(optional) The extension in the DialPlan

Return Value

0 if logged in, target asterisk >= V1.6 and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a RawMngrMsgEvent event

See Also

AMI_Client Class


ConfigUpdateAgent Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateAgent Method
AMI_Client Class See Also Send Feedback
Update an agent definition

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateAgent(
    AgentTypes AgentType,
    string AgentNo,
    string AgentPassword,
    string Name,
    string AgentEmail,
    string DefaultLocation,
    string MemberOf,
    string AgentGroupNo
)
Visual Basic
Public Function ConfigUpdateAgent ( _
    AgentType As AgentTypes, _
    AgentNo As String, _
    AgentPassword As String, _
    Name As String, _
    AgentEmail As String, _
    DefaultLocation As String, _
    MemberOf As String, _
    AgentGroupNo As String _
) As Integer
Visual C++
public:
int ConfigUpdateAgent(
    AgentTypes AgentType,
    String^ AgentNo,
    String^ AgentPassword,
    String^ Name,
    String^ AgentEmail,
    String^ DefaultLocation,
    String^ MemberOf,
    String^ AgentGroupNo
)

Parameters

AgentType
Type: AMIgo..::..AgentTypes
Type of the agent. Channel / Local
AgentNo
Type: System..::..String
The agent no.
AgentPassword
Type: System..::..String
The agent password.
Name
Type: System..::..String
The name.
AgentEmail
Type: System..::..String
The agent email. (Local agents only)
DefaultLocation
Type: System..::..String
The default location.(Local agents only)
MemberOf
Type: System..::..String
The list of queue this agent is a member of (Local agents only)
AgentGroupNo
Type: System..::..String
The agent group no. (Local agents only)

Return Value

0 if success -1 if not logged or Version < 1.4

See Also

AMI_Client Class


ConfigUpdateCategory Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateCategory Method
AMI_Client Class See Also Send Feedback
Update category in a .conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateCategory(
    string FileName,
    string Category,
    Dictionary<string, string> Dico,
    bool Reload
)
Visual Basic
Public Function ConfigUpdateCategory ( _
    FileName As String, _
    Category As String, _
    Dico As Dictionary(Of String, String), _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigUpdateCategory(
    String^ FileName,
    String^ Category,
    Dictionary<String^, String^>^ Dico,
    bool Reload
)

Parameters

FileName
Type: System..::..String
Name of the file.
Category
Type: System..::..String
The category.
Dico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The dictionary containing the category lines.
Reload
Type: System..::..Boolean
if set to true [reload].

Return Value

0 if Logged In and command sent, -1 otherwise or version < 1.4

See Also

AMI_Client Class


ConfigUpdateConference Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateConference Method
AMI_Client Class See Also Send Feedback
Update a conference definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateConference(
    Dictionary<string, string> ConfDico,
    string ConfName,
    string ConfNo,
    string ConfPIN,
    string Options
)
Visual Basic
Public Function ConfigUpdateConference ( _
    ConfDico As Dictionary(Of String, String), _
    ConfName As String, _
    ConfNo As String, _
    ConfPIN As String, _
    Options As String _
) As Integer
Visual C++
public:
int ConfigUpdateConference(
    Dictionary<String^, String^>^ ConfDico,
    String^ ConfName,
    String^ ConfNo,
    String^ ConfPIN,
    String^ Options
)

Parameters

ConfDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The conf dictionary containing the conference definition.
ConfName
Type: System..::..String
Name of the conf.
ConfNo
Type: System..::..String
The conf no.
ConfPIN
Type: System..::..String
The conf PIN.
Options
Type: System..::..String
The options.

Return Value

0 on success, -1 if not logged or Version < 1.4

See Also

AMI_Client Class


ConfigUpdateDefaultInclude Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateDefaultInclude Method
AMI_Client Class See Also Send Feedback
Test if the given context is in the list of includes in the 'default' context and update if needed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateDefaultInclude(
    string IncludeValue
)
Visual Basic
Public Function ConfigUpdateDefaultInclude ( _
    IncludeValue As String _
) As Integer
Visual C++
public:
int ConfigUpdateDefaultInclude(
    String^ IncludeValue
)

Parameters

IncludeValue
Type: System..::..String
The include value.

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

This function is used to include context in the 'default' context

See Also

AMI_Client Class


ConfigUpdateExtensionCategory Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateExtensionCategory Method
AMI_Client Class See Also Send Feedback
Update a category in the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateExtensionCategory(
    string Category,
    List<string> StrList,
    bool Reload
)
Visual Basic
Public Function ConfigUpdateExtensionCategory ( _
    Category As String, _
    StrList As List(Of String), _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigUpdateExtensionCategory(
    String^ Category,
    List<String^>^ StrList,
    bool Reload
)

Parameters

Category
Type: System..::..String
The category.
StrList
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The string list containing the lines to update.
Reload
Type: System..::..Boolean
if set to true [reload].

Return Value

0 on success, -1 if not logged or version < 1.4

See Also

AMI_Client Class


ConfigUpdateLine Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateLine Method
AMI_Client Class See Also Send Feedback
Update a given configuration line in a given .conf file

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateLine(
    string SrcFileName,
    string DstFileName,
    string Action,
    string Category,
    string Variable,
    string Value,
    string Match,
    bool Reload
)
Visual Basic
Public Function ConfigUpdateLine ( _
    SrcFileName As String, _
    DstFileName As String, _
    Action As String, _
    Category As String, _
    Variable As String, _
    Value As String, _
    Match As String, _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigUpdateLine(
    String^ SrcFileName,
    String^ DstFileName,
    String^ Action,
    String^ Category,
    String^ Variable,
    String^ Value,
    String^ Match,
    bool Reload
)

Parameters

SrcFileName
Type: System..::..String
Name of the Source .conf file.
DstFileName
Type: System..::..String
Name of the Destination .conf file.
Action
Type: System..::..String
The action. (NewCat,RenameCat,DelCat,Update,Delete,Append) (V1.6 and up NewCat,RenameCat,DelCat,EmptyCat,Update,Delete,Append,Insert)
Category
Type: System..::..String
The category.
Variable
Type: System..::..String
The variable.
Value
Type: System..::..String
The value.
Match
Type: System..::..String
This should match the original line and must be given for any Delete command. Can be set to "" otherwise
Reload
Type: System..::..Boolean
if set to true reloads after update.

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

EVENTS: This command will generate a ConfigUpdateEvent event.

See Also

AMI_Client Class


ConfigUpdateLines Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateLines Method
AMI_Client Class See Also Send Feedback
Update a given list of configuration lines in a givent .conf file

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateLines(
    string SrcFileName,
    string DstFileName,
    string[] Lines,
    bool Reload
)
Visual Basic
Public Function ConfigUpdateLines ( _
    SrcFileName As String, _
    DstFileName As String, _
    Lines As String(), _
    Reload As Boolean _
) As Integer
Visual C++
public:
int ConfigUpdateLines(
    String^ SrcFileName,
    String^ DstFileName,
    array<String^>^ Lines,
    bool Reload
)

Parameters

SrcFileName
Type: System..::..String
Name of the SRC file.
DstFileName
Type: System..::..String
Name of the DST file.
Lines
Type: array< System..::..String >[]()[][]
The lines as an array of strings.
Reload
Type: System..::..Boolean
if set to true reloads after update

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

NOTES: The array of strings must contains properly formated string for the manager UpdateConfig command: Each line to be modified must be defined with 4 (or 5) string in the following format.

Action-XXXXXX: Action to Take (NewCat,RenameCat,DelCat,Update,Delete,Append. V1.6 and up adds EmptyCat and Insert)

Cat-XXXXXX: Category to operate on

Var-XXXXXX: Variable to work on

Value-XXXXXX: Value to work on

Match-XXXXXX: Extra match required to match line (optional)

The XXXXXX must be a 6 digit string sequence number Ex: 000000

The sequence param must be incremented for each line to be modified

EVENTS: This command will generate a ConfigUpdateEvent event.

See Also

AMI_Client Class


ConfigUpdateQueue Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateQueue Method
AMI_Client Class See Also Send Feedback
Update a queue definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateQueue(
    Dictionary<string, string> QueueDico,
    string QueueNumber
)
Visual Basic
Public Function ConfigUpdateQueue ( _
    QueueDico As Dictionary(Of String, String), _
    QueueNumber As String _
) As Integer
Visual C++
public:
int ConfigUpdateQueue(
    Dictionary<String^, String^>^ QueueDico,
    String^ QueueNumber
)

Parameters

QueueDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The queue dictionary which contains the queue definition.
QueueNumber
Type: System..::..String
The queue number.

Return Value

0 on success, -1 if not logged oe Version < 1.4

See Also

AMI_Client Class


ConfigUpdateUser Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateUser Method
AMI_Client Class See Also Send Feedback
Update a User definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ConfigUpdateUser(
    Dictionary<string, string> UserDico,
    string UserNumber
)
Visual Basic
Public Function ConfigUpdateUser ( _
    UserDico As Dictionary(Of String, String), _
    UserNumber As String _
) As Integer
Visual C++
public:
int ConfigUpdateUser(
    Dictionary<String^, String^>^ UserDico,
    String^ UserNumber
)

Parameters

UserDico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The user dictionary containing the user definition.
UserNumber
Type: System..::..String
The user number.

Return Value

0 if success -1 if not logged

See Also

AMI_Client Class


ConfigWriteAgentAdminDiaplan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigWriteAgentAdminDiaplan Method
AMI_Client Class See Also Send Feedback
Write the agent admin lines to the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigWriteAgentAdminDiaplan(
    List<string> OutStrsList,
    string AgentQueueExtDef,
    int ExtSize
)
Visual Basic
Public Sub ConfigWriteAgentAdminDiaplan ( _
    OutStrsList As List(Of String), _
    AgentQueueExtDef As String, _
    ExtSize As Integer _
)
Visual C++
public:
void ConfigWriteAgentAdminDiaplan(
    List<String^>^ OutStrsList,
    String^ AgentQueueExtDef,
    int ExtSize
)

Parameters

OutStrsList
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The agent admin line to write to the DP
AgentQueueExtDef
Type: System..::..String
The agent queue ext def.
ExtSize
Type: System..::..Int32
Size of the extensions (3 or 4).

See Also

AMI_Client Class


ConfigWriteDialplanQueuesList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigWriteDialplanQueuesList Method
AMI_Client Class See Also Send Feedback
Write the queues to the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigWriteDialplanQueuesList(
    List<string> OutStrsList
)
Visual Basic
Public Sub ConfigWriteDialplanQueuesList ( _
    OutStrsList As List(Of String) _
)
Visual C++
public:
void ConfigWriteDialplanQueuesList(
    List<String^>^ OutStrsList
)

Parameters

OutStrsList
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A string list containing the lines to wtite to ther DP

See Also

AMI_Client Class


ConfigWriteDiaplanConferencesAdminToList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigWriteDiaplanConferencesAdminToList Method
AMI_Client Class See Also Send Feedback
Write the conferences admin lines to the dialplan. (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigWriteDiaplanConferencesAdminToList(
    List<string> OutStrsList
)
Visual Basic
Public Sub ConfigWriteDiaplanConferencesAdminToList ( _
    OutStrsList As List(Of String) _
)
Visual C++
public:
void ConfigWriteDiaplanConferencesAdminToList(
    List<String^>^ OutStrsList
)

Parameters

OutStrsList
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A string list containing the lines to write to the dialplan

See Also

AMI_Client Class


ConfigWriteDiaplanConferencesToList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigWriteDiaplanConferencesToList Method
AMI_Client Class See Also Send Feedback
Write the conferences to the dialplan. (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigWriteDiaplanConferencesToList(
    List<string> OutStrsList
)
Visual Basic
Public Sub ConfigWriteDiaplanConferencesToList ( _
    OutStrsList As List(Of String) _
)
Visual C++
public:
void ConfigWriteDiaplanConferencesToList(
    List<String^>^ OutStrsList
)

Parameters

OutStrsList
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A string list containing the lines to write to the dialplan

See Also

AMI_Client Class


Connect Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..Connect Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect()()()() | Connect to the Asterisk Manager server with given parameters set as properties. Change the control state to CONNECTED on success.
Public method | Connect(AstSite) | Connect to the Asterisk Manager server at location / login given by the AstSite parameter. Change the control state to CONNECTED on success.

See Also

AMI_Client Class
AMI_Client Members


Connect Method

[image]

AMIgo Controls documentation
AMI_Client..::..Connect Method
AMI_Client Class See Also Send Feedback
Connect to the Asterisk Manager server with given parameters set as properties. Change the control state to CONNECTED on success.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect
Visual C++
public:
void Connect()

Remarks

If the AutoLogin property is set to true, the Login()()()() method will be called using the AstMngrUserName and AstMngrPassword properties. Otherwise a call to the Login method will be required before sending any command.

See Also

AMI_Client Class
Connect Overload


Connect Method (AstSite)

[image]

AMIgo Controls documentation
AMI_Client..::..Connect Method (AstSite)
AMI_Client Class See Also Send Feedback
Connect to the Asterisk Manager server at location / login given by the AstSite parameter. Change the control state to CONNECTED on success.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Connect(
    AstSite ASite
)
Visual Basic
Public Sub Connect ( _
    ASite As AstSite _
)
Visual C++
public:
void Connect(
    AstSite^ ASite
)

Parameters

ASite
Type: AMIgo..::..AstSite
An AstSite object reference containing the AM connection and loggin info

Remarks

If the AutoLogin property is set to true, the Login()()()() method will be called using the AstMngrUserName and AstMngrPassword properties. Otherwise a call to the Login method will be required before sending any command.

See Also

AMI_Client Class
Connect Overload


ConvertFromUnixTimestamp Method

[image]

AMIgo Controls documentation
AMI_Client..::..ConvertFromUnixTimestamp Method
AMI_Client Class See Also Send Feedback
Converts from unix timestamp to DateTime

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public static DateTime ConvertFromUnixTimestamp(
    double timestamp
)
Visual Basic
Public Shared Function ConvertFromUnixTimestamp ( _
    timestamp As Double _
) As DateTime
Visual C++
public:
static DateTime ConvertFromUnixTimestamp(
    double timestamp
)

Parameters

timestamp
Type: System..::..Double
The UNIX timestamp.

Return Value

A DateTime object containing the converted date

See Also

AMI_Client Class


CoreSettings Method

[image]

AMIgo Controls documentation
AMI_Client..::..CoreSettings Method
AMI_Client Class See Also Send Feedback
Get asterisk core settings. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int CoreSettings()
Visual Basic
Public Function CoreSettings As Integer
Visual C++
public:
int CoreSettings()

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


CoreStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..CoreStatus Method
AMI_Client Class See Also Send Feedback
Get asterisk core status. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int CoreStatus()
Visual Basic
Public Function CoreStatus As Integer
Visual C++
public:
int CoreStatus()

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


DBDel Method

[image]

AMIgo Controls documentation
AMI_Client..::..DBDel Method
AMI_Client Class See Also Send Feedback
Delete a value from the AstDB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DBDel(
    string Family,
    string Key
)
Visual Basic
Public Function DBDel ( _
    Family As String, _
    Key As String _
) As Integer
Visual C++
public:
int DBDel(
    String^ Family,
    String^ Key
)

Parameters

Family
Type: System..::..String
The DB family.
Key
Type: System..::..String
The DB key.

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

EVENTS: This command will generate a DBEvent event.

See Also

AMI_Client Class


DBDelTree Method

[image]

AMIgo Controls documentation
AMI_Client..::..DBDelTree Method
AMI_Client Class See Also Send Feedback
Delete a whole family tree from the AstDB. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DBDelTree(
    string Family,
    string Key
)
Visual Basic
Public Function DBDelTree ( _
    Family As String, _
    Key As String _
) As Integer
Visual C++
public:
int DBDelTree(
    String^ Family,
    String^ Key
)

Parameters

Family
Type: System..::..String
The DB family.
Key
Type: System..::..String
The key.

Return Value

0 if Logged In and command sent, -1 otherwise

Remarks

EVENTS: This command will generate a DBEvent event.

See Also

AMI_Client Class


DBGet Method

[image]

AMIgo Controls documentation
AMI_Client..::..DBGet Method
AMI_Client Class See Also Send Feedback
Gets a value from the Ast DB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DBGet(
    string Family,
    string Key
)
Visual Basic
Public Function DBGet ( _
    Family As String, _
    Key As String _
) As Integer
Visual C++
public:
int DBGet(
    String^ Family,
    String^ Key
)

Parameters

Family
Type: System..::..String
The DB family.
Key
Type: System..::..String
The DB key.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a DBEvent event.

See Also

AMI_Client Class


DBGetLocalAgent Method

[image]

AMIgo Controls documentation
AMI_Client..::..DBGetLocalAgent Method
AMI_Client Class See Also Send Feedback
Gets a value from the Ast DB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DBGetLocalAgent(
    string AgentNo
)
Visual Basic
Public Function DBGetLocalAgent ( _
    AgentNo As String _
) As Integer
Visual C++
public:
int DBGetLocalAgent(
    String^ AgentNo
)

Parameters

AgentNo
Type: System..::..String
The Local Agent Number.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a DBEvent event.

See Also

AMI_Client Class


DBPut Method

[image]

AMIgo Controls documentation
AMI_Client..::..DBPut Method
AMI_Client Class See Also Send Feedback
Set a value into the AstDB

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DBPut(
    string Family,
    string Key,
    string Value
)
Visual Basic
Public Function DBPut ( _
    Family As String, _
    Key As String, _
    Value As String _
) As Integer
Visual C++
public:
int DBPut(
    String^ Family,
    String^ Key,
    String^ Value
)

Parameters

Family
Type: System..::..String
The DB family.
Key
Type: System..::..String
The DB key.
Value
Type: System..::..String
The value.

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENTS: This command will generate a DBEvent event.

See Also

AMI_Client Class


DialPlanAddHint Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanAddHint Method
AMI_Client Class See Also Send Feedback
Adds a 'hint' to the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int DialPlanAddHint(
    string Extension,
    string Hint
)
Visual Basic
Public Function DialPlanAddHint ( _
    Extension As String, _
    Hint As String _
) As Integer
Visual C++
public:
int DialPlanAddHint(
    String^ Extension,
    String^ Hint
)

Parameters

Extension
Type: System..::..String
The extension. ex: 6000
Hint
Type: System..::..String
The hint. in the form Tech/Data. Ex: Zap/1, SIP/6000

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


DialPlanBuildList Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanBuildList Method
AMI_Client Class See Also Send Feedback
Scan the dialplan dico list and build defined Dialplan list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanBuildList(
    ComboBox..::..ObjectCollection Items
)
Visual Basic
Public Sub DialPlanBuildList ( _
    Items As ComboBox..::..ObjectCollection _
)
Visual C++
public:
void DialPlanBuildList(
    ComboBox..::..ObjectCollection^ Items
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan

Remarks

This method scan the dico category and searche for category stating with "DLPN_", which is the default naming scheme for dialplan in the Asterisk GUI. It will not find any othe dialplan that does not follow this naming scheme

See Also

AMI_Client Class


DialPlanGetApplicationsList Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanGetApplicationsList Method
AMI_Client Class Example See Also Send Feedback
This function reads the extensions.conf [applications] Context and parses the applications into a string list. See: _DialplanApplicationsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanGetApplicationsList()
Visual Basic
Public Sub DialPlanGetApplicationsList
Visual C++
public:
void DialPlanGetApplicationsList()

Remarks

Names can be assigned to applictions by using a 'Noop(AppName) 'line as the first line of the application

Examples

exten => 1000,1,Noop(MyAppName)

See Also

AMI_Client Class


DialPlanGetConferencesList Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanGetConferencesList Method
AMI_Client Class See Also Send Feedback
Gets the conferences list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanGetConferencesList()
Visual Basic
Public Sub DialPlanGetConferencesList
Visual C++
public:
void DialPlanGetConferencesList()

Remarks

This function reads the extensions.conf [conferences] Context and parses the defined conferences into a string List. See: _DialplanConferencesList NOTE: Names can be assigned to conferences by using a xxx,1,Noop("ConfName") as the first line of each queue defined in the dialplan.

See Also

AMI_Client Class


DialPlanGetQueuesList Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanGetQueuesList Method
AMI_Client Class See Also Send Feedback
Gets the queues list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanGetQueuesList()
Visual Basic
Public Sub DialPlanGetQueuesList
Visual C++
public:
void DialPlanGetQueuesList()

Remarks

This function reads the extensions.conf [queues] Context and parses the defined queues into a string List. See: _DialplanQueuesList NOTE: Names can be assigned to queues by using a xxx,1,Noop("QueueName") as the first line of each queue defined in the dialplan.

See Also

AMI_Client Class


DialPlanGetVoiceMenusList Method

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanGetVoiceMenusList Method
AMI_Client Class See Also Send Feedback
Gets the voice menus list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanGetVoiceMenusList()
Visual Basic
Public Sub DialPlanGetVoiceMenusList
Visual C++
public:
void DialPlanGetVoiceMenusList()

Remarks

This function reads the extensions.conf [voicemenus] Context and parses the defined voice menus into a string List. See: _DialplanVoiceMenusList NOTE: Names can be assigned to voice menus by using xxx,1,Noop("VoiceMenuName") as the first line of each queue defined in the dialplan.

See Also

AMI_Client Class


Disconnect Method

[image]

AMIgo Controls documentation
AMI_Client..::..Disconnect Method
AMI_Client Class See Also Send Feedback
Disconnect from the target system. A LogOff command should be issued first.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect
Visual C++
public:
void Disconnect()

Remarks

EVENTS: This command will generate the following events:

CmdResultEvent, StateChangeEvent, StatusEvent

See Also

AMI_Client Class


Dispose Method

[image]

AMIgo Controls documentation
AMI_Client..::..Dispose Method
AMI_Client Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMI_Client Class


DoAutoGetConfig Method

[image]

AMIgo Controls documentation
AMI_Client..::..DoAutoGetConfig Method
AMI_Client Class See Also Send Feedback
Execute the auto login. Sends commands to get lines/trunks/registration, channels, queues, agents, voicemail, conference infos, etc and parse the result into AMIgo SyncLists AutoLogin

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DoAutoGetConfig()
Visual Basic
Public Sub DoAutoGetConfig
Visual C++
public:
void DoAutoGetConfig()

Remarks

This function is normally called internally when AutoLogon is set to true.

See Also

AMI_Client Class


ExtensionCallChannelSpy Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtensionCallChannelSpy Method
AMI_Client Class See Also Send Feedback
Originate a call to the given extension and starts 'spying' on SIP channels.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ExtensionCallChannelSpy(
    string ExtenFullName,
    string ChanPrefix,
    string Options
)
Visual Basic
Public Function ExtensionCallChannelSpy ( _
    ExtenFullName As String, _
    ChanPrefix As String, _
    Options As String _
) As Integer
Visual C++
public:
int ExtensionCallChannelSpy(
    String^ ExtenFullName,
    String^ ChanPrefix,
    String^ Options
)

Parameters

ExtenFullName
Type: System..::..String
Full name of the exten.
ChanPrefix
Type: System..::..String
An option channel prefix to restrain the spied channels
Options
Type: System..::..String
The options. See the ChanSpy applications for details

Return Value

0 if logged and command sent

See Also

AMI_Client Class


ExtensionGetState Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtensionGetState Method
AMI_Client Class See Also Send Feedback
Get the status of a given extension and update the AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ExtensionGetState(
    string Extension,
    string Context
)
Visual Basic
Public Function ExtensionGetState ( _
    Extension As String, _
    Context As String _
) As Integer
Visual C++
public:
int ExtensionGetState(
    String^ Extension,
    String^ Context
)

Parameters

Extension
Type: System..::..String
The extension number (No SIP/IAX/ZAP/DAHDI)
Context
Type: System..::..String
The Context, usually "default"

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


ExtensionsBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..ExtensionsBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExtensionsBuildList(String, Boolean) | Returns a string list of available extensions.
Public method | ExtensionsBuildList(ComboBox..::..ObjectCollection, String, Boolean) | Fills the given ComboBox items with a list of available extensions.

See Also

AMI_Client Class
AMI_Client Members


ExtensionsBuildList Method (String, Boolean)

[image]

AMIgo Controls documentation
AMI_Client..::..ExtensionsBuildList Method (String, Boolean)
AMI_Client Class See Also Send Feedback
Returns a string list of available extensions.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> ExtensionsBuildList(
    string SrcName,
    bool UseFullName
)
Visual Basic
Public Function ExtensionsBuildList ( _
    SrcName As String, _
    UseFullName As Boolean _
) As List(Of String)
Visual C++
public:
List<String^>^ ExtensionsBuildList(
    String^ SrcName,
    bool UseFullName
)

Parameters

SrcName
Type: System..::..String
Name of an item to exclude from list
UseFullName
Type: System..::..Boolean
if set to true [use full name].

Return Value

A string list of the available extension

Remarks

This list is compiled from the AstUsersObject list

See Also

AMI_Client Class
ExtensionsBuildList Overload


ExtensionsBuildList Method (ComboBox.ObjectCollection, String, Boolean)

[image]

AMIgo Controls documentation
AMI_Client..::..ExtensionsBuildList Method (ComboBox..::..ObjectCollection, String, Boolean)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of available extensions.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ExtensionsBuildList(
    ComboBox..::..ObjectCollection Items,
    string SrcName,
    bool UseFullName
)
Visual Basic
Public Sub ExtensionsBuildList ( _
    Items As ComboBox..::..ObjectCollection, _
    SrcName As String, _
    UseFullName As Boolean _
)
Visual C++
public:
void ExtensionsBuildList(
    ComboBox..::..ObjectCollection^ Items,
    String^ SrcName,
    bool UseFullName
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan
SrcName
Type: System..::..String
Name of an item to exclude from list
UseFullName
Type: System..::..Boolean
if set to true [use full name].

Remarks

This lis is compiled from the AstUsersObjects list

See Also

AMI_Client Class
ExtensionsBuildList Overload


ExtensionsGetStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtensionsGetStatus Method
AMI_Client Class See Also Send Feedback
Gets all of the defined extensions statuses and update the AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ExtensionsGetStatus()
Visual Basic
Public Function ExtensionsGetStatus As Integer
Visual C++
public:
int ExtensionsGetStatus()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command may generate several AstUsersObjectEvent events.

See Also

AMI_Client Class


ExtractAgentNo Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtractAgentNo Method
AMI_Client Class See Also Send Feedback
Extracts the agent no. from a full agent name (Ex: Agent/6007, Local/6000)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ExtractAgentNo(
    string AgentFullName
)
Visual Basic
Public Function ExtractAgentNo ( _
    AgentFullName As String _
) As String
Visual C++
public:
String^ ExtractAgentNo(
    String^ AgentFullName
)

Parameters

AgentFullName
Type: System..::..String
Full name of the agent.

Return Value

A string with the Agent number

See Also

AMI_Client Class


ExtractExtensionNo Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtractExtensionNo Method
AMI_Client Class See Also Send Feedback
Extracts the extension no. from the given tech/ext-no

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ExtractExtensionNo(
    string ExtensionFullName
)
Visual Basic
Public Function ExtractExtensionNo ( _
    ExtensionFullName As String _
) As String
Visual C++
public:
String^ ExtractExtensionNo(
    String^ ExtensionFullName
)

Parameters

ExtensionFullName
Type: System..::..String
Full name of the extension.

Return Value

A string with the extension number

See Also

AMI_Client Class


ExtractFromMsg Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtractFromMsg Method
AMI_Client Class See Also Send Feedback
Extracts the value for given parameter from a 'raw' manager message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ExtractFromMsg(
    string[] InStrs,
    string Param
)
Visual Basic
Public Function ExtractFromMsg ( _
    InStrs As String(), _
    Param As String _
) As String
Visual C++
public:
String^ ExtractFromMsg(
    array<String^>^ InStrs,
    String^ Param
)

Parameters

InStrs
Type: array< System..::..String >[]()[][]
An array of string containing the message
Param
Type: System..::..String
The param. to extract. Ex: Channel:

Return Value

The value of the parameter or "" if not found

See Also

AMI_Client Class


ExtractZapAliasName Method

[image]

AMIgo Controls documentation
AMI_Client..::..ExtractZapAliasName Method
AMI_Client Class See Also Send Feedback
Extracts the name of the zap alias. (extension associated with Zap channel) from given string in the form Zap/1 (1234)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ExtractZapAliasName(
    string ExtensionFullName
)
Visual Basic
Public Function ExtractZapAliasName ( _
    ExtensionFullName As String _
) As String
Visual C++
public:
String^ ExtractZapAliasName(
    String^ ExtensionFullName
)

Parameters

ExtensionFullName
Type: System..::..String
Full name of the extension.

Return Value

Any Zap alias name found

See Also

AMI_Client Class


GetAsteriskVersion Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetAsteriskVersion Method
AMI_Client Class See Also Send Feedback
Fills the _AsteriskVersion... public fields with the version given by the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void GetAsteriskVersion()
Visual Basic
Public Sub GetAsteriskVersion
Visual C++
public:
void GetAsteriskVersion()

Remarks

If the AutoLogin property is set to true, a call to the ChannelsGetTypes()()()() method will be issued.

EVENTS: This command will generate the following event: StateChangeEvent and VersionEvent

See Also

AMI_Client Class


GetDicoIndexInList Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetDicoIndexInList Method
AMI_Client Class See Also Send Feedback
Gets the dico index in list of a given Category. returns -1 if not found

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int GetDicoIndexInList(
    List<Dictionary<string, string>> DicoList,
    string Category
)
Visual Basic
Public Function GetDicoIndexInList ( _
    DicoList As List(Of Dictionary(Of String, String)), _
    Category As String _
) As Integer
Visual C++
public:
int GetDicoIndexInList(
    List<Dictionary<String^, String^>^>^ DicoList,
    String^ Category
)

Parameters

DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
The dico list.
Category
Type: System..::..String
The category.

Return Value

Index of dico in given list or -1 if not found

Remarks

Used internally to retreive values from config infos

See Also

AMI_Client Class


GetExtensionsConfig Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetExtensionsConfig Method
AMI_Client Class See Also Send Feedback
This will fill the _ExtensionsConfigList dictionary list with one Dictionary entry for each category defined in the extensions.conf file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void GetExtensionsConfig()
Visual Basic
Public Sub GetExtensionsConfig
Visual C++
public:
void GetExtensionsConfig()

Remarks

EVENTS: This command will generate a ConfigFileReadEvent event.

See Also

AMI_Client Class


GetLinesInfos Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetLinesInfos Method
AMI_Client Class See Also Send Feedback
Gets the Lines (Extensions and trunks) information. This fills the AstUsersObjectsList with the SIP / IAX / ZAP/DAHDI peers and registrations.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int GetLinesInfos()
Visual Basic
Public Function GetLinesInfos As Integer
Visual C++
public:
int GetLinesInfos()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This method sends several commands which generate AstUsersObjectEventevents. SIP_PeersGetDef()()()(), IAX2_PeersGetDef()()()(), SIP_GetRegistry()()()(), IAX2_GetRegistry()()()(), ZAPorDAHDI_GetDef()()()()

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


GetOriginateDataFromItems Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetOriginateDataFromItems Method
AMI_Client Class See Also Send Feedback
Translate extensions name if needed and parse dest strings for originate call.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void GetOriginateDataFromItems(
    string SrcItemName,
    string DstItemName,
    out string SrcName,
    out string DstName
)
Visual Basic
Public Sub GetOriginateDataFromItems ( _
    SrcItemName As String, _
    DstItemName As String, _
    <OutAttribute> ByRef SrcName As String, _
    <OutAttribute> ByRef DstName As String _
)
Visual C++
public:
void GetOriginateDataFromItems(
    String^ SrcItemName,
    String^ DstItemName,
    [OutAttribute] String^% SrcName,
    [OutAttribute] String^% DstName
)

Parameters

SrcItemName
Type: System..::..String
Name of the SRC item.
DstItemName
Type: System..::..String
Name of the DST item.
SrcName
Type: System..::..String %
Name of the translated SRC.
DstName
Type: System..::..String %
Name of the translated DST.

See Also

AMI_Client Class


GetSubItemTextByColumnName Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetSubItemTextByColumnName Method
AMI_Client Class See Also Send Feedback
Gets the name of the given ListView sub item text by column.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string GetSubItemTextByColumnName(
    ListView ListView,
    ListViewItem Item,
    string ColumnName
)
Visual Basic
Public Function GetSubItemTextByColumnName ( _
    ListView As ListView, _
    Item As ListViewItem, _
    ColumnName As String _
) As String
Visual C++
public:
String^ GetSubItemTextByColumnName(
    ListView^ ListView,
    ListViewItem^ Item,
    String^ ColumnName
)

Parameters

ListView
Type: System.Windows.Forms..::..ListView
The ListView.
Item
Type: System.Windows.Forms..::..ListViewItem
The item.
ColumnName
Type: System..::..String
Name of the column.

Return Value

The SubItem text or "" if not found

See Also

AMI_Client Class


GetValueFromDictionaryList Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetValueFromDictionaryList Method
AMI_Client Class See Also Send Feedback
Returns a string from a givent dictionary list

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int GetValueFromDictionaryList(
    List<Dictionary<string, string>> DicoList,
    string Category,
    string ItemName,
    ref string Value
)
Visual Basic
Public Function GetValueFromDictionaryList ( _
    DicoList As List(Of Dictionary(Of String, String)), _
    Category As String, _
    ItemName As String, _
    ByRef Value As String _
) As Integer
Visual C++
public:
int GetValueFromDictionaryList(
    List<Dictionary<String^, String^>^>^ DicoList,
    String^ Category,
    String^ ItemName,
    String^% Value
)

Parameters

DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
One of the Dictionary list
Category
Type: System..::..String
The dico category value
ItemName
Type: System..::..String
The name of the item to retreive
Value
Type: System..::..String %
ref to a string in which the value (if found) is returned

Return Value

The index of the dico in the list or -1 if not found

See Also

AMI_Client Class


GetVoicemailInfos Method

[image]

AMIgo Controls documentation
AMI_Client..::..GetVoicemailInfos Method
AMI_Client Class See Also Send Feedback
Retreive and parse the voicemail users information. This will create a list accessible with the readonly property : AstVoicemailList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void GetVoicemailInfos()
Visual Basic
Public Sub GetVoicemailInfos
Visual C++
public:
void GetVoicemailInfos()

See Also

AMI_Client Class


IAX2_GetRegistry Method

[image]

AMIgo Controls documentation
AMI_Client..::..IAX2_GetRegistry Method
AMI_Client Class See Also Send Feedback
Get the IAX2 registrations and parse into AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int IAX2_GetRegistry()
Visual Basic
Public Function IAX2_GetRegistry As Integer
Visual C++
public:
int IAX2_GetRegistry()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


IAX2_PeersGetDef Method

[image]

AMIgo Controls documentation
AMI_Client..::..IAX2_PeersGetDef Method
AMI_Client Class See Also Send Feedback
Get the IAX2 peers and parse into the AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int IAX2_PeersGetDef()
Visual Basic
Public Function IAX2_PeersGetDef As Integer
Visual C++
public:
int IAX2_PeersGetDef()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


LinesRefresh Method

[image]

AMIgo Controls documentation
AMI_Client..::..LinesRefresh Method
AMI_Client Class See Also Send Feedback
Refreshes the _astObjList. Sends command to get ZAP/DAHDI/SIP/IAX peers and registry informations.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int LinesRefresh()
Visual Basic
Public Function LinesRefresh As Integer
Visual C++
public:
int LinesRefresh()

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


LocalAgentCallbackLogin Method

[image]

AMIgo Controls documentation
AMI_Client..::..LocalAgentCallbackLogin Method
AMI_Client Class See Also Send Feedback
Login a Local agent with Callback. Add the agent in the given queue and sets the callback extension in the AstDB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int LocalAgentCallbackLogin(
    string Queue,
    string Agent,
    string Exten
)
Visual Basic
Public Function LocalAgentCallbackLogin ( _
    Queue As String, _
    Agent As String, _
    Exten As String _
) As Integer
Visual C++
public:
int LocalAgentCallbackLogin(
    String^ Queue,
    String^ Agent,
    String^ Exten
)

Parameters

Queue
Type: System..::..String
The queue number.
Agent
Type: System..::..String
The Local agent name. Ex: Local/6700
Exten
Type: System..::..String
The exten.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AgentEvent, AgentSessionEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstAgentSession


LocalAgentLogoff Method

[image]

AMIgo Controls documentation
AMI_Client..::..LocalAgentLogoff Method
AMI_Client Class See Also Send Feedback
Logs off a Local agent. Remove from queue and sets the extension into AstDB to 'n/a'

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int LocalAgentLogoff(
    string Queue,
    string Agent
)
Visual Basic
Public Function LocalAgentLogoff ( _
    Queue As String, _
    Agent As String _
) As Integer
Visual C++
public:
int LocalAgentLogoff(
    String^ Queue,
    String^ Agent
)

Parameters

Queue
Type: System..::..String
The queue.
Agent
Type: System..::..String
The agent.

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


LocalAgentsGetStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..LocalAgentsGetStatus Method
AMI_Client Class See Also Send Feedback
Gets the local agents status from the AstDB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int LocalAgentsGetStatus()
Visual Basic
Public Function LocalAgentsGetStatus As Integer
Visual C++
public:
int LocalAgentsGetStatus()

Return Value

0 if logged in and command sent, -1 otherwise. An AgentEvent will occurs for each active channel

Remarks

EVENTS: AgentEvent, AstAgent

See Also

AMI_Client Class


Login Method

[image]

AMIgo Controls documentation
AMI_Client..::..Login Method
AMI_Client Class See Also Send Feedback
Called after connect to login to the asterisk manager server.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Login()
Visual Basic
Public Sub Login
Visual C++
public:
void Login()

Remarks

You must call Connect first to establish the connection. This command must be issued and succeed before any others command are sent. The AstMngrUserName and AstMngrPassword properties must be set before calling this function.

If the AutoLogin property is set to true, the GetAsteriskVersion()()()() method will be called.

EVENTS: This command will generate the following events: StatusEvent, StateChangeEvent, ErrorEvent (if an error occurs when loggin in).

See Also

AMI_Client Class


Logoff Method

[image]

AMIgo Controls documentation
AMI_Client..::..Logoff Method
AMI_Client Class See Also Send Feedback
Logoff from the currently connected asterisk manager server.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Logoff()
Visual Basic
Public Sub Logoff
Visual C++
public:
void Logoff()

Remarks

Should be used before disconnect to 'cleanly' exit the Asterisk Manager session.

EVENTS: This command will generate the following events: CmdResultEvent, StateChangeEvent

See Also

AMI_Client Class


MailboxGetCount Method

[image]

AMIgo Controls documentation
AMI_Client..::..MailboxGetCount Method
AMI_Client Class See Also Send Feedback
Gets the numbers of voicemail in the given Mailbox

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MailboxGetCount(
    string Mailbox
)
Visual Basic
Public Function MailboxGetCount ( _
    Mailbox As String _
) As Integer
Visual C++
public:
int MailboxGetCount(
    String^ Mailbox
)

Parameters

Mailbox
Type: System..::..String
The Mailbox.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: MbxCountEvent

See Also

AMI_Client Class


ManagerCommandsGetList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ManagerCommandsGetList Method
AMI_Client Class See Also Send Feedback
Fills the string list _ManagerCommandsList with the list of available manager commands

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ManagerCommandsGetList()
Visual Basic
Public Function ManagerCommandsGetList As Integer
Visual C++
public:
int ManagerCommandsGetList()

Return Value

0 if logged in and command sent, -1 otherwise.

Remarks

EVENT: This command will generate a ManagerCommandsListEvent event.

See Also

AMI_Client Class


MeetmeKick Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeKick Method
AMI_Client Class See Also Send Feedback
Kick a Meetme conference user out.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeKick(
    string ConfNo,
    string UserNo
)
Visual Basic
Public Function MeetmeKick ( _
    ConfNo As String, _
    UserNo As String _
) As Integer
Visual C++
public:
int MeetmeKick(
    String^ ConfNo,
    String^ UserNo
)

Parameters

ConfNo
Type: System..::..String
The conf no.
UserNo
Type: System..::..String
The user no.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


MeetmeList Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeList Method
AMI_Client Class See Also Send Feedback
List the meetme conferences

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeList()
Visual Basic
Public Function MeetmeList As Integer
Visual C++
public:
int MeetmeList()

Return Value

0 if Logged In, Version >= 1.6 and command sent, -1 otherwise

See Also

AMI_Client Class


MeetmeLock Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeLock Method
AMI_Client Class See Also Send Feedback
Lock a given conference. (does not accept any new user)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeLock(
    string ConfNo
)
Visual Basic
Public Function MeetmeLock ( _
    ConfNo As String _
) As Integer
Visual C++
public:
int MeetmeLock(
    String^ ConfNo
)

Parameters

ConfNo
Type: System..::..String
The conf no.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


MeetmeMute Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeMute Method
AMI_Client Class See Also Send Feedback
Mute a Meetme conference user

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeMute(
    string ConfNo,
    string UserNo
)
Visual Basic
Public Function MeetmeMute ( _
    ConfNo As String, _
    UserNo As String _
) As Integer
Visual C++
public:
int MeetmeMute(
    String^ ConfNo,
    String^ UserNo
)

Parameters

ConfNo
Type: System..::..String
The conf no.
UserNo
Type: System..::..String
The user no.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


MeetmeUnlock Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeUnlock Method
AMI_Client Class See Also Send Feedback
Unlock a given conference. (Accept new users)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeUnlock(
    string ConfNo
)
Visual Basic
Public Function MeetmeUnlock ( _
    ConfNo As String _
) As Integer
Visual C++
public:
int MeetmeUnlock(
    String^ ConfNo
)

Parameters

ConfNo
Type: System..::..String
The conf no.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


MeetmeUnmute Method

[image]

AMIgo Controls documentation
AMI_Client..::..MeetmeUnmute Method
AMI_Client Class See Also Send Feedback
Unmute a Meetme conference user

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MeetmeUnmute(
    string ConfNo,
    string UserNo
)
Visual Basic
Public Function MeetmeUnmute ( _
    ConfNo As String, _
    UserNo As String _
) As Integer
Visual C++
public:
int MeetmeUnmute(
    String^ ConfNo,
    String^ UserNo
)

Parameters

ConfNo
Type: System..::..String
The conf no.
UserNo
Type: System..::..String
The user no.

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


ModulesGetList Method

[image]

AMIgo Controls documentation
AMI_Client..::..ModulesGetList Method
AMI_Client Class See Also Send Feedback
Get a list of the loaded modules on the currently connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ModulesGetList()
Visual Basic
Public Function ModulesGetList As Integer
Visual C++
public:
int ModulesGetList()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: ModuleListEvent

See Also

AMI_Client Class


OnAstChannelEvent Method

[image]

AMIgo Controls documentation
AMI_Client..::..OnAstChannelEvent Method
AMI_Client Class See Also Send Feedback
Raises the AstChannelEvent event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected virtual void OnAstChannelEvent(
    AstChannelEventArgs e
)
Visual Basic
Protected Overridable Sub OnAstChannelEvent ( _
    e As AstChannelEventArgs _
)
Visual C++
protected:
virtual void OnAstChannelEvent(
    AstChannelEventArgs^ e
)

Parameters

e
Type: AMIgo..::..AstChannelEventArgs
The AstChannelEventArgs instance containing the event data.

See Also

AMI_Client Class


OnAstUsersObjectEvent Method

[image]

AMIgo Controls documentation
AMI_Client..::..OnAstUsersObjectEvent Method
AMI_Client Class See Also Send Feedback
Raises the AstUsersObjectEvent event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected virtual void OnAstUsersObjectEvent(
    AstUsersObjectEventArgs e
)
Visual Basic
Protected Overridable Sub OnAstUsersObjectEvent ( _
    e As AstUsersObjectEventArgs _
)
Visual C++
protected:
virtual void OnAstUsersObjectEvent(
    AstUsersObjectEventArgs^ e
)

Parameters

e
Type: AMIgo..::..AstUsersObjectEventArgs
The AstUsersObjectEventArgs instance containing the event data.

See Also

AMI_Client Class


OnStatusEvent Method

[image]

AMIgo Controls documentation
AMI_Client..::..OnStatusEvent Method
AMI_Client Class See Also Send Feedback
Raises the StatusEvent event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected virtual void OnStatusEvent(
    StringMsgEventArgs e
)
Visual Basic
Protected Overridable Sub OnStatusEvent ( _
    e As StringMsgEventArgs _
)
Visual C++
protected:
virtual void OnStatusEvent(
    StringMsgEventArgs^ e
)

Parameters

e
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMI_Client Class


OnTransferEvent Method

[image]

AMIgo Controls documentation
AMI_Client..::..OnTransferEvent Method
AMI_Client Class See Also Send Feedback
Raises the TransferEvent event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected virtual void OnTransferEvent(
    RawMngrMsgEventArgs e
)
Visual Basic
Protected Overridable Sub OnTransferEvent ( _
    e As RawMngrMsgEventArgs _
)
Visual C++
protected:
virtual void OnTransferEvent(
    RawMngrMsgEventArgs^ e
)

Parameters

e
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMI_Client Class


Originate Method

[image]

AMIgo Controls documentation
AMI_Client..::..Originate Method
AMI_Client Class See Also Send Feedback
Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Originate(
    string TechData,
    string Context,
    string Extension,
    string Priority,
    string Variable
)
Visual Basic
Public Function Originate ( _
    TechData As String, _
    Context As String, _
    Extension As String, _
    Priority As String, _
    Variable As String _
) As Integer
Visual C++
public:
int Originate(
    String^ TechData,
    String^ Context,
    String^ Extension,
    String^ Priority,
    String^ Variable
)

Parameters

TechData
Type: System..::..String
Technology/Data. For ex: Zap/1, DAHDI/2, SIP/200.
Context
Type: System..::..String
The Context.
Extension
Type: System..::..String
The extension.
Priority
Type: System..::..String
The priority .
Variable
Type: System..::..String
Any variable to be set on the channel.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

This method calls OriginateExtension(String, String, String, String, String). EVENTS: This command will generate the following event: OriginateResultEvent

See Also

AMI_Client Class


OriginateApplication Method

[image]

AMIgo Controls documentation
AMI_Client..::..OriginateApplication Method
AMI_Client Class See Also Send Feedback
Generates a call to a given tech/data and execute an application.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int OriginateApplication(
    string TechData,
    string Application,
    string Data,
    string Variable
)
Visual Basic
Public Function OriginateApplication ( _
    TechData As String, _
    Application As String, _
    Data As String, _
    Variable As String _
) As Integer
Visual C++
public:
int OriginateApplication(
    String^ TechData,
    String^ Application,
    String^ Data,
    String^ Variable
)

Parameters

TechData
Type: System..::..String
Technology/Data. For ex: Zap/1, DAHDI/2, SIP/200
Application
Type: System..::..String
The application to execute after the called party answers.
Data
Type: System..::..String
The data for the application.
Variable
Type: System..::..String
Any variable to be set before running the application. Empty string if none.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: OriginateResultEvent

See Also

AMI_Client Class


OriginateExtension Method

[image]

AMIgo Controls documentation
AMI_Client..::..OriginateExtension Method
AMI_Client Class Example See Also Send Feedback
Generates a call to a given tech/data and branch to an Extension/Context/Priority in the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int OriginateExtension(
    string TechData,
    string Context,
    string Extension,
    string Priority,
    string Variable
)
Visual Basic
Public Function OriginateExtension ( _
    TechData As String, _
    Context As String, _
    Extension As String, _
    Priority As String, _
    Variable As String _
) As Integer
Visual C++
public:
int OriginateExtension(
    String^ TechData,
    String^ Context,
    String^ Extension,
    String^ Priority,
    String^ Variable
)

Parameters

TechData
Type: System..::..String
Technology/Data. For ex: Zap/1, DAHDI/2, SIP/200, Zap/g1/9xxxxxxxxxx
Context
Type: System..::..String
The Context.
Extension
Type: System..::..String
The extension.
Priority
Type: System..::..String
The priority .
Variable
Type: System..::..String
Any variable to be set on the channel. Empty string if none.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

This function can be used to generate calls between an extension or external phone number and branch to a dialplan extension. The dialplan extension can direct the call to an extension, a queue, an agent or an dialplan application.

The first parameter 'TechData' must include the type of extension / line and the extension or line number. For instance, for Zap / DAHDI channel it should be specified as, example: Zap/1 (or DAHDI/1). For SIP or IAX channels, example: SIP/200, IAX/6000.

If the call is answered, it will branch to the given dialplan's 'Context' / 'Extension' and Priority.

This function can be used, to integrate telephony functions in your .NET application. For example, a click to call function, to call from a contact management or clients data base.

EVENTS: This command will generate the following event: OriginateResultEvent

Examples

CopyC#
1// Call extension SIP/200 and if answered connect with extension 201 (dialplan [default] extension 200 priority 1)
2AMI_Client.OriginateExtension("SIP/200", "default", "201", "1", "")
3// Call extension SIP/6000 and if answered call external phone number using Zap group number 1
4AMI_Client.OriginateExtension("SIP/6000", "DLPN_DialPlan1", "Zap/g1/95555551212", "1", "")
5// Call external phone number using Zap group number 2 and branch to confernce 6300
6AMI_Client.OriginateExtension("Zap/g2/95555551212", "conferences", "6300", "1", "")

See Also

AMI_Client Class


Ping Method

[image]

AMIgo Controls documentation
AMI_Client..::..Ping Method
AMI_Client Class See Also Send Feedback
Send a message to verify or maintains connection.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Ping()
Visual Basic
Public Function Ping As Integer
Visual C++
public:
int Ping()

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


QueueAdd Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..QueueAdd Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueueAdd(String, String, String, String) | Add a Member to a queue
Public method | QueueAdd(String, String, String, String, String, String) | Add a Member to a queue. For Asterisk V1.6 and up only

See Also

AMI_Client Class
AMI_Client Members


QueueAdd Method (String, String, String, String)

[image]

AMIgo Controls documentation
AMI_Client..::..QueueAdd Method (String, String, String, String)
AMI_Client Class See Also Send Feedback
Add a Member to a queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueueAdd(
    string Queue,
    string Member,
    string Penalty,
    string Paused
)
Visual Basic
Public Function QueueAdd ( _
    Queue As String, _
    Member As String, _
    Penalty As String, _
    Paused As String _
) As Integer
Visual C++
public:
int QueueAdd(
    String^ Queue,
    String^ Member,
    String^ Penalty,
    String^ Paused
)

Parameters

Queue
Type: System..::..String
The queue number.
Member
Type: System..::..String
The member. Ex: Agent/6700, Local/6701, SIP/200
Penalty
Type: System..::..String
The penalty assigned to the queue member.
Paused
Type: System..::..String
The paused status ('0' = false '1' = true).

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following events: QueueMemberEvent, AgentEvent

See Also

AMI_Client Class
QueueAdd Overload
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstQueueMember


QueueAdd Method (String, String, String, String, String, String)

[image]

AMIgo Controls documentation
AMI_Client..::..QueueAdd Method (String, String, String, String, String, String)
AMI_Client Class See Also Send Feedback
Add a Member to a queue. For Asterisk V1.6 and up only

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueueAdd(
    string Queue,
    string Member,
    string Penalty,
    string Paused,
    string MemberName,
    string StateInterface
)
Visual Basic
Public Function QueueAdd ( _
    Queue As String, _
    Member As String, _
    Penalty As String, _
    Paused As String, _
    MemberName As String, _
    StateInterface As String _
) As Integer
Visual C++
public:
int QueueAdd(
    String^ Queue,
    String^ Member,
    String^ Penalty,
    String^ Paused,
    String^ MemberName,
    String^ StateInterface
)

Parameters

Queue
Type: System..::..String
The queue.
Member
Type: System..::..String
The member. Ex: Agent/6700, Local/6701, SIP/200
Penalty
Type: System..::..String
The penalty assigned to the queue member.
Paused
Type: System..::..String
The paused.
MemberName
Type: System..::..String
Name of the member.
StateInterface
Type: System..::..String
The state interface.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following events: AgentEvent, QueueMemberEvent

See Also

AMI_Client Class
QueueAdd Overload
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstQueueMember


QueueGetStatus Method

[image]

AMIgo Controls documentation
AMI_Client..::..QueueGetStatus Method
AMI_Client Class See Also Send Feedback
Gets the status of queues, queues members and queues entries

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueueGetStatus()
Visual Basic
Public Function QueueGetStatus As Integer
Visual C++
public:
int QueueGetStatus()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: QueueParamsEvent, QueueMemberEvent, QueueEntryEvent.

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstQueue
AMIgo..::..AstQueueMember
AMIgo..::..AstQueueEntry


QueuePause Method

[image]

AMIgo Controls documentation
AMI_Client..::..QueuePause Method
AMI_Client Class See Also Send Feedback
Set the Pause status of a queue member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueuePause(
    string Queue,
    string Member,
    string Paused
)
Visual Basic
Public Function QueuePause ( _
    Queue As String, _
    Member As String, _
    Paused As String _
) As Integer
Visual C++
public:
int QueuePause(
    String^ Queue,
    String^ Member,
    String^ Paused
)

Parameters

Queue
Type: System..::..String
The queue number.
Member
Type: System..::..String
The full member name. Ex: Agent/6700, Local/6500, SIP/200
Paused
Type: System..::..String
The paused status '0' = false, '1' = true.

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: QueueMemberEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstQueueMember


QueueRemove Method

[image]

AMIgo Controls documentation
AMI_Client..::..QueueRemove Method
AMI_Client Class See Also Send Feedback
Remove a member from a queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueueRemove(
    string Queue,
    string Member
)
Visual Basic
Public Function QueueRemove ( _
    Queue As String, _
    Member As String _
) As Integer
Visual C++
public:
int QueueRemove(
    String^ Queue,
    String^ Member
)

Parameters

Queue
Type: System..::..String
The queue number.
Member
Type: System..::..String
The full member name. Ex: Agent/6700, Local/6500/n, SIP/200

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following events: QueueMemberEvent, AgentEvent, AgentSessionEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstAgent
AMIgo..::..AstQueueMember
AMIgo..::..AstAgentSession


QueuesBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..QueuesBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueuesBuildList(Boolean) | Returns a string list of defined queues.
Public method | QueuesBuildList(ComboBox..::..ObjectCollection, Boolean) | Fills the given ComboBox items with a list of defined queues.

See Also

AMI_Client Class
AMI_Client Members


QueuesBuildList Method (Boolean)

[image]

AMIgo Controls documentation
AMI_Client..::..QueuesBuildList Method (Boolean)
AMI_Client Class See Also Send Feedback
Returns a string list of defined queues.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> QueuesBuildList(
    bool AllQueues
)
Visual Basic
Public Function QueuesBuildList ( _
    AllQueues As Boolean _
) As List(Of String)
Visual C++
public:
List<String^>^ QueuesBuildList(
    bool AllQueues
)

Parameters

AllQueues
Type: System..::..Boolean
if set to true [all queues].

Return Value

A string list of the queues defined on the system

Remarks

This lis is compiled from the dialplan [queues] Context

See Also

AMI_Client Class
QueuesBuildList Overload


QueuesBuildList Method (ComboBox.ObjectCollection, Boolean)

[image]

AMIgo Controls documentation
AMI_Client..::..QueuesBuildList Method (ComboBox..::..ObjectCollection, Boolean)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of defined queues.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void QueuesBuildList(
    ComboBox..::..ObjectCollection Items,
    bool AllQueues
)
Visual Basic
Public Sub QueuesBuildList ( _
    Items As ComboBox..::..ObjectCollection, _
    AllQueues As Boolean _
)
Visual C++
public:
void QueuesBuildList(
    ComboBox..::..ObjectCollection^ Items,
    bool AllQueues
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan
AllQueues
Type: System..::..Boolean
if set to true include an 'All' item.

Remarks

This lis is compiled from the dialplan [queues] Context

See Also

AMI_Client Class
QueuesBuildList Overload


QueuesClearList Method

[image]

AMIgo Controls documentation
AMI_Client..::..QueuesClearList Method
AMI_Client Class See Also Send Feedback
Clears the Queues SyncList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void QueuesClearList()
Visual Basic
Public Sub QueuesClearList
Visual C++
public:
void QueuesClearList()

See Also

AMI_Client Class


QueuesRefreshList Method

[image]

AMIgo Controls documentation
AMI_Client..::..QueuesRefreshList Method
AMI_Client Class See Also Send Feedback
Refreshes the _queuesList SyncList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int QueuesRefreshList()
Visual Basic
Public Function QueuesRefreshList As Integer
Visual C++
public:
int QueuesRefreshList()

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


ReloadDialplan Method

[image]

AMIgo Controls documentation
AMI_Client..::..ReloadDialplan Method
AMI_Client Class See Also Send Feedback
Reloads the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ReloadDialplan()
Visual Basic
Public Function ReloadDialplan As Integer
Visual C++
public:
int ReloadDialplan()

Return Value

0 if Logged In and command sent, -1 otherwise

See Also

AMI_Client Class


SendEventCommand Method

[image]

AMIgo Controls documentation
AMI_Client..::..SendEventCommand Method
AMI_Client Class See Also Send Feedback
Select the manager events to receive

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SendEventCommand(
    string EventMask
)
Visual Basic
Public Function SendEventCommand ( _
    EventMask As String _
) As Integer
Visual C++
public:
int SendEventCommand(
    String^ EventMask
)

Parameters

EventMask
Type: System..::..String
The event mask. [system],[call],[log]

Return Value

0 if logged in and command sent, -1 otherwise

See Also

AMI_Client Class


SIP_GetPeerDetails Method

[image]

AMIgo Controls documentation
AMI_Client..::..SIP_GetPeerDetails Method
AMI_Client Class See Also Send Feedback
Get detailed infos about a SIP peer.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SIP_GetPeerDetails(
    string PeerName
)
Visual Basic
Public Function SIP_GetPeerDetails ( _
    PeerName As String _
) As Integer
Visual C++
public:
int SIP_GetPeerDetails(
    String^ PeerName
)

Parameters

PeerName
Type: System..::..String
The extension number to get details on. Do not include the tech part: (SIP/)

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: PeerDetailsEvent

See Also

AMI_Client Class


SIP_GetRegistry Method

[image]

AMIgo Controls documentation
AMI_Client..::..SIP_GetRegistry Method
AMI_Client Class See Also Send Feedback
Get the SIP registrations and parse into AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SIP_GetRegistry()
Visual Basic
Public Function SIP_GetRegistry As Integer
Visual C++
public:
int SIP_GetRegistry()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


SIP_PeersGetDef Method

[image]

AMIgo Controls documentation
AMI_Client..::..SIP_PeersGetDef Method
AMI_Client Class See Also Send Feedback
Get the SIP peers and parse into the AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SIP_PeersGetDef()
Visual Basic
Public Function SIP_PeersGetDef As Integer
Visual C++
public:
int SIP_PeersGetDef()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


Start Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..Start Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start()()()() | Starts this instance with no Parent Control. (see others constructors) (Note: You must use Invoke to modify any UI element from an event handler)
Public method | Start(Control) | Start the AMC thread with the givent control (Usually the main form) as parent control
Public method | Start(Control, AstSite) | Start the AMC thread at a given site

See Also

AMI_Client Class
AMI_Client Members


Start Method

[image]

AMIgo Controls documentation
AMI_Client..::..Start Method
AMI_Client Class See Also Send Feedback
Starts this instance with no Parent Control. (see others constructors) (Note: You must use Invoke to modify any UI element from an event handler)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

AMI_Client Class
Start Overload


Start Method (Control)

[image]

AMIgo Controls documentation
AMI_Client..::..Start Method (Control)
AMI_Client Class Example See Also Send Feedback
Start the AMC thread with the givent control (Usually the main form) as parent control

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Start(
    Control ParentControl
)
Visual Basic
Public Sub Start ( _
    ParentControl As Control _
)
Visual C++
public:
void Start(
    Control^ ParentControl
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control is used to synchronize the events so that they are executed in the main thread. Usually the project's main form.

Remarks

To simplify usage, the AMI_Client component will find all AMIgo controls that are present in the application and initialize them so that they receive the proper events. It also sets a reference in the found controls so that they can 'find' this AMI_Client instance. The result is that you don't need to set anything in the AMIgo controls to use them.

All events are invoked using the given ParentControl (usually the projects main form) to synchronize the events so that they are executed in the main thread.

If the AutoLogin property is set to true, the Connect()()()() method will be called and a connection will be attempted to the site set in the AstMngrHost and AstMngrPort properties.

Examples

CopyC#
1AMI_Client MyAMI_Client = new AMI_Client();
2MyAMI_Client.Start(this);

See Also

AMI_Client Class
Start Overload
AMIgo Namespace
AMIgo..::..AMI_Client..::..AMI_ClientState


Start Method (Control, AstSite)

[image]

AMIgo Controls documentation
AMI_Client..::..Start Method (Control, AstSite)
AMI_Client Class See Also Send Feedback
Start the AMC thread at a given site

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Start(
    Control ParentControl,
    AstSite Site
)
Visual Basic
Public Sub Start ( _
    ParentControl As Control, _
    Site As AstSite _
)
Visual C++
public:
void Start(
    Control^ ParentControl,
    AstSite^ Site
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control is used to synchronize the events so that they are executed in the main thread. Usually the project's main form.
Site
Type: AMIgo..::..AstSite
The site to connect to on startup.

See Also

AMI_Client Class
Start Overload
AMIgo Namespace
AMIgo..::..AstSite


Stop Method

[image]

AMIgo Controls documentation
AMI_Client..::..Stop Method
AMI_Client Class See Also Send Feedback
Stop the AMI_Client thread. This function MUST (should) be called before exiting to stop the AMIClient thread.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

AMI_Client Class


TestLogged Method

[image]

AMIgo Controls documentation
AMI_Client..::..TestLogged Method
AMI_Client Class See Also Send Feedback
Test if state is LOGGED. Return true / false

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool TestLogged()
Visual Basic
Public Function TestLogged As Boolean
Visual C++
public:
bool TestLogged()

Return Value

Return true if coonnected and LOGGED / false otherwise

Remarks

Raise an ErrorEvent if not connected and logged

See Also

AMI_Client Class


TestVersion Method

[image]

AMIgo Controls documentation
AMI_Client..::..TestVersion Method
AMI_Client Class See Also Send Feedback
Test the given version against the one of the connected system

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool TestVersion(
    int VersionMajor,
    int VersionMinor
)
Visual Basic
Public Function TestVersion ( _
    VersionMajor As Integer, _
    VersionMinor As Integer _
) As Boolean
Visual C++
public:
bool TestVersion(
    int VersionMajor,
    int VersionMinor
)

Parameters

VersionMajor
Type: System..::..Int32
The version major. Ex: 1
VersionMinor
Type: System..::..Int32
The version minor. Ex: 4

Return Value

true if Version of connected system is higher or equal than the one given

See Also

AMI_Client Class


TimeNowToString Method

[image]

AMIgo Controls documentation
AMI_Client..::..TimeNowToString Method
AMI_Client Class See Also Send Feedback
Returns a string with current date and time in ISO8601 format

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TimeNowToString(
    bool ISO8601
)
Visual Basic
Public Function TimeNowToString ( _
    ISO8601 As Boolean _
) As String
Visual C++
public:
String^ TimeNowToString(
    bool ISO8601
)

Parameters

ISO8601
Type: System..::..Boolean
if set to true [ISO8601].

Return Value

A string with the current date and time

See Also

AMI_Client Class


TimeNowToUnixTimeStamp Method

[image]

AMIgo Controls documentation
AMI_Client..::..TimeNowToUnixTimeStamp Method
AMI_Client Class See Also Send Feedback
Returns a timestamp string in the Unix EPOCH format (Nb secs. since 01/01/1970)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public static string TimeNowToUnixTimeStamp()
Visual Basic
Public Shared Function TimeNowToUnixTimeStamp As String
Visual C++
public:
static String^ TimeNowToUnixTimeStamp()

Return Value

A Unix format timestamp string

Remarks

This is the format used in asterisk for all times and dates

See Also

AMI_Client Class


UnixTimestampToString Method

[image]

AMIgo Controls documentation
AMI_Client..::..UnixTimestampToString Method
AMI_Client Class See Also Send Feedback
Convert a UNIX timestamp to Local time. Optionally output the TIME in ISO8601 format.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public static string UnixTimestampToString(
    string Timestamp,
    bool ISO8601
)
Visual Basic
Public Shared Function UnixTimestampToString ( _
    Timestamp As String, _
    ISO8601 As Boolean _
) As String
Visual C++
public:
static String^ UnixTimestampToString(
    String^ Timestamp,
    bool ISO8601
)

Parameters

Timestamp
Type: System..::..String
The UNIX timestamp string.
ISO8601
Type: System..::..Boolean
if set to true output the time in ISO8601 format (YYYY-MM-DD HH:MM:SS)

Return Value

The converted time sting

See Also

AMI_Client Class


VoiceMenusBuildList Method

[image] [image]

AMIgo Controls documentation
AMI_Client..::..VoiceMenusBuildList Method
AMI_Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VoiceMenusBuildList()()()() | Returns a string list of defined voice menus.
Public method | VoiceMenusBuildList(ComboBox..::..ObjectCollection) | Fills the given ComboBox items with a list of defined voice menus.

See Also

AMI_Client Class
AMI_Client Members


VoiceMenusBuildList Method

[image]

AMIgo Controls documentation
AMI_Client..::..VoiceMenusBuildList Method
AMI_Client Class See Also Send Feedback
Returns a string list of defined voice menus.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<string> VoiceMenusBuildList()
Visual Basic
Public Function VoiceMenusBuildList As List(Of String)
Visual C++
public:
List<String^>^ VoiceMenusBuildList()

Return Value

A string list of the voice menus defined on the system

Remarks

This lis is compiled from the dialplan [voicemenus] Context

See Also

AMI_Client Class
VoiceMenusBuildList Overload


VoiceMenusBuildList Method (ComboBox.ObjectCollection)

[image]

AMIgo Controls documentation
AMI_Client..::..VoiceMenusBuildList Method (ComboBox..::..ObjectCollection)
AMI_Client Class See Also Send Feedback
Fills the given ComboBox items with a list of defined voice menus.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void VoiceMenusBuildList(
    ComboBox..::..ObjectCollection Items
)
Visual Basic
Public Sub VoiceMenusBuildList ( _
    Items As ComboBox..::..ObjectCollection _
)
Visual C++
public:
void VoiceMenusBuildList(
    ComboBox..::..ObjectCollection^ Items
)

Parameters

Items
Type: System.Windows.Forms..::..ComboBox..::..ObjectCollection
A comboBox items collection that will be filled with the dialplan

Remarks

This lis is compiled from the dialplan [voicemenus] Context

See Also

AMI_Client Class
VoiceMenusBuildList Overload


ZAPorDAHDI_GetDef Method

[image]

AMIgo Controls documentation
AMI_Client..::..ZAPorDAHDI_GetDef Method
AMI_Client Class See Also Send Feedback
Get the Zap/DAHDI channels and parse into AstUsersObjectsList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int ZAPorDAHDI_GetDef()
Visual Basic
Public Function ZAPorDAHDI_GetDef As Integer
Visual C++
public:
int ZAPorDAHDI_GetDef()

Return Value

0 if logged in and command sent, -1 otherwise

Remarks

EVENTS: This command will generate the following event: AstUsersObjectEvent

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstUsersObject


AMI_Client Properties

[image] [image]

AMIgo Controls documentation
AMI_Client Properties
AMI_Client Class See Also Send Feedback

The AMI_Client type exposes the following members.

Properties

 | Name | Description
Public property | AstAgentsCallsList | Ongoing agents call list. (read only).
Public property | AstAgentsList | Agents list. (read only). See: AstAgent
Public property | AstCallsList | Active call list (read only). See: AstCall
Public property | AstChannelsList | Active channels list (read only). See: AstChannel
Public property | AstConferencesList | Conferences list. (read only). See: AstConference
Public property | AstConferenceUsersList | Conferences Users list. (read only). See: AstConferenceUser
Public property | AsteriskVersion | Version of the currently connected Asterisk system (read only)
Public property | AstMngrHost | Asterisk manager HostName or IP address.
Public property | AstMngrPassword | Asterisk manager password (Secret). (As set in target system manager.conf file)
Public property | AstMngrPort | Asterisk manager port. (Usually 5038)
Public property | AstMngrSiteName | A name for this asterisk site
Public property | AstMngrUserName | Asterisk manager User Name. (As set in target system manager.conf file)
Public property | AstQueuesEntriesList | Ongoing calls in queues List. (read only). See: AstQueueEntry
Public property | AstQueuesList | Queues list. (read only). See: AstQueue
Public property | AstQueuesMembersList | Queues members list. (read only). See: AstQueueMember
Public property | AstUsersObjectsList | AstUsersObjects list. (read only). See: AstUsersObject and SyncList<(Of <(<'T>)>)>
Public property | AstVoicemailList | Voicemail list (read only).
Public property | AutoGetConfig | Gets or sets a value indicating whether to get system config on start. Default = true.
Public property | AutoLogin | AutoConnect and Login after Start. See: AutoStart. Default = true
Public property | AutoStart | AutoStart. Starts the AMI_Client thread on application startup. Default = true
Public property | DialPlanTemplate | Gets or sets the DialPlan template.
Public property | IsStopping | True if Stop() has been called
Public property | RegCode | Gets the license code.
Public property | RegKey | Gets the license key, if any
Public property | SendPingInterval | Gets or sets the send ping interval.
Public property | ShowNewExten | Show NewExten Events.
Public property | State | State of the AMI_Client control

See Also

AMI_Client Class


AstAgentsCallsList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstAgentsCallsList Property
AMI_Client Class See Also Send Feedback
Ongoing agents call list. (read only).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstAgentCall> AstAgentsCallsList { get; }
Visual Basic
Public ReadOnly Property AstAgentsCallsList As SyncList(Of AstAgentCall)
    Get
Visual C++
public:
property SyncList<AstAgentCall^>^ AstAgentsCallsList {
    SyncList<AstAgentCall^>^ get ();
}

See Also

AMI_Client Class


AstAgentsList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstAgentsList Property
AMI_Client Class See Also Send Feedback
Agents list. (read only). See: AstAgent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstAgent> AstAgentsList { get; }
Visual Basic
Public ReadOnly Property AstAgentsList As SyncList(Of AstAgent)
    Get
Visual C++
public:
property SyncList<AstAgent^>^ AstAgentsList {
    SyncList<AstAgent^>^ get ();
}

See Also

AMI_Client Class


AstCallsList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstCallsList Property
AMI_Client Class See Also Send Feedback
Active call list (read only). See: AstCall

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstCall> AstCallsList { get; }
Visual Basic
Public ReadOnly Property AstCallsList As SyncList(Of AstCall)
    Get
Visual C++
public:
property SyncList<AstCall^>^ AstCallsList {
    SyncList<AstCall^>^ get ();
}

See Also

AMI_Client Class


AstChannelsList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstChannelsList Property
AMI_Client Class See Also Send Feedback
Active channels list (read only). See: AstChannel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstChannel> AstChannelsList { get; }
Visual Basic
Public ReadOnly Property AstChannelsList As SyncList(Of AstChannel)
    Get
Visual C++
public:
property SyncList<AstChannel^>^ AstChannelsList {
    SyncList<AstChannel^>^ get ();
}

See Also

AMI_Client Class


AstConferencesList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstConferencesList Property
AMI_Client Class See Also Send Feedback
Conferences list. (read only). See: AstConference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstConference> AstConferencesList { get; }
Visual Basic
Public ReadOnly Property AstConferencesList As SyncList(Of AstConference)
    Get
Visual C++
public:
property SyncList<AstConference^>^ AstConferencesList {
    SyncList<AstConference^>^ get ();
}

See Also

AMI_Client Class


AstConferenceUsersList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstConferenceUsersList Property
AMI_Client Class See Also Send Feedback
Conferences Users list. (read only). See: AstConferenceUser

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstConferenceUser> AstConferenceUsersList { get; }
Visual Basic
Public ReadOnly Property AstConferenceUsersList As SyncList(Of AstConferenceUser)
    Get
Visual C++
public:
property SyncList<AstConferenceUser^>^ AstConferenceUsersList {
    SyncList<AstConferenceUser^>^ get ();
}

See Also

AMI_Client Class


AsteriskVersion Property

[image]

AMIgo Controls documentation
AMI_Client..::..AsteriskVersion Property
AMI_Client Class See Also Send Feedback
Version of the currently connected Asterisk system (read only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Version AsteriskVersion { get; }
Visual Basic
Public ReadOnly Property AsteriskVersion As Version
    Get
Visual C++
public:
property Version^ AsteriskVersion {
    Version^ get ();
}

See Also

AMI_Client Class


AstMngrHost Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstMngrHost Property
AMI_Client Class See Also Send Feedback
Asterisk manager HostName or IP address.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AstMngrHost { get; set; }
Visual Basic
Public Property AstMngrHost As String
    Get
    Set
Visual C++
public:
property String^ AstMngrHost {
    String^ get ();
    void set (String^ value);
}

See Also

AMI_Client Class


AstMngrPassword Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstMngrPassword Property
AMI_Client Class See Also Send Feedback
Asterisk manager password (Secret). (As set in target system manager.conf file)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AstMngrPassword { get; set; }
Visual Basic
Public Property AstMngrPassword As String
    Get
    Set
Visual C++
public:
property String^ AstMngrPassword {
    String^ get ();
    void set (String^ value);
}

See Also

AMI_Client Class


AstMngrPort Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstMngrPort Property
AMI_Client Class See Also Send Feedback
Asterisk manager port. (Usually 5038)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int AstMngrPort { get; set; }
Visual Basic
Public Property AstMngrPort As Integer
    Get
    Set
Visual C++
public:
property int AstMngrPort {
    int get ();
    void set (int value);
}

See Also

AMI_Client Class


AstMngrSiteName Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstMngrSiteName Property
AMI_Client Class See Also Send Feedback
A name for this asterisk site

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AstMngrSiteName { get; set; }
Visual Basic
Public Property AstMngrSiteName As String
    Get
    Set
Visual C++
public:
property String^ AstMngrSiteName {
    String^ get ();
    void set (String^ value);
}

See Also

AMI_Client Class


AstMngrUserName Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstMngrUserName Property
AMI_Client Class See Also Send Feedback
Asterisk manager User Name. (As set in target system manager.conf file)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AstMngrUserName { get; set; }
Visual Basic
Public Property AstMngrUserName As String
    Get
    Set
Visual C++
public:
property String^ AstMngrUserName {
    String^ get ();
    void set (String^ value);
}

See Also

AMI_Client Class


AstQueuesEntriesList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstQueuesEntriesList Property
AMI_Client Class See Also Send Feedback
Ongoing calls in queues List. (read only). See: AstQueueEntry

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstQueueEntry> AstQueuesEntriesList { get; }
Visual Basic
Public ReadOnly Property AstQueuesEntriesList As SyncList(Of AstQueueEntry)
    Get
Visual C++
public:
property SyncList<AstQueueEntry^>^ AstQueuesEntriesList {
    SyncList<AstQueueEntry^>^ get ();
}

See Also

AMI_Client Class


AstQueuesList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstQueuesList Property
AMI_Client Class See Also Send Feedback
Queues list. (read only). See: AstQueue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstQueue> AstQueuesList { get; }
Visual Basic
Public ReadOnly Property AstQueuesList As SyncList(Of AstQueue)
    Get
Visual C++
public:
property SyncList<AstQueue^>^ AstQueuesList {
    SyncList<AstQueue^>^ get ();
}

See Also

AMI_Client Class


AstQueuesMembersList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstQueuesMembersList Property
AMI_Client Class See Also Send Feedback
Queues members list. (read only). See: AstQueueMember

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstQueueMember> AstQueuesMembersList { get; }
Visual Basic
Public ReadOnly Property AstQueuesMembersList As SyncList(Of AstQueueMember)
    Get
Visual C++
public:
property SyncList<AstQueueMember^>^ AstQueuesMembersList {
    SyncList<AstQueueMember^>^ get ();
}

See Also

AMI_Client Class


AstUsersObjectsList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstUsersObjectsList Property
AMI_Client Class See Also Send Feedback
AstUsersObjects list. (read only). See: AstUsersObject and SyncList<(Of <(<'T>)>)>

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstUsersObject> AstUsersObjectsList { get; }
Visual Basic
Public ReadOnly Property AstUsersObjectsList As SyncList(Of AstUsersObject)
    Get
Visual C++
public:
property SyncList<AstUsersObject^>^ AstUsersObjectsList {
    SyncList<AstUsersObject^>^ get ();
}

Remarks

This property gives read only access to the Users Objects List. This is a list of AstUsersObject which contains the SIP / IAX / Zap/DAHDI peers, users and registrations defined on the connected system and allows to get the real time status of the object.

See Also

AMI_Client Class


AstVoicemailList Property

[image]

AMIgo Controls documentation
AMI_Client..::..AstVoicemailList Property
AMI_Client Class See Also Send Feedback
Voicemail list (read only).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList<AstVoicemail> AstVoicemailList { get; }
Visual Basic
Public ReadOnly Property AstVoicemailList As SyncList(Of AstVoicemail)
    Get
Visual C++
public:
property SyncList<AstVoicemail^>^ AstVoicemailList {
    SyncList<AstVoicemail^>^ get ();
}

See Also

AMI_Client Class


AutoGetConfig Property

[image]

AMIgo Controls documentation
AMI_Client..::..AutoGetConfig Property
AMI_Client Class See Also Send Feedback
Gets or sets a value indicating whether to get system config on start. Default = true.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool AutoGetConfig { get; set; }
Visual Basic
Public Property AutoGetConfig As Boolean
    Get
    Set
Visual C++
public:
property bool AutoGetConfig {
    bool get ();
    void set (bool value);
}

Field Value

true to get the system config after logon, false otherwise. default to true.

Remarks

If this property is true, methods to send AMI commands to get the lines, channels, agents, queues, config, etc infos. will be called after login

See Also

AMI_Client Class


AutoLogin Property

[image]

AMIgo Controls documentation
AMI_Client..::..AutoLogin Property
AMI_Client Class See Also Send Feedback
AutoConnect and Login after Start. See: AutoStart. Default = true

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool AutoLogin { get; set; }
Visual Basic
Public Property AutoLogin As Boolean
    Get
    Set
Visual C++
public:
property bool AutoLogin {
    bool get ();
    void set (bool value);
}

Remarks

If the connect and login attempt is successfull, the GetAsteriskVersion()()()() command will be sent followed by the ChannelsGetTypes()()()()method. If the AutoGetConfig property is true, this will be followed by methods to send AMI commands to get the lines, channels, agents, queues, config, etc infos.

After the AutoLogin with DoAutoGetConfig set to true has completed, the AMI client will have a complete 'picture' of the connected system and a StateChangeEvent with a AMI_Client..::..AMI_ClientState READY State will be invoked

See Also

AMI_Client Class


AutoStart Property

[image]

AMIgo Controls documentation
AMI_Client..::..AutoStart Property
AMI_Client Class See Also Send Feedback
AutoStart. Starts the AMI_Client thread on application startup. Default = true

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool AutoStart { get; set; }
Visual Basic
Public Property AutoStart As Boolean
    Get
    Set
Visual C++
public:
property bool AutoStart {
    bool get ();
    void set (bool value);
}

Remarks

The AMI Client thread is started and if AutoLogin is true and Host given, connect and login to the given site. If set to false you need to call the Start()()()() method.

See Also

AMI_Client Class


DialPlanTemplate Property

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanTemplate Property
AMI_Client Class See Also Send Feedback
Gets or sets the DialPlan template.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DialPlanTemplate { get; set; }
Visual Basic
Public Property DialPlanTemplate As String
    Get
    Set
Visual C++
public:
property String^ DialPlanTemplate {
    String^ get ();
    void set (String^ value);
}

Field Value

The path name of the template file.

Remarks

If this is set to a valid file name, it will be read in and used when writing the agent support to the dialplan. If not set or if the file not found, an internal resource file will be used.

You can use this feature to customize the DP agents's support or use it to add your own features.

See Also

AMI_Client Class


IsStopping Property

[image]

AMIgo Controls documentation
AMI_Client..::..IsStopping Property
AMI_Client Class See Also Send Feedback
True if Stop() has been called

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool IsStopping { get; }
Visual Basic
Public ReadOnly Property IsStopping As Boolean
    Get
Visual C++
public:
property bool IsStopping {
    bool get ();
}

See Also

AMI_Client Class


RegCode Property

[image]

AMIgo Controls documentation
AMI_Client..::..RegCode Property
AMI_Client Class See Also Send Feedback
Gets the license code.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string RegCode { get; }
Visual Basic
Public ReadOnly Property RegCode As String
    Get
Visual C++
public:
property String^ RegCode {
    String^ get ();
}

See Also

AMI_Client Class


RegKey Property

[image]

AMIgo Controls documentation
AMI_Client..::..RegKey Property
AMI_Client Class See Also Send Feedback
Gets the license key, if any

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string RegKey { get; set; }
Visual Basic
Public Property RegKey As String
    Get
    Set
Visual C++
public:
property String^ RegKey {
    String^ get ();
    void set (String^ value);
}

See Also

AMI_Client Class


SendPingInterval Property

[image]

AMIgo Controls documentation
AMI_Client..::..SendPingInterval Property
AMI_Client Class See Also Send Feedback
Gets or sets the send ping interval.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SendPingInterval { get; set; }
Visual Basic
Public Property SendPingInterval As Integer
    Get
    Set
Visual C++
public:
property int SendPingInterval {
    int get ();
    void set (int value);
}

Field Value

The send ping interval in seconds.

Remarks

This can sometimes be needed to 'keep the connection alive'.

See Also

AMI_Client Class


ShowNewExten Property

[image]

AMIgo Controls documentation
AMI_Client..::..ShowNewExten Property
AMI_Client Class See Also Send Feedback
Show NewExten Events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowNewExten { get; set; }
Visual Basic
Public Property ShowNewExten As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNewExten {
    bool get ();
    void set (bool value);
}

Remarks

The NewExten events are sent for each 'step' in the dialplan, for all users. This can generate a lots of useless events (unless maybe you want to 'track' the dialplan usage) so these events are just ignored by default. Set to true to Allow these events. See: NewExtenEvent

See Also

AMI_Client Class


State Property

[image]

AMIgo Controls documentation
AMI_Client..::..State Property
AMI_Client Class See Also Send Feedback
State of the AMI_Client control

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client..::..AMI_ClientState State { get; private set; }
Visual Basic
Public Property State As AMI_Client..::..AMI_ClientState
    Get
    Private Set
Visual C++
public:
property AMI_Client..::..AMI_ClientState State {
    AMI_Client..::..AMI_ClientState get ();
    private: void set (AMI_Client..::..AMI_ClientState value);
}

See Also

AMI_Client Class


AMI_Client Events

[image] [image]

AMIgo Controls documentation
AMI_Client Events
AMI_Client Class See Also Send Feedback

The AMI_Client type exposes the following members.

Events

 | Name | Description
Public event | AgentCallEvent | Occurs when an agent is called, when the call is connected (answered) and at the end of agent's calls.
Public event | AgentEvent | Occurs on Agent Status, login / off, queue members and other events affecting the agents.
Public event | AgentSessionEvent | Occurs when an agent logs in or off.
Public event | AstChannelEvent | Occurs when a channel state change
Public event | AstUsersObjectEvent | Occurs when a AstUsersObject state change.
Public event | CDR_Event | Occurs when a call ends.
Public event | ChannelDetailsEvent | Occurs after a ChannelGetDetails(String) command
Public event | CmdResultEvent | Occurs after many commands.
Public event | CommandListEvent | Occurs after a CLI_CommandsGetList()()()() command
Public event | ConferenceEvent | Occurs when a new conference starts and when it ends
Public event | ConferenceUserEvent | Occurs when a new users join or leave a conference
Public event | ConfigFileListEvent | Occurs after a system command command. V1.6 and up only
Public event | ConfigFileReadEvent | Occurs after the config file has been received and parsed
Public event | ConfigUpdateBeginEvent | Occurs after an Config Update command. is sent
Public event | ConfigUpdateEvent | Occurs after an Config Update result.
Public event | DBEvent | Occurs after commands affecting the AstDB.
Public event | DialPlanCategsEvent | Occurs after a ConfigListCategories(String) command for the dialplan (extensions.conf)
Public event | ErrorEvent | Occurs after an error.
Public event | GetChannelVariableEvent | Occurs after a ChannelGetVar command.
Public event | GetConfigEvent | Occurs after a config file has been received.
Public event | HangupEvent | Occurs when a channel is hungup
Public event | ManagerCommandsListEvent | Occurs after a ManagerCommandsGetList()()()() command
Public event | MbxCountEvent | Occurs after a call to the MailboxGetCount(String) method.
Public event | ModuleListEvent | Occurs after a ModulesGetList()()()() command
Public event | NewCallEvent | Occurs after a new call is established.
Public event | NewExtenEvent | Occurs after each step in the dialplan if enabled. See: ShowNewExten
Public event | OriginateResultEvent | Occurs after an OriginateExtension(String, String, String, String, String) or OriginateApplication(String, String, String, String) command.
Public event | PeerDetailsEvent | Occurs in response to the SIP_GetPeerDetails(String) command
Public event | QueueEntryEvent | Occurs after a AstQueueEntry event is received. See: QueueGetStatus()()()()
Public event | QueueMemberEvent | Occurs after a QueueParam event is received. See: QueueGetStatus()()()()
Public event | QueueParamsEvent | Occurs after a QueueParam event is received. See: QueueGetStatus()()()()
Public event | RawMngrMsgEvent | Occurs after commands returning result a string array.
Public event | SetChannelVariableEvent | Occurs after the ChannelSetVar command.
Public event | ShutdownEvent | Occurs after a Shutdown event is received
Public event | StateChangeEvent | Occurs after a state change of the AMI_Client.
Public event | StatusEvent | Occurs after a status change of the AMI_Client.
Public event | TransferEvent | Occurs after the reception of a TransferEvent.
Public event | UserEventEvent | Occurs after the reception of a UserEvent.
Public event | VersionEvent | Occurs after the response to the GetAsteriskVersion()()()() command.
Public event | WriteErrorEvent | Occurs after a Write error. (disconnected ...)

See Also

AMI_Client Class


AgentCallEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..AgentCallEvent Event
AMI_Client Class See Also Send Feedback
Occurs when an agent is called, when the call is connected (answered) and at the end of agent's calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AgentCallEventHandler AgentCallEvent
Visual Basic
Public Event AgentCallEvent As AgentCallEventHandler
Visual C++
public:
 event AgentCallEventHandler^ AgentCallEvent {
    void add (AgentCallEventHandler^ value);
    void remove (AgentCallEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AgentCallEventArgs
AMIgo..::..AstAgentCall


AgentEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..AgentEvent Event
AMI_Client Class See Also Send Feedback
Occurs on Agent Status, login / off, queue members and other events affecting the agents.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AgentEventHandler AgentEvent
Visual Basic
Public Event AgentEvent As AgentEventHandler
Visual C++
public:
 event AgentEventHandler^ AgentEvent {
    void add (AgentEventHandler^ value);
    void remove (AgentEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AgentsEventArgs
AMIgo..::..AstAgent


AgentSessionEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..AgentSessionEvent Event
AMI_Client Class See Also Send Feedback
Occurs when an agent logs in or off.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AgentSessionEventHandler AgentSessionEvent
Visual Basic
Public Event AgentSessionEvent As AgentSessionEventHandler
Visual C++
public:
 event AgentSessionEventHandler^ AgentSessionEvent {
    void add (AgentSessionEventHandler^ value);
    void remove (AgentSessionEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AgentSessionEventArgs
AMIgo..::..AstAgentSession


AstChannelEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..AstChannelEvent Event
AMI_Client Class See Also Send Feedback
Occurs when a channel state change

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AstChannelEventHandler AstChannelEvent
Visual Basic
Public Event AstChannelEvent As AstChannelEventHandler
Visual C++
public:
 event AstChannelEventHandler^ AstChannelEvent {
    void add (AstChannelEventHandler^ value);
    void remove (AstChannelEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstChannelEventArgs
AMIgo..::..AstChannel


AstUsersObjectEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..AstUsersObjectEvent Event
AMI_Client Class See Also Send Feedback
Occurs when a AstUsersObject state change.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AstUsersObjectEventHandler AstUsersObjectEvent
Visual Basic
Public Event AstUsersObjectEvent As AstUsersObjectEventHandler
Visual C++
public:
 event AstUsersObjectEventHandler^ AstUsersObjectEvent {
    void add (AstUsersObjectEventHandler^ value);
    void remove (AstUsersObjectEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..AstUsersObjectEvent
AMIgo..::..AstUsersObject


CDR_Event Event

[image]

AMIgo Controls documentation
AMI_Client..::..CDR_Event Event
AMI_Client Class See Also Send Feedback
Occurs when a call ends.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event CDR_EventHandler CDR_Event
Visual Basic
Public Event CDR_Event As CDR_EventHandler
Visual C++
public:
 event CDR_EventHandler^ CDR_Event {
    void add (CDR_EventHandler^ value);
    void remove (CDR_EventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..CDR_EventArgs
AMIgo..::..CDR


ChannelDetailsEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ChannelDetailsEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a ChannelGetDetails(String) command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event StatusEventHandler ChannelDetailsEvent
Visual Basic
Public Event ChannelDetailsEvent As StatusEventHandler
Visual C++
public:
 event StatusEventHandler^ ChannelDetailsEvent {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}

See Also

AMI_Client Class


CmdResultEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..CmdResultEvent Event
AMI_Client Class See Also Send Feedback
Occurs after many commands.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event CmdResultHandler CmdResultEvent
Visual Basic
Public Event CmdResultEvent As CmdResultHandler
Visual C++
public:
 event CmdResultHandler^ CmdResultEvent {
    void add (CmdResultHandler^ value);
    void remove (CmdResultHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..CmdResultEventArgs


CommandListEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..CommandListEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a CLI_CommandsGetList()()()() command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event RawMngrMsgHandler CommandListEvent
Visual Basic
Public Event CommandListEvent As RawMngrMsgHandler
Visual C++
public:
 event RawMngrMsgHandler^ CommandListEvent {
    void add (RawMngrMsgHandler^ value);
    void remove (RawMngrMsgHandler^ value);
}

See Also

AMI_Client Class


ConferenceEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConferenceEvent Event
AMI_Client Class See Also Send Feedback
Occurs when a new conference starts and when it ends

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ConferenceEventHandler ConferenceEvent
Visual Basic
Public Event ConferenceEvent As ConferenceEventHandler
Visual C++
public:
 event ConferenceEventHandler^ ConferenceEvent {
    void add (ConferenceEventHandler^ value);
    void remove (ConferenceEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..ConferenceEventArgs
AMIgo..::..AstConference


ConferenceUserEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConferenceUserEvent Event
AMI_Client Class See Also Send Feedback
Occurs when a new users join or leave a conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ConferenceUserEventHandler ConferenceUserEvent
Visual Basic
Public Event ConferenceUserEvent As ConferenceUserEventHandler
Visual C++
public:
 event ConferenceUserEventHandler^ ConferenceUserEvent {
    void add (ConferenceUserEventHandler^ value);
    void remove (ConferenceUserEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..ConferenceUserEventArgs
AMIgo..::..AstConferenceUser


ConfigFileListEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigFileListEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a system command command. V1.6 and up only

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event RawMngrMsgHandler ConfigFileListEvent
Visual Basic
Public Event ConfigFileListEvent As RawMngrMsgHandler
Visual C++
public:
 event RawMngrMsgHandler^ ConfigFileListEvent {
    void add (RawMngrMsgHandler^ value);
    void remove (RawMngrMsgHandler^ value);
}

See Also

AMI_Client Class


ConfigFileReadEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigFileReadEvent Event
AMI_Client Class See Also Send Feedback
Occurs after the config file has been received and parsed

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ConfigFileReadEventHandler ConfigFileReadEvent
Visual Basic
Public Event ConfigFileReadEvent As ConfigFileReadEventHandler
Visual C++
public:
 event ConfigFileReadEventHandler^ ConfigFileReadEvent {
    void add (ConfigFileReadEventHandler^ value);
    void remove (ConfigFileReadEventHandler^ value);
}

Remarks

Notes: This event is mainly used internally. Use ConfigGetFile(String) function to get a .conf file

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..ConfigFileReadEventArgs
ConfigFileReadEventArgs..::..dico_list


ConfigUpdateBeginEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateBeginEvent Event
AMI_Client Class See Also Send Feedback
Occurs after an Config Update command. is sent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event EventHandler ConfigUpdateBeginEvent
Visual Basic
Public Event ConfigUpdateBeginEvent As EventHandler
Visual C++
public:
 event EventHandler^ ConfigUpdateBeginEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ConfigUpdateEvent


ConfigUpdateEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ConfigUpdateEvent Event
AMI_Client Class See Also Send Feedback
Occurs after an Config Update result.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ConfigUpdateEventHandler ConfigUpdateEvent
Visual Basic
Public Event ConfigUpdateEvent As ConfigUpdateEventHandler
Visual C++
public:
 event ConfigUpdateEventHandler^ ConfigUpdateEvent {
    void add (ConfigUpdateEventHandler^ value);
    void remove (ConfigUpdateEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMI_Client..::..ConfigUpdateEvent


DBEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..DBEvent Event
AMI_Client Class See Also Send Feedback
Occurs after commands affecting the AstDB.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event DBEventHandler DBEvent
Visual Basic
Public Event DBEvent As DBEventHandler
Visual C++
public:
 event DBEventHandler^ DBEvent {
    void add (DBEventHandler^ value);
    void remove (DBEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..DBEventArgs


DialPlanCategsEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..DialPlanCategsEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a ConfigListCategories(String) command for the dialplan (extensions.conf)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event RawMngrMsgHandler DialPlanCategsEvent
Visual Basic
Public Event DialPlanCategsEvent As RawMngrMsgHandler
Visual C++
public:
 event RawMngrMsgHandler^ DialPlanCategsEvent {
    void add (RawMngrMsgHandler^ value);
    void remove (RawMngrMsgHandler^ value);
}

See Also

AMI_Client Class


ErrorEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ErrorEvent Event
AMI_Client Class See Also Send Feedback
Occurs after an error.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ErrorEventHandler ErrorEvent
Visual Basic
Public Event ErrorEvent As ErrorEventHandler
Visual C++
public:
 event ErrorEventHandler^ ErrorEvent {
    void add (ErrorEventHandler^ value);
    void remove (ErrorEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..StringMsgEventArgs


GetChannelVariableEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..GetChannelVariableEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a ChannelGetVar command.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event GetChannelVarEventHandler GetChannelVariableEvent
Visual Basic
Public Event GetChannelVariableEvent As GetChannelVarEventHandler
Visual C++
public:
 event GetChannelVarEventHandler^ GetChannelVariableEvent {
    void add (GetChannelVarEventHandler^ value);
    void remove (GetChannelVarEventHandler^ value);
}

See Also

AMI_Client Class


GetConfigEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..GetConfigEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a config file has been received.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event GetConfigEventHandler GetConfigEvent
Visual Basic
Public Event GetConfigEvent As GetConfigEventHandler
Visual C++
public:
 event GetConfigEventHandler^ GetConfigEvent {
    void add (GetConfigEventHandler^ value);
    void remove (GetConfigEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..GetConfigEventArgs


HangupEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..HangupEvent Event
AMI_Client Class See Also Send Feedback
Occurs when a channel is hungup

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AstChannelEventHandler HangupEvent
Visual Basic
Public Event HangupEvent As AstChannelEventHandler
Visual C++
public:
 event AstChannelEventHandler^ HangupEvent {
    void add (AstChannelEventHandler^ value);
    void remove (AstChannelEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstChannelEventArgs
AMIgo..::..AstChannel


ManagerCommandsListEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ManagerCommandsListEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a ManagerCommandsGetList()()()() command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ManagerCommandListHandler ManagerCommandsListEvent
Visual Basic
Public Event ManagerCommandsListEvent As ManagerCommandListHandler
Visual C++
public:
 event ManagerCommandListHandler^ ManagerCommandsListEvent {
    void add (ManagerCommandListHandler^ value);
    void remove (ManagerCommandListHandler^ value);
}

See Also

AMI_Client Class


MbxCountEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..MbxCountEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a call to the MailboxGetCount(String) method.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event MbxCountHandler MbxCountEvent
Visual Basic
Public Event MbxCountEvent As MbxCountHandler
Visual C++
public:
 event MbxCountHandler^ MbxCountEvent {
    void add (MbxCountHandler^ value);
    void remove (MbxCountHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..MbxCountHandler


ModuleListEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ModuleListEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a ModulesGetList()()()() command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event RawMngrMsgHandler ModuleListEvent
Visual Basic
Public Event ModuleListEvent As RawMngrMsgHandler
Visual C++
public:
 event RawMngrMsgHandler^ ModuleListEvent {
    void add (RawMngrMsgHandler^ value);
    void remove (RawMngrMsgHandler^ value);
}

See Also

AMI_Client Class


NewCallEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..NewCallEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a new call is established.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event NewCallEventHandler NewCallEvent
Visual Basic
Public Event NewCallEvent As NewCallEventHandler
Visual C++
public:
 event NewCallEventHandler^ NewCallEvent {
    void add (NewCallEventHandler^ value);
    void remove (NewCallEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..NewCallEventArgs


NewExtenEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..NewExtenEvent Event
AMI_Client Class See Also Send Feedback
Occurs after each step in the dialplan if enabled. See: ShowNewExten

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event AstChannelEventHandler NewExtenEvent
Visual Basic
Public Event NewExtenEvent As AstChannelEventHandler
Visual C++
public:
 event AstChannelEventHandler^ NewExtenEvent {
    void add (AstChannelEventHandler^ value);
    void remove (AstChannelEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..AstChannelEventArgs


OriginateResultEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..OriginateResultEvent Event
AMI_Client Class See Also Send Feedback
Occurs after an OriginateExtension(String, String, String, String, String) or OriginateApplication(String, String, String, String) command.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event OriginateResultEventHandler OriginateResultEvent
Visual Basic
Public Event OriginateResultEvent As OriginateResultEventHandler
Visual C++
public:
 event OriginateResultEventHandler^ OriginateResultEvent {
    void add (OriginateResultEventHandler^ value);
    void remove (OriginateResultEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..OriginateEventArgs
AMIgo..::..OriginateResponse


PeerDetailsEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..PeerDetailsEvent Event
AMI_Client Class See Also Send Feedback
Occurs in response to the SIP_GetPeerDetails(String) command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event StatusEventHandler PeerDetailsEvent
Visual Basic
Public Event PeerDetailsEvent As StatusEventHandler
Visual C++
public:
 event StatusEventHandler^ PeerDetailsEvent {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..StatusEventHandler


QueueEntryEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..QueueEntryEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a AstQueueEntry event is received. See: QueueGetStatus()()()()

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event QueueEntryEventHandler QueueEntryEvent
Visual Basic
Public Event QueueEntryEvent As QueueEntryEventHandler
Visual C++
public:
 event QueueEntryEventHandler^ QueueEntryEvent {
    void add (QueueEntryEventHandler^ value);
    void remove (QueueEntryEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..QueueEntryEventArgs


QueueMemberEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..QueueMemberEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a QueueParam event is received. See: QueueGetStatus()()()()

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event QueueMemberEventHandler QueueMemberEvent
Visual Basic
Public Event QueueMemberEvent As QueueMemberEventHandler
Visual C++
public:
 event QueueMemberEventHandler^ QueueMemberEvent {
    void add (QueueMemberEventHandler^ value);
    void remove (QueueMemberEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..QueueMemberEventArgs


QueueParamsEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..QueueParamsEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a QueueParam event is received. See: QueueGetStatus()()()()

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event QueueParamsEventHandler QueueParamsEvent
Visual Basic
Public Event QueueParamsEvent As QueueParamsEventHandler
Visual C++
public:
 event QueueParamsEventHandler^ QueueParamsEvent {
    void add (QueueParamsEventHandler^ value);
    void remove (QueueParamsEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..QueueParamsEventArgs


RawMngrMsgEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..RawMngrMsgEvent Event
AMI_Client Class See Also Send Feedback
Occurs after commands returning result a string array.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event RawMngrMsgHandler RawMngrMsgEvent
Visual Basic
Public Event RawMngrMsgEvent As RawMngrMsgHandler
Visual C++
public:
 event RawMngrMsgHandler^ RawMngrMsgEvent {
    void add (RawMngrMsgHandler^ value);
    void remove (RawMngrMsgHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..RawMngrMsgEventArgs


SetChannelVariableEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..SetChannelVariableEvent Event
AMI_Client Class See Also Send Feedback
Occurs after the ChannelSetVar command.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event CmdResultHandler SetChannelVariableEvent
Visual Basic
Public Event SetChannelVariableEvent As CmdResultHandler
Visual C++
public:
 event CmdResultHandler^ SetChannelVariableEvent {
    void add (CmdResultHandler^ value);
    void remove (CmdResultHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..CmdResultEventArgs


ShutdownEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..ShutdownEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a Shutdown event is received

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ShutdownEventHandler ShutdownEvent
Visual Basic
Public Event ShutdownEvent As ShutdownEventHandler
Visual C++
public:
 event ShutdownEventHandler^ ShutdownEvent {
    void add (ShutdownEventHandler^ value);
    void remove (ShutdownEventHandler^ value);
}

See Also

AMI_Client Class


StateChangeEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..StateChangeEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a state change of the AMI_Client.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event StateChangeEventHandler StateChangeEvent
Visual Basic
Public Event StateChangeEvent As StateChangeEventHandler
Visual C++
public:
 event StateChangeEventHandler^ StateChangeEvent {
    void add (StateChangeEventHandler^ value);
    void remove (StateChangeEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..StateChangeEventArgs


StatusEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..StatusEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a status change of the AMI_Client.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event StatusEventHandler StatusEvent
Visual Basic
Public Event StatusEvent As StatusEventHandler
Visual C++
public:
 event StatusEventHandler^ StatusEvent {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..StringMsgEventArgs


TransferEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..TransferEvent Event
AMI_Client Class See Also Send Feedback
Occurs after the reception of a TransferEvent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event TransferEventHandler TransferEvent
Visual Basic
Public Event TransferEvent As TransferEventHandler
Visual C++
public:
 event TransferEventHandler^ TransferEvent {
    void add (TransferEventHandler^ value);
    void remove (TransferEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..RawMngrMsgEventArgs


UserEventEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..UserEventEvent Event
AMI_Client Class See Also Send Feedback
Occurs after the reception of a UserEvent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event UserEventHandler UserEventEvent
Visual Basic
Public Event UserEventEvent As UserEventHandler
Visual C++
public:
 event UserEventHandler^ UserEventEvent {
    void add (UserEventHandler^ value);
    void remove (UserEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..RawMngrMsgEventArgs


VersionEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..VersionEvent Event
AMI_Client Class See Also Send Feedback
Occurs after the response to the GetAsteriskVersion()()()() command.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event VersionEventHandler VersionEvent
Visual Basic
Public Event VersionEvent As VersionEventHandler
Visual C++
public:
 event VersionEventHandler^ VersionEvent {
    void add (VersionEventHandler^ value);
    void remove (VersionEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..VersionEventArgs


WriteErrorEvent Event

[image]

AMIgo Controls documentation
AMI_Client..::..WriteErrorEvent Event
AMI_Client Class See Also Send Feedback
Occurs after a Write error. (disconnected ...)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event ErrorEventHandler WriteErrorEvent
Visual Basic
Public Event WriteErrorEvent As ErrorEventHandler
Visual C++
public:
 event ErrorEventHandler^ WriteErrorEvent {
    void add (ErrorEventHandler^ value);
    void remove (ErrorEventHandler^ value);
}

See Also

AMI_Client Class
AMIgo Namespace
AMIgo..::..StringMsgEventArgs


AMI_Client.AMI_ClientState Enumeration

[image]

AMIgo Controls documentation
AMI_Client..::..AMI_ClientState Enumeration
AMI_Client Class See Also Send Feedback
Asterisk Manager Interface Client states

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public enum AMI_ClientState
Visual Basic
Public Enumeration AMI_ClientState
Visual C++
public enum class AMI_ClientState

Members

Member name | Value | Description
IDLE | 0 | Not Started
RUNNING | 1 | After Start(Control) has been called successfully.
CONNECTING | 2 | After Connect()()()() has been called successfully.
CONNECTED | 3 | After successfull connection has been established
LOGGING | 4 | After connection and Login()()()() command sent
LOGGED | 5 | After successfull Login. Commands can be sent.
READY | 6 | After successfull Login. Version and channels types retreived OR Autologin done
LOGGING_OFF | 7 | After Logoff()()()() has been called
DISCONNECTING | 8 | After Logoff and Disconnect()()()() has been called
STOPPING | 9 | After Stop()()()() has been called

Remarks

The initial state is IDLE. A call to Connect and then Login must be issued to get to the LOGGED state before sending any command.

Setting the AutoStart and AutoLogin properties to true will make the AMI_Client attemps to connect and login to the site set in its AstMngrHost, AstMngrPort and AstMngrUserName, AstMngrPassword properties

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AMIgoCommandPanel Class

[image]

AMIgo Controls documentation
AMIgoCommandPanel Class
Members See Also Send Feedback
The Command Panel class ...

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoCommandPanel : AMIgoControl
Visual Basic
Public Class AMIgoCommandPanel _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoCommandPanel : public AMIgoControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoCommandPanel

See Also

AMIgoCommandPanel Members


AMIgoCommandPanel Members

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Members
AMIgoCommandPanel Class Constructors Methods Fields Properties Events See Also Send Feedback

The AMIgoCommandPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoCommandPanel()()()() | Initializes a new instance of the AMIgoCommandPanel class.
Public method | AMIgoCommandPanel(AMI_Client) | Initializes a new instance of the AMIgoCommandPanel class.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handles the CMD result event. Displays commands result in the command panel.
Public method | CommandListEventHandler | Commands list event handler. Handles the Command list event. Fills the CLI command list comboBox items with available CLI commands.
Public method | ConfigFileListEventHandler | Handle the ConfigFileList event
Public method | DialPlanCategsEventHandler | Handler for the ConfigListCategories command. Fills the comboBoxDialPlanCategs items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | GetConfigEventHandler | Handles the GetConfig Event. Opens a config editor with the given string array.
Public method | ModuleListEventHandler | Modules list event handler. Handles the show module event and fills the module ComboBox items with available modules
Protected method | OnHideEvent | Raises the HideEventHandler event. Applcations can use this event to adjust the UI after the command panel is opened / closed.
Public method | OpenTargetsPanel | Opens the targets panel form or restore if minimized.
Public method | StateChangeEventHandler | Handles the State changes event. Display states (etc) in the command panel
Public method | StatusEventHandler | Handles the Status events. Displays the status messages in the cmd panel.
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | HideCmdPanelButton | Gets or sets a value indicating whether to hide the CMD panel button.
Public property | HideConnectionsButton | Gets or sets a value indicating whether to hide the Connections panel button.
Public property | HideTargetButton | Gets or sets a value indicating whether to hide the Targets panel button.
Public property | OpenStatus | Gets or sets a value indicating whether the command panel is opened
Public property | ShowOnStart | Gets or sets a value indicating whether the command panel is opened on startup.

Events

 | Name | Description
Public event | HideEvent | Occurs after the panel is hidden or shown. You can use this event to adjust your layout when the command panel is shown or hidden

See Also

AMIgoCommandPanel Class


AMIgoCommandPanel Constructor

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Constructor
AMIgoCommandPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoCommandPanel()()()() | Initializes a new instance of the AMIgoCommandPanel class.
Public method | AMIgoCommandPanel(AMI_Client) | Initializes a new instance of the AMIgoCommandPanel class.

See Also

AMIgoCommandPanel Class
AMIgoCommandPanel Members


AMIgoCommandPanel Constructor

[image]

AMIgo Controls documentation
AMIgoCommandPanel Constructor
AMIgoCommandPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoCommandPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoCommandPanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoCommandPanel()

See Also

AMIgoCommandPanel Class
AMIgoCommandPanel Overload


AMIgoCommandPanel Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoCommandPanel Constructor (AMI_Client)
AMIgoCommandPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoCommandPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoCommandPanel(
    AMI_Client astMngrInstance
)
Visual Basic
Public Sub New ( _
    astMngrInstance As AMI_Client _
)
Visual C++
public:
AMIgoCommandPanel(
    AMI_Client^ astMngrInstance
)

Parameters

astMngrInstance
Type: AMIgo..::..AMI_Client
The ast MNGR instance.

See Also

AMIgoCommandPanel Class
AMIgoCommandPanel Overload


AMIgoCommandPanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Fields
AMIgoCommandPanel Class See Also Send Feedback

The AMIgoCommandPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoCommandPanel Class


AMIgoCommandPanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Methods
AMIgoCommandPanel Class See Also Send Feedback

The AMIgoCommandPanel type exposes the following members.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handles the CMD result event. Displays commands result in the command panel.
Public method | CommandListEventHandler | Commands list event handler. Handles the Command list event. Fills the CLI command list comboBox items with available CLI commands.
Public method | ConfigFileListEventHandler | Handle the ConfigFileList event
Public method | DialPlanCategsEventHandler | Handler for the ConfigListCategories command. Fills the comboBoxDialPlanCategs items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | GetConfigEventHandler | Handles the GetConfig Event. Opens a config editor with the given string array.
Public method | ModuleListEventHandler | Modules list event handler. Handles the show module event and fills the module ComboBox items with available modules
Protected method | OnHideEvent | Raises the HideEventHandler event. Applcations can use this event to adjust the UI after the command panel is opened / closed.
Public method | OpenTargetsPanel | Opens the targets panel form or restore if minimized.
Public method | StateChangeEventHandler | Handles the State changes event. Display states (etc) in the command panel
Public method | StatusEventHandler | Handles the Status events. Displays the status messages in the cmd panel.
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

See Also

AMIgoCommandPanel Class


CmdResultEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..CmdResultEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handles the CMD result event. Displays commands result in the command panel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CmdResultEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub CmdResultEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void CmdResultEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


CommandListEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..CommandListEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Commands list event handler. Handles the Command list event. Fills the CLI command list comboBox items with available CLI commands.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CommandListEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub CommandListEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void CommandListEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


ConfigFileListEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..ConfigFileListEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handle the ConfigFileList event

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigFileListEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub ConfigFileListEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void ConfigFileListEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

Remarks

This event will occurs only for V1.6 and up and must be trigerred by u auser events with specific parameters.

See Also

AMIgoCommandPanel Class


DialPlanCategsEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..DialPlanCategsEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handler for the ConfigListCategories command. Fills the comboBoxDialPlanCategs items.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DialPlanCategsEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub DialPlanCategsEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void DialPlanCategsEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..Dispose Method
AMIgoCommandPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoCommandPanel Class


GetConfigEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..GetConfigEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handles the GetConfig Event. Opens a config editor with the given string array.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void GetConfigEventHandler(
    Object sender,
    GetConfigEventArgs ev
)
Visual Basic
Public Sub GetConfigEventHandler ( _
    sender As Object, _
    ev As GetConfigEventArgs _
)
Visual C++
public:
void GetConfigEventHandler(
    Object^ sender,
    GetConfigEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..GetConfigEventArgs
The GetConfigEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


ModuleListEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..ModuleListEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Modules list event handler. Handles the show module event and fills the module ComboBox items with available modules

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ModuleListEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub ModuleListEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void ModuleListEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


OnHideEvent Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..OnHideEvent Method
AMIgoCommandPanel Class See Also Send Feedback
Raises the HideEventHandler event. Applcations can use this event to adjust the UI after the command panel is opened / closed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected void OnHideEvent(
    VisibleChangeEventArgs ev
)
Visual Basic
Protected Sub OnHideEvent ( _
    ev As VisibleChangeEventArgs _
)
Visual C++
protected:
void OnHideEvent(
    VisibleChangeEventArgs^ ev
)

Parameters

ev
Type: AMIgo..::..VisibleChangeEventArgs
The VisibleChangeEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


OpenTargetsPanel Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..OpenTargetsPanel Method
AMIgoCommandPanel Class See Also Send Feedback
Opens the targets panel form or restore if minimized.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void OpenTargetsPanel()
Visual Basic
Public Sub OpenTargetsPanel
Visual C++
public:
void OpenTargetsPanel()

See Also

AMIgoCommandPanel Class


StateChangeEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..StateChangeEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handles the State changes event. Display states (etc) in the command panel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StateChangeEventHandler(
    Object sender,
    StateChangeEventArgs ev
)
Visual Basic
Public Sub StateChangeEventHandler ( _
    sender As Object, _
    ev As StateChangeEventArgs _
)
Visual C++
public:
void StateChangeEventHandler(
    Object^ sender,
    StateChangeEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StateChangeEventArgs
The StateChangeEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


StatusEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..StatusEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handles the Status events. Displays the status messages in the cmd panel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StatusEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Sub StatusEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public:
void StatusEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


VersionEventHandler Method

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..VersionEventHandler Method
AMIgoCommandPanel Class See Also Send Feedback
Handle the VersionEvent and sets the control according to the version connected

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void VersionEventHandler(
    Object sender,
    VersionEventArgs ev
)
Visual Basic
Public Sub VersionEventHandler ( _
    sender As Object, _
    ev As VersionEventArgs _
)
Visual C++
public:
void VersionEventHandler(
    Object^ sender,
    VersionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VersionEventArgs
The VersionEventArgs instance containing the event data.

See Also

AMIgoCommandPanel Class


AMIgoCommandPanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Properties
AMIgoCommandPanel Class See Also Send Feedback

The AMIgoCommandPanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | HideCmdPanelButton | Gets or sets a value indicating whether to hide the CMD panel button.
Public property | HideConnectionsButton | Gets or sets a value indicating whether to hide the Connections panel button.
Public property | HideTargetButton | Gets or sets a value indicating whether to hide the Targets panel button.
Public property | OpenStatus | Gets or sets a value indicating whether the command panel is opened
Public property | ShowOnStart | Gets or sets a value indicating whether the command panel is opened on startup.

See Also

AMIgoCommandPanel Class


HideCmdPanelButton Property

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..HideCmdPanelButton Property
AMIgoCommandPanel Class See Also Send Feedback
Gets or sets a value indicating whether to hide the CMD panel button.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HideCmdPanelButton { get; set; }
Visual Basic
Public Property HideCmdPanelButton As Boolean
    Get
    Set
Visual C++
public:
property bool HideCmdPanelButton {
    bool get ();
    void set (bool value);
}

Field Value

true to hide the CMD panel button, default to false.

See Also

AMIgoCommandPanel Class


HideConnectionsButton Property

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..HideConnectionsButton Property
AMIgoCommandPanel Class See Also Send Feedback
Gets or sets a value indicating whether to hide the Connections panel button.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HideConnectionsButton { get; set; }
Visual Basic
Public Property HideConnectionsButton As Boolean
    Get
    Set
Visual C++
public:
property bool HideConnectionsButton {
    bool get ();
    void set (bool value);
}

Field Value

true to hide the Connections panel button, default to false.

See Also

AMIgoCommandPanel Class


HideTargetButton Property

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..HideTargetButton Property
AMIgoCommandPanel Class See Also Send Feedback
Gets or sets a value indicating whether to hide the Targets panel button.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HideTargetButton { get; set; }
Visual Basic
Public Property HideTargetButton As Boolean
    Get
    Set
Visual C++
public:
property bool HideTargetButton {
    bool get ();
    void set (bool value);
}

Field Value

true to hide the Targets panel button, default to false.

See Also

AMIgoCommandPanel Class


OpenStatus Property

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..OpenStatus Property
AMIgoCommandPanel Class See Also Send Feedback
Gets or sets a value indicating whether the command panel is opened

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool OpenStatus { get; set; }
Visual Basic
Public Property OpenStatus As Boolean
    Get
    Set
Visual C++
public:
property bool OpenStatus {
    bool get ();
    void set (bool value);
}

See Also

AMIgoCommandPanel Class


ShowOnStart Property

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..ShowOnStart Property
AMIgoCommandPanel Class See Also Send Feedback
Gets or sets a value indicating whether the command panel is opened on startup.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowOnStart { get; set; }
Visual Basic
Public Property ShowOnStart As Boolean
    Get
    Set
Visual C++
public:
property bool ShowOnStart {
    bool get ();
    void set (bool value);
}

Field Value

true if [show on start]; otherwise, false.

Remarks

Set to true to show the panel on startup.

See Also

AMIgoCommandPanel Class


AMIgoCommandPanel Events

[image] [image]

AMIgo Controls documentation
AMIgoCommandPanel Events
AMIgoCommandPanel Class See Also Send Feedback

The AMIgoCommandPanel type exposes the following members.

Events

 | Name | Description
Public event | HideEvent | Occurs after the panel is hidden or shown. You can use this event to adjust your layout when the command panel is shown or hidden

See Also

AMIgoCommandPanel Class


HideEvent Event

[image]

AMIgo Controls documentation
AMIgoCommandPanel..::..HideEvent Event
AMIgoCommandPanel Class See Also Send Feedback
Occurs after the panel is hidden or shown. You can use this event to adjust your layout when the command panel is shown or hidden

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public event HideEventHandler HideEvent
Visual Basic
Public Event HideEvent As HideEventHandler
Visual C++
public:
 event HideEventHandler^ HideEvent {
    void add (HideEventHandler^ value);
    void remove (HideEventHandler^ value);
}

See Also

AMIgoCommandPanel Class


AMIgoConfigControl Class

[image]

AMIgo Controls documentation
AMIgoConfigControl Class
Members See Also Send Feedback
This is the base control from which most config / setips controls inherits

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoConfigControl : AMIgoControl
Visual Basic
Public Class AMIgoConfigControl _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoConfigControl : public AMIgoControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoConfigEditorPanel
AMIgo..::..AMIgoDialplanEditorPanel
AMIgo..::..AMIgoSetupAgentPanel
AMIgo..::..AMIgoSetupConferencePanel
AMIgo..::..AMIgoSetupPanel
AMIgo..::..AMIgoSetupQueuePanel

See Also

AMIgoConfigControl Members


AMIgoConfigControl Members

[image] [image]

AMIgo Controls documentation
AMIgoConfigControl Members
AMIgoConfigControl Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoConfigControl type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoConfigControl | Initializes a new instance of the AMIgoConfigControl class.

Methods

 | Name | Description
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoConfigControl Class


AMIgoConfigControl Constructor

[image]

AMIgo Controls documentation
AMIgoConfigControl Constructor
AMIgoConfigControl Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigControl class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigControl()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoConfigControl()

See Also

AMIgoConfigControl Class


AMIgoConfigControl Fields

[image] [image]

AMIgo Controls documentation
AMIgoConfigControl Fields
AMIgoConfigControl Class See Also Send Feedback

The AMIgoConfigControl type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoConfigControl Class


AMIgoConfigControl Methods

[image] [image]

AMIgo Controls documentation
AMIgoConfigControl Methods
AMIgoConfigControl Class See Also Send Feedback

The AMIgoConfigControl type exposes the following members.

Methods

 | Name | Description
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary

See Also

AMIgoConfigControl Class


GetNextUnusedExtension Method

[image]

AMIgo Controls documentation
AMIgoConfigControl..::..GetNextUnusedExtension Method
AMIgoConfigControl Class See Also Send Feedback
Gets the next unused extension for the given categories taken from guipreferences.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected string GetNextUnusedExtension(
    string LabelStart,
    string LabelEnd,
    List<Dictionary<string, string>> DicoList
)
Visual Basic
Protected Function GetNextUnusedExtension ( _
    LabelStart As String, _
    LabelEnd As String, _
    DicoList As List(Of Dictionary(Of String, String)) _
) As String
Visual C++
protected:
String^ GetNextUnusedExtension(
    String^ LabelStart,
    String^ LabelEnd,
    List<Dictionary<String^, String^>^>^ DicoList
)

Parameters

LabelStart
Type: System..::..String
The Label start.
LabelEnd
Type: System..::..String
The Label end.
DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
The dico list.

Return Value

A string containing the extension or an empty string

See Also

AMIgoConfigControl Class


UpdateDicolist Method

[image]

AMIgo Controls documentation
AMIgoConfigControl..::..UpdateDicolist Method
AMIgoConfigControl Class See Also Send Feedback
Updates the given dictionary list with a given updated dictionary

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected void UpdateDicolist(
    List<Dictionary<string, string>> DicoList,
    Dictionary<string, string> Dico
)
Visual Basic
Protected Sub UpdateDicolist ( _
    DicoList As List(Of Dictionary(Of String, String)), _
    Dico As Dictionary(Of String, String) _
)
Visual C++
protected:
void UpdateDicolist(
    List<Dictionary<String^, String^>^>^ DicoList,
    Dictionary<String^, String^>^ Dico
)

Parameters

DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
The dictionary list.
Dico
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The updated dictionary.

See Also

AMIgoConfigControl Class


AMIgoConfigControl Properties

[image] [image]

AMIgo Controls documentation
AMIgoConfigControl Properties
AMIgoConfigControl Class See Also Send Feedback

The AMIgoConfigControl type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoConfigControl Class


AMIgoConfigEditorForm Class

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm Class
Members Example See Also Send Feedback
The asterisk config file editor Form class

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoConfigEditorForm : Form
Visual Basic
Public Class AMIgoConfigEditorForm _
    Inherits Form
Visual C++
public ref class AMIgoConfigEditorForm : public Form

Remarks

This control displays the AMIgoConfigEditorPanel in a form.

Examples

USAGE: Use this form in response to a GetConfigEvent which is triggered after a config file has been received and parsed. Use the ConfigGetFile(String) file to get a configuration file presernt in the asterisk config directory. (usually /etc/asterisk).

To create a new form, you can use the AMI_Client method ConfigOpenEditor(String, array<String>[]()[][]) . Or you can create a new form using one of the constructors:

CopyC#
1 // Create a new form with the given FileName and config strings
2AMIgoConfigEditorForm ConfigEditor = new AMIgoConfigEditorForm(this, FileName, Strings, false);
3// Show the form with the config text and Allow to edit.
4ConfigEditor.Show();

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..AMIgoConfigEditorForm

See Also

AMIgoConfigEditorForm Members
AMIgo Namespace
AMIgo..::..AMIgoConfigEditorPanel


AMIgoConfigEditorForm Members

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorForm Members
AMIgoConfigEditorForm Class Constructors Methods See Also Send Feedback

The AMIgoConfigEditorForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoConfigEditorForm()()()() | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorForm(AMI_Client, String, String, array<String>[]()[][]) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorForm(AMI_Client, String, array<String>[]()[][], Boolean) | Initializes a new instance of the AMIgoConfigEditorForm class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | LoadConfig | Loads and parses the config lines .
Public method | LoadConfigCategory | Loads a given Context (index in a Dictionary List.

See Also

AMIgoConfigEditorForm Class


AMIgoConfigEditorForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorForm Constructor
AMIgoConfigEditorForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoConfigEditorForm()()()() | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorForm(AMI_Client, String, String, array<String>[]()[][]) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorForm(AMI_Client, String, array<String>[]()[][], Boolean) | Initializes a new instance of the AMIgoConfigEditorForm class.

See Also

AMIgoConfigEditorForm Class
AMIgoConfigEditorForm Members


AMIgoConfigEditorForm Constructor

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm Constructor
AMIgoConfigEditorForm Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoConfigEditorForm()

See Also

AMIgoConfigEditorForm Class
AMIgoConfigEditorForm Overload


AMIgoConfigEditorForm Constructor (AMI_Client, String, String, String[])

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm Constructor (AMI_Client, String, String, array<String>[]()[][])
AMIgoConfigEditorForm Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorForm(
    AMI_Client AMIgoClientInstance,
    string FileName,
    string Context,
    string[] EditStrings
)
Visual Basic
Public Sub New ( _
    AMIgoClientInstance As AMI_Client, _
    FileName As String, _
    Context As String, _
    EditStrings As String() _
)
Visual C++
public:
AMIgoConfigEditorForm(
    AMI_Client^ AMIgoClientInstance,
    String^ FileName,
    String^ Context,
    array<String^>^ EditStrings
)

Parameters

AMIgoClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager client instance.
FileName
Type: System..::..String
Name of the file.
Context
Type: System..::..String
The Context name
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.

Remarks

Use this constructor to load a given Context from a parsed .conf

See Also

AMIgoConfigEditorForm Class
AMIgoConfigEditorForm Overload


AMIgoConfigEditorForm Constructor (AMI_Client, String, String[], Boolean)

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm Constructor (AMI_Client, String, array<String>[]()[][], Boolean)
AMIgoConfigEditorForm Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorForm(
    AMI_Client AMIgoClientInstance,
    string FileName,
    string[] EditStrings,
    bool IsParsed
)
Visual Basic
Public Sub New ( _
    AMIgoClientInstance As AMI_Client, _
    FileName As String, _
    EditStrings As String(), _
    IsParsed As Boolean _
)
Visual C++
public:
AMIgoConfigEditorForm(
    AMI_Client^ AMIgoClientInstance,
    String^ FileName,
    array<String^>^ EditStrings,
    bool IsParsed
)

Parameters

AMIgoClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager client instance.
FileName
Type: System..::..String
Name of the file.
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.
IsParsed
Type: System..::..Boolean
false if strings needs to be parsed, otherwise true.

Remarks

Use this constructor to load a complete unparsed .conf file

See Also

AMIgoConfigEditorForm Class
AMIgoConfigEditorForm Overload


AMIgoConfigEditorForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorForm Methods
AMIgoConfigEditorForm Class See Also Send Feedback

The AMIgoConfigEditorForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | LoadConfig | Loads and parses the config lines .
Public method | LoadConfigCategory | Loads a given Context (index in a Dictionary List.

See Also

AMIgoConfigEditorForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm..::..Dispose Method
AMIgoConfigEditorForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoConfigEditorForm Class


LoadConfig Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm..::..LoadConfig Method
AMIgoConfigEditorForm Class See Also Send Feedback
Loads and parses the config lines .

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void LoadConfig(
    string FileName,
    string[] EditStrings,
    bool IsParsed
)
Visual Basic
Public Sub LoadConfig ( _
    FileName As String, _
    EditStrings As String(), _
    IsParsed As Boolean _
)
Visual C++
public:
void LoadConfig(
    String^ FileName,
    array<String^>^ EditStrings,
    bool IsParsed
)

Parameters

FileName
Type: System..::..String
Name of the file.
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.
IsParsed
Type: System..::..Boolean
false if strings needs to be parsed, otherwise true.

See Also

AMIgoConfigEditorForm Class


LoadConfigCategory Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorForm..::..LoadConfigCategory Method
AMIgoConfigEditorForm Class See Also Send Feedback
Loads a given Context (index in a Dictionary List.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void LoadConfigCategory(
    List<Dictionary<string, string>> DicoList,
    int IndexInList
)
Visual Basic
Public Sub LoadConfigCategory ( _
    DicoList As List(Of Dictionary(Of String, String)), _
    IndexInList As Integer _
)
Visual C++
public:
void LoadConfigCategory(
    List<Dictionary<String^, String^>^>^ DicoList,
    int IndexInList
)

Parameters

DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
List of dictionary from parsed config lines.
IndexInList
Type: System..::..Int32
Index in List of dictionary of Category to edit

See Also

AMIgoConfigEditorForm Class


AMIgoConfigEditorPanel Class

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Class
Members See Also Send Feedback
The asterisk config file editor Panel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoConfigEditorPanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoConfigEditorPanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoConfigEditorPanel : public AMIgoConfigControl

Remarks

Used by the AMIgoConfigEditorForm.

This panel can be droped into your application supplied container (i.e. form, SplitPanel etc)

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoConfigEditorPanel

See Also

AMIgoConfigEditorPanel Members


AMIgoConfigEditorPanel Members

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Members
AMIgoConfigEditorPanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoConfigEditorPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoConfigEditorPanel()()()() | Initializes a new instance of the AMIgoConfigEditorPanel class.
Public method | AMIgoConfigEditorPanel(AMI_Client, List<(Of <<'(Dictionary<(Of <<'(String, String>)>>)>)>>), Int32) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorPanel(AMI_Client, String, String, array<String>[]()[][]) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorPanel(AMI_Client, String, array<String>[]()[][], Boolean) | Initializes a new instance of the AMIgoConfigEditorForm class.

Methods

 | Name | Description
Public method | AstConfigEditor_FormClosing | Handles the FormClosing event of the AstConfigEditor control.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | LoadConfig | Loads and parses the config lines .
Public method | LoadConfigCategory | Loads a given Context (index in a Dictionary List.
Public method | LoadConfigContext | Loads and optionally parses the config lines .
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoConfigEditorPanel Class


AMIgoConfigEditorPanel Constructor

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Constructor
AMIgoConfigEditorPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoConfigEditorPanel()()()() | Initializes a new instance of the AMIgoConfigEditorPanel class.
Public method | AMIgoConfigEditorPanel(AMI_Client, List<(Of <<'(Dictionary<(Of <<'(String, String>)>>)>)>>), Int32) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorPanel(AMI_Client, String, String, array<String>[]()[][]) | Initializes a new instance of the AMIgoConfigEditorForm class.
Public method | AMIgoConfigEditorPanel(AMI_Client, String, array<String>[]()[][], Boolean) | Initializes a new instance of the AMIgoConfigEditorForm class.

See Also

AMIgoConfigEditorPanel Class
AMIgoConfigEditorPanel Members


AMIgoConfigEditorPanel Constructor

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Constructor
AMIgoConfigEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorPanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoConfigEditorPanel()

See Also

AMIgoConfigEditorPanel Class
AMIgoConfigEditorPanel Overload


AMIgoConfigEditorPanel Constructor (AMI_Client, List(Dictionary(String, String)), Int32)

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Constructor (AMI_Client, List<(Of <(<'Dictionary<(Of <(<'String, String>)>)>>)>)>, Int32)
AMIgoConfigEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorPanel(
    AMI_Client AMIgoClientInstance,
    List<Dictionary<string, string>> DicoList,
    int IndexInList
)
Visual Basic
Public Sub New ( _
    AMIgoClientInstance As AMI_Client, _
    DicoList As List(Of Dictionary(Of String, String)), _
    IndexInList As Integer _
)
Visual C++
public:
AMIgoConfigEditorPanel(
    AMI_Client^ AMIgoClientInstance,
    List<Dictionary<String^, String^>^>^ DicoList,
    int IndexInList
)

Parameters

AMIgoClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager client instance.
DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
List of dictionary from parsed config lines.
IndexInList
Type: System..::..Int32
Index in List of dictionary of Category to edit

Remarks

Use this constructor to load a given Context from a parsed .conf

See Also

AMIgoConfigEditorPanel Class
AMIgoConfigEditorPanel Overload


AMIgoConfigEditorPanel Constructor (AMI_Client, String, String, String[])

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Constructor (AMI_Client, String, String, array<String>[]()[][])
AMIgoConfigEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorPanel(
    AMI_Client AMIgoClientInstance,
    string FileName,
    string Context,
    string[] EditStrings
)
Visual Basic
Public Sub New ( _
    AMIgoClientInstance As AMI_Client, _
    FileName As String, _
    Context As String, _
    EditStrings As String() _
)
Visual C++
public:
AMIgoConfigEditorPanel(
    AMI_Client^ AMIgoClientInstance,
    String^ FileName,
    String^ Context,
    array<String^>^ EditStrings
)

Parameters

AMIgoClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager client instance.
FileName
Type: System..::..String
Name of the file.
Context
Type: System..::..String
The Context name
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.

Remarks

Use this constructor to load a given Context from a parsed .conf

See Also

AMIgoConfigEditorPanel Class
AMIgoConfigEditorPanel Overload


AMIgoConfigEditorPanel Constructor (AMI_Client, String, String[], Boolean)

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Constructor (AMI_Client, String, array<String>[]()[][], Boolean)
AMIgoConfigEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoConfigEditorForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoConfigEditorPanel(
    AMI_Client AMIgoClientInstance,
    string FileName,
    string[] EditStrings,
    bool IsParsed
)
Visual Basic
Public Sub New ( _
    AMIgoClientInstance As AMI_Client, _
    FileName As String, _
    EditStrings As String(), _
    IsParsed As Boolean _
)
Visual C++
public:
AMIgoConfigEditorPanel(
    AMI_Client^ AMIgoClientInstance,
    String^ FileName,
    array<String^>^ EditStrings,
    bool IsParsed
)

Parameters

AMIgoClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager client instance.
FileName
Type: System..::..String
Name of the file.
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.
IsParsed
Type: System..::..Boolean
false if strings needs to be parsed, otherwise true.

Remarks

Use this constructor to load a complete unparsed .conf file

See Also

AMIgoConfigEditorPanel Class
AMIgoConfigEditorPanel Overload


AMIgoConfigEditorPanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Fields
AMIgoConfigEditorPanel Class See Also Send Feedback

The AMIgoConfigEditorPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoConfigEditorPanel Class


AMIgoConfigEditorPanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Methods
AMIgoConfigEditorPanel Class See Also Send Feedback

The AMIgoConfigEditorPanel type exposes the following members.

Methods

 | Name | Description
Public method | AstConfigEditor_FormClosing | Handles the FormClosing event of the AstConfigEditor control.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | LoadConfig | Loads and parses the config lines .
Public method | LoadConfigCategory | Loads a given Context (index in a Dictionary List.
Public method | LoadConfigContext | Loads and optionally parses the config lines .
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoConfigEditorPanel Class


AstConfigEditor_FormClosing Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel..::..AstConfigEditor_FormClosing Method
AMIgoConfigEditorPanel Class See Also Send Feedback
Handles the FormClosing event of the AstConfigEditor control.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void AstConfigEditor_FormClosing(
    Object sender,
    FormClosingEventArgs e
)
Visual Basic
Public Sub AstConfigEditor_FormClosing ( _
    sender As Object, _
    e As FormClosingEventArgs _
)
Visual C++
public:
void AstConfigEditor_FormClosing(
    Object^ sender,
    FormClosingEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: System.Windows.Forms..::..FormClosingEventArgs
The FormClosingEventArgs instance containing the event data.

See Also

AMIgoConfigEditorPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel..::..Dispose Method
AMIgoConfigEditorPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoConfigEditorPanel Class


LoadConfig Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel..::..LoadConfig Method
AMIgoConfigEditorPanel Class See Also Send Feedback
Loads and parses the config lines .

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void LoadConfig(
    string FileName,
    string[] EditStrings,
    bool IsParsed
)
Visual Basic
Public Sub LoadConfig ( _
    FileName As String, _
    EditStrings As String(), _
    IsParsed As Boolean _
)
Visual C++
public:
void LoadConfig(
    String^ FileName,
    array<String^>^ EditStrings,
    bool IsParsed
)

Parameters

FileName
Type: System..::..String
Name of the file.
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.
IsParsed
Type: System..::..Boolean
false if strings needs to be parsed, otherwise true.

See Also

AMIgoConfigEditorPanel Class


LoadConfigCategory Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel..::..LoadConfigCategory Method
AMIgoConfigEditorPanel Class See Also Send Feedback
Loads a given Context (index in a Dictionary List.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void LoadConfigCategory(
    List<Dictionary<string, string>> DicoList,
    int IndexInList
)
Visual Basic
Public Sub LoadConfigCategory ( _
    DicoList As List(Of Dictionary(Of String, String)), _
    IndexInList As Integer _
)
Visual C++
public:
void LoadConfigCategory(
    List<Dictionary<String^, String^>^>^ DicoList,
    int IndexInList
)

Parameters

DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
List of dictionary from parsed config lines.
IndexInList
Type: System..::..Int32
Index in List of dictionary of Category to edit

See Also

AMIgoConfigEditorPanel Class


LoadConfigContext Method

[image]

AMIgo Controls documentation
AMIgoConfigEditorPanel..::..LoadConfigContext Method
AMIgoConfigEditorPanel Class See Also Send Feedback
Loads and optionally parses the config lines .

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void LoadConfigContext(
    string FileName,
    string Context,
    string[] EditStrings,
    bool IsParsed
)
Visual Basic
Public Sub LoadConfigContext ( _
    FileName As String, _
    Context As String, _
    EditStrings As String(), _
    IsParsed As Boolean _
)
Visual C++
public:
void LoadConfigContext(
    String^ FileName,
    String^ Context,
    array<String^>^ EditStrings,
    bool IsParsed
)

Parameters

FileName
Type: System..::..String
Name of the file.
Context
Type: System..::..String
Name of the Context to load.
EditStrings
Type: array< System..::..String >[]()[][]
The edit strings.
IsParsed
Type: System..::..Boolean
false if strings needs to be parsed, otherwise true.

See Also

AMIgoConfigEditorPanel Class


AMIgoConfigEditorPanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoConfigEditorPanel Properties
AMIgoConfigEditorPanel Class See Also Send Feedback

The AMIgoConfigEditorPanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoConfigEditorPanel Class


AMIgoControl Class

[image]

AMIgo Controls documentation
AMIgoControl Class
Members See Also Send Feedback
This is the base control from which inherit most of the AMIgo controls

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoControl : UserControl
Visual Basic
Public Class AMIgoControl _
    Inherits UserControl
Visual C++
public ref class AMIgoControl : public UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoCommandPanel
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..AmigoMsgDisplayPanel
AMIgo..::..AMIgoSetupAgentForm
AMIgo..::..AMIgoSetupConferenceForm
AMIgo..::..AMIgoSetupQueueForm
AMIgo..::..AMIgoStatusStrip
AMIgo..::..DataGridViewAgents
AMIgo..::..DataGridViewAgentsEntries
AMIgo..::..DataGridViewChannels
AMIgo..::..DataGridViewLines
AMIgo..::..DataGridViewQueueMembers
AMIgo..::..DataGridViewQueues
AMIgo..::..DataGridViewQueuesEntries
AMIgo..::..ListViewCalls

See Also

AMIgoControl Members


AMIgoControl Members

[image] [image]

AMIgo Controls documentation
AMIgoControl Members
AMIgoControl Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoControl type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoControl()()()() | Initializes a new instance of the AMIgoControl class.
Public method | AMIgoControl(AMI_Client) | Initializes a new instance of the AMIgoControl class.

Methods

 | Name | Description
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank.

See Also

AMIgoControl Class


AMIgoControl Constructor

[image] [image]

AMIgo Controls documentation
AMIgoControl Constructor
AMIgoControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoControl()()()() | Initializes a new instance of the AMIgoControl class.
Public method | AMIgoControl(AMI_Client) | Initializes a new instance of the AMIgoControl class.

See Also

AMIgoControl Class
AMIgoControl Members


AMIgoControl Constructor

[image]

AMIgo Controls documentation
AMIgoControl Constructor
AMIgoControl Class See Also Send Feedback
Initializes a new instance of the AMIgoControl class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoControl()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoControl()

See Also

AMIgoControl Class
AMIgoControl Overload


AMIgoControl Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoControl Constructor (AMI_Client)
AMIgoControl Class See Also Send Feedback
Initializes a new instance of the AMIgoControl class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoControl(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoControl(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.

See Also

AMIgoControl Class
AMIgoControl Overload


AMIgoControl Fields

[image] [image]

AMIgo Controls documentation
AMIgoControl Fields
AMIgoControl Class See Also Send Feedback

The AMIgoControl type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized.

See Also

AMIgoControl Class


_InitDone Field

[image]

AMIgo Controls documentation
AMIgoControl..::.._InitDone Field
AMIgoControl Class See Also Send Feedback
true after this control has been initialized.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool _InitDone
Visual Basic
Public _InitDone As Boolean
Visual C++
public:
bool _InitDone

See Also

AMIgoControl Class


AMIgoControl Methods

[image] [image]

AMIgo Controls documentation
AMIgoControl Methods
AMIgoControl Class See Also Send Feedback

The AMIgoControl type exposes the following members.

Methods

 | Name | Description
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits

See Also

AMIgoControl Class


FindControlRecursive Method

[image]

AMIgo Controls documentation
AMIgoControl..::..FindControlRecursive Method
AMIgoControl Class See Also Send Feedback
Finds a Control recursively. Note finds the first match and exits

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Control FindControlRecursive(
    Control Container,
    string TypeName
)
Visual Basic
Public Function FindControlRecursive ( _
    Container As Control, _
    TypeName As String _
) As Control
Visual C++
public:
Control^ FindControlRecursive(
    Control^ Container,
    String^ TypeName
)

Parameters

Container
Type: System.Windows.Forms..::..Control
The container to search for the given control type. Remember all controls (Panel, GroupBox, Form, etc are all containers for controls
TypeName
Type: System..::..String
Name of the type of control to look for

Return Value

The control object if found or null

See Also

AMIgoControl Class


AMIgoControl Properties

[image] [image]

AMIgo Controls documentation
AMIgoControl Properties
AMIgoControl Class See Also Send Feedback

The AMIgoControl type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank.

See Also

AMIgoControl Class


AMI_ClientInstance Property

[image]

AMIgo Controls documentation
AMIgoControl..::..AMI_ClientInstance Property
AMIgoControl Class See Also Send Feedback
Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public virtual AMI_Client AMI_ClientInstance { get; set; }
Visual Basic
Public Overridable Property AMI_ClientInstance As AMI_Client
    Get
    Set
Visual C++
public:
virtual property AMI_Client^ AMI_ClientInstance {
    AMI_Client^ get ();
    void set (AMI_Client^ value);
}

See Also

AMIgoControl Class


AMIgoDialplanEditorPanel Class

[image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Class
Members See Also Send Feedback
This control is used to edit the dial plan (extensions.conf).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoDialplanEditorPanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoDialplanEditorPanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoDialplanEditorPanel : public AMIgoConfigControl

Remarks

This Panel is intended to be displayed in another container or in a Form. It is used in the AMIgoSetupPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoDialplanEditorPanel

See Also

AMIgoDialplanEditorPanel Members


AMIgoDialplanEditorPanel Members

[image] [image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Members
AMIgoDialplanEditorPanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoDialplanEditorPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoDialplanEditorPanel()()()() | Initializes a new instance of the AMIgoDialplanEditorPanel class.
Public method | AMIgoDialplanEditorPanel(AMI_Client) | Initializes a new instance of the AMIgoDialplanEditorPanel class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | UpdateContextsTree | Updates the contexts tree.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoDialplanEditorPanel Class


AMIgoDialplanEditorPanel Constructor

[image] [image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Constructor
AMIgoDialplanEditorPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoDialplanEditorPanel()()()() | Initializes a new instance of the AMIgoDialplanEditorPanel class.
Public method | AMIgoDialplanEditorPanel(AMI_Client) | Initializes a new instance of the AMIgoDialplanEditorPanel class.

See Also

AMIgoDialplanEditorPanel Class
AMIgoDialplanEditorPanel Members


AMIgoDialplanEditorPanel Constructor

[image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Constructor
AMIgoDialplanEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoDialplanEditorPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDialplanEditorPanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoDialplanEditorPanel()

See Also

AMIgoDialplanEditorPanel Class
AMIgoDialplanEditorPanel Overload


AMIgoDialplanEditorPanel Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Constructor (AMI_Client)
AMIgoDialplanEditorPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoDialplanEditorPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDialplanEditorPanel(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoDialplanEditorPanel(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AM i_ client instance.

See Also

AMIgoDialplanEditorPanel Class
AMIgoDialplanEditorPanel Overload


AMIgoDialplanEditorPanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Fields
AMIgoDialplanEditorPanel Class See Also Send Feedback

The AMIgoDialplanEditorPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoDialplanEditorPanel Class


AMIgoDialplanEditorPanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Methods
AMIgoDialplanEditorPanel Class See Also Send Feedback

The AMIgoDialplanEditorPanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | UpdateContextsTree | Updates the contexts tree.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoDialplanEditorPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel..::..Dispose Method
AMIgoDialplanEditorPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoDialplanEditorPanel Class


UpdateContextsTree Method

[image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel..::..UpdateContextsTree Method
AMIgoDialplanEditorPanel Class See Also Send Feedback
Updates the contexts tree.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void UpdateContextsTree()
Visual Basic
Public Sub UpdateContextsTree
Visual C++
public:
void UpdateContextsTree()

See Also

AMIgoDialplanEditorPanel Class


AMIgoDialplanEditorPanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoDialplanEditorPanel Properties
AMIgoDialplanEditorPanel Class See Also Send Feedback

The AMIgoDialplanEditorPanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoDialplanEditorPanel Class


AMIgoDisplayForm Class

[image]

AMIgo Controls documentation
AMIgoDisplayForm Class
Members Example See Also Send Feedback
This is a form descendant used to display elements details

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoDisplayForm : Form
Visual Basic
Public Class AMIgoDisplayForm _
    Inherits Form
Visual C++
public ref class AMIgoDisplayForm : public Form

Remarks

This form can be used to display the peers / channels details or any other information given in the string parameter. The given sting is displayed in a form and can be copied to the clipboard.

Examples

CopyC#
1private void AMI_Client_PeerDetailsEvent(object sender, AMIgo.StringMsgEventArgs ev)
2{
3  AMIgoDisplayForm df = new  AMIgoDisplayForm("Peer Details", ev.string_msg);
4  df.Show();
5}

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..AMIgoDisplayForm

See Also

AMIgoDisplayForm Members
AMIgo Namespace
AMI_Client..::..SIP_GetPeerDetails(String)
AMI_Client..::..PeerDetailsEvent


AMIgoDisplayForm Members

[image] [image]

AMIgo Controls documentation
AMIgoDisplayForm Members
AMIgoDisplayForm Class Constructors Methods Properties See Also Send Feedback

The AMIgoDisplayForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoDisplayForm()()()() | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String) | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String, String) | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String, array<String>[]()[][]) | Initializes a new instance of the AMIgoDisplayForm class.

Methods

 | Name | Description
Public method | CopyToClipboard | Copies the content of the textbox to the clipboard.
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | FormText | Gets or sets the form's header text.

See Also

AMIgoDisplayForm Class


AMIgoDisplayForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoDisplayForm Constructor
AMIgoDisplayForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoDisplayForm()()()() | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String) | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String, String) | Initializes a new instance of the AMIgoDisplayForm class.
Public method | AMIgoDisplayForm(String, array<String>[]()[][]) | Initializes a new instance of the AMIgoDisplayForm class.

See Also

AMIgoDisplayForm Class
AMIgoDisplayForm Members


AMIgoDisplayForm Constructor

[image]

AMIgo Controls documentation
AMIgoDisplayForm Constructor
AMIgoDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDisplayForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoDisplayForm()

See Also

AMIgoDisplayForm Class
AMIgoDisplayForm Overload


AMIgoDisplayForm Constructor (String)

[image]

AMIgo Controls documentation
AMIgoDisplayForm Constructor (String)
AMIgoDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDisplayForm(
    string TextBoxString
)
Visual Basic
Public Sub New ( _
    TextBoxString As String _
)
Visual C++
public:
AMIgoDisplayForm(
    String^ TextBoxString
)

Parameters

TextBoxString
Type: System..::..String
The text to display.

See Also

AMIgoDisplayForm Class
AMIgoDisplayForm Overload


AMIgoDisplayForm Constructor (String, String)

[image]

AMIgo Controls documentation
AMIgoDisplayForm Constructor (String, String)
AMIgoDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDisplayForm(
    string FormTitle,
    string TextBoxString
)
Visual Basic
Public Sub New ( _
    FormTitle As String, _
    TextBoxString As String _
)
Visual C++
public:
AMIgoDisplayForm(
    String^ FormTitle,
    String^ TextBoxString
)

Parameters

FormTitle
Type: System..::..String
The form header text (title).
TextBoxString
Type: System..::..String
The text to display.

See Also

AMIgoDisplayForm Class
AMIgoDisplayForm Overload


AMIgoDisplayForm Constructor (String, String[])

[image]

AMIgo Controls documentation
AMIgoDisplayForm Constructor (String, array<String>[]()[][])
AMIgoDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDisplayForm(
    string FormTitle,
    string[] TextBoxStrings
)
Visual Basic
Public Sub New ( _
    FormTitle As String, _
    TextBoxStrings As String() _
)
Visual C++
public:
AMIgoDisplayForm(
    String^ FormTitle,
    array<String^>^ TextBoxStrings
)

Parameters

FormTitle
Type: System..::..String
The form caption.
TextBoxStrings
Type: array< System..::..String >[]()[][]
An array of strings with the text to display.

See Also

AMIgoDisplayForm Class
AMIgoDisplayForm Overload


AMIgoDisplayForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoDisplayForm Methods
AMIgoDisplayForm Class See Also Send Feedback

The AMIgoDisplayForm type exposes the following members.

Methods

 | Name | Description
Public method | CopyToClipboard | Copies the content of the textbox to the clipboard.
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoDisplayForm Class


CopyToClipboard Method

[image]

AMIgo Controls documentation
AMIgoDisplayForm..::..CopyToClipboard Method
AMIgoDisplayForm Class See Also Send Feedback
Copies the content of the textbox to the clipboard.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CopyToClipboard()
Visual Basic
Public Sub CopyToClipboard
Visual C++
public:
void CopyToClipboard()

See Also

AMIgoDisplayForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoDisplayForm..::..Dispose Method
AMIgoDisplayForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoDisplayForm Class


AMIgoDisplayForm Properties

[image] [image]

AMIgo Controls documentation
AMIgoDisplayForm Properties
AMIgoDisplayForm Class See Also Send Feedback

The AMIgoDisplayForm type exposes the following members.

Properties

 | Name | Description
Public property | FormText | Gets or sets the form's header text.

See Also

AMIgoDisplayForm Class


FormText Property

[image]

AMIgo Controls documentation
AMIgoDisplayForm..::..FormText Property
AMIgoDisplayForm Class See Also Send Feedback
Gets or sets the form's header text.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FormText { get; set; }
Visual Basic
Public Property FormText As String
    Get
    Set
Visual C++
public:
property String^ FormText {
    String^ get ();
    void set (String^ value);
}

Field Value

The form header text.

See Also

AMIgoDisplayForm Class


AMIgoDropTarget Class

[image]

AMIgo Controls documentation
AMIgoDropTarget Class
Members See Also Send Feedback
This class inherited from Form is a form that lists drop targets on which ListView items can be dropped to originate calls or to redirect active channels / calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoDropTarget : Form
Visual Basic
Public Class AMIgoDropTarget _
    Inherits Form
Visual C++
public ref class AMIgoDropTarget : public Form

Remarks

The AMIGO Drop target form displays a list of extensions, queues, conferences, voice menus and applications that are defined on the system and allows to originate or Transfer calls to selected destination by draging and droping items from the ListView displays (extensions, active, channels, calls and agents).

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..AMIgoDropTarget

See Also

AMIgoDropTarget Members


AMIgoDropTarget Members

[image] [image]

AMIgo Controls documentation
AMIgoDropTarget Members
AMIgoDropTarget Class Constructors Methods See Also Send Feedback

The AMIgoDropTarget type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoDropTarget()()()() | Initializes a new instance of the AMIgoDropTarget class.
Public method | AMIgoDropTarget(AMI_Client) | Initializes a new instance of the AMIgoDropTarget class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoDropTarget Class


AMIgoDropTarget Constructor

[image] [image]

AMIgo Controls documentation
AMIgoDropTarget Constructor
AMIgoDropTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoDropTarget()()()() | Initializes a new instance of the AMIgoDropTarget class.
Public method | AMIgoDropTarget(AMI_Client) | Initializes a new instance of the AMIgoDropTarget class.

See Also

AMIgoDropTarget Class
AMIgoDropTarget Members


AMIgoDropTarget Constructor

[image]

AMIgo Controls documentation
AMIgoDropTarget Constructor
AMIgoDropTarget Class See Also Send Feedback
Initializes a new instance of the AMIgoDropTarget class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDropTarget()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoDropTarget()

See Also

AMIgoDropTarget Class
AMIgoDropTarget Overload


AMIgoDropTarget Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoDropTarget Constructor (AMI_Client)
AMIgoDropTarget Class See Also Send Feedback
Initializes a new instance of the AMIgoDropTarget class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoDropTarget(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoDropTarget(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The asterisk manager instance.

See Also

AMIgoDropTarget Class
AMIgoDropTarget Overload


AMIgoDropTarget Methods

[image] [image]

AMIgo Controls documentation
AMIgoDropTarget Methods
AMIgoDropTarget Class See Also Send Feedback

The AMIgoDropTarget type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoDropTarget Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoDropTarget..::..Dispose Method
AMIgoDropTarget Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoDropTarget Class


AMIgoListViewControl Class

[image]

AMIgo Controls documentation
AMIgoListViewControl Class
Members See Also Send Feedback
This is the base class from which all of the AMIgo ListView controls inherit

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoListViewControl : AMIgoControl
Visual Basic
Public Class AMIgoListViewControl _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoListViewControl : public AMIgoControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewAgents
AMIgo..::..ListViewAgentsCalls
AMIgo..::..ListViewChannels
AMIgo..::..ListViewConferences
AMIgo..::..ListViewConferenceUsers
AMIgo..::..ListViewLines
AMIgo..::..ListViewQueueEntries
AMIgo..::..ListViewQueueMembers
AMIgo..::..ListViewQueues

See Also

AMIgoListViewControl Members


AMIgoListViewControl Members

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl Members
AMIgoListViewControl Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoListViewControl type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoListViewControl | Initializes a new instance of the AMIgoListViewControl class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view.
Public method | EndUpdateListView | Ends the update list view.
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key.
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key.
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column.
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column.
Public method | RemoveObject | Removes the given item index from the ListView object.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoListViewControl Class


AMIgoListViewControl Constructor

[image]

AMIgo Controls documentation
AMIgoListViewControl Constructor
AMIgoListViewControl Class See Also Send Feedback
Initializes a new instance of the AMIgoListViewControl class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoListViewControl()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoListViewControl()

See Also

AMIgoListViewControl Class


AMIgoListViewControl Fields

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl Fields
AMIgoListViewControl Class See Also Send Feedback

The AMIgoListViewControl type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control.

See Also

AMIgoListViewControl Class


AlistView Field

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..AlistView Field
AMIgoListViewControl Class See Also Send Feedback
Points to the descendant ListView control.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListView AlistView
Visual Basic
Public AlistView As ListView
Visual C++
public:
ListView^ AlistView

See Also

AMIgoListViewControl Class


AMIgoListViewControl Methods

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl Methods
AMIgoListViewControl Class See Also Send Feedback

The AMIgoListViewControl type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view.
Public method | EndUpdateListView | Ends the update list view.
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key.
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key.
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column.
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column.
Public method | RemoveObject | Removes the given item index from the ListView object.

See Also

AMIgoListViewControl Class


BeginUpdateListView Method

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..BeginUpdateListView Method
AMIgoListViewControl Class See Also Send Feedback
Begins the update list view.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void BeginUpdateListView()
Visual Basic
Public Sub BeginUpdateListView
Visual C++
public:
void BeginUpdateListView()

See Also

AMIgoListViewControl Class


EndUpdateListView Method

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..EndUpdateListView Method
AMIgoListViewControl Class See Also Send Feedback
Ends the update list view.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void EndUpdateListView()
Visual Basic
Public Sub EndUpdateListView
Visual C++
public:
void EndUpdateListView()

See Also

AMIgoListViewControl Class


ExtractFromMsg Method

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..ExtractFromMsg Method
AMIgoListViewControl Class See Also Send Feedback
Extracts the value of a from an event MSG in the form Param: value

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected string ExtractFromMsg(
    string[] InStrs,
    string Param
)
Visual Basic
Protected Function ExtractFromMsg ( _
    InStrs As String(), _
    Param As String _
) As String
Visual C++
protected:
String^ ExtractFromMsg(
    array<String^>^ InStrs,
    String^ Param
)

Parameters

InStrs
Type: array< System..::..String >[]()[][]
The raw message strings.
Param
Type: System..::..String
The param you want to extract the value for.

Return Value

A string containing the Value or an empty sting if not found

See Also

AMIgoListViewControl Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetItemIndexByTagKey Method
AMIgoListViewControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key.
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key.

See Also

AMIgoListViewControl Class
AMIgoListViewControl Members


GetItemIndexByTagKey Method (Int32)

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetItemIndexByTagKey Method (Int32)
AMIgoListViewControl Class See Also Send Feedback
Gets the item index by tag key.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected int GetItemIndexByTagKey(
    int TagKey
)
Visual Basic
Protected Function GetItemIndexByTagKey ( _
    TagKey As Integer _
) As Integer
Visual C++
protected:
int GetItemIndexByTagKey(
    int TagKey
)

Parameters

TagKey
Type: System..::..Int32
The tag key.

Return Value

The index of the item if found, otherwise -1

See Also

AMIgoListViewControl Class
GetItemIndexByTagKey Overload


GetItemIndexByTagKey Method (ListView, Int32)

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetItemIndexByTagKey Method (ListView, Int32)
AMIgoListViewControl Class See Also Send Feedback
Gets the item index by tag key.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected int GetItemIndexByTagKey(
    ListView ListView,
    int TagKey
)
Visual Basic
Protected Function GetItemIndexByTagKey ( _
    ListView As ListView, _
    TagKey As Integer _
) As Integer
Visual C++
protected:
int GetItemIndexByTagKey(
    ListView^ ListView,
    int TagKey
)

Parameters

ListView
Type: System.Windows.Forms..::..ListView
The list view.
TagKey
Type: System..::..Int32
The tag key.

Return Value

The index of the item if found, otherwise -1

See Also

AMIgoListViewControl Class
GetItemIndexByTagKey Overload


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetSubItemTextByColumnName Method
AMIgoListViewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column.
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column.

See Also

AMIgoListViewControl Class
AMIgoListViewControl Members


GetSubItemTextByColumnName Method (ListViewItem, String)

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetSubItemTextByColumnName Method (ListViewItem, String)
AMIgoListViewControl Class See Also Send Feedback
Gets the name of the sub item text by column.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string GetSubItemTextByColumnName(
    ListViewItem Item,
    string ColumnName
)
Visual Basic
Public Function GetSubItemTextByColumnName ( _
    Item As ListViewItem, _
    ColumnName As String _
) As String
Visual C++
public:
String^ GetSubItemTextByColumnName(
    ListViewItem^ Item,
    String^ ColumnName
)

Parameters

Item
Type: System.Windows.Forms..::..ListViewItem
The item.
ColumnName
Type: System..::..String
Name of the column.

Return Value

The sub Item value

See Also

AMIgoListViewControl Class
GetSubItemTextByColumnName Overload


GetSubItemTextByColumnName Method (ListView, ListViewItem, String)

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..GetSubItemTextByColumnName Method (ListView, ListViewItem, String)
AMIgoListViewControl Class See Also Send Feedback
Gets the name of the sub item text by column.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string GetSubItemTextByColumnName(
    ListView ListView,
    ListViewItem Item,
    string ColumnName
)
Visual Basic
Public Function GetSubItemTextByColumnName ( _
    ListView As ListView, _
    Item As ListViewItem, _
    ColumnName As String _
) As String
Visual C++
public:
String^ GetSubItemTextByColumnName(
    ListView^ ListView,
    ListViewItem^ Item,
    String^ ColumnName
)

Parameters

ListView
Type: System.Windows.Forms..::..ListView
The list view.
Item
Type: System.Windows.Forms..::..ListViewItem
The item.
ColumnName
Type: System..::..String
Name of the column.

Return Value

The SubItem text or "" if not found

See Also

AMIgoListViewControl Class
GetSubItemTextByColumnName Overload


RemoveObject Method

[image]

AMIgo Controls documentation
AMIgoListViewControl..::..RemoveObject Method
AMIgoListViewControl Class See Also Send Feedback
Removes the given item index from the ListView object.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void RemoveObject(
    ListView listView,
    int ObjIndex
)
Visual Basic
Public Sub RemoveObject ( _
    listView As ListView, _
    ObjIndex As Integer _
)
Visual C++
public:
void RemoveObject(
    ListView^ listView,
    int ObjIndex
)

Parameters

listView
Type: System.Windows.Forms..::..ListView
The list view.
ObjIndex
Type: System..::..Int32
Index of the obj.

See Also

AMIgoListViewControl Class


AMIgoListViewControl Properties

[image] [image]

AMIgo Controls documentation
AMIgoListViewControl Properties
AMIgoListViewControl Class See Also Send Feedback

The AMIgoListViewControl type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoListViewControl Class


AMIgoMsgDisplayForm Class

[image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Class
Members Example See Also Send Feedback
This Form is used as a container for a AmigoMsgDisplayPanel to display raw manager message in a Form.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoMsgDisplayForm : Form
Visual Basic
Public Class AMIgoMsgDisplayForm _
    Inherits Form
Visual C++
public ref class AMIgoMsgDisplayForm : public Form

Remarks

You can use this form to display the raw manager message in a distinct window or use the AMIgoSetupConferencePanel in one of your application container.

Examples

USAGE:
CopyC#
1AMIgoMsgDisplayForm df = new AMIgoMsgDisplayForm(AMI_Client1);
2df.Show();

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..AMIgoMsgDisplayForm

See Also

AMIgoMsgDisplayForm Members


AMIgoMsgDisplayForm Members

[image] [image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Members
AMIgoMsgDisplayForm Class Constructors Methods Properties See Also Send Feedback

The AMIgoMsgDisplayForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoMsgDisplayForm()()()() | Initializes a new instance of the AMIgoMsgDisplayForm class.
Public method | AMIgoMsgDisplayForm(AMI_Client) | Initializes a new instance of the AMIgoMsgDisplayForm class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance.

See Also

AMIgoMsgDisplayForm Class


AMIgoMsgDisplayForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Constructor
AMIgoMsgDisplayForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoMsgDisplayForm()()()() | Initializes a new instance of the AMIgoMsgDisplayForm class.
Public method | AMIgoMsgDisplayForm(AMI_Client) | Initializes a new instance of the AMIgoMsgDisplayForm class.

See Also

AMIgoMsgDisplayForm Class
AMIgoMsgDisplayForm Members


AMIgoMsgDisplayForm Constructor

[image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Constructor
AMIgoMsgDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoMsgDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoMsgDisplayForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoMsgDisplayForm()

See Also

AMIgoMsgDisplayForm Class
AMIgoMsgDisplayForm Overload


AMIgoMsgDisplayForm Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Constructor (AMI_Client)
AMIgoMsgDisplayForm Class See Also Send Feedback
Initializes a new instance of the AMIgoMsgDisplayForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoMsgDisplayForm(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoMsgDisplayForm(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.

See Also

AMIgoMsgDisplayForm Class
AMIgoMsgDisplayForm Overload


AMIgoMsgDisplayForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Methods
AMIgoMsgDisplayForm Class See Also Send Feedback

The AMIgoMsgDisplayForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoMsgDisplayForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoMsgDisplayForm..::..Dispose Method
AMIgoMsgDisplayForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoMsgDisplayForm Class


AMIgoMsgDisplayForm Properties

[image] [image]

AMIgo Controls documentation
AMIgoMsgDisplayForm Properties
AMIgoMsgDisplayForm Class See Also Send Feedback

The AMIgoMsgDisplayForm type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance.

See Also

AMIgoMsgDisplayForm Class


AMI_ClientInstance Property

[image]

AMIgo Controls documentation
AMIgoMsgDisplayForm..::..AMI_ClientInstance Property
AMIgoMsgDisplayForm Class See Also Send Feedback
Gets or sets the AMI_Client instance.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client AMI_ClientInstance { get; set; }
Visual Basic
Public Property AMI_ClientInstance As AMI_Client
    Get
    Set
Visual C++
public:
property AMI_Client^ AMI_ClientInstance {
    AMI_Client^ get ();
    void set (AMI_Client^ value);
}

Field Value

The AMI_Client instance.

See Also

AMIgoMsgDisplayForm Class


AmigoMsgDisplayPanel Class

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Class
Members See Also Send Feedback
This controls is used to display the 'raw' AMI message.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AmigoMsgDisplayPanel : AMIgoControl
Visual Basic
Public Class AmigoMsgDisplayPanel _
    Inherits AMIgoControl
Visual C++
public ref class AmigoMsgDisplayPanel : public AMIgoControl

Remarks

This panel displays all of the received AMI messages. Displaying all messages can noticably slow down the program execution. In consquence this panel should be set active only when needed. This can be minimized by setting the buffer to a

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AmigoMsgDisplayPanel

See Also

AmigoMsgDisplayPanel Members


AmigoMsgDisplayPanel Members

[image] [image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Members
AmigoMsgDisplayPanel Class Constructors Methods Fields Properties See Also Send Feedback

The AmigoMsgDisplayPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AmigoMsgDisplayPanel | Initializes a new instance of the AmigoMsgDisplayPanel class.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handle the CmdResult event
Public method | DisplayMessage | Displays the given message.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ErrorEventHandler | Handle and display the Errors event.
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | RawMngrMsgEventHandler | Handles the RawMngrMsgEvent.
Public method | StatusEventHandler | Display the status events

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this AmigoMsgDisplayPanel is active.
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | BufferSize | Gets or sets the size of the message buffer. Default to 32768 chars.

See Also

AmigoMsgDisplayPanel Class


AmigoMsgDisplayPanel Constructor

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Constructor
AmigoMsgDisplayPanel Class See Also Send Feedback
Initializes a new instance of the AmigoMsgDisplayPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AmigoMsgDisplayPanel()
Visual Basic
Public Sub New
Visual C++
public:
AmigoMsgDisplayPanel()

See Also

AmigoMsgDisplayPanel Class


AmigoMsgDisplayPanel Fields

[image] [image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Fields
AmigoMsgDisplayPanel Class See Also Send Feedback

The AmigoMsgDisplayPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AmigoMsgDisplayPanel Class


AmigoMsgDisplayPanel Methods

[image] [image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Methods
AmigoMsgDisplayPanel Class See Also Send Feedback

The AmigoMsgDisplayPanel type exposes the following members.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handle the CmdResult event
Public method | DisplayMessage | Displays the given message.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ErrorEventHandler | Handle and display the Errors event.
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | RawMngrMsgEventHandler | Handles the RawMngrMsgEvent.
Public method | StatusEventHandler | Display the status events

See Also

AmigoMsgDisplayPanel Class


CmdResultEventHandler Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..CmdResultEventHandler Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Handle the CmdResult event

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CmdResultEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub CmdResultEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void CmdResultEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AmigoMsgDisplayPanel Class


DisplayMessage Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..DisplayMessage Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Displays the given message.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void DisplayMessage(
    string MsgString
)
Visual Basic
Public Sub DisplayMessage ( _
    MsgString As String _
)
Visual C++
public:
void DisplayMessage(
    String^ MsgString
)

Parameters

MsgString
Type: System..::..String
The MSG string.

See Also

AmigoMsgDisplayPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..Dispose Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AmigoMsgDisplayPanel Class


ErrorEventHandler Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..ErrorEventHandler Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Handle and display the Errors event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ErrorEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Sub ErrorEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public:
void ErrorEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AmigoMsgDisplayPanel Class


RawMngrMsgEventHandler Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..RawMngrMsgEventHandler Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Handles the RawMngrMsgEvent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void RawMngrMsgEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub RawMngrMsgEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void RawMngrMsgEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AmigoMsgDisplayPanel Class


StatusEventHandler Method

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..StatusEventHandler Method
AmigoMsgDisplayPanel Class See Also Send Feedback
Display the status events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StatusEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Sub StatusEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public:
void StatusEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AmigoMsgDisplayPanel Class


AmigoMsgDisplayPanel Properties

[image] [image]

AMIgo Controls documentation
AmigoMsgDisplayPanel Properties
AmigoMsgDisplayPanel Class See Also Send Feedback

The AmigoMsgDisplayPanel type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this AmigoMsgDisplayPanel is active.
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | BufferSize | Gets or sets the size of the message buffer. Default to 32768 chars.

See Also

AmigoMsgDisplayPanel Class


Active Property

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..Active Property
AmigoMsgDisplayPanel Class See Also Send Feedback
Gets or sets a value indicating whether this AmigoMsgDisplayPanel is active.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Active { get; set; }
Visual Basic
Public Property Active As Boolean
    Get
    Set
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

Field Value

true if active; otherwise, false.

See Also

AmigoMsgDisplayPanel Class


BufferSize Property

[image]

AMIgo Controls documentation
AmigoMsgDisplayPanel..::..BufferSize Property
AmigoMsgDisplayPanel Class See Also Send Feedback
Gets or sets the size of the message buffer. Default to 32768 chars.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int BufferSize { get; set; }
Visual Basic
Public Property BufferSize As Integer
    Get
    Set
Visual C++
public:
property int BufferSize {
    int get ();
    void set (int value);
}

Field Value

The size of the buffer.

Remarks

Increasing the size of this buffer can slow down program execution

See Also

AmigoMsgDisplayPanel Class


AMIgoSetupAgentForm Class

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm Class
Members Example See Also Send Feedback
This Form descendant allows to create / edit agents definitions.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupAgentForm : AMIgoControl
Visual Basic
Public Class AMIgoSetupAgentForm _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoSetupAgentForm : public AMIgoControl

Remarks

To create a new agent definition, create a new instance with ItemIndex = -1 or use the constructor without index. To edit an existing agent definition, create a new instance with the Item index of the agent in the _AgentsConfigList list of dictionary. This list can be filled with a call to the ConfigGetAgents()()()() method

This form is used as a container for a AMIgoSetupAgentPanel.

Examples

USAGE: Use this to create and display a new form.
CopyC#
1new AMIgoSetupAgentForm(this.AMI_Client1); /// Create a new agent
2new AMIgoSetupAgentForm(this.AMI_Client1, 0); // Edit first entry in agents config list

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoSetupAgentForm

See Also

AMIgoSetupAgentForm Members


AMIgoSetupAgentForm Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentForm Members
AMIgoSetupAgentForm Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupAgentForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupAgentForm()()()() | Initializes a new instance of the AMIgoSetupAgentForm class.
Public method | AMIgoSetupAgentForm(AMI_Client) | Initializes a new instance of the AMIgoSetupAgentForm class to create a new agent definition.
Public method | AMIgoSetupAgentForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupAgentForm class to edit given agent definition at index.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the agent at given index in the config list.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentForm Class


AMIgoSetupAgentForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentForm Constructor
AMIgoSetupAgentForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoSetupAgentForm()()()() | Initializes a new instance of the AMIgoSetupAgentForm class.
Public method | AMIgoSetupAgentForm(AMI_Client) | Initializes a new instance of the AMIgoSetupAgentForm class to create a new agent definition.
Public method | AMIgoSetupAgentForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupAgentForm class to edit given agent definition at index.

See Also

AMIgoSetupAgentForm Class
AMIgoSetupAgentForm Members


AMIgoSetupAgentForm Constructor

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm Constructor
AMIgoSetupAgentForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupAgentForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupAgentForm()

See Also

AMIgoSetupAgentForm Class
AMIgoSetupAgentForm Overload


AMIgoSetupAgentForm Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm Constructor (AMI_Client)
AMIgoSetupAgentForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentForm class to create a new agent definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupAgentForm(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoSetupAgentForm(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.

See Also

AMIgoSetupAgentForm Class
AMIgoSetupAgentForm Overload


AMIgoSetupAgentForm Constructor (AMI_Client, Int32)

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm Constructor (AMI_Client, Int32)
AMIgoSetupAgentForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentForm class to edit given agent definition at index.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupAgentForm(
    AMI_Client AMI_ClientInstance,
    int ItemIndex
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client, _
    ItemIndex As Integer _
)
Visual C++
public:
AMIgoSetupAgentForm(
    AMI_Client^ AMI_ClientInstance,
    int ItemIndex
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.
ItemIndex
Type: System..::..Int32
Index of the item in the list.

See Also

AMIgoSetupAgentForm Class
AMIgoSetupAgentForm Overload


AMIgoSetupAgentForm Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentForm Fields
AMIgoSetupAgentForm Class See Also Send Feedback

The AMIgoSetupAgentForm type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentForm Class


AMIgoSetupAgentForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentForm Methods
AMIgoSetupAgentForm Class See Also Send Feedback

The AMIgoSetupAgentForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the agent at given index in the config list.

See Also

AMIgoSetupAgentForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm..::..Dispose Method
AMIgoSetupAgentForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupAgentForm Class


SelectQueueAtIndex Method

[image]

AMIgo Controls documentation
AMIgoSetupAgentForm..::..SelectQueueAtIndex Method
AMIgoSetupAgentForm Class See Also Send Feedback
Selects the the agent at given index in the config list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectQueueAtIndex(
    int ItemIndex
)
Visual Basic
Public Sub SelectQueueAtIndex ( _
    ItemIndex As Integer _
)
Visual C++
public:
void SelectQueueAtIndex(
    int ItemIndex
)

Parameters

ItemIndex
Type: System..::..Int32
Index of the item.

Remarks

The agent definition must exist at given index in the _AgentsConfigList list.

See Also

AMIgoSetupAgentForm Class


AMIgoSetupAgentForm Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentForm Properties
AMIgoSetupAgentForm Class See Also Send Feedback

The AMIgoSetupAgentForm type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentForm Class


AMIgoSetupAgentPanel Class

[image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Class
Members See Also Send Feedback
This control is used to edit and create new agents.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupAgentPanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoSetupAgentPanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoSetupAgentPanel : public AMIgoConfigControl

Remarks

This Panel is intended to be displayed in another container or in a Form. See: AMIgoSetupAgentForm. It is also used in the AMIgoSetupPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoSetupAgentPanel

See Also

AMIgoSetupAgentPanel Members


AMIgoSetupAgentPanel Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Members
AMIgoSetupAgentPanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupAgentPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupAgentPanel | Initializes a new instance of the AMIgoSetupAgentPanel class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectAgent | Selects the agent to be edited.
Public method | SetButtonCloseVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentPanel Class


AMIgoSetupAgentPanel Constructor

[image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Constructor
AMIgoSetupAgentPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupAgentPanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupAgentPanel()

See Also

AMIgoSetupAgentPanel Class


AMIgoSetupAgentPanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Fields
AMIgoSetupAgentPanel Class See Also Send Feedback

The AMIgoSetupAgentPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentPanel Class


AMIgoSetupAgentPanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Methods
AMIgoSetupAgentPanel Class See Also Send Feedback

The AMIgoSetupAgentPanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectAgent | Selects the agent to be edited.
Public method | SetButtonCloseVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoSetupAgentPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupAgentPanel..::..Dispose Method
AMIgoSetupAgentPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupAgentPanel Class


SelectAgent Method

[image]

AMIgo Controls documentation
AMIgoSetupAgentPanel..::..SelectAgent Method
AMIgoSetupAgentPanel Class See Also Send Feedback
Selects the agent to be edited.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectAgent(
    int IndexInList
)
Visual Basic
Public Sub SelectAgent ( _
    IndexInList As Integer _
)
Visual C++
public:
void SelectAgent(
    int IndexInList
)

Parameters

IndexInList
Type: System..::..Int32
The index in list.

Remarks

You can also give an index of -1 to create a new agent

See Also

AMIgoSetupAgentPanel Class


SetButtonCloseVisible Method

[image]

AMIgo Controls documentation
AMIgoSetupAgentPanel..::..SetButtonCloseVisible Method
AMIgoSetupAgentPanel Class See Also Send Feedback
Sets the button close visible state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetButtonCloseVisible()
Visual Basic
Public Sub SetButtonCloseVisible
Visual C++
public:
void SetButtonCloseVisible()

Remarks

Used to show a close button when used in a parent form

See Also

AMIgoSetupAgentPanel Class


AMIgoSetupAgentPanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupAgentPanel Properties
AMIgoSetupAgentPanel Class See Also Send Feedback

The AMIgoSetupAgentPanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupAgentPanel Class


AMIgoSetupConferenceForm Class

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Class
Members Example See Also Send Feedback
This Form descendant allows to create / edit conferences definitions.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupConferenceForm : AMIgoControl
Visual Basic
Public Class AMIgoSetupConferenceForm _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoSetupConferenceForm : public AMIgoControl

Remarks

To create a new conference definition, create a new instance with ItemIndex = -1 or use the constructor without index. To edit an existing conference definition, create a new instance with the Item index of the agent in the _ConferencesConfigList list of dictionary. This list can be filled with a call to the ConfigGetConferences()()()() method

This form is used as a container for a AMIgoSetupConferencePanel.

Examples

USAGE:
CopyC#
1new AMIgoSetupConferenceForm(this.AMI_Client1); /// Create a new conference
2new AMIgoSetupConferenceForm(this.AMI_Client1, -1); /// Create a new conference
3new AMIgoSetupConferenceForm(this.AMI_Client1, 0); // Edit first entry in conferences config list

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoSetupConferenceForm

See Also

AMIgoSetupConferenceForm Members


AMIgoSetupConferenceForm Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Members
AMIgoSetupConferenceForm Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupConferenceForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupConferenceForm()()()() | Initializes a new instance of the AMIgoSetupConferenceForm class.
Public method | AMIgoSetupConferenceForm(AMI_Client) | Initializes a new instance of the AMIgoSetupConferenceForm class to create a new conference definition.
Public method | AMIgoSetupConferenceForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupConferenceForm class to edit given conference definition at index.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the conference at given index in the config list.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferenceForm Class


AMIgoSetupConferenceForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Constructor
AMIgoSetupConferenceForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoSetupConferenceForm()()()() | Initializes a new instance of the AMIgoSetupConferenceForm class.
Public method | AMIgoSetupConferenceForm(AMI_Client) | Initializes a new instance of the AMIgoSetupConferenceForm class to create a new conference definition.
Public method | AMIgoSetupConferenceForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupConferenceForm class to edit given conference definition at index.

See Also

AMIgoSetupConferenceForm Class
AMIgoSetupConferenceForm Members


AMIgoSetupConferenceForm Constructor

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Constructor
AMIgoSetupConferenceForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupConferenceForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupConferenceForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupConferenceForm()

See Also

AMIgoSetupConferenceForm Class
AMIgoSetupConferenceForm Overload


AMIgoSetupConferenceForm Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Constructor (AMI_Client)
AMIgoSetupConferenceForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupConferenceForm class to create a new conference definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupConferenceForm(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoSetupConferenceForm(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.

See Also

AMIgoSetupConferenceForm Class
AMIgoSetupConferenceForm Overload


AMIgoSetupConferenceForm Constructor (AMI_Client, Int32)

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Constructor (AMI_Client, Int32)
AMIgoSetupConferenceForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupConferenceForm class to edit given conference definition at index.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupConferenceForm(
    AMI_Client AMI_ClientInstance,
    int ItemIndex
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client, _
    ItemIndex As Integer _
)
Visual C++
public:
AMIgoSetupConferenceForm(
    AMI_Client^ AMI_ClientInstance,
    int ItemIndex
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.
ItemIndex
Type: System..::..Int32
Index of the item in the list.

See Also

AMIgoSetupConferenceForm Class
AMIgoSetupConferenceForm Overload


AMIgoSetupConferenceForm Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Fields
AMIgoSetupConferenceForm Class See Also Send Feedback

The AMIgoSetupConferenceForm type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferenceForm Class


AMIgoSetupConferenceForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Methods
AMIgoSetupConferenceForm Class See Also Send Feedback

The AMIgoSetupConferenceForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the conference at given index in the config list.

See Also

AMIgoSetupConferenceForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm..::..Dispose Method
AMIgoSetupConferenceForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupConferenceForm Class


SelectQueueAtIndex Method

[image]

AMIgo Controls documentation
AMIgoSetupConferenceForm..::..SelectQueueAtIndex Method
AMIgoSetupConferenceForm Class See Also Send Feedback
Selects the the conference at given index in the config list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectQueueAtIndex(
    int ItemIndex
)
Visual Basic
Public Sub SelectQueueAtIndex ( _
    ItemIndex As Integer _
)
Visual C++
public:
void SelectQueueAtIndex(
    int ItemIndex
)

Parameters

ItemIndex
Type: System..::..Int32
Index of the item.

Remarks

The conference definition must exist at given index in the _ConferencesConfigList list.

See Also

AMIgoSetupConferenceForm Class


AMIgoSetupConferenceForm Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferenceForm Properties
AMIgoSetupConferenceForm Class See Also Send Feedback

The AMIgoSetupConferenceForm type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferenceForm Class


AMIgoSetupConferencePanel Class

[image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Class
Members See Also Send Feedback
This control is used to edit and create new conferences.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupConferencePanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoSetupConferencePanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoSetupConferencePanel : public AMIgoConfigControl

Remarks

This Panel is intended to be displayed in another container or in a Form. See: AMIgoSetupConferenceForm. It is also used in the AMIgoSetupPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoSetupConferencePanel

See Also

AMIgoSetupConferencePanel Members


AMIgoSetupConferencePanel Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Members
AMIgoSetupConferencePanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupConferencePanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupConferencePanel | Initializes a new instance of the AMIgoSetupConferencePanel class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectConference | Selects the conference to be edited.
Public method | SetCloseButtonVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferencePanel Class


AMIgoSetupConferencePanel Constructor

[image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Constructor
AMIgoSetupConferencePanel Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupConferencePanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupConferencePanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupConferencePanel()

See Also

AMIgoSetupConferencePanel Class


AMIgoSetupConferencePanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Fields
AMIgoSetupConferencePanel Class See Also Send Feedback

The AMIgoSetupConferencePanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferencePanel Class


AMIgoSetupConferencePanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Methods
AMIgoSetupConferencePanel Class See Also Send Feedback

The AMIgoSetupConferencePanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectConference | Selects the conference to be edited.
Public method | SetCloseButtonVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoSetupConferencePanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupConferencePanel..::..Dispose Method
AMIgoSetupConferencePanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupConferencePanel Class


SelectConference Method

[image]

AMIgo Controls documentation
AMIgoSetupConferencePanel..::..SelectConference Method
AMIgoSetupConferencePanel Class See Also Send Feedback
Selects the conference to be edited.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectConference(
    int IndexInList
)
Visual Basic
Public Sub SelectConference ( _
    IndexInList As Integer _
)
Visual C++
public:
void SelectConference(
    int IndexInList
)

Parameters

IndexInList
Type: System..::..Int32
The index in list.

Remarks

You can also give an index of -1 to create a new conference

See Also

AMIgoSetupConferencePanel Class


SetCloseButtonVisible Method

[image]

AMIgo Controls documentation
AMIgoSetupConferencePanel..::..SetCloseButtonVisible Method
AMIgoSetupConferencePanel Class See Also Send Feedback
Sets the button close visible state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetCloseButtonVisible()
Visual Basic
Public Sub SetCloseButtonVisible
Visual C++
public:
void SetCloseButtonVisible()

Remarks

Used to show a close button when used in a parent form

See Also

AMIgoSetupConferencePanel Class


AMIgoSetupConferencePanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupConferencePanel Properties
AMIgoSetupConferencePanel Class See Also Send Feedback

The AMIgoSetupConferencePanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupConferencePanel Class


AMIgoSetupPanel Class

[image]

AMIgo Controls documentation
AMIgoSetupPanel Class
Members See Also Send Feedback
This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupPanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoSetupPanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoSetupPanel : public AMIgoConfigControl

Remarks

This control groups several other setup panels into a Tab Control to form a setup / configuration control.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoSetupPanel

See Also

AMIgoSetupPanel Members
AMIgo Namespace
AMIgo..::..AMIgoSetupAgentPanel
AMIgo..::..AMIgoSetupQueuePanel
AMIgo..::..AMIgoSetupConferencePanel


AMIgoSetupPanel Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel Members
AMIgoSetupPanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupPanel | Initializes a new instance of the AMIgoSetupPanel class.

Methods

 | Name | Description
Public method | CmdResultEventHandler | CMDs the result event handler.
Public method | ConfigFileReadEventHandler | Configs the file read event handler.
Public method | ConfigUpdateEventHandler | Handles the ConfigUpdate event
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | ModuleListEventHandler | Handles the ModuleList event
Public method | StateChangeEventHandler | Handle the StateChangeEvent and refresh the dialplan and module list
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Overrides AMIgoControl..::..AMI_ClientInstance.)
Public property | SelectedIndex | Gets or sets the index of the selected tab

See Also

AMIgoSetupPanel Class


AMIgoSetupPanel Constructor

[image]

AMIgo Controls documentation
AMIgoSetupPanel Constructor
AMIgoSetupPanel Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupPanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupPanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupPanel()

See Also

AMIgoSetupPanel Class


AMIgoSetupPanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel Fields
AMIgoSetupPanel Class See Also Send Feedback

The AMIgoSetupPanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupPanel Class


AMIgoSetupPanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel Methods
AMIgoSetupPanel Class See Also Send Feedback

The AMIgoSetupPanel type exposes the following members.

Methods

 | Name | Description
Public method | CmdResultEventHandler | CMDs the result event handler.
Public method | ConfigFileReadEventHandler | Configs the file read event handler.
Public method | ConfigUpdateEventHandler | Handles the ConfigUpdate event
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | ModuleListEventHandler | Handles the ModuleList event
Public method | StateChangeEventHandler | Handle the StateChangeEvent and refresh the dialplan and module list
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoSetupPanel Class


CmdResultEventHandler Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..CmdResultEventHandler Method
AMIgoSetupPanel Class See Also Send Feedback
CMDs the result event handler.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CmdResultEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub CmdResultEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void CmdResultEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgoSetupPanel Class


ConfigFileReadEventHandler Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConfigFileReadEventHandler Method
AMIgoSetupPanel Class See Also Send Feedback
Configs the file read event handler.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigFileReadEventHandler(
    Object sender,
    ConfigFileReadEventArgs ev
)
Visual Basic
Public Sub ConfigFileReadEventHandler ( _
    sender As Object, _
    ev As ConfigFileReadEventArgs _
)
Visual C++
public:
void ConfigFileReadEventHandler(
    Object^ sender,
    ConfigFileReadEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..ConfigFileReadEventArgs
The ConfigFileReadEventArgs instance containing the event data.

See Also

AMIgoSetupPanel Class


ConfigUpdateEventHandler Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConfigUpdateEventHandler Method
AMIgoSetupPanel Class See Also Send Feedback
Handles the ConfigUpdate event

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigUpdateEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub ConfigUpdateEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void ConfigUpdateEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgoSetupPanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..Dispose Method
AMIgoSetupPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupPanel Class


ModuleListEventHandler Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ModuleListEventHandler Method
AMIgoSetupPanel Class See Also Send Feedback
Handles the ModuleList event

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ModuleListEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub ModuleListEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void ModuleListEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgoSetupPanel Class


StateChangeEventHandler Method

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..StateChangeEventHandler Method
AMIgoSetupPanel Class See Also Send Feedback
Handle the StateChangeEvent and refresh the dialplan and module list

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StateChangeEventHandler(
    Object sender,
    StateChangeEventArgs ev
)
Visual Basic
Public Sub StateChangeEventHandler ( _
    sender As Object, _
    ev As StateChangeEventArgs _
)
Visual C++
public:
void StateChangeEventHandler(
    Object^ sender,
    StateChangeEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StateChangeEventArgs
The StateChangeEventArgs instance containing the event data.

See Also

AMIgoSetupPanel Class


AMIgoSetupPanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel Properties
AMIgoSetupPanel Class See Also Send Feedback

The AMIgoSetupPanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Overrides AMIgoControl..::..AMI_ClientInstance.)
Public property | SelectedIndex | Gets or sets the index of the selected tab

See Also

AMIgoSetupPanel Class


AMI_ClientInstance Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AMI_ClientInstance Property
AMIgoSetupPanel Class See Also Send Feedback
Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public override AMI_Client AMI_ClientInstance { get; set; }
Visual Basic
Public Overrides Property AMI_ClientInstance As AMI_Client
    Get
    Set
Visual C++
public:
virtual property AMI_Client^ AMI_ClientInstance {
    AMI_Client^ get () override;
    void set (AMI_Client^ value) override;
}

See Also

AMIgoSetupPanel Class


SelectedIndex Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..SelectedIndex Property
AMIgoSetupPanel Class See Also Send Feedback
Gets or sets the index of the selected tab

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the selected.

See Also

AMIgoSetupPanel Class


AMIgoSetupPanel.AgentConfig Class

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig Class
AMIgoSetupPanel Class Members See Also Send Feedback
This holds the information for an agent (from agents.conf) or from the AstDB

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AgentConfig
Visual Basic
Public Class AgentConfig
Visual C++
public ref class AgentConfig

Inheritance Hierarchy

System..::..Object
AMIgo..::..AMIgoSetupPanel..::..AgentConfig

See Also

AMIgoSetupPanel..::..AgentConfig Members


AMIgoSetupPanel.AgentConfig Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig Members
AMIgoSetupPanel..::..AgentConfig Class Constructors Properties See Also Send Feedback

This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc

The AMIgoSetupPanel..::..AgentConfig type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupPanel..::..AgentConfig | Initializes a new instance of the AMIgoSetupPanel..::..AgentConfig class

Properties

 | Name | Description
Public property | AgentEmail | Gets or sets the agent Email.
Public property | AgentGroupNo | An optional agent group number
Public property | AgentName | Gets or sets the name of the agent.
Public property | AgentNo | Gets or sets the agent no.
Public property | AgentPassword | Gets or sets the agent password.
Public property | AgentsCBLoginExtension | Gets or sets the extension for Agents Callback Login.
Public property | AgentsLoginExtension | Gets or sets the extension for Agents Login.
Public property | AgentType | Gets or sets the type of the agent.
Public property | DefaultCallbackLocation | Gets or sets the Default Callback Location (Extension)
Public property | DefaultDialPlan | Gets or sets the Default Callback Trunk used to dial the 'off premise' agent
Public property | LoginChannel | Gets or sets the login channel.
Public property | LoginTime | Gets or sets the login time.
Public property | MemberOfQueuesConfs | Gets or sets the list of Queues and.or conference this agent is a member

See Also

AMIgoSetupPanel..::..AgentConfig Class


AMIgoSetupPanel.AgentConfig Constructor

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig Constructor
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupPanel..::..AgentConfig class

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentConfig()
Visual Basic
Public Sub New
Visual C++
public:
AgentConfig()

See Also

AMIgoSetupPanel..::..AgentConfig Class


AMIgoSetupPanel.AgentConfig Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig Properties
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback

The AMIgoSetupPanel..::..AgentConfig type exposes the following members.

Properties

 | Name | Description
Public property | AgentEmail | Gets or sets the agent Email.
Public property | AgentGroupNo | An optional agent group number
Public property | AgentName | Gets or sets the name of the agent.
Public property | AgentNo | Gets or sets the agent no.
Public property | AgentPassword | Gets or sets the agent password.
Public property | AgentsCBLoginExtension | Gets or sets the extension for Agents Callback Login.
Public property | AgentsLoginExtension | Gets or sets the extension for Agents Login.
Public property | AgentType | Gets or sets the type of the agent.
Public property | DefaultCallbackLocation | Gets or sets the Default Callback Location (Extension)
Public property | DefaultDialPlan | Gets or sets the Default Callback Trunk used to dial the 'off premise' agent
Public property | LoginChannel | Gets or sets the login channel.
Public property | LoginTime | Gets or sets the login time.
Public property | MemberOfQueuesConfs | Gets or sets the list of Queues and.or conference this agent is a member

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentEmail Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentEmail Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the agent Email.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentEmail { get; set; }
Visual Basic
Public Property AgentEmail As String
    Get
    Set
Visual C++
public:
property String^ AgentEmail {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentGroupNo Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentGroupNo Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
An optional agent group number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentGroupNo { get; set; }
Visual Basic
Public Property AgentGroupNo As String
    Get
    Set
Visual C++
public:
property String^ AgentGroupNo {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentName Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the name of the agent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentName { get; set; }
Visual Basic
Public Property AgentName As String
    Get
    Set
Visual C++
public:
property String^ AgentName {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentNo Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentNo Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the agent no.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentNo { get; set; }
Visual Basic
Public Property AgentNo As String
    Get
    Set
Visual C++
public:
property String^ AgentNo {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentPassword Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentPassword Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the agent password.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentPassword { get; set; }
Visual Basic
Public Property AgentPassword As String
    Get
    Set
Visual C++
public:
property String^ AgentPassword {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentsCBLoginExtension Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentsCBLoginExtension Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the extension for Agents Callback Login.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentsCBLoginExtension { get; set; }
Visual Basic
Public Property AgentsCBLoginExtension As String
    Get
    Set
Visual C++
public:
property String^ AgentsCBLoginExtension {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentsLoginExtension Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentsLoginExtension Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the extension for Agents Login.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentsLoginExtension { get; set; }
Visual Basic
Public Property AgentsLoginExtension As String
    Get
    Set
Visual C++
public:
property String^ AgentsLoginExtension {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AgentType Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..AgentType Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the type of the agent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentTypes AgentType { get; set; }
Visual Basic
Public Property AgentType As AgentTypes
    Get
    Set
Visual C++
public:
property AgentTypes AgentType {
    AgentTypes get ();
    void set (AgentTypes value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


DefaultCallbackLocation Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..DefaultCallbackLocation Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the Default Callback Location (Extension)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DefaultCallbackLocation { get; set; }
Visual Basic
Public Property DefaultCallbackLocation As String
    Get
    Set
Visual C++
public:
property String^ DefaultCallbackLocation {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


DefaultDialPlan Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..DefaultDialPlan Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the Default Callback Trunk used to dial the 'off premise' agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DefaultDialPlan { get; set; }
Visual Basic
Public Property DefaultDialPlan As String
    Get
    Set
Visual C++
public:
property String^ DefaultDialPlan {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


LoginChannel Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..LoginChannel Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the login channel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LoginChannel { get; set; }
Visual Basic
Public Property LoginChannel As String
    Get
    Set
Visual C++
public:
property String^ LoginChannel {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


LoginTime Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..LoginTime Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the login time.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LoginTime { get; set; }
Visual Basic
Public Property LoginTime As String
    Get
    Set
Visual C++
public:
property String^ LoginTime {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


MemberOfQueuesConfs Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..AgentConfig..::..MemberOfQueuesConfs Property
AMIgoSetupPanel..::..AgentConfig Class See Also Send Feedback
Gets or sets the list of Queues and.or conference this agent is a member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MemberOfQueuesConfs { get; set; }
Visual Basic
Public Property MemberOfQueuesConfs As String
    Get
    Set
Visual C++
public:
property String^ MemberOfQueuesConfs {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..AgentConfig Class


AMIgoSetupPanel.ConferenceConfig Class

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig Class
AMIgoSetupPanel Class Members See Also Send Feedback
This contains the information for a conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ConferenceConfig
Visual Basic
Public Class ConferenceConfig
Visual C++
public ref class ConferenceConfig

Inheritance Hierarchy

System..::..Object
AMIgo..::..AMIgoSetupPanel..::..ConferenceConfig

See Also

AMIgoSetupPanel..::..ConferenceConfig Members


AMIgoSetupPanel.ConferenceConfig Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig Members
AMIgoSetupPanel..::..ConferenceConfig Class Constructors Properties See Also Send Feedback

This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc

The AMIgoSetupPanel..::..ConferenceConfig type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupPanel..::..ConferenceConfig | Initializes a new instance of the AMIgoSetupPanel..::..ConferenceConfig class

Properties

 | Name | Description
Public property | AdminAccessExten | Gets or sets the Admin access extension to the conferences
Public property | ConfName | Gets or sets the name of the conf.
Public property | ConfNo | Gets or sets the extension number to reach this conference.
Public property | ConfPIN | Gets or sets the PIN for the conference.
Public property | DynamicExten | Gets or sets the extension to access the dynamic conference entry point
Public property | FirstAvailableExten | Gets or sets the extension to access to the first available conference.
Public property | Options | Gets or sets the options for the conf.

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


AMIgoSetupPanel.ConferenceConfig Constructor

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig Constructor
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupPanel..::..ConferenceConfig class

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ConferenceConfig()
Visual Basic
Public Sub New
Visual C++
public:
ConferenceConfig()

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


AMIgoSetupPanel.ConferenceConfig Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig Properties
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback

The AMIgoSetupPanel..::..ConferenceConfig type exposes the following members.

Properties

 | Name | Description
Public property | AdminAccessExten | Gets or sets the Admin access extension to the conferences
Public property | ConfName | Gets or sets the name of the conf.
Public property | ConfNo | Gets or sets the extension number to reach this conference.
Public property | ConfPIN | Gets or sets the PIN for the conference.
Public property | DynamicExten | Gets or sets the extension to access the dynamic conference entry point
Public property | FirstAvailableExten | Gets or sets the extension to access to the first available conference.
Public property | Options | Gets or sets the options for the conf.

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


AdminAccessExten Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..AdminAccessExten Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the Admin access extension to the conferences

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AdminAccessExten { get; set; }
Visual Basic
Public Property AdminAccessExten As String
    Get
    Set
Visual C++
public:
property String^ AdminAccessExten {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


ConfName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..ConfName Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the name of the conf.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfName { get; set; }
Visual Basic
Public Property ConfName As String
    Get
    Set
Visual C++
public:
property String^ ConfName {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


ConfNo Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..ConfNo Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the extension number to reach this conference.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfNo { get; set; }
Visual Basic
Public Property ConfNo As String
    Get
    Set
Visual C++
public:
property String^ ConfNo {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


ConfPIN Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..ConfPIN Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the PIN for the conference.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfPIN { get; set; }
Visual Basic
Public Property ConfPIN As String
    Get
    Set
Visual C++
public:
property String^ ConfPIN {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


DynamicExten Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..DynamicExten Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the extension to access the dynamic conference entry point

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DynamicExten { get; set; }
Visual Basic
Public Property DynamicExten As String
    Get
    Set
Visual C++
public:
property String^ DynamicExten {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


FirstAvailableExten Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..FirstAvailableExten Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the extension to access to the first available conference.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FirstAvailableExten { get; set; }
Visual Basic
Public Property FirstAvailableExten As String
    Get
    Set
Visual C++
public:
property String^ FirstAvailableExten {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


Options Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..ConferenceConfig..::..Options Property
AMIgoSetupPanel..::..ConferenceConfig Class See Also Send Feedback
Gets or sets the options for the conf.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Options { get; set; }
Visual Basic
Public Property Options As String
    Get
    Set
Visual C++
public:
property String^ Options {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..ConferenceConfig Class


AMIgoSetupPanel.QueueConfig Class

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig Class
AMIgoSetupPanel Class Members See Also Send Feedback
This contains a Queue configuration parameters

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class QueueConfig
Visual Basic
Public Class QueueConfig
Visual C++
public ref class QueueConfig

Inheritance Hierarchy

System..::..Object
AMIgo..::..AMIgoSetupPanel..::..QueueConfig

See Also

AMIgoSetupPanel..::..QueueConfig Members


AMIgoSetupPanel.QueueConfig Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig Members
AMIgoSetupPanel..::..QueueConfig Class Constructors Properties See Also Send Feedback

This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc

The AMIgoSetupPanel..::..QueueConfig type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupPanel..::..QueueConfig | Initializes a new instance of the AMIgoSetupPanel..::..QueueConfig class.

Properties

 | Name | Description
Public property | AnnounceFrequency | The main queue announce frequency in seconnds
Public property | Autofill | Wheter to automatically send more than one caller to the queue. Normally 'yes'
Public property | Autopause | Pause a queue member when a call is not answered
Public property | EventMemberStatus | Report the queue status to the AMI
Public property | EventWhenCalled | Send manager event on agents calls
Public property | FullName | The queue name
Public property | JoinEmpty | Let caller join when no members assigne to the queue
Public property | Leavewhenempty | Leave the queue when the last member logoff
Public property | MaxLen | Queues entries can be limited by setting this value. 0 = unlimited
Public property | MusicClass | The queue music class.
Public property | PeriodicAnnounceFrequency | The frequency to say waiting caller their position in a queue
Public property | QueueNumber | The queue extension
Public property | ReportHoldTime | Report the hold time to the queue member who takes a call
Public property | RingInUse | This controls wheter calls are sent on extension already in use.
Public property | ServiceLevel | A number of seconds which represents the expected waiting time for caller A performance level is then calculated in terms of % of calls that are answered within the expected time
Public property | Strategy | The queue Strategy.(Ring all, Round Robin etc )
Public property | Timeout | The Timeout when calling the member of this queue. (secs)
Public property | WrapupTime | A number of seconds to wait before sending a new call to a member

See Also

AMIgoSetupPanel..::..QueueConfig Class


AMIgoSetupPanel.QueueConfig Constructor

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig Constructor
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupPanel..::..QueueConfig class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public QueueConfig()
Visual Basic
Public Sub New
Visual C++
public:
QueueConfig()

See Also

AMIgoSetupPanel..::..QueueConfig Class


AMIgoSetupPanel.QueueConfig Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig Properties
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback

The AMIgoSetupPanel..::..QueueConfig type exposes the following members.

Properties

 | Name | Description
Public property | AnnounceFrequency | The main queue announce frequency in seconnds
Public property | Autofill | Wheter to automatically send more than one caller to the queue. Normally 'yes'
Public property | Autopause | Pause a queue member when a call is not answered
Public property | EventMemberStatus | Report the queue status to the AMI
Public property | EventWhenCalled | Send manager event on agents calls
Public property | FullName | The queue name
Public property | JoinEmpty | Let caller join when no members assigne to the queue
Public property | Leavewhenempty | Leave the queue when the last member logoff
Public property | MaxLen | Queues entries can be limited by setting this value. 0 = unlimited
Public property | MusicClass | The queue music class.
Public property | PeriodicAnnounceFrequency | The frequency to say waiting caller their position in a queue
Public property | QueueNumber | The queue extension
Public property | ReportHoldTime | Report the hold time to the queue member who takes a call
Public property | RingInUse | This controls wheter calls are sent on extension already in use.
Public property | ServiceLevel | A number of seconds which represents the expected waiting time for caller A performance level is then calculated in terms of % of calls that are answered within the expected time
Public property | Strategy | The queue Strategy.(Ring all, Round Robin etc )
Public property | Timeout | The Timeout when calling the member of this queue. (secs)
Public property | WrapupTime | A number of seconds to wait before sending a new call to a member

See Also

AMIgoSetupPanel..::..QueueConfig Class


AnnounceFrequency Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..AnnounceFrequency Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The main queue announce frequency in seconnds

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AnnounceFrequency { get; set; }
Visual Basic
Public Property AnnounceFrequency As String
    Get
    Set
Visual C++
public:
property String^ AnnounceFrequency {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


Autofill Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..Autofill Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Wheter to automatically send more than one caller to the queue. Normally 'yes'

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Autofill { get; set; }
Visual Basic
Public Property Autofill As Boolean
    Get
    Set
Visual C++
public:
property bool Autofill {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


Autopause Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..Autopause Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Pause a queue member when a call is not answered

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Autopause { get; set; }
Visual Basic
Public Property Autopause As Boolean
    Get
    Set
Visual C++
public:
property bool Autopause {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


EventMemberStatus Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..EventMemberStatus Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Report the queue status to the AMI

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool EventMemberStatus { get; set; }
Visual Basic
Public Property EventMemberStatus As Boolean
    Get
    Set
Visual C++
public:
property bool EventMemberStatus {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


EventWhenCalled Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..EventWhenCalled Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Send manager event on agents calls

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool EventWhenCalled { get; set; }
Visual Basic
Public Property EventWhenCalled As Boolean
    Get
    Set
Visual C++
public:
property bool EventWhenCalled {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


FullName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..FullName Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The queue name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FullName { get; set; }
Visual Basic
Public Property FullName As String
    Get
    Set
Visual C++
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


JoinEmpty Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..JoinEmpty Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Let caller join when no members assigne to the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool JoinEmpty { get; set; }
Visual Basic
Public Property JoinEmpty As Boolean
    Get
    Set
Visual C++
public:
property bool JoinEmpty {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


Leavewhenempty Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..Leavewhenempty Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Leave the queue when the last member logoff

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Leavewhenempty { get; set; }
Visual Basic
Public Property Leavewhenempty As Boolean
    Get
    Set
Visual C++
public:
property bool Leavewhenempty {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


MaxLen Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..MaxLen Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Queues entries can be limited by setting this value. 0 = unlimited

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MaxLen { get; set; }
Visual Basic
Public Property MaxLen As String
    Get
    Set
Visual C++
public:
property String^ MaxLen {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


MusicClass Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..MusicClass Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The queue music class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MusicClass { get; set; }
Visual Basic
Public Property MusicClass As String
    Get
    Set
Visual C++
public:
property String^ MusicClass {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


PeriodicAnnounceFrequency Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..PeriodicAnnounceFrequency Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The frequency to say waiting caller their position in a queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string PeriodicAnnounceFrequency { get; set; }
Visual Basic
Public Property PeriodicAnnounceFrequency As String
    Get
    Set
Visual C++
public:
property String^ PeriodicAnnounceFrequency {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


QueueNumber Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..QueueNumber Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The queue extension

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string QueueNumber { get; set; }
Visual Basic
Public Property QueueNumber As String
    Get
    Set
Visual C++
public:
property String^ QueueNumber {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


ReportHoldTime Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..ReportHoldTime Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
Report the hold time to the queue member who takes a call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ReportHoldTime { get; set; }
Visual Basic
Public Property ReportHoldTime As Boolean
    Get
    Set
Visual C++
public:
property bool ReportHoldTime {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


RingInUse Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..RingInUse Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
This controls wheter calls are sent on extension already in use.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool RingInUse { get; set; }
Visual Basic
Public Property RingInUse As Boolean
    Get
    Set
Visual C++
public:
property bool RingInUse {
    bool get ();
    void set (bool value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


ServiceLevel Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..ServiceLevel Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
A number of seconds which represents the expected waiting time for caller A performance level is then calculated in terms of % of calls that are answered within the expected time

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ServiceLevel { get; set; }
Visual Basic
Public Property ServiceLevel As String
    Get
    Set
Visual C++
public:
property String^ ServiceLevel {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


Strategy Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..Strategy Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The queue Strategy.(Ring all, Round Robin etc )

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Strategy { get; set; }
Visual Basic
Public Property Strategy As String
    Get
    Set
Visual C++
public:
property String^ Strategy {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


Timeout Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..Timeout Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
The Timeout when calling the member of this queue. (secs)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Timeout { get; set; }
Visual Basic
Public Property Timeout As String
    Get
    Set
Visual C++
public:
property String^ Timeout {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


WrapupTime Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..QueueConfig..::..WrapupTime Property
AMIgoSetupPanel..::..QueueConfig Class See Also Send Feedback
A number of seconds to wait before sending a new call to a member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string WrapupTime { get; set; }
Visual Basic
Public Property WrapupTime As String
    Get
    Set
Visual C++
public:
property String^ WrapupTime {
    String^ get ();
    void set (String^ value);
}

See Also

AMIgoSetupPanel..::..QueueConfig Class


AMIgoSetupPanel.UserConfig Class

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig Class
AMIgoSetupPanel Class Members See Also Send Feedback
This class hold the information for a user contained in the users.conf config file.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class UserConfig
Visual Basic
Public Class UserConfig
Visual C++
public ref class UserConfig

Inheritance Hierarchy

System..::..Object
AMIgo..::..AMIgoSetupPanel..::..UserConfig

See Also

AMIgoSetupPanel..::..UserConfig Members


AMIgoSetupPanel.UserConfig Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig Members
AMIgoSetupPanel..::..UserConfig Class Constructors Properties See Also Send Feedback

This class implement the AMIgo setup panel that allows to manage the configuration of Users, Queues, Agents, Conferences etc

The AMIgoSetupPanel..::..UserConfig type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupPanel..::..UserConfig | Initializes a new instance of the AMIgoSetupPanel..::..UserConfig class.

Properties

 | Name | Description
Public property | Allow | Gets or sets list of codecs that are allowed.
Public property | AutoProv | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is AutoProv.
Public property | CallGroup | Gets or sets the CallGroup.
Public property | CallLimit | Gets or sets the CallLimit. Must be set for SIP object to get device state.
Public property | CallWaiting | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has call waiting.
Public property | CanreInvite | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has can reinvite.
Public property | CID_Number | Gets or sets the CID_Number.
Public property | Context | Gets or sets the dialplan Context for this account.
Public property | Disallow | Gets or sets the codecs Disallow value.
Public property | DTMF_Mode | Gets or sets the DTMF_Mode for this account.
Public property | Email | Gets or sets the Email for this extension.
Public property | Extension | Gets or sets the extension.
Public property | FromDomain | Gets or sets the FromDomain value. (used in some SIP account).
Public property | FromUser | Gets or sets the FromUser (used in some SIP account).
Public property | FullName | Gets or sets the FullName.
Public property | Group | Gets or sets the Group if any
Public property | HasAgent | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an agent agent.
Public property | HasDirectory | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is included in the directory.
Public property | HasExten | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an Extension.
Public property | HasIAX | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account is an IAX account.
Public property | HasManager | / Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has a manager account.
Public property | HasSIP | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is a SIP account.
Public property | HasVoicemail | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account has voicemail.
Public property | Host | Gets or sets the Host for a dynamic account
Public property | Insecure | Gets or sets the Insecure value.
Public property | Label | Gets or sets the Label assigned to this account.
Public property | LineNumber | Gets or sets the LineNumber.
Public property | MAC_Address | Gets or sets the MAC_Address.
Public property | Mailbox | Gets or sets if this account has a voice Mailbox.
Public property | NAT | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has NAT enabled.
Public property | PickupGroup | Gets or sets the PickupGroup, if any
Public property | RegisterIAX | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register in IAX.
Public property | RegisterSIP | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register SIP.
Public property | Secret | Gets or sets the Secret.
Public property | ThreeWayCalling | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has three way calling.
Public property | Transfer | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig supports transfers.
Public property | TrunkName | Gets or sets the TrunkName value. Userd to identify voip trunks in dialplan
Public property | TrunkStyle | Gets or sets the TrunkStyle.
Public property | UserName | Gets or sets the UserName.
Public property | VMSecret | Gets or sets the VMSecret.
Public property | ZapChan | Gets or sets the ZapChan.

See Also

AMIgoSetupPanel..::..UserConfig Class


AMIgoSetupPanel.UserConfig Constructor

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig Constructor
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupPanel..::..UserConfig class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public UserConfig()
Visual Basic
Public Sub New
Visual C++
public:
UserConfig()

See Also

AMIgoSetupPanel..::..UserConfig Class


AMIgoSetupPanel.UserConfig Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig Properties
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback

The AMIgoSetupPanel..::..UserConfig type exposes the following members.

Properties

 | Name | Description
Public property | Allow | Gets or sets list of codecs that are allowed.
Public property | AutoProv | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is AutoProv.
Public property | CallGroup | Gets or sets the CallGroup.
Public property | CallLimit | Gets or sets the CallLimit. Must be set for SIP object to get device state.
Public property | CallWaiting | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has call waiting.
Public property | CanreInvite | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has can reinvite.
Public property | CID_Number | Gets or sets the CID_Number.
Public property | Context | Gets or sets the dialplan Context for this account.
Public property | Disallow | Gets or sets the codecs Disallow value.
Public property | DTMF_Mode | Gets or sets the DTMF_Mode for this account.
Public property | Email | Gets or sets the Email for this extension.
Public property | Extension | Gets or sets the extension.
Public property | FromDomain | Gets or sets the FromDomain value. (used in some SIP account).
Public property | FromUser | Gets or sets the FromUser (used in some SIP account).
Public property | FullName | Gets or sets the FullName.
Public property | Group | Gets or sets the Group if any
Public property | HasAgent | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an agent agent.
Public property | HasDirectory | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is included in the directory.
Public property | HasExten | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an Extension.
Public property | HasIAX | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account is an IAX account.
Public property | HasManager | / Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has a manager account.
Public property | HasSIP | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is a SIP account.
Public property | HasVoicemail | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account has voicemail.
Public property | Host | Gets or sets the Host for a dynamic account
Public property | Insecure | Gets or sets the Insecure value.
Public property | Label | Gets or sets the Label assigned to this account.
Public property | LineNumber | Gets or sets the LineNumber.
Public property | MAC_Address | Gets or sets the MAC_Address.
Public property | Mailbox | Gets or sets if this account has a voice Mailbox.
Public property | NAT | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has NAT enabled.
Public property | PickupGroup | Gets or sets the PickupGroup, if any
Public property | RegisterIAX | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register in IAX.
Public property | RegisterSIP | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register SIP.
Public property | Secret | Gets or sets the Secret.
Public property | ThreeWayCalling | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has three way calling.
Public property | Transfer | Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig supports transfers.
Public property | TrunkName | Gets or sets the TrunkName value. Userd to identify voip trunks in dialplan
Public property | TrunkStyle | Gets or sets the TrunkStyle.
Public property | UserName | Gets or sets the UserName.
Public property | VMSecret | Gets or sets the VMSecret.
Public property | ZapChan | Gets or sets the ZapChan.

See Also

AMIgoSetupPanel..::..UserConfig Class


Allow Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Allow Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets list of codecs that are allowed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Allow { get; set; }
Visual Basic
Public Property Allow As String
    Get
    Set
Visual C++
public:
property String^ Allow {
    String^ get ();
    void set (String^ value);
}

Field Value

The Allow.

See Also

AMIgoSetupPanel..::..UserConfig Class


AutoProv Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..AutoProv Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is AutoProv.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool AutoProv { get; set; }
Visual Basic
Public Property AutoProv As Boolean
    Get
    Set
Visual C++
public:
property bool AutoProv {
    bool get ();
    void set (bool value);
}

Field Value

true if AutoProv; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


CallGroup Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..CallGroup Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the CallGroup.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallGroup { get; set; }
Visual Basic
Public Property CallGroup As String
    Get
    Set
Visual C++
public:
property String^ CallGroup {
    String^ get ();
    void set (String^ value);
}

Field Value

The CallGroup.

See Also

AMIgoSetupPanel..::..UserConfig Class


CallLimit Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..CallLimit Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the CallLimit. Must be set for SIP object to get device state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallLimit { get; set; }
Visual Basic
Public Property CallLimit As String
    Get
    Set
Visual C++
public:
property String^ CallLimit {
    String^ get ();
    void set (String^ value);
}

Field Value

The CallLimit.

See Also

AMIgoSetupPanel..::..UserConfig Class


CallWaiting Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..CallWaiting Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has call waiting.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool CallWaiting { get; set; }
Visual Basic
Public Property CallWaiting As Boolean
    Get
    Set
Visual C++
public:
property bool CallWaiting {
    bool get ();
    void set (bool value);
}

Field Value

true if CallWaiting; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


CanreInvite Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..CanreInvite Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has can reinvite.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool CanreInvite { get; set; }
Visual Basic
Public Property CanreInvite As Boolean
    Get
    Set
Visual C++
public:
property bool CanreInvite {
    bool get ();
    void set (bool value);
}

Field Value

true if CanreInvite; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


CID_Number Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..CID_Number Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the CID_Number.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CID_Number { get; set; }
Visual Basic
Public Property CID_Number As String
    Get
    Set
Visual C++
public:
property String^ CID_Number {
    String^ get ();
    void set (String^ value);
}

Field Value

The CID_Number.

See Also

AMIgoSetupPanel..::..UserConfig Class


Context Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Context Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the dialplan Context for this account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Context { get; set; }
Visual Basic
Public Property Context As String
    Get
    Set
Visual C++
public:
property String^ Context {
    String^ get ();
    void set (String^ value);
}

Field Value

The dialplan Context

See Also

AMIgoSetupPanel..::..UserConfig Class


Disallow Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Disallow Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the codecs Disallow value.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Disallow { get; set; }
Visual Basic
Public Property Disallow As String
    Get
    Set
Visual C++
public:
property String^ Disallow {
    String^ get ();
    void set (String^ value);
}

Field Value

The Disallow.

See Also

AMIgoSetupPanel..::..UserConfig Class


DTMF_Mode Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..DTMF_Mode Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the DTMF_Mode for this account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DTMF_Mode { get; set; }
Visual Basic
Public Property DTMF_Mode As String
    Get
    Set
Visual C++
public:
property String^ DTMF_Mode {
    String^ get ();
    void set (String^ value);
}

Field Value

The DTMF_Mode.

See Also

AMIgoSetupPanel..::..UserConfig Class


Email Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Email Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Email for this extension.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Field Value

The Email.

See Also

AMIgoSetupPanel..::..UserConfig Class


Extension Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Extension Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the extension.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set
Visual C++
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}

Field Value

The extension number.

See Also

AMIgoSetupPanel..::..UserConfig Class


FromDomain Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..FromDomain Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the FromDomain value. (used in some SIP account).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FromDomain { get; set; }
Visual Basic
Public Property FromDomain As String
    Get
    Set
Visual C++
public:
property String^ FromDomain {
    String^ get ();
    void set (String^ value);
}

Field Value

The FromDomain value.

See Also

AMIgoSetupPanel..::..UserConfig Class


FromUser Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..FromUser Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the FromUser (used in some SIP account).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FromUser { get; set; }
Visual Basic
Public Property FromUser As String
    Get
    Set
Visual C++
public:
property String^ FromUser {
    String^ get ();
    void set (String^ value);
}

Field Value

The FromUser value.

See Also

AMIgoSetupPanel..::..UserConfig Class


FullName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..FullName Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the FullName.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string FullName { get; set; }
Visual Basic
Public Property FullName As String
    Get
    Set
Visual C++
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

Field Value

The FullName.

See Also

AMIgoSetupPanel..::..UserConfig Class


Group Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Group Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Group if any

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Group { get; set; }
Visual Basic
Public Property Group As String
    Get
    Set
Visual C++
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}

Field Value

The Group number.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasAgent Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasAgent Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an agent agent.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasAgent { get; set; }
Visual Basic
Public Property HasAgent As Boolean
    Get
    Set
Visual C++
public:
property bool HasAgent {
    bool get ();
    void set (bool value);
}

Field Value

Set to true if user is an agent, otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasDirectory Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasDirectory Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is included in the directory.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasDirectory { get; set; }
Visual Basic
Public Property HasDirectory As Boolean
    Get
    Set
Visual C++
public:
property bool HasDirectory {
    bool get ();
    void set (bool value);
}

Field Value

true if HasDirectory; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasExten Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasExten Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is an Extension.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasExten { get; set; }
Visual Basic
Public Property HasExten As Boolean
    Get
    Set
Visual C++
public:
property bool HasExten {
    bool get ();
    void set (bool value);
}

Field Value

Set to true if this account is a AIP account, otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasIAX Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasIAX Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account is an IAX account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasIAX { get; set; }
Visual Basic
Public Property HasIAX As Boolean
    Get
    Set
Visual C++
public:
property bool HasIAX {
    bool get ();
    void set (bool value);
}

Field Value

true if HasIAX; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasManager Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasManager Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
/ Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has a manager account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasManager { get; set; }
Visual Basic
Public Property HasManager As Boolean
    Get
    Set
Visual C++
public:
property bool HasManager {
    bool get ();
    void set (bool value);
}

Field Value

Set to true if HasManager; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasSIP Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasSIP Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig is a SIP account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasSIP { get; set; }
Visual Basic
Public Property HasSIP As Boolean
    Get
    Set
Visual C++
public:
property bool HasSIP {
    bool get ();
    void set (bool value);
}

Field Value

Set to true if this account is a AIP account, otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


HasVoicemail Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..HasVoicemail Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account has voicemail.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool HasVoicemail { get; set; }
Visual Basic
Public Property HasVoicemail As Boolean
    Get
    Set
Visual C++
public:
property bool HasVoicemail {
    bool get ();
    void set (bool value);
}

Field Value

true if HasVoicemail; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


Host Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Host Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Host for a dynamic account

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

Field Value

The Host.

See Also

AMIgoSetupPanel..::..UserConfig Class


Insecure Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Insecure Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Insecure value.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Insecure { get; set; }
Visual Basic
Public Property Insecure As String
    Get
    Set
Visual C++
public:
property String^ Insecure {
    String^ get ();
    void set (String^ value);
}

Field Value

The Insecure value .

See Also

AMIgoSetupPanel..::..UserConfig Class


Label Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Label Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Label assigned to this account.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Label { get; set; }
Visual Basic
Public Property Label As String
    Get
    Set
Visual C++
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

Field Value

The Label.

See Also

AMIgoSetupPanel..::..UserConfig Class


LineNumber Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..LineNumber Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the LineNumber.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LineNumber { get; set; }
Visual Basic
Public Property LineNumber As String
    Get
    Set
Visual C++
public:
property String^ LineNumber {
    String^ get ();
    void set (String^ value);
}

Field Value

The LineNumber.

See Also

AMIgoSetupPanel..::..UserConfig Class


MAC_Address Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..MAC_Address Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the MAC_Address.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MAC_Address { get; set; }
Visual Basic
Public Property MAC_Address As String
    Get
    Set
Visual C++
public:
property String^ MAC_Address {
    String^ get ();
    void set (String^ value);
}

Field Value

The MAC_Address.

See Also

AMIgoSetupPanel..::..UserConfig Class


Mailbox Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Mailbox Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets if this account has a voice Mailbox.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Mailbox { get; set; }
Visual Basic
Public Property Mailbox As String
    Get
    Set
Visual C++
public:
property String^ Mailbox {
    String^ get ();
    void set (String^ value);
}

Field Value

yes or no

See Also

AMIgoSetupPanel..::..UserConfig Class


NAT Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..NAT Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has NAT enabled.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool NAT { get; set; }
Visual Basic
Public Property NAT As Boolean
    Get
    Set
Visual C++
public:
property bool NAT {
    bool get ();
    void set (bool value);
}

Field Value

true if NAT; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


PickupGroup Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..PickupGroup Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the PickupGroup, if any

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string PickupGroup { get; set; }
Visual Basic
Public Property PickupGroup As String
    Get
    Set
Visual C++
public:
property String^ PickupGroup {
    String^ get ();
    void set (String^ value);
}

Field Value

The PickupGroup.

See Also

AMIgoSetupPanel..::..UserConfig Class


RegisterIAX Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..RegisterIAX Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register in IAX.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool RegisterIAX { get; set; }
Visual Basic
Public Property RegisterIAX As Boolean
    Get
    Set
Visual C++
public:
property bool RegisterIAX {
    bool get ();
    void set (bool value);
}

Field Value

true if RegisterIAX; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


RegisterSIP Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..RegisterSIP Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig account needs to is register SIP.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool RegisterSIP { get; set; }
Visual Basic
Public Property RegisterSIP As Boolean
    Get
    Set
Visual C++
public:
property bool RegisterSIP {
    bool get ();
    void set (bool value);
}

Field Value

true if RegisterSIP; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


Secret Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Secret Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the Secret.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Secret { get; set; }
Visual Basic
Public Property Secret As String
    Get
    Set
Visual C++
public:
property String^ Secret {
    String^ get ();
    void set (String^ value);
}

Field Value

The Secret.

See Also

AMIgoSetupPanel..::..UserConfig Class


ThreeWayCalling Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..ThreeWayCalling Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig has three way calling.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ThreeWayCalling { get; set; }
Visual Basic
Public Property ThreeWayCalling As Boolean
    Get
    Set
Visual C++
public:
property bool ThreeWayCalling {
    bool get ();
    void set (bool value);
}

Field Value

true if ThreeWayCalling; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


Transfer Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..Transfer Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets a value indicating whether this AMIgoSetupPanel..::..UserConfig supports transfers.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Transfer { get; set; }
Visual Basic
Public Property Transfer As Boolean
    Get
    Set
Visual C++
public:
property bool Transfer {
    bool get ();
    void set (bool value);
}

Field Value

true if Transfer; otherwise, false.

See Also

AMIgoSetupPanel..::..UserConfig Class


TrunkName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..TrunkName Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the TrunkName value. Userd to identify voip trunks in dialplan

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TrunkName { get; set; }
Visual Basic
Public Property TrunkName As String
    Get
    Set
Visual C++
public:
property String^ TrunkName {
    String^ get ();
    void set (String^ value);
}

Field Value

The TrunkName value.

See Also

AMIgoSetupPanel..::..UserConfig Class


TrunkStyle Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..TrunkStyle Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the TrunkStyle.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TrunkStyle { get; set; }
Visual Basic
Public Property TrunkStyle As String
    Get
    Set
Visual C++
public:
property String^ TrunkStyle {
    String^ get ();
    void set (String^ value);
}

Field Value

The TrunkStyle, (analog, digital, voip) if a Trunk object.

See Also

AMIgoSetupPanel..::..UserConfig Class


UserName Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..UserName Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the UserName.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Field Value

The UserName.

See Also

AMIgoSetupPanel..::..UserConfig Class


VMSecret Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..VMSecret Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the VMSecret.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string VMSecret { get; set; }
Visual Basic
Public Property VMSecret As String
    Get
    Set
Visual C++
public:
property String^ VMSecret {
    String^ get ();
    void set (String^ value);
}

Field Value

The VMSecret.

See Also

AMIgoSetupPanel..::..UserConfig Class


ZapChan Property

[image]

AMIgo Controls documentation
AMIgoSetupPanel..::..UserConfig..::..ZapChan Property
AMIgoSetupPanel..::..UserConfig Class See Also Send Feedback
Gets or sets the ZapChan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ZapChan { get; set; }
Visual Basic
Public Property ZapChan As String
    Get
    Set
Visual C++
public:
property String^ ZapChan {
    String^ get ();
    void set (String^ value);
}

Field Value

The ZapChan, if a ZAP object.

See Also

AMIgoSetupPanel..::..UserConfig Class


AMIgoSetupQueueForm Class

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm Class
Members Example See Also Send Feedback
This Form descendant allows to create / edit queues definitions.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupQueueForm : AMIgoControl
Visual Basic
Public Class AMIgoSetupQueueForm _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoSetupQueueForm : public AMIgoControl

Remarks

To create a new queue definition, create a new instance with ItemIndex = -1 or use the constructor without index. To edit an existing queue definition, create a new instance with the Item index of the queue in the _QueuesConfigList list of dictionary. This list can be filled with a call to the ConfigGetQueues()()()() method

This form is used as a container for a AMIgoSetupAgentPanel.

Examples

USAGE: Create a new form:
CopyC#
1new AMIgoSetupQueueForm(this.AMI_Client1); /// Create a new queue
2new AMIgoSetupQueueForm(this.AMI_Client1, 0); // Edit first entry in list

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoSetupQueueForm

See Also

AMIgoSetupQueueForm Members


AMIgoSetupQueueForm Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueueForm Members
AMIgoSetupQueueForm Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupQueueForm type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupQueueForm()()()() | Initializes a new instance of the AMIgoSetupQueueForm class.
Public method | AMIgoSetupQueueForm(AMI_Client) | Initializes a new instance of the AMIgoSetupAgentForm class to create a new queue definition.
Public method | AMIgoSetupQueueForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupAgentForm class to edit given queue definition at index.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the queue at given index in the config list.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueueForm Class


AMIgoSetupQueueForm Constructor

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueueForm Constructor
AMIgoSetupQueueForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoSetupQueueForm()()()() | Initializes a new instance of the AMIgoSetupQueueForm class.
Public method | AMIgoSetupQueueForm(AMI_Client) | Initializes a new instance of the AMIgoSetupAgentForm class to create a new queue definition.
Public method | AMIgoSetupQueueForm(AMI_Client, Int32) | Initializes a new instance of the AMIgoSetupAgentForm class to edit given queue definition at index.

See Also

AMIgoSetupQueueForm Class
AMIgoSetupQueueForm Members


AMIgoSetupQueueForm Constructor

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm Constructor
AMIgoSetupQueueForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupQueueForm class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupQueueForm()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupQueueForm()

See Also

AMIgoSetupQueueForm Class
AMIgoSetupQueueForm Overload


AMIgoSetupQueueForm Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm Constructor (AMI_Client)
AMIgoSetupQueueForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentForm class to create a new queue definition.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupQueueForm(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoSetupQueueForm(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.

See Also

AMIgoSetupQueueForm Class
AMIgoSetupQueueForm Overload


AMIgoSetupQueueForm Constructor (AMI_Client, Int32)

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm Constructor (AMI_Client, Int32)
AMIgoSetupQueueForm Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupAgentForm class to edit given queue definition at index.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupQueueForm(
    AMI_Client AMI_ClientInstance,
    int ItemIndex
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client, _
    ItemIndex As Integer _
)
Visual C++
public:
AMIgoSetupQueueForm(
    AMI_Client^ AMI_ClientInstance,
    int ItemIndex
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_Client instance.
ItemIndex
Type: System..::..Int32
Index of the item in the list.

See Also

AMIgoSetupQueueForm Class
AMIgoSetupQueueForm Overload


AMIgoSetupQueueForm Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueueForm Fields
AMIgoSetupQueueForm Class See Also Send Feedback

The AMIgoSetupQueueForm type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueueForm Class


AMIgoSetupQueueForm Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueueForm Methods
AMIgoSetupQueueForm Class See Also Send Feedback

The AMIgoSetupQueueForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SelectQueueAtIndex | Selects the the queue at given index in the config list.

See Also

AMIgoSetupQueueForm Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm..::..Dispose Method
AMIgoSetupQueueForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupQueueForm Class


SelectQueueAtIndex Method

[image]

AMIgo Controls documentation
AMIgoSetupQueueForm..::..SelectQueueAtIndex Method
AMIgoSetupQueueForm Class See Also Send Feedback
Selects the the queue at given index in the config list.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectQueueAtIndex(
    int ItemIndex
)
Visual Basic
Public Sub SelectQueueAtIndex ( _
    ItemIndex As Integer _
)
Visual C++
public:
void SelectQueueAtIndex(
    int ItemIndex
)

Parameters

ItemIndex
Type: System..::..Int32
Index of the item.

Remarks

The queue definition must exist at given index in the _QueuesConfigList list.

See Also

AMIgoSetupQueueForm Class


AMIgoSetupQueueForm Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueueForm Properties
AMIgoSetupQueueForm Class See Also Send Feedback

The AMIgoSetupQueueForm type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueueForm Class


AMIgoSetupQueuePanel Class

[image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Class
Members See Also Send Feedback
This control is used to edit and create new queues.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSetupQueuePanel : AMIgoConfigControl
Visual Basic
Public Class AMIgoSetupQueuePanel _
    Inherits AMIgoConfigControl
Visual C++
public ref class AMIgoSetupQueuePanel : public AMIgoConfigControl

Remarks

This Panel is intended to be displayed in another container or in a Form. See: AMIgoSetupQueueForm. It is also used in the AMIgoSetupPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoConfigControl
AMIgo..::..AMIgoSetupQueuePanel

See Also

AMIgoSetupQueuePanel Members


AMIgoSetupQueuePanel Members

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Members
AMIgoSetupQueuePanel Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoSetupQueuePanel type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSetupQueuePanel | Initializes a new instance of the AMIgoSetupQueuePanel class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectQueue | Selects the queue to be edited.
Public method | SetCloseButtonVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueuePanel Class


AMIgoSetupQueuePanel Constructor

[image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Constructor
AMIgoSetupQueuePanel Class See Also Send Feedback
Initializes a new instance of the AMIgoSetupQueuePanel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSetupQueuePanel()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSetupQueuePanel()

See Also

AMIgoSetupQueuePanel Class


AMIgoSetupQueuePanel Fields

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Fields
AMIgoSetupQueuePanel Class See Also Send Feedback

The AMIgoSetupQueuePanel type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueuePanel Class


AMIgoSetupQueuePanel Methods

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Methods
AMIgoSetupQueuePanel Class See Also Send Feedback

The AMIgoSetupQueuePanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetNextUnusedExtension | Gets the next unused extension for the given categories taken from guipreferences.conf (Inherited from AMIgoConfigControl.)
Public method | SelectQueue | Selects the queue to be edited.
Public method | SetCloseButtonVisible | Sets the button close visible state.
Protected method | UpdateDicolist | Updates the given dictionary list with a given updated dictionary (Inherited from AMIgoConfigControl.)

See Also

AMIgoSetupQueuePanel Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSetupQueuePanel..::..Dispose Method
AMIgoSetupQueuePanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSetupQueuePanel Class


SelectQueue Method

[image]

AMIgo Controls documentation
AMIgoSetupQueuePanel..::..SelectQueue Method
AMIgoSetupQueuePanel Class See Also Send Feedback
Selects the queue to be edited.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SelectQueue(
    int IndexInList
)
Visual Basic
Public Sub SelectQueue ( _
    IndexInList As Integer _
)
Visual C++
public:
void SelectQueue(
    int IndexInList
)

Parameters

IndexInList
Type: System..::..Int32
The index in list.

Remarks

You can also give an index of -1 to create a new queue

See Also

AMIgoSetupQueuePanel Class


SetCloseButtonVisible Method

[image]

AMIgo Controls documentation
AMIgoSetupQueuePanel..::..SetCloseButtonVisible Method
AMIgoSetupQueuePanel Class See Also Send Feedback
Sets the button close visible state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetCloseButtonVisible()
Visual Basic
Public Sub SetCloseButtonVisible
Visual C++
public:
void SetCloseButtonVisible()

Remarks

Used to show a close button when used in a parent form

See Also

AMIgoSetupQueuePanel Class


AMIgoSetupQueuePanel Properties

[image] [image]

AMIgo Controls documentation
AMIgoSetupQueuePanel Properties
AMIgoSetupQueuePanel Class See Also Send Feedback

The AMIgoSetupQueuePanel type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoSetupQueuePanel Class


AMIgoSitesManager Class

[image]

AMIgo Controls documentation
AMIgoSitesManager Class
Members Example See Also Send Feedback
This Controls implements a DataBase of Asterisk sites and provides an easy and quick way to connect and login to a selected site.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoSitesManager : Form
Visual Basic
Public Class AMIgoSitesManager _
    Inherits Form
Visual C++
public ref class AMIgoSitesManager : public Form

Remarks

This control allows to enter and edit the host and manager login information for a list of asterisk sites. And provides an easy way to connect to a site by simply selecting it from a list.This control can be created by the AMIgoCommandPanel by clicking on its "Connections" button or by creating a new instance and calling it's show method.

Examples

CopyC#
1AMIgoSitesManager sites = new AMIgoSitesManager(this, AMI_Client);
2sites.Show();

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..AMIgoSitesManager

See Also

AMIgoSitesManager Members


AMIgoSitesManager Members

[image] [image]

AMIgo Controls documentation
AMIgoSitesManager Members
AMIgoSitesManager Class Constructors Methods See Also Send Feedback

The AMIgoSitesManager type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoSitesManager()()()() | Initializes a new instance of the AMIgoSitesManager class.
Public method | AMIgoSitesManager(Control, AMI_Client) | Initializes a new instance of the AMIgoSitesManager class. Creates the site table if it does not exists

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoSitesManager Class


AMIgoSitesManager Constructor

[image] [image]

AMIgo Controls documentation
AMIgoSitesManager Constructor
AMIgoSitesManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoSitesManager()()()() | Initializes a new instance of the AMIgoSitesManager class.
Public method | AMIgoSitesManager(Control, AMI_Client) | Initializes a new instance of the AMIgoSitesManager class. Creates the site table if it does not exists

See Also

AMIgoSitesManager Class
AMIgoSitesManager Members


AMIgoSitesManager Constructor

[image]

AMIgo Controls documentation
AMIgoSitesManager Constructor
AMIgoSitesManager Class See Also Send Feedback
Initializes a new instance of the AMIgoSitesManager class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSitesManager()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoSitesManager()

See Also

AMIgoSitesManager Class
AMIgoSitesManager Overload


AMIgoSitesManager Constructor (Control, AMI_Client)

[image]

AMIgo Controls documentation
AMIgoSitesManager Constructor (Control, AMI_Client)
AMIgoSitesManager Class Example See Also Send Feedback
Initializes a new instance of the AMIgoSitesManager class. Creates the site table if it does not exists

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoSitesManager(
    Control ParentControl,
    AMI_Client MngrInstance
)
Visual Basic
Public Sub New ( _
    ParentControl As Control, _
    MngrInstance As AMI_Client _
)
Visual C++
public:
AMIgoSitesManager(
    Control^ ParentControl,
    AMI_Client^ MngrInstance
)

Parameters

ParentControl
Type: System.Windows.Forms..::..Control
The parent control. Ususally the main form (this)
MngrInstance
Type: AMIgo..::..AMI_Client
The MNGR instance.

Remarks

This constructor is used to show the AMIgoSitesManager with the parent control and an existing AMI_Client instance. The control can then start the given AMI_Client thread and connect to the selected site

Examples

CopyC#
1AMIgoSitesManager sites = new AMIgoSitesManager(this, AMI_Client1);

See Also

AMIgoSitesManager Class
AMIgoSitesManager Overload


AMIgoSitesManager Methods

[image] [image]

AMIgo Controls documentation
AMIgoSitesManager Methods
AMIgoSitesManager Class See Also Send Feedback

The AMIgoSitesManager type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

AMIgoSitesManager Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoSitesManager..::..Dispose Method
AMIgoSitesManager Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoSitesManager Class


AMIgoStatusStrip Class

[image]

AMIgo Controls documentation
AMIgoStatusStrip Class
Members See Also Send Feedback
This is the AMIgo status strip class, used to display status message .

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AMIgoStatusStrip : AMIgoControl
Visual Basic
Public Class AMIgoStatusStrip _
    Inherits AMIgoControl
Visual C++
public ref class AMIgoStatusStrip : public AMIgoControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoStatusStrip

See Also

AMIgoStatusStrip Members


AMIgoStatusStrip Members

[image] [image]

AMIgo Controls documentation
AMIgoStatusStrip Members
AMIgoStatusStrip Class Constructors Methods Fields Properties See Also Send Feedback

The AMIgoStatusStrip type exposes the following members.

Constructors

 | Name | Description
Public method | AMIgoStatusStrip()()()() | Initializes a new instance of the AMIgoStatusStrip class.
Public method | AMIgoStatusStrip(AMI_Client) | Initializes a new instance of the AMIgoStatusStrip class.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handles the command results events.
Public method | ConfigUpdateBeginEventHandler | Handles the ConfigUpdateBeginEvent Event.
Public method | ConfigUpdateEventHandler | Handles the ConfigUpdateEvent Event.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ErrorEventHandler | Handles the error events.
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | OriginateResultEventHandler | Handles the Originates the result events.
Public method | ShowMessage | Shows the given message on the status strip.
Public method | StateChangeEventHandler | Handles the StateChange events.
Public method | StatusEventHandler | Handles the Statuses events.
Public method | UserEventHandler | Handles the UserEvent events.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoStatusStrip Class


AMIgoStatusStrip Constructor

[image] [image]

AMIgo Controls documentation
AMIgoStatusStrip Constructor
AMIgoStatusStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AMIgoStatusStrip()()()() | Initializes a new instance of the AMIgoStatusStrip class.
Public method | AMIgoStatusStrip(AMI_Client) | Initializes a new instance of the AMIgoStatusStrip class.

See Also

AMIgoStatusStrip Class
AMIgoStatusStrip Members


AMIgoStatusStrip Constructor

[image]

AMIgo Controls documentation
AMIgoStatusStrip Constructor
AMIgoStatusStrip Class See Also Send Feedback
Initializes a new instance of the AMIgoStatusStrip class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoStatusStrip()
Visual Basic
Public Sub New
Visual C++
public:
AMIgoStatusStrip()

See Also

AMIgoStatusStrip Class
AMIgoStatusStrip Overload


AMIgoStatusStrip Constructor (AMI_Client)

[image]

AMIgo Controls documentation
AMIgoStatusStrip Constructor (AMI_Client)
AMIgoStatusStrip Class See Also Send Feedback
Initializes a new instance of the AMIgoStatusStrip class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMIgoStatusStrip(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
AMIgoStatusStrip(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AM i_ client instance.

See Also

AMIgoStatusStrip Class
AMIgoStatusStrip Overload


AMIgoStatusStrip Fields

[image] [image]

AMIgo Controls documentation
AMIgoStatusStrip Fields
AMIgoStatusStrip Class See Also Send Feedback

The AMIgoStatusStrip type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

AMIgoStatusStrip Class


AMIgoStatusStrip Methods

[image] [image]

AMIgo Controls documentation
AMIgoStatusStrip Methods
AMIgoStatusStrip Class See Also Send Feedback

The AMIgoStatusStrip type exposes the following members.

Methods

 | Name | Description
Public method | CmdResultEventHandler | Handles the command results events.
Public method | ConfigUpdateBeginEventHandler | Handles the ConfigUpdateBeginEvent Event.
Public method | ConfigUpdateEventHandler | Handles the ConfigUpdateEvent Event.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ErrorEventHandler | Handles the error events.
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | OriginateResultEventHandler | Handles the Originates the result events.
Public method | ShowMessage | Shows the given message on the status strip.
Public method | StateChangeEventHandler | Handles the StateChange events.
Public method | StatusEventHandler | Handles the Statuses events.
Public method | UserEventHandler | Handles the UserEvent events.

See Also

AMIgoStatusStrip Class


CmdResultEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..CmdResultEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the command results events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void CmdResultEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub CmdResultEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void CmdResultEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


ConfigUpdateBeginEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..ConfigUpdateBeginEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the ConfigUpdateBeginEvent Event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigUpdateBeginEventHandler(
    Object sender,
    EventArgs ev
)
Visual Basic
Public Sub ConfigUpdateBeginEventHandler ( _
    sender As Object, _
    ev As EventArgs _
)
Visual C++
public:
void ConfigUpdateBeginEventHandler(
    Object^ sender,
    EventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


ConfigUpdateEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..ConfigUpdateEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the ConfigUpdateEvent Event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ConfigUpdateEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Sub ConfigUpdateEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public:
void ConfigUpdateEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


Dispose Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..Dispose Method
AMIgoStatusStrip Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AMIgoStatusStrip Class


ErrorEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..ErrorEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the error events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ErrorEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Sub ErrorEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public:
void ErrorEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


OriginateResultEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..OriginateResultEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the Originates the result events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void OriginateResultEventHandler(
    Object sender,
    OriginateEventArgs ev
)
Visual Basic
Public Sub OriginateResultEventHandler ( _
    sender As Object, _
    ev As OriginateEventArgs _
)
Visual C++
public:
void OriginateResultEventHandler(
    Object^ sender,
    OriginateEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..OriginateEventArgs
The OriginateEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


ShowMessage Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..ShowMessage Method
AMIgoStatusStrip Class See Also Send Feedback
Shows the given message on the status strip.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ShowMessage(
    string Msg
)
Visual Basic
Public Sub ShowMessage ( _
    Msg As String _
)
Visual C++
public:
void ShowMessage(
    String^ Msg
)

Parameters

Msg
Type: System..::..String
The MSG.

See Also

AMIgoStatusStrip Class


StateChangeEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..StateChangeEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the StateChange events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StateChangeEventHandler(
    Object sender,
    StateChangeEventArgs ev
)
Visual Basic
Public Sub StateChangeEventHandler ( _
    sender As Object, _
    ev As StateChangeEventArgs _
)
Visual C++
public:
void StateChangeEventHandler(
    Object^ sender,
    StateChangeEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StateChangeEventArgs
The StateChangeEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


StatusEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..StatusEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the Statuses events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void StatusEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Sub StatusEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public:
void StatusEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


UserEventHandler Method

[image]

AMIgo Controls documentation
AMIgoStatusStrip..::..UserEventHandler Method
AMIgoStatusStrip Class See Also Send Feedback
Handles the UserEvent events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void UserEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Sub UserEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public:
void UserEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgoStatusStrip Class


AMIgoStatusStrip Properties

[image] [image]

AMIgo Controls documentation
AMIgoStatusStrip Properties
AMIgoStatusStrip Class See Also Send Feedback

The AMIgoStatusStrip type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

AMIgoStatusStrip Class


AstAgent Class

[image]

AMIgo Controls documentation
AstAgent Class
Members See Also Send Feedback
This class is the base for the Agents list. See: AstAgentsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstAgent
Visual Basic
Public Class AstAgent
Visual C++
public ref class AstAgent

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstAgent

See Also

AstAgent Members


AstAgent Members

[image] [image]

AMIgo Controls documentation
AstAgent Members
AstAgent Class Constructors Properties See Also Send Feedback

The AstAgent type exposes the following members.

Constructors

 | Name | Description
Public method | AstAgent | Initializes a new instance of the AstAgent class.

Properties

 | Name | Description
Public property | Agent | The agent number
Public property | AgentGroupNo | An optional agent group number
Public property | AgentName | The agent name
Public property | AgentType | Channel or Local agent
Public property | DefaultCallbackLocation | (Local agent only) The default callback location
Public property | LoggedInTime | The time the agent logged in.
Public property | Loginchan | The callback channel
Public property | Logintime | The time the agent has been logged for (set after logoff)
Public property | MemberOfQueuesConfs | (Local agent only) The default queues this agent is member of
Public property | Reason | The reason of the las logoff (agent / command ...)
Public property | Session | A session number (timestamp of the loggin)
Public property | Site | An asterisk site name
Public property | Status | The current status of this agent
Public property | TimeStamp | The timestamp of the last message

See Also

AstAgent Class


AstAgent Constructor

[image]

AMIgo Controls documentation
AstAgent Constructor
AstAgent Class See Also Send Feedback
Initializes a new instance of the AstAgent class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgent()
Visual Basic
Public Sub New
Visual C++
public:
AstAgent()

See Also

AstAgent Class


AstAgent Properties

[image] [image]

AMIgo Controls documentation
AstAgent Properties
AstAgent Class See Also Send Feedback

The AstAgent type exposes the following members.

Properties

 | Name | Description
Public property | Agent | The agent number
Public property | AgentGroupNo | An optional agent group number
Public property | AgentName | The agent name
Public property | AgentType | Channel or Local agent
Public property | DefaultCallbackLocation | (Local agent only) The default callback location
Public property | LoggedInTime | The time the agent logged in.
Public property | Loginchan | The callback channel
Public property | Logintime | The time the agent has been logged for (set after logoff)
Public property | MemberOfQueuesConfs | (Local agent only) The default queues this agent is member of
Public property | Reason | The reason of the las logoff (agent / command ...)
Public property | Session | A session number (timestamp of the loggin)
Public property | Site | An asterisk site name
Public property | Status | The current status of this agent
Public property | TimeStamp | The timestamp of the last message

See Also

AstAgent Class


Agent Property

[image]

AMIgo Controls documentation
AstAgent..::..Agent Property
AstAgent Class See Also Send Feedback
The agent number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Agent { get; set; }
Visual Basic
Public Property Agent As String
    Get
    Set
Visual C++
public:
property String^ Agent {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


AgentGroupNo Property

[image]

AMIgo Controls documentation
AstAgent..::..AgentGroupNo Property
AstAgent Class See Also Send Feedback
An optional agent group number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentGroupNo { get; set; }
Visual Basic
Public Property AgentGroupNo As String
    Get
    Set
Visual C++
public:
property String^ AgentGroupNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


AgentName Property

[image]

AMIgo Controls documentation
AstAgent..::..AgentName Property
AstAgent Class See Also Send Feedback
The agent name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentName { get; set; }
Visual Basic
Public Property AgentName As String
    Get
    Set
Visual C++
public:
property String^ AgentName {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


AgentType Property

[image]

AMIgo Controls documentation
AstAgent..::..AgentType Property
AstAgent Class See Also Send Feedback
Channel or Local agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentTypes AgentType { get; set; }
Visual Basic
Public Property AgentType As AgentTypes
    Get
    Set
Visual C++
public:
property AgentTypes AgentType {
    AgentTypes get ();
    void set (AgentTypes value);
}

See Also

AstAgent Class


DefaultCallbackLocation Property

[image]

AMIgo Controls documentation
AstAgent..::..DefaultCallbackLocation Property
AstAgent Class See Also Send Feedback
(Local agent only) The default callback location

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DefaultCallbackLocation { get; set; }
Visual Basic
Public Property DefaultCallbackLocation As String
    Get
    Set
Visual C++
public:
property String^ DefaultCallbackLocation {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


LoggedInTime Property

[image]

AMIgo Controls documentation
AstAgent..::..LoggedInTime Property
AstAgent Class See Also Send Feedback
The time the agent logged in.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LoggedInTime { get; set; }
Visual Basic
Public Property LoggedInTime As String
    Get
    Set
Visual C++
public:
property String^ LoggedInTime {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Loginchan Property

[image]

AMIgo Controls documentation
AstAgent..::..Loginchan Property
AstAgent Class See Also Send Feedback
The callback channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Loginchan { get; set; }
Visual Basic
Public Property Loginchan As String
    Get
    Set
Visual C++
public:
property String^ Loginchan {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Logintime Property

[image]

AMIgo Controls documentation
AstAgent..::..Logintime Property
AstAgent Class See Also Send Feedback
The time the agent has been logged for (set after logoff)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Logintime { get; set; }
Visual Basic
Public Property Logintime As String
    Get
    Set
Visual C++
public:
property String^ Logintime {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


MemberOfQueuesConfs Property

[image]

AMIgo Controls documentation
AstAgent..::..MemberOfQueuesConfs Property
AstAgent Class See Also Send Feedback
(Local agent only) The default queues this agent is member of

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MemberOfQueuesConfs { get; set; }
Visual Basic
Public Property MemberOfQueuesConfs As String
    Get
    Set
Visual C++
public:
property String^ MemberOfQueuesConfs {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Reason Property

[image]

AMIgo Controls documentation
AstAgent..::..Reason Property
AstAgent Class See Also Send Feedback
The reason of the las logoff (agent / command ...)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Reason { get; set; }
Visual Basic
Public Property Reason As String
    Get
    Set
Visual C++
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Session Property

[image]

AMIgo Controls documentation
AstAgent..::..Session Property
AstAgent Class See Also Send Feedback
A session number (timestamp of the loggin)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Session { get; set; }
Visual Basic
Public Property Session As String
    Get
    Set
Visual C++
public:
property String^ Session {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Site Property

[image]

AMIgo Controls documentation
AstAgent..::..Site Property
AstAgent Class See Also Send Feedback
An asterisk site name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Site { get; set; }
Visual Basic
Public Property Site As String
    Get
    Set
Visual C++
public:
property String^ Site {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


Status Property

[image]

AMIgo Controls documentation
AstAgent..::..Status Property
AstAgent Class See Also Send Feedback
The current status of this agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


TimeStamp Property

[image]

AMIgo Controls documentation
AstAgent..::..TimeStamp Property
AstAgent Class See Also Send Feedback
The timestamp of the last message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As String
    Get
    Set
Visual C++
public:
property String^ TimeStamp {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgent Class


AstAgentCall Class

[image]

AMIgo Controls documentation
AstAgentCall Class
Members See Also Send Feedback
This class is the base for the Agents Calls list. See: AstAgentsCallsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstAgentCall
Visual Basic
Public Class AstAgentCall
Visual C++
public ref class AstAgentCall

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstAgentCall

See Also

AstAgentCall Members


AstAgentCall Members

[image] [image]

AMIgo Controls documentation
AstAgentCall Members
AstAgentCall Class Constructors Properties See Also Send Feedback

The AstAgentCall type exposes the following members.

Constructors

 | Name | Description
Public method | AstAgentCall | Initializes a new instance of the AstAgentCall class.

Properties

 | Name | Description
Public property | Agent | The agent number
Public property | AgentCalled | The agent that has been called
Public property | BridgedChannel | Any bridge channel (V1.6 only)
Public property | CallerID | The caller id of the caller
Public property | CallerIDName | The caller id name of the caller
Public property | Channel | The agent channel
Public property | ChannelCalling | The channel id of the caller
Public property | Context | The dialplan Context
Public property | Extension | The dialplan extension
Public property | HoldTime | The time the call has been on hold
Public property | Member | The member id of the agent
Public property | MemberName | The name of the agent
Public property | Priority | The dialplan priority
Public property | Queue | The queue number
Public property | Reason | The reason of the call termination (agent / caller hangup)
Public property | Session | A session id (timestamp of login)
Public property | Site | The currently connected site name
Public property | TalkTime | The time that the caller has been conneted to the agent
Public property | TimeStamp | the timestamp of the message
Public property | Uniqueid | The usnique id for the call

See Also

AstAgentCall Class


AstAgentCall Constructor

[image]

AMIgo Controls documentation
AstAgentCall Constructor
AstAgentCall Class See Also Send Feedback
Initializes a new instance of the AstAgentCall class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgentCall()
Visual Basic
Public Sub New
Visual C++
public:
AstAgentCall()

See Also

AstAgentCall Class


AstAgentCall Properties

[image] [image]

AMIgo Controls documentation
AstAgentCall Properties
AstAgentCall Class See Also Send Feedback

The AstAgentCall type exposes the following members.

Properties

 | Name | Description
Public property | Agent | The agent number
Public property | AgentCalled | The agent that has been called
Public property | BridgedChannel | Any bridge channel (V1.6 only)
Public property | CallerID | The caller id of the caller
Public property | CallerIDName | The caller id name of the caller
Public property | Channel | The agent channel
Public property | ChannelCalling | The channel id of the caller
Public property | Context | The dialplan Context
Public property | Extension | The dialplan extension
Public property | HoldTime | The time the call has been on hold
Public property | Member | The member id of the agent
Public property | MemberName | The name of the agent
Public property | Priority | The dialplan priority
Public property | Queue | The queue number
Public property | Reason | The reason of the call termination (agent / caller hangup)
Public property | Session | A session id (timestamp of login)
Public property | Site | The currently connected site name
Public property | TalkTime | The time that the caller has been conneted to the agent
Public property | TimeStamp | the timestamp of the message
Public property | Uniqueid | The usnique id for the call

See Also

AstAgentCall Class


Agent Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Agent Property
AstAgentCall Class See Also Send Feedback
The agent number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Agent { get; set; }
Visual Basic
Public Property Agent As String
    Get
    Set
Visual C++
public:
property String^ Agent {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


AgentCalled Property

[image]

AMIgo Controls documentation
AstAgentCall..::..AgentCalled Property
AstAgentCall Class See Also Send Feedback
The agent that has been called

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AgentCalled { get; set; }
Visual Basic
Public Property AgentCalled As String
    Get
    Set
Visual C++
public:
property String^ AgentCalled {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


BridgedChannel Property

[image]

AMIgo Controls documentation
AstAgentCall..::..BridgedChannel Property
AstAgentCall Class See Also Send Feedback
Any bridge channel (V1.6 only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string BridgedChannel { get; set; }
Visual Basic
Public Property BridgedChannel As String
    Get
    Set
Visual C++
public:
property String^ BridgedChannel {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


CallerID Property

[image]

AMIgo Controls documentation
AstAgentCall..::..CallerID Property
AstAgentCall Class See Also Send Feedback
The caller id of the caller

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID { get; set; }
Visual Basic
Public Property CallerID As String
    Get
    Set
Visual C++
public:
property String^ CallerID {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


CallerIDName Property

[image]

AMIgo Controls documentation
AstAgentCall..::..CallerIDName Property
AstAgentCall Class See Also Send Feedback
The caller id name of the caller

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerIDName { get; set; }
Visual Basic
Public Property CallerIDName As String
    Get
    Set
Visual C++
public:
property String^ CallerIDName {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Channel Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Channel Property
AstAgentCall Class See Also Send Feedback
The agent channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel { get; set; }
Visual Basic
Public Property Channel As String
    Get
    Set
Visual C++
public:
property String^ Channel {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


ChannelCalling Property

[image]

AMIgo Controls documentation
AstAgentCall..::..ChannelCalling Property
AstAgentCall Class See Also Send Feedback
The channel id of the caller

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ChannelCalling { get; set; }
Visual Basic
Public Property ChannelCalling As String
    Get
    Set
Visual C++
public:
property String^ ChannelCalling {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Context Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Context Property
AstAgentCall Class See Also Send Feedback
The dialplan Context

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Context { get; set; }
Visual Basic
Public Property Context As String
    Get
    Set
Visual C++
public:
property String^ Context {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Extension Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Extension Property
AstAgentCall Class See Also Send Feedback
The dialplan extension

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set
Visual C++
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


HoldTime Property

[image]

AMIgo Controls documentation
AstAgentCall..::..HoldTime Property
AstAgentCall Class See Also Send Feedback
The time the call has been on hold

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string HoldTime { get; set; }
Visual Basic
Public Property HoldTime As String
    Get
    Set
Visual C++
public:
property String^ HoldTime {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Member Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Member Property
AstAgentCall Class See Also Send Feedback
The member id of the agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Member { get; set; }
Visual Basic
Public Property Member As String
    Get
    Set
Visual C++
public:
property String^ Member {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


MemberName Property

[image]

AMIgo Controls documentation
AstAgentCall..::..MemberName Property
AstAgentCall Class See Also Send Feedback
The name of the agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MemberName { get; set; }
Visual Basic
Public Property MemberName As String
    Get
    Set
Visual C++
public:
property String^ MemberName {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Priority Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Priority Property
AstAgentCall Class See Also Send Feedback
The dialplan priority

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Priority { get; set; }
Visual Basic
Public Property Priority As String
    Get
    Set
Visual C++
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Queue Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Queue Property
AstAgentCall Class See Also Send Feedback
The queue number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Queue { get; set; }
Visual Basic
Public Property Queue As String
    Get
    Set
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Reason Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Reason Property
AstAgentCall Class See Also Send Feedback
The reason of the call termination (agent / caller hangup)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Reason { get; set; }
Visual Basic
Public Property Reason As String
    Get
    Set
Visual C++
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Session Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Session Property
AstAgentCall Class See Also Send Feedback
A session id (timestamp of login)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Session { get; set; }
Visual Basic
Public Property Session As String
    Get
    Set
Visual C++
public:
property String^ Session {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Site Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Site Property
AstAgentCall Class See Also Send Feedback
The currently connected site name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Site { get; set; }
Visual Basic
Public Property Site As String
    Get
    Set
Visual C++
public:
property String^ Site {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


TalkTime Property

[image]

AMIgo Controls documentation
AstAgentCall..::..TalkTime Property
AstAgentCall Class See Also Send Feedback
The time that the caller has been conneted to the agent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TalkTime { get; set; }
Visual Basic
Public Property TalkTime As String
    Get
    Set
Visual C++
public:
property String^ TalkTime {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


TimeStamp Property

[image]

AMIgo Controls documentation
AstAgentCall..::..TimeStamp Property
AstAgentCall Class See Also Send Feedback
the timestamp of the message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As String
    Get
    Set
Visual C++
public:
property String^ TimeStamp {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


Uniqueid Property

[image]

AMIgo Controls documentation
AstAgentCall..::..Uniqueid Property
AstAgentCall Class See Also Send Feedback
The usnique id for the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Uniqueid { get; set; }
Visual Basic
Public Property Uniqueid As String
    Get
    Set
Visual C++
public:
property String^ Uniqueid {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentCall Class


AstAgentSession Class

[image]

AMIgo Controls documentation
AstAgentSession Class
Members See Also Send Feedback
This class is the base for the Agents sessions DB record.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstAgentSession
Visual Basic
Public Class AstAgentSession
Visual C++
public ref class AstAgentSession

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstAgentSession

See Also

AstAgentSession Members


AstAgentSession Members

[image] [image]

AMIgo Controls documentation
AstAgentSession Members
AstAgentSession Class Constructors Properties See Also Send Feedback

The AstAgentSession type exposes the following members.

Constructors

 | Name | Description
Public method | AstAgentSession | Initializes a new instance of the AstAgentSession class.

Properties

 | Name | Description
Public property | Agent | The agent no.
Public property | CallsTaken | The number of calls handled during this session
Public property | Duration | The duration of this session, in seconds
Public property | End | The end time of this session
Public property | Queue | The queue number
Public property | Reason | The reason of the session termination
Public property | Session | The session id (timestamp of login)
Public property | Site | The asterisk site name
Public property | Start | The start time of this session

See Also

AstAgentSession Class


AstAgentSession Constructor

[image]

AMIgo Controls documentation
AstAgentSession Constructor
AstAgentSession Class See Also Send Feedback
Initializes a new instance of the AstAgentSession class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstAgentSession()
Visual Basic
Public Sub New
Visual C++
public:
AstAgentSession()

See Also

AstAgentSession Class


AstAgentSession Properties

[image] [image]

AMIgo Controls documentation
AstAgentSession Properties
AstAgentSession Class See Also Send Feedback

The AstAgentSession type exposes the following members.

Properties

 | Name | Description
Public property | Agent | The agent no.
Public property | CallsTaken | The number of calls handled during this session
Public property | Duration | The duration of this session, in seconds
Public property | End | The end time of this session
Public property | Queue | The queue number
Public property | Reason | The reason of the session termination
Public property | Session | The session id (timestamp of login)
Public property | Site | The asterisk site name
Public property | Start | The start time of this session

See Also

AstAgentSession Class


Agent Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Agent Property
AstAgentSession Class See Also Send Feedback
The agent no.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Agent { get; set; }
Visual Basic
Public Property Agent As String
    Get
    Set
Visual C++
public:
property String^ Agent {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


CallsTaken Property

[image]

AMIgo Controls documentation
AstAgentSession..::..CallsTaken Property
AstAgentSession Class See Also Send Feedback
The number of calls handled during this session

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int CallsTaken { get; set; }
Visual Basic
Public Property CallsTaken As Integer
    Get
    Set
Visual C++
public:
property int CallsTaken {
    int get ();
    void set (int value);
}

See Also

AstAgentSession Class


Duration Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Duration Property
AstAgentSession Class See Also Send Feedback
The duration of this session, in seconds

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Duration { get; set; }
Visual Basic
Public Property Duration As Integer
    Get
    Set
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

See Also

AstAgentSession Class


End Property

[image]

AMIgo Controls documentation
AstAgentSession..::..End Property
AstAgentSession Class See Also Send Feedback
The end time of this session

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string End { get; set; }
Visual Basic
Public Property End As String
    Get
    Set
Visual C++
public:
property String^ End {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


Queue Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Queue Property
AstAgentSession Class See Also Send Feedback
The queue number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Queue { get; set; }
Visual Basic
Public Property Queue As String
    Get
    Set
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


Reason Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Reason Property
AstAgentSession Class See Also Send Feedback
The reason of the session termination

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Reason { get; set; }
Visual Basic
Public Property Reason As String
    Get
    Set
Visual C++
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


Session Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Session Property
AstAgentSession Class See Also Send Feedback
The session id (timestamp of login)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Session { get; set; }
Visual Basic
Public Property Session As String
    Get
    Set
Visual C++
public:
property String^ Session {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


Site Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Site Property
AstAgentSession Class See Also Send Feedback
The asterisk site name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Site { get; set; }
Visual Basic
Public Property Site As String
    Get
    Set
Visual C++
public:
property String^ Site {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


Start Property

[image]

AMIgo Controls documentation
AstAgentSession..::..Start Property
AstAgentSession Class See Also Send Feedback
The start time of this session

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Start { get; set; }
Visual Basic
Public Property Start As String
    Get
    Set
Visual C++
public:
property String^ Start {
    String^ get ();
    void set (String^ value);
}

See Also

AstAgentSession Class


AstCall Class

[image]

AMIgo Controls documentation
AstCall Class
Members See Also Send Feedback
This class is the base for the ongoing calls list

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstCall
Visual Basic
Public Class AstCall
Visual C++
public ref class AstCall

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstCall

See Also

AstCall Members


AstCall Members

[image] [image]

AMIgo Controls documentation
AstCall Members
AstCall Class Constructors Properties See Also Send Feedback

The AstCall type exposes the following members.

Constructors

 | Name | Description
Public method | AstCall | Initializes a new instance of the AstCall class.

Properties

 | Name | Description
Public property | CallerID1 | The source channel caller id num.
Public property | CallerID2 | The destination channel caller id num.
Public property | CallerName1 | The source channel caller id name
Public property | CallerName2 | The destination channel id name
Public property | CallType | The call type. See: CallType
Public property | Channel1 | The source channel
Public property | Channel1ObjType | The source channel object type
Public property | Channel1Type | The source channel type
Public property | Channel2 | The destination channel
Public property | Channel2ObjType | The destination channel object type
Public property | Channel2Type | The destination channel type
Public property | TimeStamp | The Unix timestamp of the call
Public property | UniqueID1 | The source channel unique id
Public property | UniqueID2 | The destination channel unique id

See Also

AstCall Class


AstCall Constructor

[image]

AMIgo Controls documentation
AstCall Constructor
AstCall Class See Also Send Feedback
Initializes a new instance of the AstCall class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstCall()
Visual Basic
Public Sub New
Visual C++
public:
AstCall()

See Also

AstCall Class


AstCall Properties

[image] [image]

AMIgo Controls documentation
AstCall Properties
AstCall Class See Also Send Feedback

The AstCall type exposes the following members.

Properties

 | Name | Description
Public property | CallerID1 | The source channel caller id num.
Public property | CallerID2 | The destination channel caller id num.
Public property | CallerName1 | The source channel caller id name
Public property | CallerName2 | The destination channel id name
Public property | CallType | The call type. See: CallType
Public property | Channel1 | The source channel
Public property | Channel1ObjType | The source channel object type
Public property | Channel1Type | The source channel type
Public property | Channel2 | The destination channel
Public property | Channel2ObjType | The destination channel object type
Public property | Channel2Type | The destination channel type
Public property | TimeStamp | The Unix timestamp of the call
Public property | UniqueID1 | The source channel unique id
Public property | UniqueID2 | The destination channel unique id

See Also

AstCall Class


CallerID1 Property

[image]

AMIgo Controls documentation
AstCall..::..CallerID1 Property
AstCall Class See Also Send Feedback
The source channel caller id num.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID1 { get; set; }
Visual Basic
Public Property CallerID1 As String
    Get
    Set
Visual C++
public:
property String^ CallerID1 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


CallerID2 Property

[image]

AMIgo Controls documentation
AstCall..::..CallerID2 Property
AstCall Class See Also Send Feedback
The destination channel caller id num.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID2 { get; set; }
Visual Basic
Public Property CallerID2 As String
    Get
    Set
Visual C++
public:
property String^ CallerID2 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


CallerName1 Property

[image]

AMIgo Controls documentation
AstCall..::..CallerName1 Property
AstCall Class See Also Send Feedback
The source channel caller id name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerName1 { get; set; }
Visual Basic
Public Property CallerName1 As String
    Get
    Set
Visual C++
public:
property String^ CallerName1 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


CallerName2 Property

[image]

AMIgo Controls documentation
AstCall..::..CallerName2 Property
AstCall Class See Also Send Feedback
The destination channel id name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerName2 { get; set; }
Visual Basic
Public Property CallerName2 As String
    Get
    Set
Visual C++
public:
property String^ CallerName2 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


CallType Property

[image]

AMIgo Controls documentation
AstCall..::..CallType Property
AstCall Class See Also Send Feedback
The call type. See: CallType

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CallType CallType { get; set; }
Visual Basic
Public Property CallType As CallType
    Get
    Set
Visual C++
public:
property CallType CallType {
    CallType get ();
    void set (CallType value);
}

See Also

AstCall Class


Channel1 Property

[image]

AMIgo Controls documentation
AstCall..::..Channel1 Property
AstCall Class See Also Send Feedback
The source channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel1 { get; set; }
Visual Basic
Public Property Channel1 As String
    Get
    Set
Visual C++
public:
property String^ Channel1 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


Channel1ObjType Property

[image]

AMIgo Controls documentation
AstCall..::..Channel1ObjType Property
AstCall Class See Also Send Feedback
The source channel object type

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel1ObjType { get; set; }
Visual Basic
Public Property Channel1ObjType As String
    Get
    Set
Visual C++
public:
property String^ Channel1ObjType {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


Channel1Type Property

[image]

AMIgo Controls documentation
AstCall..::..Channel1Type Property
AstCall Class See Also Send Feedback
The source channel type

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel1Type { get; set; }
Visual Basic
Public Property Channel1Type As String
    Get
    Set
Visual C++
public:
property String^ Channel1Type {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


Channel2 Property

[image]

AMIgo Controls documentation
AstCall..::..Channel2 Property
AstCall Class See Also Send Feedback
The destination channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel2 { get; set; }
Visual Basic
Public Property Channel2 As String
    Get
    Set
Visual C++
public:
property String^ Channel2 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


Channel2ObjType Property

[image]

AMIgo Controls documentation
AstCall..::..Channel2ObjType Property
AstCall Class See Also Send Feedback
The destination channel object type

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel2ObjType { get; set; }
Visual Basic
Public Property Channel2ObjType As String
    Get
    Set
Visual C++
public:
property String^ Channel2ObjType {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


Channel2Type Property

[image]

AMIgo Controls documentation
AstCall..::..Channel2Type Property
AstCall Class See Also Send Feedback
The destination channel type

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel2Type { get; set; }
Visual Basic
Public Property Channel2Type As String
    Get
    Set
Visual C++
public:
property String^ Channel2Type {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


TimeStamp Property

[image]

AMIgo Controls documentation
AstCall..::..TimeStamp Property
AstCall Class See Also Send Feedback
The Unix timestamp of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As String
    Get
    Set
Visual C++
public:
property String^ TimeStamp {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


UniqueID1 Property

[image]

AMIgo Controls documentation
AstCall..::..UniqueID1 Property
AstCall Class See Also Send Feedback
The source channel unique id

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UniqueID1 { get; set; }
Visual Basic
Public Property UniqueID1 As String
    Get
    Set
Visual C++
public:
property String^ UniqueID1 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


UniqueID2 Property

[image]

AMIgo Controls documentation
AstCall..::..UniqueID2 Property
AstCall Class See Also Send Feedback
The destination channel unique id

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UniqueID2 { get; set; }
Visual Basic
Public Property UniqueID2 As String
    Get
    Set
Visual C++
public:
property String^ UniqueID2 {
    String^ get ();
    void set (String^ value);
}

See Also

AstCall Class


AstChannel Class

[image]

AMIgo Controls documentation
AstChannel Class
Members See Also Send Feedback
This is the base class for the AstChannelsList SyncList, which contains the definition of sip / iax / zap objects present in the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstChannel
Visual Basic
Public Class AstChannel
Visual C++
public ref class AstChannel

Remarks

A list of active channels is maintained in _astChannelsList. This is a SyncList of AstChannel object that can be accessed in readonly through the AstChannelsList read-only property.

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstChannel

See Also

AstChannel Members


AstChannel Members

[image] [image]

AMIgo Controls documentation
AstChannel Members
AstChannel Class Constructors Properties See Also Send Feedback

The AstChannel type exposes the following members.

Constructors

 | Name | Description
Public method | AstChannel | Initializes a new instance of the AstChannel class.

Properties

 | Name | Description
Public property | AppData | The last dialplan application data.
Public property | Application | The last dialplan application.
Public property | BridgedChannel | Any bridged channel ID. (V1.6 and up only)
Public property | BridgedUniqueid | Any bridged channel UniqueID. (V1.6 and up only).
Public property | CallerID | The caller ID no. if available.
Public property | CallerName | The caller ID Name if available.
Public property | CallType | The call type. See: CallType
Public property | ChannelID | Gets or sets the channel ID.
Public property | Context | The current Context in the dialplan.
Public property | Extension | The current extension in the dialplan.
Public property | LinkToUniqueID | If linked to another channel, this contains it's ID.
Public property | MeetMeConf | If part of a conference, the ConfNo.
Public property | MeetMeUserNo | If part of a conference, the AstConference User no.
Public property | ParkingExtension | If channel parked, the extension
Public property | ParkingTimeout | A parking Timeout (in secs)
Public property | Priority | The current priority in the dialplan.
Public property | Seconds | The numbers of seconds the channel has been active
Public property | State | Gets or sets the channel State.
Public property | TimeStamp | The UNIX timestamp of the message
Public property | UniqueID | Gets or sets the channel UniqueID.

See Also

AstChannel Class


AstChannel Constructor

[image]

AMIgo Controls documentation
AstChannel Constructor
AstChannel Class See Also Send Feedback
Initializes a new instance of the AstChannel class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstChannel()
Visual Basic
Public Sub New
Visual C++
public:
AstChannel()

See Also

AstChannel Class


AstChannel Properties

[image] [image]

AMIgo Controls documentation
AstChannel Properties
AstChannel Class See Also Send Feedback

The AstChannel type exposes the following members.

Properties

 | Name | Description
Public property | AppData | The last dialplan application data.
Public property | Application | The last dialplan application.
Public property | BridgedChannel | Any bridged channel ID. (V1.6 and up only)
Public property | BridgedUniqueid | Any bridged channel UniqueID. (V1.6 and up only).
Public property | CallerID | The caller ID no. if available.
Public property | CallerName | The caller ID Name if available.
Public property | CallType | The call type. See: CallType
Public property | ChannelID | Gets or sets the channel ID.
Public property | Context | The current Context in the dialplan.
Public property | Extension | The current extension in the dialplan.
Public property | LinkToUniqueID | If linked to another channel, this contains it's ID.
Public property | MeetMeConf | If part of a conference, the ConfNo.
Public property | MeetMeUserNo | If part of a conference, the AstConference User no.
Public property | ParkingExtension | If channel parked, the extension
Public property | ParkingTimeout | A parking Timeout (in secs)
Public property | Priority | The current priority in the dialplan.
Public property | Seconds | The numbers of seconds the channel has been active
Public property | State | Gets or sets the channel State.
Public property | TimeStamp | The UNIX timestamp of the message
Public property | UniqueID | Gets or sets the channel UniqueID.

See Also

AstChannel Class


AppData Property

[image]

AMIgo Controls documentation
AstChannel..::..AppData Property
AstChannel Class See Also Send Feedback
The last dialplan application data.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AppData { get; set; }
Visual Basic
Public Property AppData As String
    Get
    Set
Visual C++
public:
property String^ AppData {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


Application Property

[image]

AMIgo Controls documentation
AstChannel..::..Application Property
AstChannel Class See Also Send Feedback
The last dialplan application.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Application { get; set; }
Visual Basic
Public Property Application As String
    Get
    Set
Visual C++
public:
property String^ Application {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


BridgedChannel Property

[image]

AMIgo Controls documentation
AstChannel..::..BridgedChannel Property
AstChannel Class See Also Send Feedback
Any bridged channel ID. (V1.6 and up only)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string BridgedChannel { get; set; }
Visual Basic
Public Property BridgedChannel As String
    Get
    Set
Visual C++
public:
property String^ BridgedChannel {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


BridgedUniqueid Property

[image]

AMIgo Controls documentation
AstChannel..::..BridgedUniqueid Property
AstChannel Class See Also Send Feedback
Any bridged channel UniqueID. (V1.6 and up only).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string BridgedUniqueid { get; set; }
Visual Basic
Public Property BridgedUniqueid As String
    Get
    Set
Visual C++
public:
property String^ BridgedUniqueid {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


CallerID Property

[image]

AMIgo Controls documentation
AstChannel..::..CallerID Property
AstChannel Class See Also Send Feedback
The caller ID no. if available.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID { get; set; }
Visual Basic
Public Property CallerID As String
    Get
    Set
Visual C++
public:
property String^ CallerID {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


CallerName Property

[image]

AMIgo Controls documentation
AstChannel..::..CallerName Property
AstChannel Class See Also Send Feedback
The caller ID Name if available.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerName { get; set; }
Visual Basic
Public Property CallerName As String
    Get
    Set
Visual C++
public:
property String^ CallerName {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


CallType Property

[image]

AMIgo Controls documentation
AstChannel..::..CallType Property
AstChannel Class See Also Send Feedback
The call type. See: CallType

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CallType CallType { get; set; }
Visual Basic
Public Property CallType As CallType
    Get
    Set
Visual C++
public:
property CallType CallType {
    CallType get ();
    void set (CallType value);
}

See Also

AstChannel Class


ChannelID Property

[image]

AMIgo Controls documentation
AstChannel..::..ChannelID Property
AstChannel Class See Also Send Feedback
Gets or sets the channel ID.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ChannelID { get; set; }
Visual Basic
Public Property ChannelID As String
    Get
    Set
Visual C++
public:
property String^ ChannelID {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


Context Property

[image]

AMIgo Controls documentation
AstChannel..::..Context Property
AstChannel Class See Also Send Feedback
The current Context in the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Context { get; set; }
Visual Basic
Public Property Context As String
    Get
    Set
Visual C++
public:
property String^ Context {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


Extension Property

[image]

AMIgo Controls documentation
AstChannel..::..Extension Property
AstChannel Class See Also Send Feedback
The current extension in the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set
Visual C++
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


LinkToUniqueID Property

[image]

AMIgo Controls documentation
AstChannel..::..LinkToUniqueID Property
AstChannel Class See Also Send Feedback
If linked to another channel, this contains it's ID.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LinkToUniqueID { get; set; }
Visual Basic
Public Property LinkToUniqueID As String
    Get
    Set
Visual C++
public:
property String^ LinkToUniqueID {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


MeetMeConf Property

[image]

AMIgo Controls documentation
AstChannel..::..MeetMeConf Property
AstChannel Class See Also Send Feedback
If part of a conference, the ConfNo.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MeetMeConf { get; set; }
Visual Basic
Public Property MeetMeConf As String
    Get
    Set
Visual C++
public:
property String^ MeetMeConf {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


MeetMeUserNo Property

[image]

AMIgo Controls documentation
AstChannel..::..MeetMeUserNo Property
AstChannel Class See Also Send Feedback
If part of a conference, the AstConference User no.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MeetMeUserNo { get; set; }
Visual Basic
Public Property MeetMeUserNo As String
    Get
    Set
Visual C++
public:
property String^ MeetMeUserNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


ParkingExtension Property

[image]

AMIgo Controls documentation
AstChannel..::..ParkingExtension Property
AstChannel Class See Also Send Feedback
If channel parked, the extension

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ParkingExtension { get; set; }
Visual Basic
Public Property ParkingExtension As String
    Get
    Set
Visual C++
public:
property String^ ParkingExtension {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


ParkingTimeout Property

[image]

AMIgo Controls documentation
AstChannel..::..ParkingTimeout Property
AstChannel Class See Also Send Feedback
A parking Timeout (in secs)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ParkingTimeout { get; set; }
Visual Basic
Public Property ParkingTimeout As String
    Get
    Set
Visual C++
public:
property String^ ParkingTimeout {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


Priority Property

[image]

AMIgo Controls documentation
AstChannel..::..Priority Property
AstChannel Class See Also Send Feedback
The current priority in the dialplan.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Priority { get; set; }
Visual Basic
Public Property Priority As String
    Get
    Set
Visual C++
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


Seconds Property

[image]

AMIgo Controls documentation
AstChannel..::..Seconds Property
AstChannel Class See Also Send Feedback
The numbers of seconds the channel has been active

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Seconds { get; set; }
Visual Basic
Public Property Seconds As String
    Get
    Set
Visual C++
public:
property String^ Seconds {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


State Property

[image]

AMIgo Controls documentation
AstChannel..::..State Property
AstChannel Class See Also Send Feedback
Gets or sets the channel State.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


TimeStamp Property

[image]

AMIgo Controls documentation
AstChannel..::..TimeStamp Property
AstChannel Class See Also Send Feedback
The UNIX timestamp of the message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As String
    Get
    Set
Visual C++
public:
property String^ TimeStamp {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


UniqueID Property

[image]

AMIgo Controls documentation
AstChannel..::..UniqueID Property
AstChannel Class See Also Send Feedback
Gets or sets the channel UniqueID.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UniqueID { get; set; }
Visual Basic
Public Property UniqueID As String
    Get
    Set
Visual C++
public:
property String^ UniqueID {
    String^ get ();
    void set (String^ value);
}

See Also

AstChannel Class


AstChannelEventArgs Class

[image]

AMIgo Controls documentation
AstChannelEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Channels events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstChannelEventArgs : EventArgs
Visual Basic
Public Class AstChannelEventArgs _
    Inherits EventArgs
Visual C++
public ref class AstChannelEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..AstChannelEventArgs

See Also

AstChannelEventArgs Members


AstChannelEventArgs Members

[image] [image]

AMIgo Controls documentation
AstChannelEventArgs Members
AstChannelEventArgs Class Constructors Fields See Also Send Feedback

The AstChannelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AstChannelEventArgs | Initializes a new instance of the AstChannelEventArgs class.

Fields

 | Name | Description
Public field | ast_channel | A AstChannel struc containing the info about the channel.
Public field | event_strs | The raw event strings

See Also

AstChannelEventArgs Class


AstChannelEventArgs Constructor

[image]

AMIgo Controls documentation
AstChannelEventArgs Constructor
AstChannelEventArgs Class See Also Send Feedback
Initializes a new instance of the AstChannelEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstChannelEventArgs(
    string[] EventStrs,
    AstChannel Channel
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Channel As AstChannel _
)
Visual C++
public:
AstChannelEventArgs(
    array<String^>^ EventStrs,
    AstChannel^ Channel
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Channel
Type: AMIgo..::..AstChannel
The channel.

See Also

AstChannelEventArgs Class


AstChannelEventArgs Fields

[image] [image]

AMIgo Controls documentation
AstChannelEventArgs Fields
AstChannelEventArgs Class See Also Send Feedback

The AstChannelEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | ast_channel | A AstChannel struc containing the info about the channel.
Public field | event_strs | The raw event strings

See Also

AstChannelEventArgs Class


ast_channel Field

[image]

AMIgo Controls documentation
AstChannelEventArgs..::..ast_channel Field
AstChannelEventArgs Class See Also Send Feedback
A AstChannel struc containing the info about the channel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstChannel ast_channel
Visual Basic
Public ast_channel As AstChannel
Visual C++
public:
AstChannel^ ast_channel

See Also

AstChannelEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
AstChannelEventArgs..::..event_strs Field
AstChannelEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

AstChannelEventArgs Class


AstChannelEventHandler Delegate

[image]

AMIgo Controls documentation
AstChannelEventHandler Delegate
See Also Send Feedback
delegate for the AstChannel Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void AstChannelEventHandler(
    Object sender,
    AstChannelEventArgs ev
)
Visual Basic
Public Delegate Sub AstChannelEventHandler ( _
    sender As Object, _
    ev As AstChannelEventArgs _
)
Visual C++
public delegate void AstChannelEventHandler(
    Object^ sender,
    AstChannelEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..AstChannelEventArgs
The AstChannelEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AstConference Class

[image]

AMIgo Controls documentation
AstConference Class
Members See Also Send Feedback
This class is the base for the conferences list. See: AstConferencesList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstConference
Visual Basic
Public Class AstConference
Visual C++
public ref class AstConference

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstConference

See Also

AstConference Members


AstConference Members

[image] [image]

AMIgo Controls documentation
AstConference Members
AstConference Class Constructors Properties See Also Send Feedback

The AstConference type exposes the following members.

Constructors

 | Name | Description
Public method | AstConference | Initializes a new instance of the AstConference class.

Properties

 | Name | Description
Public property | ConfID | A conference ID (Confo No - timestamp of start)
Public property | ConfName | A name for this conference
Public property | ConfNo | The conference no / dialplan's extension
Public property | Duration | The duration, in seconds of this conference
Public property | EndTime | The end date / time of the conference
Public property | MaxUsers | The maximum number of participants during this conference
Public property | NbUsers | The current number of users
Public property | SilenceTime | The total silence time
Public property | StartTime | The start date / time of the conference
Public property | TalkTime | The total talking time

See Also

AstConference Class


AstConference Constructor

[image]

AMIgo Controls documentation
AstConference Constructor
AstConference Class See Also Send Feedback
Initializes a new instance of the AstConference class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstConference()
Visual Basic
Public Sub New
Visual C++
public:
AstConference()

See Also

AstConference Class


AstConference Properties

[image] [image]

AMIgo Controls documentation
AstConference Properties
AstConference Class See Also Send Feedback

The AstConference type exposes the following members.

Properties

 | Name | Description
Public property | ConfID | A conference ID (Confo No - timestamp of start)
Public property | ConfName | A name for this conference
Public property | ConfNo | The conference no / dialplan's extension
Public property | Duration | The duration, in seconds of this conference
Public property | EndTime | The end date / time of the conference
Public property | MaxUsers | The maximum number of participants during this conference
Public property | NbUsers | The current number of users
Public property | SilenceTime | The total silence time
Public property | StartTime | The start date / time of the conference
Public property | TalkTime | The total talking time

See Also

AstConference Class


ConfID Property

[image]

AMIgo Controls documentation
AstConference..::..ConfID Property
AstConference Class See Also Send Feedback
A conference ID (Confo No - timestamp of start)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfID { get; set; }
Visual Basic
Public Property ConfID As String
    Get
    Set
Visual C++
public:
property String^ ConfID {
    String^ get ();
    void set (String^ value);
}

See Also

AstConference Class


ConfName Property

[image]

AMIgo Controls documentation
AstConference..::..ConfName Property
AstConference Class See Also Send Feedback
A name for this conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfName { get; set; }
Visual Basic
Public Property ConfName As String
    Get
    Set
Visual C++
public:
property String^ ConfName {
    String^ get ();
    void set (String^ value);
}

See Also

AstConference Class


ConfNo Property

[image]

AMIgo Controls documentation
AstConference..::..ConfNo Property
AstConference Class See Also Send Feedback
The conference no / dialplan's extension

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfNo { get; set; }
Visual Basic
Public Property ConfNo As String
    Get
    Set
Visual C++
public:
property String^ ConfNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstConference Class


Duration Property

[image]

AMIgo Controls documentation
AstConference..::..Duration Property
AstConference Class See Also Send Feedback
The duration, in seconds of this conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Duration { get; set; }
Visual Basic
Public Property Duration As Integer
    Get
    Set
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

See Also

AstConference Class


EndTime Property

[image]

AMIgo Controls documentation
AstConference..::..EndTime Property
AstConference Class See Also Send Feedback
The end date / time of the conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

AstConference Class


MaxUsers Property

[image]

AMIgo Controls documentation
AstConference..::..MaxUsers Property
AstConference Class See Also Send Feedback
The maximum number of participants during this conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int MaxUsers { get; set; }
Visual Basic
Public Property MaxUsers As Integer
    Get
    Set
Visual C++
public:
property int MaxUsers {
    int get ();
    void set (int value);
}

See Also

AstConference Class


NbUsers Property

[image]

AMIgo Controls documentation
AstConference..::..NbUsers Property
AstConference Class See Also Send Feedback
The current number of users

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int NbUsers { get; set; }
Visual Basic
Public Property NbUsers As Integer
    Get
    Set
Visual C++
public:
property int NbUsers {
    int get ();
    void set (int value);
}

See Also

AstConference Class


SilenceTime Property

[image]

AMIgo Controls documentation
AstConference..::..SilenceTime Property
AstConference Class See Also Send Feedback
The total silence time

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SilenceTime { get; set; }
Visual Basic
Public Property SilenceTime As Integer
    Get
    Set
Visual C++
public:
property int SilenceTime {
    int get ();
    void set (int value);
}

See Also

AstConference Class


StartTime Property

[image]

AMIgo Controls documentation
AstConference..::..StartTime Property
AstConference Class See Also Send Feedback
The start date / time of the conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

AstConference Class


TalkTime Property

[image]

AMIgo Controls documentation
AstConference..::..TalkTime Property
AstConference Class See Also Send Feedback
The total talking time

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int TalkTime { get; set; }
Visual Basic
Public Property TalkTime As Integer
    Get
    Set
Visual C++
public:
property int TalkTime {
    int get ();
    void set (int value);
}

See Also

AstConference Class


AstConferenceUser Class

[image]

AMIgo Controls documentation
AstConferenceUser Class
Members See Also Send Feedback
This class is the base for the conferences users records. See: AstConferenceUsersList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstConferenceUser
Visual Basic
Public Class AstConferenceUser
Visual C++
public ref class AstConferenceUser

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstConferenceUser

See Also

AstConferenceUser Members


AstConferenceUser Members

[image] [image]

AMIgo Controls documentation
AstConferenceUser Members
AstConferenceUser Class Constructors Properties See Also Send Feedback

The AstConferenceUser type exposes the following members.

Constructors

 | Name | Description
Public method | AstConferenceUser | Initializes a new instance of the AstConferenceUser class.

Properties

 | Name | Description
Public property | Admin | Indicate an admin conf. user.
Public property | CallerID | The caller id of the user
Public property | CallerName | The caller id name of the user
Public property | ChannelID | The channel id of this conf user
Public property | ConfID | The Id of the conference
Public property | ConfNo | The conference number
Public property | Duration | The duration of participation of this user to the conference
Public property | EndTime | The dtae / time the user exited the conference.
Public property | MarkedUser | Indicate a 'marked' conf user.
Public property | MeetMeTimeStamp | Used internally to track talk / silence time
Public property | MutedStatus | The muted status 0 = false 1 = muted
Public property | Role | The role of the user V1.6
Public property | SilenceTime | The time spent in silence
Public property | StartTime | The dtae / time the user entered the conference.
Public property | TalkStatus | 'on' if the user is currently talking, off after talks ends.
Public property | TalkTime | The time spent talking
Public property | UniqueId | the uniqueid of the user channel
Public property | UserNo | The user number in the conference

See Also

AstConferenceUser Class


AstConferenceUser Constructor

[image]

AMIgo Controls documentation
AstConferenceUser Constructor
AstConferenceUser Class See Also Send Feedback
Initializes a new instance of the AstConferenceUser class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstConferenceUser()
Visual Basic
Public Sub New
Visual C++
public:
AstConferenceUser()

See Also

AstConferenceUser Class


AstConferenceUser Properties

[image] [image]

AMIgo Controls documentation
AstConferenceUser Properties
AstConferenceUser Class See Also Send Feedback

The AstConferenceUser type exposes the following members.

Properties

 | Name | Description
Public property | Admin | Indicate an admin conf. user.
Public property | CallerID | The caller id of the user
Public property | CallerName | The caller id name of the user
Public property | ChannelID | The channel id of this conf user
Public property | ConfID | The Id of the conference
Public property | ConfNo | The conference number
Public property | Duration | The duration of participation of this user to the conference
Public property | EndTime | The dtae / time the user exited the conference.
Public property | MarkedUser | Indicate a 'marked' conf user.
Public property | MeetMeTimeStamp | Used internally to track talk / silence time
Public property | MutedStatus | The muted status 0 = false 1 = muted
Public property | Role | The role of the user V1.6
Public property | SilenceTime | The time spent in silence
Public property | StartTime | The dtae / time the user entered the conference.
Public property | TalkStatus | 'on' if the user is currently talking, off after talks ends.
Public property | TalkTime | The time spent talking
Public property | UniqueId | the uniqueid of the user channel
Public property | UserNo | The user number in the conference

See Also

AstConferenceUser Class


Admin Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..Admin Property
AstConferenceUser Class See Also Send Feedback
Indicate an admin conf. user.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Admin { get; set; }
Visual Basic
Public Property Admin As String
    Get
    Set
Visual C++
public:
property String^ Admin {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


CallerID Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..CallerID Property
AstConferenceUser Class See Also Send Feedback
The caller id of the user

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID { get; set; }
Visual Basic
Public Property CallerID As String
    Get
    Set
Visual C++
public:
property String^ CallerID {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


CallerName Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..CallerName Property
AstConferenceUser Class See Also Send Feedback
The caller id name of the user

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerName { get; set; }
Visual Basic
Public Property CallerName As String
    Get
    Set
Visual C++
public:
property String^ CallerName {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


ChannelID Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..ChannelID Property
AstConferenceUser Class See Also Send Feedback
The channel id of this conf user

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ChannelID { get; set; }
Visual Basic
Public Property ChannelID As String
    Get
    Set
Visual C++
public:
property String^ ChannelID {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


ConfID Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..ConfID Property
AstConferenceUser Class See Also Send Feedback
The Id of the conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfID { get; set; }
Visual Basic
Public Property ConfID As String
    Get
    Set
Visual C++
public:
property String^ ConfID {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


ConfNo Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..ConfNo Property
AstConferenceUser Class See Also Send Feedback
The conference number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfNo { get; set; }
Visual Basic
Public Property ConfNo As String
    Get
    Set
Visual C++
public:
property String^ ConfNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


Duration Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..Duration Property
AstConferenceUser Class See Also Send Feedback
The duration of participation of this user to the conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Duration { get; set; }
Visual Basic
Public Property Duration As Integer
    Get
    Set
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

See Also

AstConferenceUser Class


EndTime Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..EndTime Property
AstConferenceUser Class See Also Send Feedback
The dtae / time the user exited the conference.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

AstConferenceUser Class


MarkedUser Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..MarkedUser Property
AstConferenceUser Class See Also Send Feedback
Indicate a 'marked' conf user.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MarkedUser { get; set; }
Visual Basic
Public Property MarkedUser As String
    Get
    Set
Visual C++
public:
property String^ MarkedUser {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


MeetMeTimeStamp Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..MeetMeTimeStamp Property
AstConferenceUser Class See Also Send Feedback
Used internally to track talk / silence time

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DateTime MeetMeTimeStamp { get; set; }
Visual Basic
Public Property MeetMeTimeStamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime MeetMeTimeStamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

AstConferenceUser Class


MutedStatus Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..MutedStatus Property
AstConferenceUser Class See Also Send Feedback
The muted status 0 = false 1 = muted

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MutedStatus { get; set; }
Visual Basic
Public Property MutedStatus As String
    Get
    Set
Visual C++
public:
property String^ MutedStatus {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


Role Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..Role Property
AstConferenceUser Class See Also Send Feedback
The role of the user V1.6

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Role { get; set; }
Visual Basic
Public Property Role As String
    Get
    Set
Visual C++
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


SilenceTime Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..SilenceTime Property
AstConferenceUser Class See Also Send Feedback
The time spent in silence

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int SilenceTime { get; set; }
Visual Basic
Public Property SilenceTime As Integer
    Get
    Set
Visual C++
public:
property int SilenceTime {
    int get ();
    void set (int value);
}

See Also

AstConferenceUser Class


StartTime Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..StartTime Property
AstConferenceUser Class See Also Send Feedback
The dtae / time the user entered the conference.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

AstConferenceUser Class


TalkStatus Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..TalkStatus Property
AstConferenceUser Class See Also Send Feedback
'on' if the user is currently talking, off after talks ends.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TalkStatus { get; set; }
Visual Basic
Public Property TalkStatus As String
    Get
    Set
Visual C++
public:
property String^ TalkStatus {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


TalkTime Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..TalkTime Property
AstConferenceUser Class See Also Send Feedback
The time spent talking

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int TalkTime { get; set; }
Visual Basic
Public Property TalkTime As Integer
    Get
    Set
Visual C++
public:
property int TalkTime {
    int get ();
    void set (int value);
}

See Also

AstConferenceUser Class


UniqueId Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..UniqueId Property
AstConferenceUser Class See Also Send Feedback
the uniqueid of the user channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


UserNo Property

[image]

AMIgo Controls documentation
AstConferenceUser..::..UserNo Property
AstConferenceUser Class See Also Send Feedback
The user number in the conference

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserNo { get; set; }
Visual Basic
Public Property UserNo As String
    Get
    Set
Visual C++
public:
property String^ UserNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstConferenceUser Class


AstQueue Class

[image]

AMIgo Controls documentation
AstQueue Class
Members See Also Send Feedback
This class is the base for the Queues list. See AstQueuesList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstQueue
Visual Basic
Public Class AstQueue
Visual C++
public ref class AstQueue

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstQueue

See Also

AstQueue Members


AstQueue Members

[image] [image]

AMIgo Controls documentation
AstQueue Members
AstQueue Class Constructors Properties See Also Send Feedback

The AstQueue type exposes the following members.

Constructors

 | Name | Description
Public method | AstQueue | Initializes a new instance of the AstQueue class.

Properties

 | Name | Description
Public property | Abandoned | The number of calls that have been abandoned by the callers
Public property | Calls | The number of calls currently waiting in the queue
Public property | Completed | The number of completed calls
Public property | Holdtime | The average hold time for this queue
Public property | Max | The maximum of entries. 0 = unlimited
Public property | Queue | The Queue number (extension in the dialplan)
Public property | QueueName | The queue name
Public property | ServiceLevel | The level of service in seconds.
Public property | ServicelevelPerf | The percentage of calls complying to the set Service. Level.
Public property | Weight | The weight of this queue

See Also

AstQueue Class


AstQueue Constructor

[image]

AMIgo Controls documentation
AstQueue Constructor
AstQueue Class See Also Send Feedback
Initializes a new instance of the AstQueue class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueue()
Visual Basic
Public Sub New
Visual C++
public:
AstQueue()

See Also

AstQueue Class


AstQueue Properties

[image] [image]

AMIgo Controls documentation
AstQueue Properties
AstQueue Class See Also Send Feedback

The AstQueue type exposes the following members.

Properties

 | Name | Description
Public property | Abandoned | The number of calls that have been abandoned by the callers
Public property | Calls | The number of calls currently waiting in the queue
Public property | Completed | The number of completed calls
Public property | Holdtime | The average hold time for this queue
Public property | Max | The maximum of entries. 0 = unlimited
Public property | Queue | The Queue number (extension in the dialplan)
Public property | QueueName | The queue name
Public property | ServiceLevel | The level of service in seconds.
Public property | ServicelevelPerf | The percentage of calls complying to the set Service. Level.
Public property | Weight | The weight of this queue

See Also

AstQueue Class


Abandoned Property

[image]

AMIgo Controls documentation
AstQueue..::..Abandoned Property
AstQueue Class See Also Send Feedback
The number of calls that have been abandoned by the callers

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Abandoned { get; set; }
Visual Basic
Public Property Abandoned As String
    Get
    Set
Visual C++
public:
property String^ Abandoned {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Calls Property

[image]

AMIgo Controls documentation
AstQueue..::..Calls Property
AstQueue Class See Also Send Feedback
The number of calls currently waiting in the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Calls { get; set; }
Visual Basic
Public Property Calls As String
    Get
    Set
Visual C++
public:
property String^ Calls {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Completed Property

[image]

AMIgo Controls documentation
AstQueue..::..Completed Property
AstQueue Class See Also Send Feedback
The number of completed calls

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Completed { get; set; }
Visual Basic
Public Property Completed As String
    Get
    Set
Visual C++
public:
property String^ Completed {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Holdtime Property

[image]

AMIgo Controls documentation
AstQueue..::..Holdtime Property
AstQueue Class See Also Send Feedback
The average hold time for this queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Holdtime { get; set; }
Visual Basic
Public Property Holdtime As String
    Get
    Set
Visual C++
public:
property String^ Holdtime {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Max Property

[image]

AMIgo Controls documentation
AstQueue..::..Max Property
AstQueue Class See Also Send Feedback
The maximum of entries. 0 = unlimited

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Max { get; set; }
Visual Basic
Public Property Max As String
    Get
    Set
Visual C++
public:
property String^ Max {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Queue Property

[image]

AMIgo Controls documentation
AstQueue..::..Queue Property
AstQueue Class See Also Send Feedback
The Queue number (extension in the dialplan)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Queue { get; set; }
Visual Basic
Public Property Queue As String
    Get
    Set
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


QueueName Property

[image]

AMIgo Controls documentation
AstQueue..::..QueueName Property
AstQueue Class See Also Send Feedback
The queue name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string QueueName { get; set; }
Visual Basic
Public Property QueueName As String
    Get
    Set
Visual C++
public:
property String^ QueueName {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


ServiceLevel Property

[image]

AMIgo Controls documentation
AstQueue..::..ServiceLevel Property
AstQueue Class See Also Send Feedback
The level of service in seconds.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ServiceLevel { get; set; }
Visual Basic
Public Property ServiceLevel As String
    Get
    Set
Visual C++
public:
property String^ ServiceLevel {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


ServicelevelPerf Property

[image]

AMIgo Controls documentation
AstQueue..::..ServicelevelPerf Property
AstQueue Class See Also Send Feedback
The percentage of calls complying to the set Service. Level.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ServicelevelPerf { get; set; }
Visual Basic
Public Property ServicelevelPerf As String
    Get
    Set
Visual C++
public:
property String^ ServicelevelPerf {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


Weight Property

[image]

AMIgo Controls documentation
AstQueue..::..Weight Property
AstQueue Class See Also Send Feedback
The weight of this queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Weight { get; set; }
Visual Basic
Public Property Weight As String
    Get
    Set
Visual C++
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueue Class


AstQueueEntry Class

[image]

AMIgo Controls documentation
AstQueueEntry Class
Members See Also Send Feedback
This class is the base for the Queues entries list (users waiting in queues) AstQueuesEntriesList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstQueueEntry
Visual Basic
Public Class AstQueueEntry
Visual C++
public ref class AstQueueEntry

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstQueueEntry

See Also

AstQueueEntry Members


AstQueueEntry Members

[image] [image]

AMIgo Controls documentation
AstQueueEntry Members
AstQueueEntry Class Constructors Properties See Also Send Feedback

The AstQueueEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AstQueueEntry | Initializes a new instance of the AstQueueEntry class.

Properties

 | Name | Description
Public property | CallerID | The caller id for this queue entry
Public property | CallerIDName | The caller id Name this queue entry
Public property | Channel | The channel of this queue entry
Public property | Count | The number of calls currently waiting in the queue
Public property | Position | The position of this entry in the queue
Public property | Queue | The Queue number (extension in the dialplan)
Public property | Uniqueid | The unique id of this active channel
Public property | Wait | The number of seconds waiting in the queue

See Also

AstQueueEntry Class


AstQueueEntry Constructor

[image]

AMIgo Controls documentation
AstQueueEntry Constructor
AstQueueEntry Class See Also Send Feedback
Initializes a new instance of the AstQueueEntry class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueueEntry()
Visual Basic
Public Sub New
Visual C++
public:
AstQueueEntry()

See Also

AstQueueEntry Class


AstQueueEntry Properties

[image] [image]

AMIgo Controls documentation
AstQueueEntry Properties
AstQueueEntry Class See Also Send Feedback

The AstQueueEntry type exposes the following members.

Properties

 | Name | Description
Public property | CallerID | The caller id for this queue entry
Public property | CallerIDName | The caller id Name this queue entry
Public property | Channel | The channel of this queue entry
Public property | Count | The number of calls currently waiting in the queue
Public property | Position | The position of this entry in the queue
Public property | Queue | The Queue number (extension in the dialplan)
Public property | Uniqueid | The unique id of this active channel
Public property | Wait | The number of seconds waiting in the queue

See Also

AstQueueEntry Class


CallerID Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..CallerID Property
AstQueueEntry Class See Also Send Feedback
The caller id for this queue entry

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID { get; set; }
Visual Basic
Public Property CallerID As String
    Get
    Set
Visual C++
public:
property String^ CallerID {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


CallerIDName Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..CallerIDName Property
AstQueueEntry Class See Also Send Feedback
The caller id Name this queue entry

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerIDName { get; set; }
Visual Basic
Public Property CallerIDName As String
    Get
    Set
Visual C++
public:
property String^ CallerIDName {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Channel Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Channel Property
AstQueueEntry Class See Also Send Feedback
The channel of this queue entry

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel { get; set; }
Visual Basic
Public Property Channel As String
    Get
    Set
Visual C++
public:
property String^ Channel {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Count Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Count Property
AstQueueEntry Class See Also Send Feedback
The number of calls currently waiting in the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Count { get; set; }
Visual Basic
Public Property Count As String
    Get
    Set
Visual C++
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Position Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Position Property
AstQueueEntry Class See Also Send Feedback
The position of this entry in the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Position { get; set; }
Visual Basic
Public Property Position As String
    Get
    Set
Visual C++
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Queue Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Queue Property
AstQueueEntry Class See Also Send Feedback
The Queue number (extension in the dialplan)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Queue { get; set; }
Visual Basic
Public Property Queue As String
    Get
    Set
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Uniqueid Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Uniqueid Property
AstQueueEntry Class See Also Send Feedback
The unique id of this active channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Uniqueid { get; set; }
Visual Basic
Public Property Uniqueid As String
    Get
    Set
Visual C++
public:
property String^ Uniqueid {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


Wait Property

[image]

AMIgo Controls documentation
AstQueueEntry..::..Wait Property
AstQueueEntry Class See Also Send Feedback
The number of seconds waiting in the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Wait { get; set; }
Visual Basic
Public Property Wait As String
    Get
    Set
Visual C++
public:
property String^ Wait {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueEntry Class


AstQueueMember Class

[image]

AMIgo Controls documentation
AstQueueMember Class
Members See Also Send Feedback
This class is the base for the Queues members list (extension defined to handle the calls in the queues) See: AstQueuesMembersList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstQueueMember
Visual Basic
Public Class AstQueueMember
Visual C++
public ref class AstQueueMember

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstQueueMember

See Also

AstQueueMember Members


AstQueueMember Members

[image] [image]

AMIgo Controls documentation
AstQueueMember Members
AstQueueMember Class Constructors Properties See Also Send Feedback

The AstQueueMember type exposes the following members.

Constructors

 | Name | Description
Public method | AstQueueMember | Initializes a new instance of the AstQueueMember class.

Properties

 | Name | Description
Public property | AgentType | The type of the agent (Local / Channel).
Public property | CallsTaken | The numbers of calls taken in this session.
Public property | LastCall | The date time of the last call taken
Public property | Location | The current location to reach this member(extension / ( or phone number for local agents)
Public property | MemberName | The Name of this queue member
Public property | Membership | The type of membership: static / dynamic
Public property | Paused | The paused status 0 = not paused, 1 = paused
Public property | Penalty | Any penalty for this member
Public property | QMStatus | The current status of the queue member
Public property | Queue | The Queue number (extension in the dialplan)
Public property | Status | The current status of the queue member

See Also

AstQueueMember Class


AstQueueMember Constructor

[image]

AMIgo Controls documentation
AstQueueMember Constructor
AstQueueMember Class See Also Send Feedback
Initializes a new instance of the AstQueueMember class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueueMember()
Visual Basic
Public Sub New
Visual C++
public:
AstQueueMember()

See Also

AstQueueMember Class


AstQueueMember Properties

[image] [image]

AMIgo Controls documentation
AstQueueMember Properties
AstQueueMember Class See Also Send Feedback

The AstQueueMember type exposes the following members.

Properties

 | Name | Description
Public property | AgentType | The type of the agent (Local / Channel).
Public property | CallsTaken | The numbers of calls taken in this session.
Public property | LastCall | The date time of the last call taken
Public property | Location | The current location to reach this member(extension / ( or phone number for local agents)
Public property | MemberName | The Name of this queue member
Public property | Membership | The type of membership: static / dynamic
Public property | Paused | The paused status 0 = not paused, 1 = paused
Public property | Penalty | Any penalty for this member
Public property | QMStatus | The current status of the queue member
Public property | Queue | The Queue number (extension in the dialplan)
Public property | Status | The current status of the queue member

See Also

AstQueueMember Class


AgentType Property

[image]

AMIgo Controls documentation
AstQueueMember..::..AgentType Property
AstQueueMember Class See Also Send Feedback
The type of the agent (Local / Channel).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AgentTypes AgentType { get; set; }
Visual Basic
Public Property AgentType As AgentTypes
    Get
    Set
Visual C++
public:
property AgentTypes AgentType {
    AgentTypes get ();
    void set (AgentTypes value);
}

See Also

AstQueueMember Class


CallsTaken Property

[image]

AMIgo Controls documentation
AstQueueMember..::..CallsTaken Property
AstQueueMember Class See Also Send Feedback
The numbers of calls taken in this session.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallsTaken { get; set; }
Visual Basic
Public Property CallsTaken As String
    Get
    Set
Visual C++
public:
property String^ CallsTaken {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


LastCall Property

[image]

AMIgo Controls documentation
AstQueueMember..::..LastCall Property
AstQueueMember Class See Also Send Feedback
The date time of the last call taken

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LastCall { get; set; }
Visual Basic
Public Property LastCall As String
    Get
    Set
Visual C++
public:
property String^ LastCall {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


Location Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Location Property
AstQueueMember Class See Also Send Feedback
The current location to reach this member(extension / ( or phone number for local agents)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Location { get; set; }
Visual Basic
Public Property Location As String
    Get
    Set
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


MemberName Property

[image]

AMIgo Controls documentation
AstQueueMember..::..MemberName Property
AstQueueMember Class See Also Send Feedback
The Name of this queue member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MemberName { get; set; }
Visual Basic
Public Property MemberName As String
    Get
    Set
Visual C++
public:
property String^ MemberName {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


Membership Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Membership Property
AstQueueMember Class See Also Send Feedback
The type of membership: static / dynamic

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Membership { get; set; }
Visual Basic
Public Property Membership As String
    Get
    Set
Visual C++
public:
property String^ Membership {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


Paused Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Paused Property
AstQueueMember Class See Also Send Feedback
The paused status 0 = not paused, 1 = paused

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Paused { get; set; }
Visual Basic
Public Property Paused As String
    Get
    Set
Visual C++
public:
property String^ Paused {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


Penalty Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Penalty Property
AstQueueMember Class See Also Send Feedback
Any penalty for this member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Penalty { get; set; }
Visual Basic
Public Property Penalty As String
    Get
    Set
Visual C++
public:
property String^ Penalty {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


QMStatus Property

[image]

AMIgo Controls documentation
AstQueueMember..::..QMStatus Property
AstQueueMember Class See Also Send Feedback
The current status of the queue member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public QueueMemberStatus QMStatus { get; set; }
Visual Basic
Public Property QMStatus As QueueMemberStatus
    Get
    Set
Visual C++
public:
property QueueMemberStatus QMStatus {
    QueueMemberStatus get ();
    void set (QueueMemberStatus value);
}

See Also

AstQueueMember Class


Queue Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Queue Property
AstQueueMember Class See Also Send Feedback
The Queue number (extension in the dialplan)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Queue { get; set; }
Visual Basic
Public Property Queue As String
    Get
    Set
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


Status Property

[image]

AMIgo Controls documentation
AstQueueMember..::..Status Property
AstQueueMember Class See Also Send Feedback
The current status of the queue member

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

AstQueueMember Class


AstSite Class

[image]

AMIgo Controls documentation
AstSite Class
Members See Also Send Feedback
This class hold the sites location and manager login information for a list of asterisk installations.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstSite
Visual Basic
Public Class AstSite
Visual C++
public ref class AstSite

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstSite

See Also

AstSite Members


AstSite Members

[image] [image]

AMIgo Controls documentation
AstSite Members
AstSite Class Constructors Properties See Also Send Feedback

The AstSite type exposes the following members.

Constructors

 | Name | Description
Public method | AstSite()()()() | Initializes a new instance of the AstSite class.
Public method | AstSite(array<Object>[]()[][]) | Initializes a new instance of the AstSite class.
Public method | AstSite(String, String, String, String, String, Boolean) | Initializes a new instance of the AstSite class.

Properties

 | Name | Description
Public property | Host | Gets or sets the target asterisk system IP Address or Domain Name.
Public property | IsDefault | Gets or sets this site as default (connect on startup)
Public property | Password | Gets or sets the manager account Password (or Secret)
Public property | Port | Gets or sets the target asterisk system Port. Usually 5038.
Public property | RecID | Gets or sets the rec ID. Normally assigned by the DataBase
Public property | SiteName | Gets or sets the Site Name.
Public property | UserName | Gets or sets the manager account UserName

See Also

AstSite Class


AstSite Constructor

[image] [image]

AMIgo Controls documentation
AstSite Constructor
AstSite Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AstSite()()()() | Initializes a new instance of the AstSite class.
Public method | AstSite(array<Object>[]()[][]) | Initializes a new instance of the AstSite class.
Public method | AstSite(String, String, String, String, String, Boolean) | Initializes a new instance of the AstSite class.

See Also

AstSite Class
AstSite Members


AstSite Constructor

[image]

AMIgo Controls documentation
AstSite Constructor
AstSite Class See Also Send Feedback
Initializes a new instance of the AstSite class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstSite()
Visual Basic
Public Sub New
Visual C++
public:
AstSite()

See Also

AstSite Class
AstSite Overload


AstSite Constructor (Object[])

[image]

AMIgo Controls documentation
AstSite Constructor (array<Object>[]()[][])
AstSite Class See Also Send Feedback
Initializes a new instance of the AstSite class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstSite(
    Object[] ItemArray
)
Visual Basic
Public Sub New ( _
    ItemArray As Object() _
)
Visual C++
public:
AstSite(
    array<Object^>^ ItemArray
)

Parameters

ItemArray
Type: array< System..::..Object >[]()[][]
The item array.

See Also

AstSite Class
AstSite Overload


AstSite Constructor (String, String, String, String, String, Boolean)

[image]

AMIgo Controls documentation
AstSite Constructor (String, String, String, String, String, Boolean)
AstSite Class See Also Send Feedback
Initializes a new instance of the AstSite class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstSite(
    string SiteName,
    string Host,
    string Port,
    string UserName,
    string Password,
    bool IsDefault
)
Visual Basic
Public Sub New ( _
    SiteName As String, _
    Host As String, _
    Port As String, _
    UserName As String, _
    Password As String, _
    IsDefault As Boolean _
)
Visual C++
public:
AstSite(
    String^ SiteName,
    String^ Host,
    String^ Port,
    String^ UserName,
    String^ Password,
    bool IsDefault
)

Parameters

SiteName
Type: System..::..String
Name of the site.
Host
Type: System..::..String
The Host.
Port
Type: System..::..String
The port.
UserName
Type: System..::..String
Name of the user.
Password
Type: System..::..String
The password.
IsDefault
Type: System..::..Boolean
ture if this is default site, false otherwise

See Also

AstSite Class
AstSite Overload


AstSite Properties

[image] [image]

AMIgo Controls documentation
AstSite Properties
AstSite Class See Also Send Feedback

The AstSite type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets or sets the target asterisk system IP Address or Domain Name.
Public property | IsDefault | Gets or sets this site as default (connect on startup)
Public property | Password | Gets or sets the manager account Password (or Secret)
Public property | Port | Gets or sets the target asterisk system Port. Usually 5038.
Public property | RecID | Gets or sets the rec ID. Normally assigned by the DataBase
Public property | SiteName | Gets or sets the Site Name.
Public property | UserName | Gets or sets the manager account UserName

See Also

AstSite Class


Host Property

[image]

AMIgo Controls documentation
AstSite..::..Host Property
AstSite Class See Also Send Feedback
Gets or sets the target asterisk system IP Address or Domain Name.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

See Also

AstSite Class


IsDefault Property

[image]

AMIgo Controls documentation
AstSite..::..IsDefault Property
AstSite Class See Also Send Feedback
Gets or sets this site as default (connect on startup)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

AstSite Class


Password Property

[image]

AMIgo Controls documentation
AstSite..::..Password Property
AstSite Class See Also Send Feedback
Gets or sets the manager account Password (or Secret)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

AstSite Class


Port Property

[image]

AMIgo Controls documentation
AstSite..::..Port Property
AstSite Class See Also Send Feedback
Gets or sets the target asterisk system Port. Usually 5038.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Port { get; set; }
Visual Basic
Public Property Port As String
    Get
    Set
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

See Also

AstSite Class


RecID Property

[image]

AMIgo Controls documentation
AstSite..::..RecID Property
AstSite Class See Also Send Feedback
Gets or sets the rec ID. Normally assigned by the DataBase

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public long RecID { get; set; }
Visual Basic
Public Property RecID As Long
    Get
    Set
Visual C++
public:
property long long RecID {
    long long get ();
    void set (long long value);
}

See Also

AstSite Class


SiteName Property

[image]

AMIgo Controls documentation
AstSite..::..SiteName Property
AstSite Class See Also Send Feedback
Gets or sets the Site Name.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string SiteName { get; set; }
Visual Basic
Public Property SiteName As String
    Get
    Set
Visual C++
public:
property String^ SiteName {
    String^ get ();
    void set (String^ value);
}

See Also

AstSite Class


UserName Property

[image]

AMIgo Controls documentation
AstSite..::..UserName Property
AstSite Class See Also Send Feedback
Gets or sets the manager account UserName

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

AstSite Class


AstUsersObject Class

[image]

AMIgo Controls documentation
AstUsersObject Class
Members See Also Send Feedback
This is the base class for the AstUsersObjectsList SyncList, which contains the definition of sip / iax / zap objects present in the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstUsersObject
Visual Basic
Public Class AstUsersObject
Visual C++
public ref class AstUsersObject

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstUsersObject

See Also

AstUsersObject Members


AstUsersObject Members

[image] [image]

AMIgo Controls documentation
AstUsersObject Members
AstUsersObject Class Constructors Properties See Also Send Feedback

The AstUsersObject type exposes the following members.

Constructors

 | Name | Description
Public method | AstUsersObject | Initializes a new instance of the AstUsersObject class.

Properties

 | Name | Description
Public property | ChannelType | Gets or sets the type of the channel.
Public property | Context | Gets or sets the Context.
Public property | IP_Address | Gets or sets the IP address.
Public property | IP_Port | Gets or sets the IP port.
Public property | LineUserName | Gets or sets the name of the line user.
Public property | NewVmail | Gets or sets the new vmail.
Public property | ObjectType | Gets or sets the type of the object.
Public property | ObjName | Gets or sets the name of the obj.
Public property | OldVmail | Gets or sets the old vmail.
Public property | State | Gets or sets the state.
Public property | Status | Gets or sets the status.
Public property | TrunkStyle | Gets or sets the trunk style.
Public property | UserDictionary | Gets or sets the user dictionary.
Public property | ZapAliasName | Gets or sets the name of the zap alias.

See Also

AstUsersObject Class


AstUsersObject Constructor

[image]

AMIgo Controls documentation
AstUsersObject Constructor
AstUsersObject Class See Also Send Feedback
Initializes a new instance of the AstUsersObject class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstUsersObject()
Visual Basic
Public Sub New
Visual C++
public:
AstUsersObject()

See Also

AstUsersObject Class


AstUsersObject Properties

[image] [image]

AMIgo Controls documentation
AstUsersObject Properties
AstUsersObject Class See Also Send Feedback

The AstUsersObject type exposes the following members.

Properties

 | Name | Description
Public property | ChannelType | Gets or sets the type of the channel.
Public property | Context | Gets or sets the Context.
Public property | IP_Address | Gets or sets the IP address.
Public property | IP_Port | Gets or sets the IP port.
Public property | LineUserName | Gets or sets the name of the line user.
Public property | NewVmail | Gets or sets the new vmail.
Public property | ObjectType | Gets or sets the type of the object.
Public property | ObjName | Gets or sets the name of the obj.
Public property | OldVmail | Gets or sets the old vmail.
Public property | State | Gets or sets the state.
Public property | Status | Gets or sets the status.
Public property | TrunkStyle | Gets or sets the trunk style.
Public property | UserDictionary | Gets or sets the user dictionary.
Public property | ZapAliasName | Gets or sets the name of the zap alias.

See Also

AstUsersObject Class


ChannelType Property

[image]

AMIgo Controls documentation
AstUsersObject..::..ChannelType Property
AstUsersObject Class See Also Send Feedback
Gets or sets the type of the channel.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ChannelType { get; set; }
Visual Basic
Public Property ChannelType As String
    Get
    Set
Visual C++
public:
property String^ ChannelType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the channel. SIP / IAX / Zap/DAHDI

See Also

AstUsersObject Class


Context Property

[image]

AMIgo Controls documentation
AstUsersObject..::..Context Property
AstUsersObject Class See Also Send Feedback
Gets or sets the Context.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Context { get; set; }
Visual Basic
Public Property Context As String
    Get
    Set
Visual C++
public:
property String^ Context {
    String^ get ();
    void set (String^ value);
}

Field Value

The Context for the extension or trunk.

See Also

AstUsersObject Class


IP_Address Property

[image]

AMIgo Controls documentation
AstUsersObject..::..IP_Address Property
AstUsersObject Class See Also Send Feedback
Gets or sets the IP address.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string IP_Address { get; set; }
Visual Basic
Public Property IP_Address As String
    Get
    Set
Visual C++
public:
property String^ IP_Address {
    String^ get ();
    void set (String^ value);
}

Field Value

The IP address of the object. (Unused for Zap/DAHDI)

See Also

AstUsersObject Class


IP_Port Property

[image]

AMIgo Controls documentation
AstUsersObject..::..IP_Port Property
AstUsersObject Class See Also Send Feedback
Gets or sets the IP port.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string IP_Port { get; set; }
Visual Basic
Public Property IP_Port As String
    Get
    Set
Visual C++
public:
property String^ IP_Port {
    String^ get ();
    void set (String^ value);
}

Field Value

The IP_ port. Unused for Zap/DAHDI

See Also

AstUsersObject Class


LineUserName Property

[image]

AMIgo Controls documentation
AstUsersObject..::..LineUserName Property
AstUsersObject Class See Also Send Feedback
Gets or sets the name of the line user.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LineUserName { get; set; }
Visual Basic
Public Property LineUserName As String
    Get
    Set
Visual C++
public:
property String^ LineUserName {
    String^ get ();
    void set (String^ value);
}

Field Value

The full name of the line user.

See Also

AstUsersObject Class


NewVmail Property

[image]

AMIgo Controls documentation
AstUsersObject..::..NewVmail Property
AstUsersObject Class See Also Send Feedback
Gets or sets the new vmail.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int NewVmail { get; set; }
Visual Basic
Public Property NewVmail As Integer
    Get
    Set
Visual C++
public:
property int NewVmail {
    int get ();
    void set (int value);
}

Field Value

The new vmail in this user voicemail box. (Valid for extensions only)

See Also

AstUsersObject Class


ObjectType Property

[image]

AMIgo Controls documentation
AstUsersObject..::..ObjectType Property
AstUsersObject Class See Also Send Feedback
Gets or sets the type of the object.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ObjectType { get; set; }
Visual Basic
Public Property ObjectType As String
    Get
    Set
Visual C++
public:
property String^ ObjectType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the object. "peer" / "reg" / "FXO" / "FXS"

See Also

AstUsersObject Class


ObjName Property

[image]

AMIgo Controls documentation
AstUsersObject..::..ObjName Property
AstUsersObject Class See Also Send Feedback
Gets or sets the name of the obj.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ObjName { get; set; }
Visual Basic
Public Property ObjName As String
    Get
    Set
Visual C++
public:
property String^ ObjName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the obj. Ex. 200

See Also

AstUsersObject Class


OldVmail Property

[image]

AMIgo Controls documentation
AstUsersObject..::..OldVmail Property
AstUsersObject Class See Also Send Feedback
Gets or sets the old vmail.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int OldVmail { get; set; }
Visual Basic
Public Property OldVmail As Integer
    Get
    Set
Visual C++
public:
property int OldVmail {
    int get ();
    void set (int value);
}

Field Value

The old vmail in this user voicemail box. (Valid for extensions only)

See Also

AstUsersObject Class


State Property

[image]

AMIgo Controls documentation
AstUsersObject..::..State Property
AstUsersObject Class See Also Send Feedback
Gets or sets the state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

Field Value

The state as a string value.

See Also

AstUsersObject Class


Status Property

[image]

AMIgo Controls documentation
AstUsersObject..::..Status Property
AstUsersObject Class See Also Send Feedback
Gets or sets the status.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int Status { get; set; }
Visual Basic
Public Property Status As Integer
    Get
    Set
Visual C++
public:
property int Status {
    int get ();
    void set (int value);
}

Field Value

The status as an int value

See Also

AstUsersObject Class


TrunkStyle Property

[image]

AMIgo Controls documentation
AstUsersObject..::..TrunkStyle Property
AstUsersObject Class See Also Send Feedback
Gets or sets the trunk style.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string TrunkStyle { get; set; }
Visual Basic
Public Property TrunkStyle As String
    Get
    Set
Visual C++
public:
property String^ TrunkStyle {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the trunk. Blank if not a trunk or Analog, Voip, Digital ...

See Also

AstUsersObject Class


UserDictionary Property

[image]

AMIgo Controls documentation
AstUsersObject..::..UserDictionary Property
AstUsersObject Class See Also Send Feedback
Gets or sets the user dictionary.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Dictionary<string, string> UserDictionary { get; set; }
Visual Basic
Public Property UserDictionary As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ UserDictionary {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Field Value

The user dictionary containing the users.conf entries for that user (if any) Only available for extensions created through the users.conf file.

See Also

AstUsersObject Class


ZapAliasName Property

[image]

AMIgo Controls documentation
AstUsersObject..::..ZapAliasName Property
AstUsersObject Class See Also Send Feedback
Gets or sets the name of the zap alias.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ZapAliasName { get; set; }
Visual Basic
Public Property ZapAliasName As String
    Get
    Set
Visual C++
public:
property String^ ZapAliasName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the zap alias. That is an extension assigned to the Zap/DAHDI channel.

See Also

AstUsersObject Class


AstUsersObjectEventArgs Class

[image]

AMIgo Controls documentation
AstUsersObjectEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for AstUsersObjects (Extensions, trunks, registrations) events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstUsersObjectEventArgs : EventArgs
Visual Basic
Public Class AstUsersObjectEventArgs _
    Inherits EventArgs
Visual C++
public ref class AstUsersObjectEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..AstUsersObjectEventArgs

See Also

AstUsersObjectEventArgs Members


AstUsersObjectEventArgs Members

[image] [image]

AMIgo Controls documentation
AstUsersObjectEventArgs Members
AstUsersObjectEventArgs Class Constructors Fields See Also Send Feedback

The AstUsersObjectEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AstUsersObjectEventArgs | Initializes a new instance of the AstUsersObjectEventArgs class.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | user_object | A AstUsersObject struc containing the info about the object

See Also

AstUsersObjectEventArgs Class


AstUsersObjectEventArgs Constructor

[image]

AMIgo Controls documentation
AstUsersObjectEventArgs Constructor
AstUsersObjectEventArgs Class See Also Send Feedback
Initializes a new instance of the AstUsersObjectEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstUsersObjectEventArgs(
    string[] EventStrs,
    AstUsersObject UserObject
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    UserObject As AstUsersObject _
)
Visual C++
public:
AstUsersObjectEventArgs(
    array<String^>^ EventStrs,
    AstUsersObject^ UserObject
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
UserObject
Type: AMIgo..::..AstUsersObject
The vo I p_ object.

See Also

AstUsersObjectEventArgs Class


AstUsersObjectEventArgs Fields

[image] [image]

AMIgo Controls documentation
AstUsersObjectEventArgs Fields
AstUsersObjectEventArgs Class See Also Send Feedback

The AstUsersObjectEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | user_object | A AstUsersObject struc containing the info about the object

See Also

AstUsersObjectEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
AstUsersObjectEventArgs..::..event_strs Field
AstUsersObjectEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

AstUsersObjectEventArgs Class


user_object Field

[image]

AMIgo Controls documentation
AstUsersObjectEventArgs..::..user_object Field
AstUsersObjectEventArgs Class See Also Send Feedback
A AstUsersObject struc containing the info about the object

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstUsersObject user_object
Visual Basic
Public user_object As AstUsersObject
Visual C++
public:
AstUsersObject^ user_object

See Also

AstUsersObjectEventArgs Class


AstUsersObjectEventHandler Delegate

[image]

AMIgo Controls documentation
AstUsersObjectEventHandler Delegate
See Also Send Feedback
delegate for the AstUsersObjects Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void AstUsersObjectEventHandler(
    Object sender,
    AstUsersObjectEventArgs ev
)
Visual Basic
Public Delegate Sub AstUsersObjectEventHandler ( _
    sender As Object, _
    ev As AstUsersObjectEventArgs _
)
Visual C++
public delegate void AstUsersObjectEventHandler(
    Object^ sender,
    AstUsersObjectEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..AstUsersObjectEventArgs
The AstUsersObjectEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


AstVoicemail Class

[image]

AMIgo Controls documentation
AstVoicemail Class
Members See Also Send Feedback
This class is used a a template for a voice Mailbox definition

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class AstVoicemail
Visual Basic
Public Class AstVoicemail
Visual C++
public ref class AstVoicemail

Inheritance Hierarchy

System..::..Object
AMIgo..::..AstVoicemail

See Also

AstVoicemail Members


AstVoicemail Members

[image] [image]

AMIgo Controls documentation
AstVoicemail Members
AstVoicemail Class Constructors Properties See Also Send Feedback

The AstVoicemail type exposes the following members.

Constructors

 | Name | Description
Public method | AstVoicemail | Initializes a new instance of the AstVoicemail class.

Properties

 | Name | Description
Public property | ConfigLine | The full Mailbox definition text line in voicemail.conf
Public property | MaiboxNo | The Mailbox number.
Public property | MailboxGroup | Any Mailbox Group this mbx is part of
Public property | NewVmail | The number of new voicemail in the Mailbox
Public property | Password | The Mailbox password
Public property | UserEmail | The Mailbox user's Email address.
Public property | UserName | The Mailbox full user name.

See Also

AstVoicemail Class


AstVoicemail Constructor

[image]

AMIgo Controls documentation
AstVoicemail Constructor
AstVoicemail Class See Also Send Feedback
Initializes a new instance of the AstVoicemail class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstVoicemail()
Visual Basic
Public Sub New
Visual C++
public:
AstVoicemail()

See Also

AstVoicemail Class


AstVoicemail Properties

[image] [image]

AMIgo Controls documentation
AstVoicemail Properties
AstVoicemail Class See Also Send Feedback

The AstVoicemail type exposes the following members.

Properties

 | Name | Description
Public property | ConfigLine | The full Mailbox definition text line in voicemail.conf
Public property | MaiboxNo | The Mailbox number.
Public property | MailboxGroup | Any Mailbox Group this mbx is part of
Public property | NewVmail | The number of new voicemail in the Mailbox
Public property | Password | The Mailbox password
Public property | UserEmail | The Mailbox user's Email address.
Public property | UserName | The Mailbox full user name.

See Also

AstVoicemail Class


ConfigLine Property

[image]

AMIgo Controls documentation
AstVoicemail..::..ConfigLine Property
AstVoicemail Class See Also Send Feedback
The full Mailbox definition text line in voicemail.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string ConfigLine { get; set; }
Visual Basic
Public Property ConfigLine As String
    Get
    Set
Visual C++
public:
property String^ ConfigLine {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


MaiboxNo Property

[image]

AMIgo Controls documentation
AstVoicemail..::..MaiboxNo Property
AstVoicemail Class See Also Send Feedback
The Mailbox number.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MaiboxNo { get; set; }
Visual Basic
Public Property MaiboxNo As String
    Get
    Set
Visual C++
public:
property String^ MaiboxNo {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


MailboxGroup Property

[image]

AMIgo Controls documentation
AstVoicemail..::..MailboxGroup Property
AstVoicemail Class See Also Send Feedback
Any Mailbox Group this mbx is part of

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string MailboxGroup { get; set; }
Visual Basic
Public Property MailboxGroup As String
    Get
    Set
Visual C++
public:
property String^ MailboxGroup {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


NewVmail Property

[image]

AMIgo Controls documentation
AstVoicemail..::..NewVmail Property
AstVoicemail Class See Also Send Feedback
The number of new voicemail in the Mailbox

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string NewVmail { get; set; }
Visual Basic
Public Property NewVmail As String
    Get
    Set
Visual C++
public:
property String^ NewVmail {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


Password Property

[image]

AMIgo Controls documentation
AstVoicemail..::..Password Property
AstVoicemail Class See Also Send Feedback
The Mailbox password

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


UserEmail Property

[image]

AMIgo Controls documentation
AstVoicemail..::..UserEmail Property
AstVoicemail Class See Also Send Feedback
The Mailbox user's Email address.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserEmail { get; set; }
Visual Basic
Public Property UserEmail As String
    Get
    Set
Visual C++
public:
property String^ UserEmail {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


UserName Property

[image]

AMIgo Controls documentation
AstVoicemail..::..UserName Property
AstVoicemail Class See Also Send Feedback
The Mailbox full user name.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

AstVoicemail Class


CallType Enumeration

[image]

AMIgo Controls documentation
CallType Enumeration
See Also Send Feedback
Enum the direction / source / dest of calls

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public enum CallType
Visual Basic
Public Enumeration CallType
Visual C++
public enum class CallType

Members

Member name | Value | Description
Unknown | 0 | Undeterminated call type.
Inbound | 1 | Calls from an external source to a internal extensions.
Outbound | 2 | Calls from an internal source to an external phone number.
Internal | 3 | Internal call (between extensions).

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


CDR Class

[image]

AMIgo Controls documentation
CDR Class
Members See Also Send Feedback
This class is the base for the AstCall details report record

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class CDR
Visual Basic
Public Class CDR
Visual C++
public ref class CDR

Inheritance Hierarchy

System..::..Object
AMIgo..::..CDR

See Also

CDR Members


CDR Members

[image] [image]

AMIgo Controls documentation
CDR Members
CDR Class Constructors Properties See Also Send Feedback

The CDR type exposes the following members.

Constructors

 | Name | Description
Public method | CDR | Initializes a new instance of the CDR class.

Properties

 | Name | Description
Public property | AccountCode | Ant account code
Public property | AnswerTime | The time the call has been answered
Public property | BillableSeconds | The number of billable seconds.
Public property | CallerID | The caller ID of the caller
Public property | Channel | Thesource channel used for the call
Public property | Destination | The desination of the call
Public property | DestinationChannel | The channel of the destination
Public property | DestinationContext | The destination Context
Public property | Disposition | The disposition (result) of the call
Public property | Duration | The call duration in seconds
Public property | EndTime | the end time of the call
Public property | LastApplication | The last application invoked during the call.
Public property | LastData | The data for the last application
Public property | Source | The source of the call
Public property | StartTime | The start time of the call
Public property | Timestamp | The timestamp of the call
Public property | UniqueID | The usnique id for this call
Public property | UserField | Any user field

See Also

CDR Class


CDR Constructor

[image]

AMIgo Controls documentation
CDR Constructor
CDR Class See Also Send Feedback
Initializes a new instance of the CDR class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CDR()
Visual Basic
Public Sub New
Visual C++
public:
CDR()

See Also

CDR Class


CDR Properties

[image] [image]

AMIgo Controls documentation
CDR Properties
CDR Class See Also Send Feedback

The CDR type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | Ant account code
Public property | AnswerTime | The time the call has been answered
Public property | BillableSeconds | The number of billable seconds.
Public property | CallerID | The caller ID of the caller
Public property | Channel | Thesource channel used for the call
Public property | Destination | The desination of the call
Public property | DestinationChannel | The channel of the destination
Public property | DestinationContext | The destination Context
Public property | Disposition | The disposition (result) of the call
Public property | Duration | The call duration in seconds
Public property | EndTime | the end time of the call
Public property | LastApplication | The last application invoked during the call.
Public property | LastData | The data for the last application
Public property | Source | The source of the call
Public property | StartTime | The start time of the call
Public property | Timestamp | The timestamp of the call
Public property | UniqueID | The usnique id for this call
Public property | UserField | Any user field

See Also

CDR Class


AccountCode Property

[image]

AMIgo Controls documentation
CDR..::..AccountCode Property
CDR Class See Also Send Feedback
Ant account code

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set
Visual C++
public:
property String^ AccountCode {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


AnswerTime Property

[image]

AMIgo Controls documentation
CDR..::..AnswerTime Property
CDR Class See Also Send Feedback
The time the call has been answered

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string AnswerTime { get; set; }
Visual Basic
Public Property AnswerTime As String
    Get
    Set
Visual C++
public:
property String^ AnswerTime {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


BillableSeconds Property

[image]

AMIgo Controls documentation
CDR..::..BillableSeconds Property
CDR Class See Also Send Feedback
The number of billable seconds.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string BillableSeconds { get; set; }
Visual Basic
Public Property BillableSeconds As String
    Get
    Set
Visual C++
public:
property String^ BillableSeconds {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


CallerID Property

[image]

AMIgo Controls documentation
CDR..::..CallerID Property
CDR Class See Also Send Feedback
The caller ID of the caller

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string CallerID { get; set; }
Visual Basic
Public Property CallerID As String
    Get
    Set
Visual C++
public:
property String^ CallerID {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Channel Property

[image]

AMIgo Controls documentation
CDR..::..Channel Property
CDR Class See Also Send Feedback
Thesource channel used for the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Channel { get; set; }
Visual Basic
Public Property Channel As String
    Get
    Set
Visual C++
public:
property String^ Channel {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Destination Property

[image]

AMIgo Controls documentation
CDR..::..Destination Property
CDR Class See Also Send Feedback
The desination of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Destination { get; set; }
Visual Basic
Public Property Destination As String
    Get
    Set
Visual C++
public:
property String^ Destination {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


DestinationChannel Property

[image]

AMIgo Controls documentation
CDR..::..DestinationChannel Property
CDR Class See Also Send Feedback
The channel of the destination

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DestinationChannel { get; set; }
Visual Basic
Public Property DestinationChannel As String
    Get
    Set
Visual C++
public:
property String^ DestinationChannel {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


DestinationContext Property

[image]

AMIgo Controls documentation
CDR..::..DestinationContext Property
CDR Class See Also Send Feedback
The destination Context

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string DestinationContext { get; set; }
Visual Basic
Public Property DestinationContext As String
    Get
    Set
Visual C++
public:
property String^ DestinationContext {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Disposition Property

[image]

AMIgo Controls documentation
CDR..::..Disposition Property
CDR Class See Also Send Feedback
The disposition (result) of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Disposition { get; set; }
Visual Basic
Public Property Disposition As String
    Get
    Set
Visual C++
public:
property String^ Disposition {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Duration Property

[image]

AMIgo Controls documentation
CDR..::..Duration Property
CDR Class See Also Send Feedback
The call duration in seconds

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Duration { get; set; }
Visual Basic
Public Property Duration As String
    Get
    Set
Visual C++
public:
property String^ Duration {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


EndTime Property

[image]

AMIgo Controls documentation
CDR..::..EndTime Property
CDR Class See Also Send Feedback
the end time of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string EndTime { get; set; }
Visual Basic
Public Property EndTime As String
    Get
    Set
Visual C++
public:
property String^ EndTime {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


LastApplication Property

[image]

AMIgo Controls documentation
CDR..::..LastApplication Property
CDR Class See Also Send Feedback
The last application invoked during the call.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LastApplication { get; set; }
Visual Basic
Public Property LastApplication As String
    Get
    Set
Visual C++
public:
property String^ LastApplication {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


LastData Property

[image]

AMIgo Controls documentation
CDR..::..LastData Property
CDR Class See Also Send Feedback
The data for the last application

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string LastData { get; set; }
Visual Basic
Public Property LastData As String
    Get
    Set
Visual C++
public:
property String^ LastData {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Source Property

[image]

AMIgo Controls documentation
CDR..::..Source Property
CDR Class See Also Send Feedback
The source of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Source { get; set; }
Visual Basic
Public Property Source As String
    Get
    Set
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


StartTime Property

[image]

AMIgo Controls documentation
CDR..::..StartTime Property
CDR Class See Also Send Feedback
The start time of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string StartTime { get; set; }
Visual Basic
Public Property StartTime As String
    Get
    Set
Visual C++
public:
property String^ StartTime {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


Timestamp Property

[image]

AMIgo Controls documentation
CDR..::..Timestamp Property
CDR Class See Also Send Feedback
The timestamp of the call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string Timestamp { get; set; }
Visual Basic
Public Property Timestamp As String
    Get
    Set
Visual C++
public:
property String^ Timestamp {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


UniqueID Property

[image]

AMIgo Controls documentation
CDR..::..UniqueID Property
CDR Class See Also Send Feedback
The usnique id for this call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UniqueID { get; set; }
Visual Basic
Public Property UniqueID As String
    Get
    Set
Visual C++
public:
property String^ UniqueID {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


UserField Property

[image]

AMIgo Controls documentation
CDR..::..UserField Property
CDR Class See Also Send Feedback
Any user field

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string UserField { get; set; }
Visual Basic
Public Property UserField As String
    Get
    Set
Visual C++
public:
property String^ UserField {
    String^ get ();
    void set (String^ value);
}

See Also

CDR Class


CDR_EventArgs Class

[image]

AMIgo Controls documentation
CDR_EventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Calls Details Report sent after a call is completed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class CDR_EventArgs : EventArgs
Visual Basic
Public Class CDR_EventArgs _
    Inherits EventArgs
Visual C++
public ref class CDR_EventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..CDR_EventArgs

See Also

CDR_EventArgs Members


CDR_EventArgs Members

[image] [image]

AMIgo Controls documentation
CDR_EventArgs Members
CDR_EventArgs Class Constructors Fields See Also Send Feedback

The CDR_EventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CDR_EventArgs | Initializes a new instance of the CDR_EventArgs class.

Fields

 | Name | Description
Public field | cdr | A CDR struct containing the call information
Public field | event_strs | The raw event strings

See Also

CDR_EventArgs Class


CDR_EventArgs Constructor

[image]

AMIgo Controls documentation
CDR_EventArgs Constructor
CDR_EventArgs Class See Also Send Feedback
Initializes a new instance of the CDR_EventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CDR_EventArgs(
    string[] EventStrs,
    CDR Cdr
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Cdr As CDR _
)
Visual C++
public:
CDR_EventArgs(
    array<String^>^ EventStrs,
    CDR^ Cdr
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Cdr
Type: AMIgo..::..CDR
The CDR.

See Also

CDR_EventArgs Class


CDR_EventArgs Fields

[image] [image]

AMIgo Controls documentation
CDR_EventArgs Fields
CDR_EventArgs Class See Also Send Feedback

The CDR_EventArgs type exposes the following members.

Fields

 | Name | Description
Public field | cdr | A CDR struct containing the call information
Public field | event_strs | The raw event strings

See Also

CDR_EventArgs Class


cdr Field

[image]

AMIgo Controls documentation
CDR_EventArgs..::..cdr Field
CDR_EventArgs Class See Also Send Feedback
A CDR struct containing the call information

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CDR cdr
Visual Basic
Public cdr As CDR
Visual C++
public:
CDR^ cdr

See Also

CDR_EventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
CDR_EventArgs..::..event_strs Field
CDR_EventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

CDR_EventArgs Class


CDR_EventHandler Delegate

[image]

AMIgo Controls documentation
CDR_EventHandler Delegate
See Also Send Feedback
delegate for the AstCall Details Report Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void CDR_EventHandler(
    Object sender,
    CDR_EventArgs ev
)
Visual Basic
Public Delegate Sub CDR_EventHandler ( _
    sender As Object, _
    ev As CDR_EventArgs _
)
Visual C++
public delegate void CDR_EventHandler(
    Object^ sender,
    CDR_EventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CDR_EventArgs
The CDR_EventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


CmdResultEventArgs Class

[image]

AMIgo Controls documentation
CmdResultEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Commands results events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class CmdResultEventArgs : EventArgs
Visual Basic
Public Class CmdResultEventArgs _
    Inherits EventArgs
Visual C++
public ref class CmdResultEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..CmdResultEventArgs

See Also

CmdResultEventArgs Members


CmdResultEventArgs Members

[image] [image]

AMIgo Controls documentation
CmdResultEventArgs Members
CmdResultEventArgs Class Constructors Fields See Also Send Feedback

The CmdResultEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CmdResultEventArgs | Initializes a new instance of the CmdResultEventArgs class.

Fields

 | Name | Description
Public field | cmd | A description of the command
Public field | msg | A result message
Public field | result | The numeric result: 0 = success

See Also

CmdResultEventArgs Class


CmdResultEventArgs Constructor

[image]

AMIgo Controls documentation
CmdResultEventArgs Constructor
CmdResultEventArgs Class See Also Send Feedback
Initializes a new instance of the CmdResultEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CmdResultEventArgs(
    string Cmd,
    int Result,
    string Msg
)
Visual Basic
Public Sub New ( _
    Cmd As String, _
    Result As Integer, _
    Msg As String _
)
Visual C++
public:
CmdResultEventArgs(
    String^ Cmd,
    int Result,
    String^ Msg
)

Parameters

Cmd
Type: System..::..String
The CMD.
Result
Type: System..::..Int32
The result.
Msg
Type: System..::..String
The MSG.

See Also

CmdResultEventArgs Class


CmdResultEventArgs Fields

[image] [image]

AMIgo Controls documentation
CmdResultEventArgs Fields
CmdResultEventArgs Class See Also Send Feedback

The CmdResultEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | cmd | A description of the command
Public field | msg | A result message
Public field | result | The numeric result: 0 = success

See Also

CmdResultEventArgs Class


cmd Field

[image]

AMIgo Controls documentation
CmdResultEventArgs..::..cmd Field
CmdResultEventArgs Class See Also Send Feedback
A description of the command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string cmd
Visual Basic
Public cmd As String
Visual C++
public:
String^ cmd

See Also

CmdResultEventArgs Class


msg Field

[image]

AMIgo Controls documentation
CmdResultEventArgs..::..msg Field
CmdResultEventArgs Class See Also Send Feedback
A result message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string msg
Visual Basic
Public msg As String
Visual C++
public:
String^ msg

See Also

CmdResultEventArgs Class


result Field

[image]

AMIgo Controls documentation
CmdResultEventArgs..::..result Field
CmdResultEventArgs Class See Also Send Feedback
The numeric result: 0 = success

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int result
Visual Basic
Public result As Integer
Visual C++
public:
int result

See Also

CmdResultEventArgs Class


CmdResultHandler Delegate

[image]

AMIgo Controls documentation
CmdResultHandler Delegate
See Also Send Feedback
delegate for the CmdResult Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void CmdResultHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Delegate Sub CmdResultHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public delegate void CmdResultHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ConferenceEventArgs Class

[image]

AMIgo Controls documentation
ConferenceEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Conferences events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ConferenceEventArgs : EventArgs
Visual Basic
Public Class ConferenceEventArgs _
    Inherits EventArgs
Visual C++
public ref class ConferenceEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..ConferenceEventArgs

See Also

ConferenceEventArgs Members


ConferenceEventArgs Members

[image] [image]

AMIgo Controls documentation
ConferenceEventArgs Members
ConferenceEventArgs Class Constructors Fields See Also Send Feedback

The ConferenceEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceEventArgs | Initializes a new instance of the ConferenceEventArgs class.

Fields

 | Name | Description
Public field | conference | A AstConference struct containing the conference information.
Public field | event_strs | The raw event strings

See Also

ConferenceEventArgs Class


ConferenceEventArgs Constructor

[image]

AMIgo Controls documentation
ConferenceEventArgs Constructor
ConferenceEventArgs Class See Also Send Feedback
Initializes a new instance of the ConferenceEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ConferenceEventArgs(
    string[] EventStrs,
    AstConference Conference
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Conference As AstConference _
)
Visual C++
public:
ConferenceEventArgs(
    array<String^>^ EventStrs,
    AstConference^ Conference
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Conference
Type: AMIgo..::..AstConference
The conference.

See Also

ConferenceEventArgs Class


ConferenceEventArgs Fields

[image] [image]

AMIgo Controls documentation
ConferenceEventArgs Fields
ConferenceEventArgs Class See Also Send Feedback

The ConferenceEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | conference | A AstConference struct containing the conference information.
Public field | event_strs | The raw event strings

See Also

ConferenceEventArgs Class


conference Field

[image]

AMIgo Controls documentation
ConferenceEventArgs..::..conference Field
ConferenceEventArgs Class See Also Send Feedback
A AstConference struct containing the conference information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstConference conference
Visual Basic
Public conference As AstConference
Visual C++
public:
AstConference^ conference

See Also

ConferenceEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
ConferenceEventArgs..::..event_strs Field
ConferenceEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

ConferenceEventArgs Class


ConferenceEventHandler Delegate

[image]

AMIgo Controls documentation
ConferenceEventHandler Delegate
See Also Send Feedback
delegate for the AstConference Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ConferenceEventHandler(
    Object sender,
    ConferenceEventArgs ev
)
Visual Basic
Public Delegate Sub ConferenceEventHandler ( _
    sender As Object, _
    ev As ConferenceEventArgs _
)
Visual C++
public delegate void ConferenceEventHandler(
    Object^ sender,
    ConferenceEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..ConferenceEventArgs
The ConferenceEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ConferenceUserEventArgs Class

[image]

AMIgo Controls documentation
ConferenceUserEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for AstConferenceUser events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ConferenceUserEventArgs : EventArgs
Visual Basic
Public Class ConferenceUserEventArgs _
    Inherits EventArgs
Visual C++
public ref class ConferenceUserEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..ConferenceUserEventArgs

See Also

ConferenceUserEventArgs Members


ConferenceUserEventArgs Members

[image] [image]

AMIgo Controls documentation
ConferenceUserEventArgs Members
ConferenceUserEventArgs Class Constructors Fields See Also Send Feedback

The ConferenceUserEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceUserEventArgs | Initializes a new instance of the ConferenceUserEventArgs class.

Fields

 | Name | Description
Public field | conference_user | An AstConferenceUser struct containing the conference user information.
Public field | event_strs | The raw event strings

See Also

ConferenceUserEventArgs Class


ConferenceUserEventArgs Constructor

[image]

AMIgo Controls documentation
ConferenceUserEventArgs Constructor
ConferenceUserEventArgs Class See Also Send Feedback
Initializes a new instance of the ConferenceUserEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ConferenceUserEventArgs(
    string[] EventStrs,
    AstConferenceUser ConferenceUser
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    ConferenceUser As AstConferenceUser _
)
Visual C++
public:
ConferenceUserEventArgs(
    array<String^>^ EventStrs,
    AstConferenceUser^ ConferenceUser
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
ConferenceUser
Type: AMIgo..::..AstConferenceUser
The conference user.

See Also

ConferenceUserEventArgs Class


ConferenceUserEventArgs Fields

[image] [image]

AMIgo Controls documentation
ConferenceUserEventArgs Fields
ConferenceUserEventArgs Class See Also Send Feedback

The ConferenceUserEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | conference_user | An AstConferenceUser struct containing the conference user information.
Public field | event_strs | The raw event strings

See Also

ConferenceUserEventArgs Class


conference_user Field

[image]

AMIgo Controls documentation
ConferenceUserEventArgs..::..conference_user Field
ConferenceUserEventArgs Class See Also Send Feedback
An AstConferenceUser struct containing the conference user information.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstConferenceUser conference_user
Visual Basic
Public conference_user As AstConferenceUser
Visual C++
public:
AstConferenceUser^ conference_user

See Also

ConferenceUserEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
ConferenceUserEventArgs..::..event_strs Field
ConferenceUserEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

ConferenceUserEventArgs Class


ConferenceUserEventHandler Delegate

[image]

AMIgo Controls documentation
ConferenceUserEventHandler Delegate
See Also Send Feedback
delegate for the AstConference User Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ConferenceUserEventHandler(
    Object sender,
    ConferenceUserEventArgs ev
)
Visual Basic
Public Delegate Sub ConferenceUserEventHandler ( _
    sender As Object, _
    ev As ConferenceUserEventArgs _
)
Visual C++
public delegate void ConferenceUserEventHandler(
    Object^ sender,
    ConferenceUserEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..ConferenceUserEventArgs
The ConferenceUserEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ConfigFileReadEventArgs Class

[image]

AMIgo Controls documentation
ConfigFileReadEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Config File read events.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ConfigFileReadEventArgs : EventArgs
Visual Basic
Public Class ConfigFileReadEventArgs _
    Inherits EventArgs
Visual C++
public ref class ConfigFileReadEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..ConfigFileReadEventArgs

See Also

ConfigFileReadEventArgs Members


ConfigFileReadEventArgs Members

[image] [image]

AMIgo Controls documentation
ConfigFileReadEventArgs Members
ConfigFileReadEventArgs Class Constructors Fields See Also Send Feedback

The ConfigFileReadEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigFileReadEventArgs | Initializes a new instance of the ConfigFileReadEventArgs class.

Fields

 | Name | Description
Public field | dico_list | A list of Dictionary that contains on dico for each item read.
Public field | filename | The name of the config file. Ex. users.conf

See Also

ConfigFileReadEventArgs Class


ConfigFileReadEventArgs Constructor

[image]

AMIgo Controls documentation
ConfigFileReadEventArgs Constructor
ConfigFileReadEventArgs Class See Also Send Feedback
Initializes a new instance of the ConfigFileReadEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ConfigFileReadEventArgs(
    string FileName,
    List<Dictionary<string, string>> DicoList,
    int DicoIndex
)
Visual Basic
Public Sub New ( _
    FileName As String, _
    DicoList As List(Of Dictionary(Of String, String)), _
    DicoIndex As Integer _
)
Visual C++
public:
ConfigFileReadEventArgs(
    String^ FileName,
    List<Dictionary<String^, String^>^>^ DicoList,
    int DicoIndex
)

Parameters

FileName
Type: System..::..String
Name of the file.
DicoList
Type: System.Collections.Generic..::..List <(Of <(<' Dictionary <(Of <(<' String, String >)>)>>)>)>
The dico list.
DicoIndex
Type: System..::..Int32
Index of the dico.

See Also

ConfigFileReadEventArgs Class


ConfigFileReadEventArgs Fields

[image] [image]

AMIgo Controls documentation
ConfigFileReadEventArgs Fields
ConfigFileReadEventArgs Class See Also Send Feedback

The ConfigFileReadEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | dico_list | A list of Dictionary that contains on dico for each item read.
Public field | filename | The name of the config file. Ex. users.conf

See Also

ConfigFileReadEventArgs Class


dico_list Field

[image]

AMIgo Controls documentation
ConfigFileReadEventArgs..::..dico_list Field
ConfigFileReadEventArgs Class See Also Send Feedback
A list of Dictionary that contains on dico for each item read.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public List<Dictionary<string, string>> dico_list
Visual Basic
Public dico_list As List(Of Dictionary(Of String, String))
Visual C++
public:
List<Dictionary<String^, String^>^>^ dico_list

See Also

ConfigFileReadEventArgs Class


filename Field

[image]

AMIgo Controls documentation
ConfigFileReadEventArgs..::..filename Field
ConfigFileReadEventArgs Class See Also Send Feedback
The name of the config file. Ex. users.conf

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string filename
Visual Basic
Public filename As String
Visual C++
public:
String^ filename

See Also

ConfigFileReadEventArgs Class


ConfigFileReadEventHandler Delegate

[image]

AMIgo Controls documentation
ConfigFileReadEventHandler Delegate
See Also Send Feedback
delegate for the ConfigFileRead Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ConfigFileReadEventHandler(
    Object sender,
    ConfigFileReadEventArgs ev
)
Visual Basic
Public Delegate Sub ConfigFileReadEventHandler ( _
    sender As Object, _
    ev As ConfigFileReadEventArgs _
)
Visual C++
public delegate void ConfigFileReadEventHandler(
    Object^ sender,
    ConfigFileReadEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..ConfigFileReadEventArgs
The ConfigFileReadEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ConfigUpdateEventHandler Delegate

[image]

AMIgo Controls documentation
ConfigUpdateEventHandler Delegate
See Also Send Feedback
delegate for the ConfigUpdate Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ConfigUpdateEventHandler(
    Object sender,
    CmdResultEventArgs ev
)
Visual Basic
Public Delegate Sub ConfigUpdateEventHandler ( _
    sender As Object, _
    ev As CmdResultEventArgs _
)
Visual C++
public delegate void ConfigUpdateEventHandler(
    Object^ sender,
    CmdResultEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..CmdResultEventArgs
The CmdResultEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


DataGridViewAgents Class

[image]

AMIgo Controls documentation
DataGridViewAgents Class
Members See Also Send Feedback
This control display a tabular list of agents and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewAgents : AMIgoControl
Visual Basic
Public Class DataGridViewAgents _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewAgents : public AMIgoControl

Remarks

This display reflect the content of the AstAgentsList which contains the agents definitions and current status information.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewAgents

See Also

DataGridViewAgents Members
AMIgo Namespace
AMIgo..::..AstAgent
AMI_Client..::..AgentEvent
AMI_Client..::..AstAgentsList


DataGridViewAgents Members

[image] [image]

AMIgo Controls documentation
DataGridViewAgents Members
DataGridViewAgents Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewAgents type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewAgents | Initializes a new instance of the DataGridViewAgents class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewAgents Class


DataGridViewAgents Constructor

[image]

AMIgo Controls documentation
DataGridViewAgents Constructor
DataGridViewAgents Class See Also Send Feedback
Initializes a new instance of the DataGridViewAgents class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewAgents()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewAgents()

See Also

DataGridViewAgents Class


DataGridViewAgents Fields

[image] [image]

AMIgo Controls documentation
DataGridViewAgents Fields
DataGridViewAgents Class See Also Send Feedback

The DataGridViewAgents type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewAgents Class


DataGridViewAgents Methods

[image] [image]

AMIgo Controls documentation
DataGridViewAgents Methods
DataGridViewAgents Class See Also Send Feedback

The DataGridViewAgents type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

See Also

DataGridViewAgents Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewAgents..::..Dispose Method
DataGridViewAgents Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewAgents Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewAgents..::..SetDataSource Method
DataGridViewAgents Class See Also Send Feedback
Sets the data source of the DataGridView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data source.

Remarks

Used to set the Data source on the AstAgentsList.

See Also

DataGridViewAgents Class
AMIgo Namespace
AMIgo..::..AstAgent


DataGridViewAgents Properties

[image] [image]

AMIgo Controls documentation
DataGridViewAgents Properties
DataGridViewAgents Class See Also Send Feedback

The DataGridViewAgents type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewAgents Class


DataGridViewAgentsEntries Class

[image]

AMIgo Controls documentation
DataGridViewAgentsEntries Class
Members See Also Send Feedback
This control display a tabular list of agents calls and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewAgentsEntries : AMIgoControl
Visual Basic
Public Class DataGridViewAgentsEntries _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewAgentsEntries : public AMIgoControl

Remarks

This display reflect the content of the AstAgentsCallsList which contains the current agents' call definitions and status information.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewAgentsEntries

See Also

DataGridViewAgentsEntries Members
AMIgo Namespace
AMIgo..::..AstAgentCall
AMI_Client..::..AgentCallEvent
AMI_Client..::..AstAgentsCallsList


DataGridViewAgentsEntries Members

[image] [image]

AMIgo Controls documentation
DataGridViewAgentsEntries Members
DataGridViewAgentsEntries Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewAgentsEntries type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewAgentsEntries | Initializes a new instance of the DataGridViewAgentsEntries class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the DataGridView DataSource

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewAgentsEntries Class


DataGridViewAgentsEntries Constructor

[image]

AMIgo Controls documentation
DataGridViewAgentsEntries Constructor
DataGridViewAgentsEntries Class See Also Send Feedback
Initializes a new instance of the DataGridViewAgentsEntries class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewAgentsEntries()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewAgentsEntries()

See Also

DataGridViewAgentsEntries Class


DataGridViewAgentsEntries Fields

[image] [image]

AMIgo Controls documentation
DataGridViewAgentsEntries Fields
DataGridViewAgentsEntries Class See Also Send Feedback

The DataGridViewAgentsEntries type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewAgentsEntries Class


DataGridViewAgentsEntries Methods

[image] [image]

AMIgo Controls documentation
DataGridViewAgentsEntries Methods
DataGridViewAgentsEntries Class See Also Send Feedback

The DataGridViewAgentsEntries type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the DataGridView DataSource

See Also

DataGridViewAgentsEntries Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewAgentsEntries..::..Dispose Method
DataGridViewAgentsEntries Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewAgentsEntries Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewAgentsEntries..::..SetDataSource Method
DataGridViewAgentsEntries Class See Also Send Feedback
Sets the DataGridView DataSource

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data SRC.

Remarks

Used to set the Data source on the AstAgentsCallsList.

See Also

DataGridViewAgentsEntries Class


DataGridViewAgentsEntries Properties

[image] [image]

AMIgo Controls documentation
DataGridViewAgentsEntries Properties
DataGridViewAgentsEntries Class See Also Send Feedback

The DataGridViewAgentsEntries type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewAgentsEntries Class


DataGridViewChannels Class

[image]

AMIgo Controls documentation
DataGridViewChannels Class
Members See Also Send Feedback
This control display a tabular list of currently active channels on the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewChannels : AMIgoControl
Visual Basic
Public Class DataGridViewChannels _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewChannels : public AMIgoControl

Remarks

AMIgo's DataGriView use DataBinding with SyncList<(Of <(<'T>)>)> that insure that UI elements are updated within the application main thread.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewChannels

See Also

DataGridViewChannels Members
AMIgo Namespace
AMIgo..::..AstChannel
AMI_Client..::..AstChannelEvent
AMI_Client..::..AstChannelsList


DataGridViewChannels Members

[image] [image]

AMIgo Controls documentation
DataGridViewChannels Members
DataGridViewChannels Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewChannels type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewChannels | Initializes a new instance of the DataGridViewChannels class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source to the DataGridView.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewChannels Class


DataGridViewChannels Constructor

[image]

AMIgo Controls documentation
DataGridViewChannels Constructor
DataGridViewChannels Class See Also Send Feedback
Initializes a new instance of the DataGridViewChannels class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewChannels()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewChannels()

See Also

DataGridViewChannels Class


DataGridViewChannels Fields

[image] [image]

AMIgo Controls documentation
DataGridViewChannels Fields
DataGridViewChannels Class See Also Send Feedback

The DataGridViewChannels type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewChannels Class


DataGridViewChannels Methods

[image] [image]

AMIgo Controls documentation
DataGridViewChannels Methods
DataGridViewChannels Class See Also Send Feedback

The DataGridViewChannels type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source to the DataGridView.

See Also

DataGridViewChannels Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewChannels..::..Dispose Method
DataGridViewChannels Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewChannels Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewChannels..::..SetDataSource Method
DataGridViewChannels Class See Also Send Feedback
Sets the data source to the DataGridView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
Used to set the Data source on the AstChannelsList.

See Also

DataGridViewChannels Class


DataGridViewChannels Properties

[image] [image]

AMIgo Controls documentation
DataGridViewChannels Properties
DataGridViewChannels Class See Also Send Feedback

The DataGridViewChannels type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewChannels Class


DataGridViewLines Class

[image]

AMIgo Controls documentation
DataGridViewLines Class
Members See Also Send Feedback
This control display a tabular list of SIP / IAX2 peers / registration and Zap/DAHDI channela present on the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewLines : AMIgoControl
Visual Basic
Public Class DataGridViewLines _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewLines : public AMIgoControl

Remarks

AMIgo's DataGriView use DataBinding with SyncList<(Of <(<'T>)>)> that insure that UI elements are updated whitin the application main thread. AstUsersObjectsList

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewLines

See Also

DataGridViewLines Members
AMIgo Namespace
AMIgo..::..AstUsersObject
AMI_Client..::..AstUsersObjectEvent
AMI_Client..::..GetLinesInfos()()()()


DataGridViewLines Members

[image] [image]

AMIgo Controls documentation
DataGridViewLines Members
DataGridViewLines Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewLines type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewLines | Initializes a new instance of the DataGridViewLines class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewLines Class


DataGridViewLines Constructor

[image]

AMIgo Controls documentation
DataGridViewLines Constructor
DataGridViewLines Class See Also Send Feedback
Initializes a new instance of the DataGridViewLines class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewLines()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewLines()

See Also

DataGridViewLines Class


DataGridViewLines Fields

[image] [image]

AMIgo Controls documentation
DataGridViewLines Fields
DataGridViewLines Class See Also Send Feedback

The DataGridViewLines type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewLines Class


DataGridViewLines Methods

[image] [image]

AMIgo Controls documentation
DataGridViewLines Methods
DataGridViewLines Class See Also Send Feedback

The DataGridViewLines type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

See Also

DataGridViewLines Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewLines..::..Dispose Method
DataGridViewLines Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewLines Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewLines..::..SetDataSource Method
DataGridViewLines Class See Also Send Feedback
Sets the data source of the DataGridView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data source.

Remarks

Used to set the Data source on the AstUsersObjectsList.

See Also

DataGridViewLines Class
AMIgo Namespace
AMIgo..::..AstUsersObject


DataGridViewLines Properties

[image] [image]

AMIgo Controls documentation
DataGridViewLines Properties
DataGridViewLines Class See Also Send Feedback

The DataGridViewLines type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewLines Class


DataGridViewQueueMembers Class

[image]

AMIgo Controls documentation
DataGridViewQueueMembers Class
Members See Also Send Feedback
This control display a tabular list current queues members and status infos. on the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewQueueMembers : AMIgoControl
Visual Basic
Public Class DataGridViewQueueMembers _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewQueueMembers : public AMIgoControl

Remarks

AMIgo's DataGriView use DataBinding with SyncList<(Of <(<'T>)>)> that insure that UI elements are updated within the application main thread. This display reflect the content of the AstQueuesMembersList which contains the currents queues members definitions and status information.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewQueueMembers

See Also

DataGridViewQueueMembers Members
AMIgo Namespace
AMIgo..::..AstQueueMember
AMI_Client..::..AstQueuesMembersList
AMI_Client..::..QueueParamsEvent


DataGridViewQueueMembers Members

[image] [image]

AMIgo Controls documentation
DataGridViewQueueMembers Members
DataGridViewQueueMembers Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewQueueMembers type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewQueueMembers | Initializes a new instance of the DataGridViewQueueMembers class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView to the AstQueuesMembersList.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueueMembers Class


DataGridViewQueueMembers Constructor

[image]

AMIgo Controls documentation
DataGridViewQueueMembers Constructor
DataGridViewQueueMembers Class See Also Send Feedback
Initializes a new instance of the DataGridViewQueueMembers class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewQueueMembers()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewQueueMembers()

See Also

DataGridViewQueueMembers Class


DataGridViewQueueMembers Fields

[image] [image]

AMIgo Controls documentation
DataGridViewQueueMembers Fields
DataGridViewQueueMembers Class See Also Send Feedback

The DataGridViewQueueMembers type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewQueueMembers Class


DataGridViewQueueMembers Methods

[image] [image]

AMIgo Controls documentation
DataGridViewQueueMembers Methods
DataGridViewQueueMembers Class See Also Send Feedback

The DataGridViewQueueMembers type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView to the AstQueuesMembersList.

See Also

DataGridViewQueueMembers Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewQueueMembers..::..Dispose Method
DataGridViewQueueMembers Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewQueueMembers Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewQueueMembers..::..SetDataSource Method
DataGridViewQueueMembers Class See Also Send Feedback
Sets the data source of the DataGridView to the AstQueuesMembersList.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data SRC.

See Also

DataGridViewQueueMembers Class


DataGridViewQueueMembers Properties

[image] [image]

AMIgo Controls documentation
DataGridViewQueueMembers Properties
DataGridViewQueueMembers Class See Also Send Feedback

The DataGridViewQueueMembers type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueueMembers Class


DataGridViewQueues Class

[image]

AMIgo Controls documentation
DataGridViewQueues Class
Members See Also Send Feedback
This control display a tabular list of defined queues and some status infos. on the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewQueues : AMIgoControl
Visual Basic
Public Class DataGridViewQueues _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewQueues : public AMIgoControl

Remarks

AMIgo's DataGriView use DataBinding with SyncList<(Of <(<'T>)>)> that insure that UI elements are updated within the application main thread. This display reflect the content of the AstQueuesList which contains the queues definitions and current status information.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewQueues

See Also

DataGridViewQueues Members
AMIgo Namespace
AMIgo..::..AstQueue
AMI_Client..::..QueueMemberEvent
AMI_Client..::..AstQueuesList


DataGridViewQueues Members

[image] [image]

AMIgo Controls documentation
DataGridViewQueues Members
DataGridViewQueues Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewQueues type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewQueues | Initializes a new instance of the DataGridViewQueues class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueues Class


DataGridViewQueues Constructor

[image]

AMIgo Controls documentation
DataGridViewQueues Constructor
DataGridViewQueues Class See Also Send Feedback
Initializes a new instance of the DataGridViewQueues class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewQueues()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewQueues()

See Also

DataGridViewQueues Class


DataGridViewQueues Fields

[image] [image]

AMIgo Controls documentation
DataGridViewQueues Fields
DataGridViewQueues Class See Also Send Feedback

The DataGridViewQueues type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewQueues Class


DataGridViewQueues Methods

[image] [image]

AMIgo Controls documentation
DataGridViewQueues Methods
DataGridViewQueues Class See Also Send Feedback

The DataGridViewQueues type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

See Also

DataGridViewQueues Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewQueues..::..Dispose Method
DataGridViewQueues Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewQueues Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewQueues..::..SetDataSource Method
DataGridViewQueues Class See Also Send Feedback
Sets the data source of the DataGridView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data source.

Remarks

Used to set the Data source on the AstQueuesList.

See Also

DataGridViewQueues Class
AMIgo Namespace
AMIgo..::..AstQueue


DataGridViewQueues Properties

[image] [image]

AMIgo Controls documentation
DataGridViewQueues Properties
DataGridViewQueues Class See Also Send Feedback

The DataGridViewQueues type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueues Class


DataGridViewQueuesEntries Class

[image]

AMIgo Controls documentation
DataGridViewQueuesEntries Class
Members See Also Send Feedback
This control display a tabular list of queneue entries (call waiting in queue)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DataGridViewQueuesEntries : AMIgoControl
Visual Basic
Public Class DataGridViewQueuesEntries _
    Inherits AMIgoControl
Visual C++
public ref class DataGridViewQueuesEntries : public AMIgoControl

Remarks

This display reflect the content of the AstQueuesEntriesList which contains the list of queue members (agents or lines) and their statuses.

Context Menu: Right click on an item to open a Context menu.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..DataGridViewQueuesEntries

See Also

DataGridViewQueuesEntries Members
AMIgo Namespace
AMIgo..::..AstQueueEntry
AMI_Client..::..AstQueuesEntriesList
AMI_Client..::..QueueEntryEvent


DataGridViewQueuesEntries Members

[image] [image]

AMIgo Controls documentation
DataGridViewQueuesEntries Members
DataGridViewQueuesEntries Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridViewQueuesEntries type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridViewQueuesEntries | Initializes a new instance of the DataGridViewQueuesEntries class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueuesEntries Class


DataGridViewQueuesEntries Constructor

[image]

AMIgo Controls documentation
DataGridViewQueuesEntries Constructor
DataGridViewQueuesEntries Class See Also Send Feedback
Initializes a new instance of the DataGridViewQueuesEntries class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DataGridViewQueuesEntries()
Visual Basic
Public Sub New
Visual C++
public:
DataGridViewQueuesEntries()

See Also

DataGridViewQueuesEntries Class


DataGridViewQueuesEntries Fields

[image] [image]

AMIgo Controls documentation
DataGridViewQueuesEntries Fields
DataGridViewQueuesEntries Class See Also Send Feedback

The DataGridViewQueuesEntries type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

DataGridViewQueuesEntries Class


DataGridViewQueuesEntries Methods

[image] [image]

AMIgo Controls documentation
DataGridViewQueuesEntries Methods
DataGridViewQueuesEntries Class See Also Send Feedback

The DataGridViewQueuesEntries type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | SetDataSource | Sets the data source of the DataGridView.

See Also

DataGridViewQueuesEntries Class


Dispose Method

[image]

AMIgo Controls documentation
DataGridViewQueuesEntries..::..Dispose Method
DataGridViewQueuesEntries Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataGridViewQueuesEntries Class


SetDataSource Method

[image]

AMIgo Controls documentation
DataGridViewQueuesEntries..::..SetDataSource Method
DataGridViewQueuesEntries Class See Also Send Feedback
Sets the data source of the DataGridView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetDataSource(
    Object DataSrc
)
Visual Basic
Public Sub SetDataSource ( _
    DataSrc As Object _
)
Visual C++
public:
void SetDataSource(
    Object^ DataSrc
)

Parameters

DataSrc
Type: System..::..Object
The data source.

Remarks

Used to set the Data source on the AstQueuesEntriesList.

See Also

DataGridViewQueuesEntries Class
AMIgo Namespace
AMIgo..::..AstQueueEntry


DataGridViewQueuesEntries Properties

[image] [image]

AMIgo Controls documentation
DataGridViewQueuesEntries Properties
DataGridViewQueuesEntries Class See Also Send Feedback

The DataGridViewQueuesEntries type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)

See Also

DataGridViewQueuesEntries Class


DBEventArgs Class

[image]

AMIgo Controls documentation
DBEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Ast Database events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class DBEventArgs : EventArgs
Visual Basic
Public Class DBEventArgs _
    Inherits EventArgs
Visual C++
public ref class DBEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..DBEventArgs

See Also

DBEventArgs Members


DBEventArgs Members

[image] [image]

AMIgo Controls documentation
DBEventArgs Members
DBEventArgs Class Constructors Fields See Also Send Feedback

The DBEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DBEventArgs | Initializes a new instance of the DBEventArgs class.

Fields

 | Name | Description
Public field | action | The acion DbGet / DbPut etc
Public field | family | The DB Familly
Public field | key | The DB Key number
Public field | message | A result message
Public field | result | The result of the operation
Public field | value | The value

See Also

DBEventArgs Class


DBEventArgs Constructor

[image]

AMIgo Controls documentation
DBEventArgs Constructor
DBEventArgs Class See Also Send Feedback
Initializes a new instance of the DBEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public DBEventArgs(
    string Action,
    string Family,
    string Key,
    string Value,
    string Result,
    string Message
)
Visual Basic
Public Sub New ( _
    Action As String, _
    Family As String, _
    Key As String, _
    Value As String, _
    Result As String, _
    Message As String _
)
Visual C++
public:
DBEventArgs(
    String^ Action,
    String^ Family,
    String^ Key,
    String^ Value,
    String^ Result,
    String^ Message
)

Parameters

Action
Type: System..::..String
The DB action.
Family
Type: System..::..String
The DB family.
Key
Type: System..::..String
The DB key.
Value
Type: System..::..String
The value.
Result
Type: System..::..String
The result.
Message
Type: System..::..String
The message.

See Also

DBEventArgs Class


DBEventArgs Fields

[image] [image]

AMIgo Controls documentation
DBEventArgs Fields
DBEventArgs Class See Also Send Feedback

The DBEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | action | The acion DbGet / DbPut etc
Public field | family | The DB Familly
Public field | key | The DB Key number
Public field | message | A result message
Public field | result | The result of the operation
Public field | value | The value

See Also

DBEventArgs Class


action Field

[image]

AMIgo Controls documentation
DBEventArgs..::..action Field
DBEventArgs Class See Also Send Feedback
The acion DbGet / DbPut etc

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string action
Visual Basic
Public action As String
Visual C++
public:
String^ action

See Also

DBEventArgs Class


family Field

[image]

AMIgo Controls documentation
DBEventArgs..::..family Field
DBEventArgs Class See Also Send Feedback
The DB Familly

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string family
Visual Basic
Public family As String
Visual C++
public:
String^ family

See Also

DBEventArgs Class


key Field

[image]

AMIgo Controls documentation
DBEventArgs..::..key Field
DBEventArgs Class See Also Send Feedback
The DB Key number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string key
Visual Basic
Public key As String
Visual C++
public:
String^ key

See Also

DBEventArgs Class


message Field

[image]

AMIgo Controls documentation
DBEventArgs..::..message Field
DBEventArgs Class See Also Send Feedback
A result message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string message
Visual Basic
Public message As String
Visual C++
public:
String^ message

See Also

DBEventArgs Class


result Field

[image]

AMIgo Controls documentation
DBEventArgs..::..result Field
DBEventArgs Class See Also Send Feedback
The result of the operation

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string result
Visual Basic
Public result As String
Visual C++
public:
String^ result

See Also

DBEventArgs Class


value Field

[image]

AMIgo Controls documentation
DBEventArgs..::..value Field
DBEventArgs Class See Also Send Feedback
The value

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string value
Visual Basic
Public value As String
Visual C++
public:
String^ value

See Also

DBEventArgs Class


DBEventHandler Delegate

[image]

AMIgo Controls documentation
DBEventHandler Delegate
See Also Send Feedback
delegate for the Data Base Events Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void DBEventHandler(
    Object sender,
    DBEventArgs ev
)
Visual Basic
Public Delegate Sub DBEventHandler ( _
    sender As Object, _
    ev As DBEventArgs _
)
Visual C++
public delegate void DBEventHandler(
    Object^ sender,
    DBEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..DBEventArgs
The DBEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ErrorEventHandler Delegate

[image]

AMIgo Controls documentation
ErrorEventHandler Delegate
See Also Send Feedback
delegate for the Error Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ErrorEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Delegate Sub ErrorEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public delegate void ErrorEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


FormLicense Class

[image]

AMIgo Controls documentation
FormLicense Class
Members See Also Send Feedback
A form for lincense display and input

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class FormLicense : Form
Visual Basic
Public Class FormLicense _
    Inherits Form
Visual C++
public ref class FormLicense : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
AMIgo..::..FormLicense

See Also

FormLicense Members


FormLicense Members

[image] [image]

AMIgo Controls documentation
FormLicense Members
FormLicense Class Constructors Methods See Also Send Feedback

The FormLicense type exposes the following members.

Constructors

 | Name | Description
Public method | FormLicense()()()() | Initializes a new instance of the FormLicense class.
Public method | FormLicense(String, String) | Initializes a new instance of the FormLicense class.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | SetTrialInfo | Sets the trial info.

See Also

FormLicense Class


FormLicense Constructor

[image] [image]

AMIgo Controls documentation
FormLicense Constructor
FormLicense Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FormLicense()()()() | Initializes a new instance of the FormLicense class.
Public method | FormLicense(String, String) | Initializes a new instance of the FormLicense class.

See Also

FormLicense Class
FormLicense Members


FormLicense Constructor

[image]

AMIgo Controls documentation
FormLicense Constructor
FormLicense Class See Also Send Feedback
Initializes a new instance of the FormLicense class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public FormLicense()
Visual Basic
Public Sub New
Visual C++
public:
FormLicense()

See Also

FormLicense Class
FormLicense Overload


FormLicense Constructor (String, String)

[image]

AMIgo Controls documentation
FormLicense Constructor (String, String)
FormLicense Class See Also Send Feedback
Initializes a new instance of the FormLicense class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public FormLicense(
    string RegCode,
    string RegKey
)
Visual Basic
Public Sub New ( _
    RegCode As String, _
    RegKey As String _
)
Visual C++
public:
FormLicense(
    String^ RegCode,
    String^ RegKey
)

Parameters

RegCode
Type: System..::..String
The reg code.
RegKey
Type: System..::..String
The reg key.

See Also

FormLicense Class
FormLicense Overload


FormLicense Methods

[image] [image]

AMIgo Controls documentation
FormLicense Methods
FormLicense Class See Also Send Feedback

The FormLicense type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | SetTrialInfo | Sets the trial info.

See Also

FormLicense Class


Dispose Method

[image]

AMIgo Controls documentation
FormLicense..::..Dispose Method
FormLicense Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FormLicense Class


SetTrialInfo Method

[image]

AMIgo Controls documentation
FormLicense..::..SetTrialInfo Method
FormLicense Class See Also Send Feedback
Sets the trial info.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetTrialInfo(
    int NbDaysInTrial,
    int MaxDays
)
Visual Basic
Public Sub SetTrialInfo ( _
    NbDaysInTrial As Integer, _
    MaxDays As Integer _
)
Visual C++
public:
void SetTrialInfo(
    int NbDaysInTrial,
    int MaxDays
)

Parameters

NbDaysInTrial
Type: System..::..Int32
The nb days in trial.
MaxDays
Type: System..::..Int32
The max days.

See Also

FormLicense Class


GetChannelVarEventArgs Class

[image]

AMIgo Controls documentation
GetChannelVarEventArgs Class
Members See Also Send Feedback
Custom EventArgs used to for 'ChannelGetVar' events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class GetChannelVarEventArgs : EventArgs
Visual Basic
Public Class GetChannelVarEventArgs _
    Inherits EventArgs
Visual C++
public ref class GetChannelVarEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..GetChannelVarEventArgs

See Also

GetChannelVarEventArgs Members


GetChannelVarEventArgs Members

[image] [image]

AMIgo Controls documentation
GetChannelVarEventArgs Members
GetChannelVarEventArgs Class Constructors Fields See Also Send Feedback

The GetChannelVarEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetChannelVarEventArgs | Initializes a new instance of the RawMngrMsgEventArgs class.

Fields

 | Name | Description
Public field | result | The get channel vare numeric result. 0 = success
Public field | value | The value contained in the variable
Public field | variable | The variable

See Also

GetChannelVarEventArgs Class


GetChannelVarEventArgs Constructor

[image]

AMIgo Controls documentation
GetChannelVarEventArgs Constructor
GetChannelVarEventArgs Class See Also Send Feedback
Initializes a new instance of the RawMngrMsgEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public GetChannelVarEventArgs(
    int Result,
    string Variable,
    string Value
)
Visual Basic
Public Sub New ( _
    Result As Integer, _
    Variable As String, _
    Value As String _
)
Visual C++
public:
GetChannelVarEventArgs(
    int Result,
    String^ Variable,
    String^ Value
)

Parameters

Result
Type: System..::..Int32
The result of the get variable command: 0 = Success, -1 = Failure.
Variable
Type: System..::..String
The variable name.
Value
Type: System..::..String
The returned variable value.

See Also

GetChannelVarEventArgs Class


GetChannelVarEventArgs Fields

[image] [image]

AMIgo Controls documentation
GetChannelVarEventArgs Fields
GetChannelVarEventArgs Class See Also Send Feedback

The GetChannelVarEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | result | The get channel vare numeric result. 0 = success
Public field | value | The value contained in the variable
Public field | variable | The variable

See Also

GetChannelVarEventArgs Class


result Field

[image]

AMIgo Controls documentation
GetChannelVarEventArgs..::..result Field
GetChannelVarEventArgs Class See Also Send Feedback
The get channel vare numeric result. 0 = success

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int result
Visual Basic
Public result As Integer
Visual C++
public:
int result

See Also

GetChannelVarEventArgs Class


value Field

[image]

AMIgo Controls documentation
GetChannelVarEventArgs..::..value Field
GetChannelVarEventArgs Class See Also Send Feedback
The value contained in the variable

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string value
Visual Basic
Public value As String
Visual C++
public:
String^ value

See Also

GetChannelVarEventArgs Class


variable Field

[image]

AMIgo Controls documentation
GetChannelVarEventArgs..::..variable Field
GetChannelVarEventArgs Class See Also Send Feedback
The variable

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string variable
Visual Basic
Public variable As String
Visual C++
public:
String^ variable

See Also

GetChannelVarEventArgs Class


GetChannelVarEventHandler Delegate

[image]

AMIgo Controls documentation
GetChannelVarEventHandler Delegate
See Also Send Feedback
delegate for the ChannelGetVar command

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void GetChannelVarEventHandler(
    Object sender,
    GetChannelVarEventArgs ev
)
Visual Basic
Public Delegate Sub GetChannelVarEventHandler ( _
    sender As Object, _
    ev As GetChannelVarEventArgs _
)
Visual C++
public delegate void GetChannelVarEventHandler(
    Object^ sender,
    GetChannelVarEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..GetChannelVarEventArgs
The GetChannelVarEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


GetConfigEventArgs Class

[image]

AMIgo Controls documentation
GetConfigEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for ConfigGetFile events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class GetConfigEventArgs : EventArgs
Visual Basic
Public Class GetConfigEventArgs _
    Inherits EventArgs
Visual C++
public ref class GetConfigEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..GetConfigEventArgs

See Also

GetConfigEventArgs Members


GetConfigEventArgs Members

[image] [image]

AMIgo Controls documentation
GetConfigEventArgs Members
GetConfigEventArgs Class Constructors Fields See Also Send Feedback

The GetConfigEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetConfigEventArgs | Initializes a new instance of the GetConfigEventArgs class.

Fields

 | Name | Description
Public field | filename | The config file name
Public field | strings | The content of the file as a string array

See Also

GetConfigEventArgs Class


GetConfigEventArgs Constructor

[image]

AMIgo Controls documentation
GetConfigEventArgs Constructor
GetConfigEventArgs Class See Also Send Feedback
Initializes a new instance of the GetConfigEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public GetConfigEventArgs(
    string FileName,
    string[] Strings
)
Visual Basic
Public Sub New ( _
    FileName As String, _
    Strings As String() _
)
Visual C++
public:
GetConfigEventArgs(
    String^ FileName,
    array<String^>^ Strings
)

Parameters

FileName
Type: System..::..String
Name of the file.
Strings
Type: array< System..::..String >[]()[][]
The file content strings .

See Also

GetConfigEventArgs Class


GetConfigEventArgs Fields

[image] [image]

AMIgo Controls documentation
GetConfigEventArgs Fields
GetConfigEventArgs Class See Also Send Feedback

The GetConfigEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | filename | The config file name
Public field | strings | The content of the file as a string array

See Also

GetConfigEventArgs Class


filename Field

[image]

AMIgo Controls documentation
GetConfigEventArgs..::..filename Field
GetConfigEventArgs Class See Also Send Feedback
The config file name

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string filename
Visual Basic
Public filename As String
Visual C++
public:
String^ filename

See Also

GetConfigEventArgs Class


strings Field

[image]

AMIgo Controls documentation
GetConfigEventArgs..::..strings Field
GetConfigEventArgs Class See Also Send Feedback
The content of the file as a string array

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] strings
Visual Basic
Public strings As String()
Visual C++
public:
array<String^>^ strings

See Also

GetConfigEventArgs Class


GetConfigEventHandler Delegate

[image]

AMIgo Controls documentation
GetConfigEventHandler Delegate
See Also Send Feedback
delegate for the ConfigGetFile Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void GetConfigEventHandler(
    Object sender,
    GetConfigEventArgs ev
)
Visual Basic
Public Delegate Sub GetConfigEventHandler ( _
    sender As Object, _
    ev As GetConfigEventArgs _
)
Visual C++
public delegate void GetConfigEventHandler(
    Object^ sender,
    GetConfigEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..GetConfigEventArgs
The GetConfigEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


HideEventHandler Delegate

[image]

AMIgo Controls documentation
HideEventHandler Delegate
See Also Send Feedback
delegate for the Hide Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void HideEventHandler(
    Object sender,
    VisibleChangeEventArgs ev
)
Visual Basic
Public Delegate Sub HideEventHandler ( _
    sender As Object, _
    ev As VisibleChangeEventArgs _
)
Visual C++
public delegate void HideEventHandler(
    Object^ sender,
    VisibleChangeEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VisibleChangeEventArgs
The VisibleChangeEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ListViewAgents Class

[image]

AMIgo Controls documentation
ListViewAgents Class
Members See Also Send Feedback
This class implement a ListView control to display defined agents and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewAgents : AMIgoListViewControl
Visual Basic
Public Class ListViewAgents _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewAgents : public AMIgoListViewControl

Remarks

This display reflect the content of the AstAgentsList which contains the agents definitions and current status information. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Drag / Drop: You can drag an agent from the ListViewAgents and drop it onto a queue to add the agent as a member of the queue.

Click on the 'New' toolbox button to create a new Agent. This will open a AMIgoSetupAgentForm object which display a form that allows to set the agent number, name and options. You can also double click on an item to edit the agent.

Context Menu: Right click on an item to open a Context menu.

Examples

USAGE: Just drop the ListViewAgents control on your project main form which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call AgentsGetStatus()()()() after connection and login to fill the control and display the statuses of the agents defined on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewAgents

See Also

ListViewAgents Members
AMIgo Namespace
AMIgo..::..AstAgent
AMI_Client..::..AstAgentsList
AMI_Client..::..AgentEvent


ListViewAgents Members

[image] [image]

AMIgo Controls documentation
ListViewAgents Members
ListViewAgents Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewAgents type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewAgents | Initializes a new instance of the ListViewAgents class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the items from this control's ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the Agents SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control visibility according to the version connected

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewAgents Class


ListViewAgents Constructor

[image]

AMIgo Controls documentation
ListViewAgents Constructor
ListViewAgents Class See Also Send Feedback
Initializes a new instance of the ListViewAgents class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewAgents()
Visual Basic
Public Sub New
Visual C++
public:
ListViewAgents()

See Also

ListViewAgents Class


ListViewAgents Fields

[image] [image]

AMIgo Controls documentation
ListViewAgents Fields
ListViewAgents Class See Also Send Feedback

The ListViewAgents type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgents Class


ListViewAgents Methods

[image] [image]

AMIgo Controls documentation
ListViewAgents Methods
ListViewAgents Class See Also Send Feedback

The ListViewAgents type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the items from this control's ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the Agents SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control visibility according to the version connected

See Also

ListViewAgents Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewAgents..::..ClearAll Method
ListViewAgents Class See Also Send Feedback
Clears all of the items from this control's ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewAgents Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewAgents..::..Dispose Method
ListViewAgents Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewAgents Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewAgents..::..GetItemIndexByTagKey Method
ListViewAgents Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgents Class
ListViewAgents Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewAgents..::..GetSubItemTextByColumnName Method
ListViewAgents Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgents Class
ListViewAgents Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewAgents..::..ListChangedEventHandler Method
ListViewAgents Class See Also Send Feedback
This event handler is called when the Agents SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewAgents Class


VersionEventHandler Method

[image]

AMIgo Controls documentation
ListViewAgents..::..VersionEventHandler Method
ListViewAgents Class See Also Send Feedback
Handle the VersionEvent and sets the control visibility according to the version connected

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void VersionEventHandler(
    Object sender,
    VersionEventArgs ev
)
Visual Basic
Public Sub VersionEventHandler ( _
    sender As Object, _
    ev As VersionEventArgs _
)
Visual C++
public:
void VersionEventHandler(
    Object^ sender,
    VersionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VersionEventArgs
The VersionEventArgs instance containing the event data.

See Also

ListViewAgents Class


ListViewAgents Properties

[image] [image]

AMIgo Controls documentation
ListViewAgents Properties
ListViewAgents Class See Also Send Feedback

The ListViewAgents type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewAgents Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewAgents..::..LargeImages Property
ListViewAgents Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewAgents Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewAgents..::..ListViewBackColor Property
ListViewAgents Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewAgents Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewAgents..::..ListViewFont Property
ListViewAgents Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewAgents Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewAgents..::..ListViewForeColor Property
ListViewAgents Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewAgents Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewAgents..::..SmallImages Property
ListViewAgents Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewAgents Class


View Property

[image]

AMIgo Controls documentation
ListViewAgents..::..View Property
ListViewAgents Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewAgents Class


ListViewAgentsCalls Class

[image]

AMIgo Controls documentation
ListViewAgentsCalls Class
Members See Also Send Feedback
This class implement a ListView control to display the calls that have been received by the agents.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewAgentsCalls : AMIgoListViewControl
Visual Basic
Public Class ListViewAgentsCalls _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewAgentsCalls : public AMIgoListViewControl

Remarks

This display reflect the content of the AstAgentsCallsList which contains the agents definitions and current status information. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Drag / Drop: You can drag an agent from the ListViewAgents and drop it onto a queue to add the agent as a member of the queue.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewAgentsCalls

See Also

ListViewAgentsCalls Members
AMIgo Namespace
AMIgo..::..AstAgentCall
AMI_Client..::..AstAgentsCallsList
AMI_Client..::..AgentCallEvent


ListViewAgentsCalls Members

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls Members
ListViewAgentsCalls Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewAgentsCalls type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewAgentsCalls | Initializes a new instance of the ListViewAgentsCalls class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the items in this control's ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the Agents Entries SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewAgentsCalls Class


ListViewAgentsCalls Constructor

[image]

AMIgo Controls documentation
ListViewAgentsCalls Constructor
ListViewAgentsCalls Class See Also Send Feedback
Initializes a new instance of the ListViewAgentsCalls class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewAgentsCalls()
Visual Basic
Public Sub New
Visual C++
public:
ListViewAgentsCalls()

See Also

ListViewAgentsCalls Class


ListViewAgentsCalls Fields

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls Fields
ListViewAgentsCalls Class See Also Send Feedback

The ListViewAgentsCalls type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgentsCalls Class


ListViewAgentsCalls Methods

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls Methods
ListViewAgentsCalls Class See Also Send Feedback

The ListViewAgentsCalls type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the items in this control's ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the Agents Entries SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgentsCalls Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..ClearAll Method
ListViewAgentsCalls Class See Also Send Feedback
Clears all of the items in this control's ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewAgentsCalls Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..Dispose Method
ListViewAgentsCalls Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewAgentsCalls Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls..::..GetItemIndexByTagKey Method
ListViewAgentsCalls Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgentsCalls Class
ListViewAgentsCalls Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls..::..GetSubItemTextByColumnName Method
ListViewAgentsCalls Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewAgentsCalls Class
ListViewAgentsCalls Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..ListChangedEventHandler Method
ListViewAgentsCalls Class See Also Send Feedback
This event handler is called when the Agents Entries SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewAgentsCalls Class


ListViewAgentsCalls Properties

[image] [image]

AMIgo Controls documentation
ListViewAgentsCalls Properties
ListViewAgentsCalls Class See Also Send Feedback

The ListViewAgentsCalls type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewAgentsCalls Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..LargeImages Property
ListViewAgentsCalls Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewAgentsCalls Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..ListViewBackColor Property
ListViewAgentsCalls Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewAgentsCalls Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..ListViewFont Property
ListViewAgentsCalls Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewAgentsCalls Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..ListViewForeColor Property
ListViewAgentsCalls Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewAgentsCalls Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..SmallImages Property
ListViewAgentsCalls Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewAgentsCalls Class


View Property

[image]

AMIgo Controls documentation
ListViewAgentsCalls..::..View Property
ListViewAgentsCalls Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewAgentsCalls Class


ListViewCalls Class

[image]

AMIgo Controls documentation
ListViewCalls Class
Members See Also Send Feedback
A UserControl used to display and interact with the active calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewCalls : AMIgoControl
Visual Basic
Public Class ListViewCalls _
    Inherits AMIgoControl
Visual C++
public ref class ListViewCalls : public AMIgoControl

Remarks

This display reflect the content of the AstCallsList which contains the current active calls. The ListViewCalls display allows to show the items in differents layouts, in a similar way than the windows file explorer.

A menu allows to select to display Inbound( show in Red (default), Outbound (shown in blue) and internal (shown in gray) calls.

Properties allows to set the font and colors of the ListView and ListItems

Drag / Drop: You can drag an active call and drop it onto an extension in the ListViewLines display to Transfer a caller to an extension. You can drag and drop an active call to the display toolbar drop target to Transfer the active channel to the selected destination, to park the call or to hang it up. You can also drag an active channel to the AMIgoDropTarget form to Transfer a call to the selected destination. (Extension, queue, conference, etc)

Context Menu: Right click on an item to open a Context menu.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..ListViewCalls

See Also

ListViewCalls Members
AMIgo Namespace
AMIgo..::..AstCall
AMI_Client..::..NewCallEvent


ListViewCalls Members

[image] [image]

AMIgo Controls documentation
ListViewCalls Members
ListViewCalls Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewCalls type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewCalls | Initializes a new instance of the ListViewCalls class.

Methods

 | Name | Description
Public method | ClearObjects | Clears the Items in the view lists.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | ListChangedEventHandler | Handle the CallsList view changed events and reflects change in this control.
Public method | RefreshDisplay | Refreshes the display from the AstCallsList

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | InboundBackColor | Gets or sets the color of background for inbound calls.
Public property | InboundForeColor | Gets or sets the color of the text for inbounds calls.
Public property | InternalBackColor | Gets or sets the color of the background for Internals calls.
Public property | InternalForeColor | Gets or sets the color of the text for Internals calls.
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListViews background color
Public property | ListViewFont | Get or set the ListViews font
Public property | ListViewForeColor | Get or set the ListViews foreground color
Public property | OutboundBackColor | Gets or sets the color of the background for outbound calls.
Public property | OutboundForeColor | Gets or sets the color of the text for outbounds calls.
Public property | ShowAgentsChannels | Gets or sets a value indicating whether the intermediary agents channels are displayed.
Public property | ShowInternalCalls | Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.
Public property | ShowOutboundCalls | Gets or sets a value indicating whether the outbound calls are displayed.
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode of the ListView. (Details / Tile / Small/Large Icons)

See Also

ListViewCalls Class


ListViewCalls Constructor

[image]

AMIgo Controls documentation
ListViewCalls Constructor
ListViewCalls Class See Also Send Feedback
Initializes a new instance of the ListViewCalls class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewCalls()
Visual Basic
Public Sub New
Visual C++
public:
ListViewCalls()

See Also

ListViewCalls Class


ListViewCalls Fields

[image] [image]

AMIgo Controls documentation
ListViewCalls Fields
ListViewCalls Class See Also Send Feedback

The ListViewCalls type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)

See Also

ListViewCalls Class


ListViewCalls Methods

[image] [image]

AMIgo Controls documentation
ListViewCalls Methods
ListViewCalls Class See Also Send Feedback

The ListViewCalls type exposes the following members.

Methods

 | Name | Description
Public method | ClearObjects | Clears the Items in the view lists.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Public method | ListChangedEventHandler | Handle the CallsList view changed events and reflects change in this control.
Public method | RefreshDisplay | Refreshes the display from the AstCallsList

See Also

ListViewCalls Class


ClearObjects Method

[image]

AMIgo Controls documentation
ListViewCalls..::..ClearObjects Method
ListViewCalls Class See Also Send Feedback
Clears the Items in the view lists.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearObjects()
Visual Basic
Public Sub ClearObjects
Visual C++
public:
void ClearObjects()

See Also

ListViewCalls Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewCalls..::..Dispose Method
ListViewCalls Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewCalls Class


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewCalls..::..ListChangedEventHandler Method
ListViewCalls Class See Also Send Feedback
Handle the CallsList view changed events and reflects change in this control.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewCalls Class


RefreshDisplay Method

[image]

AMIgo Controls documentation
ListViewCalls..::..RefreshDisplay Method
ListViewCalls Class See Also Send Feedback
Refreshes the display from the AstCallsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void RefreshDisplay()
Visual Basic
Public Sub RefreshDisplay
Visual C++
public:
void RefreshDisplay()

See Also

ListViewCalls Class


ListViewCalls Properties

[image] [image]

AMIgo Controls documentation
ListViewCalls Properties
ListViewCalls Class See Also Send Feedback

The ListViewCalls type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | InboundBackColor | Gets or sets the color of background for inbound calls.
Public property | InboundForeColor | Gets or sets the color of the text for inbounds calls.
Public property | InternalBackColor | Gets or sets the color of the background for Internals calls.
Public property | InternalForeColor | Gets or sets the color of the text for Internals calls.
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListViews background color
Public property | ListViewFont | Get or set the ListViews font
Public property | ListViewForeColor | Get or set the ListViews foreground color
Public property | OutboundBackColor | Gets or sets the color of the background for outbound calls.
Public property | OutboundForeColor | Gets or sets the color of the text for outbounds calls.
Public property | ShowAgentsChannels | Gets or sets a value indicating whether the intermediary agents channels are displayed.
Public property | ShowInternalCalls | Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.
Public property | ShowOutboundCalls | Gets or sets a value indicating whether the outbound calls are displayed.
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode of the ListView. (Details / Tile / Small/Large Icons)

See Also

ListViewCalls Class


InboundBackColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..InboundBackColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of background for inbound calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InboundBackColor { get; set; }
Visual Basic
Public Property InboundBackColor As Color
    Get
    Set
Visual C++
public:
property Color InboundBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


InboundForeColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..InboundForeColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of the text for inbounds calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InboundForeColor { get; set; }
Visual Basic
Public Property InboundForeColor As Color
    Get
    Set
Visual C++
public:
property Color InboundForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


InternalBackColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..InternalBackColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of the background for Internals calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InternalBackColor { get; set; }
Visual Basic
Public Property InternalBackColor As Color
    Get
    Set
Visual C++
public:
property Color InternalBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


InternalForeColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..InternalForeColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of the text for Internals calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InternalForeColor { get; set; }
Visual Basic
Public Property InternalForeColor As Color
    Get
    Set
Visual C++
public:
property Color InternalForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewCalls..::..LargeImages Property
ListViewCalls Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewCalls Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ListViewBackColor Property
ListViewCalls Class See Also Send Feedback
Get or set the ListViews background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ListViewFont Property
ListViewCalls Class See Also Send Feedback
Get or set the ListViews font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewCalls Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ListViewForeColor Property
ListViewCalls Class See Also Send Feedback
Get or set the ListViews foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


OutboundBackColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..OutboundBackColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of the background for outbound calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color OutboundBackColor { get; set; }
Visual Basic
Public Property OutboundBackColor As Color
    Get
    Set
Visual C++
public:
property Color OutboundBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


OutboundForeColor Property

[image]

AMIgo Controls documentation
ListViewCalls..::..OutboundForeColor Property
ListViewCalls Class See Also Send Feedback
Gets or sets the color of the text for outbounds calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color OutboundForeColor { get; set; }
Visual Basic
Public Property OutboundForeColor As Color
    Get
    Set
Visual C++
public:
property Color OutboundForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewCalls Class


ShowAgentsChannels Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ShowAgentsChannels Property
ListViewCalls Class See Also Send Feedback
Gets or sets a value indicating whether the intermediary agents channels are displayed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowAgentsChannels { get; set; }
Visual Basic
Public Property ShowAgentsChannels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowAgentsChannels {
    bool get ();
    void set (bool value);
}

Field Value

true to show Agents channels otherwise, false.

See Also

ListViewCalls Class


ShowInternalCalls Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ShowInternalCalls Property
ListViewCalls Class See Also Send Feedback
Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowInternalCalls { get; set; }
Visual Basic
Public Property ShowInternalCalls As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInternalCalls {
    bool get ();
    void set (bool value);
}

Field Value

true to show internal calls, otherwise, false.

See Also

ListViewCalls Class


ShowOutboundCalls Property

[image]

AMIgo Controls documentation
ListViewCalls..::..ShowOutboundCalls Property
ListViewCalls Class See Also Send Feedback
Gets or sets a value indicating whether the outbound calls are displayed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowOutboundCalls { get; set; }
Visual Basic
Public Property ShowOutboundCalls As Boolean
    Get
    Set
Visual C++
public:
property bool ShowOutboundCalls {
    bool get ();
    void set (bool value);
}

Field Value

true to show outbound calls, otherwise, false.

See Also

ListViewCalls Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewCalls..::..SmallImages Property
ListViewCalls Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewCalls Class


View Property

[image]

AMIgo Controls documentation
ListViewCalls..::..View Property
ListViewCalls Class See Also Send Feedback
Gets or sets the view mode of the ListView. (Details / Tile / Small/Large Icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

See Also

ListViewCalls Class


ListViewChannels Class

[image]

AMIgo Controls documentation
ListViewChannels Class
Members Example See Also Send Feedback
A UserControl used to display and interact with the channels objects that are active on the connected system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewChannels : AMIgoListViewControl
Visual Basic
Public Class ListViewChannels _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewChannels : public AMIgoListViewControl

Remarks

This display reflect the content of the AstChannelsList which contains the current active channels. The ListViewChannels display allows to show the items in differents layouts, in a similar way than the windows file explorer.

A menu allows to select to display Inbound( show in Red (default), Outbound (shown in blue) and internal (shown in gray) calls.

Groups: The items ares displayed under two groups: "Active Channels" and "Parked Calls"

Properties allows to set the font and colors of the ListView and ListItems

Drag / Drop: You can drag an active channel and drop it onto an extension in the ListViewLines display to Transfer a caller to an extension. You can drag and drop an active channel to the display toolbar drop target to Transfer the active channel to the selected destination, to park the call or to hang it up. You can also drag an active channel to the AMIgoDropTarget form to Transfer a call to the selected destination. (Extension, queue, conference, etc)

V1.6 and up: Drag an active channel onto another one to bridge the two channels. See: ChannelBridge(String, String, Boolean)

Context Menu: Right click on an item to open a Context menu.

Examples

USAGE: Just drop the ListViewChannels control into a container in your project which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call ChannelsGetStatus()()()() after connection and login to fill the control with the active channels on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewChannels

See Also

ListViewChannels Members
AMIgo Namespace
AMIgo..::..AstChannel


ListViewChannels Members

[image] [image]

AMIgo Controls documentation
ListViewChannels Members
ListViewChannels Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewChannels type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewChannels()()()() | Initializes a new instance of the ListViewChannels class.
Public method | ListViewChannels(AMI_Client) | Initializes a new instance of the ListViewChannels class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all items in this control ListView.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the voipChannels SyncList changes. It reflects the change to this control ListView
Public method | RefreshDisplay | Refreshes the display from the AstChannelsList
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | SetView | Sets the view for the control's ListView

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | InboundBackColor | Gets or sets the color of background for inbound calls.
Public property | InboundForeColor | Gets or sets the color of the text for inbounds calls.
Public property | InternalBackColor | Gets or sets the color of the background for Internals calls.
Public property | InternalForeColor | Gets or sets the color of the text for Internals calls.
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | OutboundBackColor | Gets or sets the color of the background for outbound calls.
Public property | OutboundForeColor | Gets or sets the color of the text for outbounds calls.
Public property | ShowAgentsChannels | Gets or sets a value indicating whether to show agents channels
Public property | ShowInternalChannels | Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.
Public property | ShowOutboundChannels | Gets or sets a value indicating whether the outbound calls are displayed.
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewChannels Class


ListViewChannels Constructor

[image] [image]

AMIgo Controls documentation
ListViewChannels Constructor
ListViewChannels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ListViewChannels()()()() | Initializes a new instance of the ListViewChannels class.
Public method | ListViewChannels(AMI_Client) | Initializes a new instance of the ListViewChannels class.

See Also

ListViewChannels Class
ListViewChannels Members


ListViewChannels Constructor

[image]

AMIgo Controls documentation
ListViewChannels Constructor
ListViewChannels Class See Also Send Feedback
Initializes a new instance of the ListViewChannels class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewChannels()
Visual Basic
Public Sub New
Visual C++
public:
ListViewChannels()

See Also

ListViewChannels Class
ListViewChannels Overload


ListViewChannels Constructor (AMI_Client)

[image]

AMIgo Controls documentation
ListViewChannels Constructor (AMI_Client)
ListViewChannels Class See Also Send Feedback
Initializes a new instance of the ListViewChannels class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewChannels(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
ListViewChannels(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AM i_ client instance.

See Also

ListViewChannels Class
ListViewChannels Overload


ListViewChannels Fields

[image] [image]

AMIgo Controls documentation
ListViewChannels Fields
ListViewChannels Class See Also Send Feedback

The ListViewChannels type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewChannels Class


ListViewChannels Methods

[image] [image]

AMIgo Controls documentation
ListViewChannels Methods
ListViewChannels Class See Also Send Feedback

The ListViewChannels type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all items in this control ListView.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the voipChannels SyncList changes. It reflects the change to this control ListView
Public method | RefreshDisplay | Refreshes the display from the AstChannelsList
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | SetView | Sets the view for the control's ListView

See Also

ListViewChannels Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewChannels..::..ClearAll Method
ListViewChannels Class See Also Send Feedback
Clears all items in this control ListView.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewChannels Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewChannels..::..Dispose Method
ListViewChannels Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewChannels Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewChannels..::..GetItemIndexByTagKey Method
ListViewChannels Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewChannels Class
ListViewChannels Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewChannels..::..GetSubItemTextByColumnName Method
ListViewChannels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewChannels Class
ListViewChannels Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewChannels..::..ListChangedEventHandler Method
ListViewChannels Class See Also Send Feedback
This event handler is called when the voipChannels SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewChannels Class


RefreshDisplay Method

[image]

AMIgo Controls documentation
ListViewChannels..::..RefreshDisplay Method
ListViewChannels Class See Also Send Feedback
Refreshes the display from the AstChannelsList

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void RefreshDisplay()
Visual Basic
Public Sub RefreshDisplay
Visual C++
public:
void RefreshDisplay()

See Also

ListViewChannels Class


SetView Method

[image]

AMIgo Controls documentation
ListViewChannels..::..SetView Method
ListViewChannels Class See Also Send Feedback
Sets the view for the control's ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetView(
    View ViewP
)
Visual Basic
Public Sub SetView ( _
    ViewP As View _
)
Visual C++
public:
void SetView(
    View ViewP
)

Parameters

ViewP
Type: System.Windows.Forms..::..View
The view mode(Details / Tile / Large/Small Icons)

See Also

ListViewChannels Class


ListViewChannels Properties

[image] [image]

AMIgo Controls documentation
ListViewChannels Properties
ListViewChannels Class See Also Send Feedback

The ListViewChannels type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | InboundBackColor | Gets or sets the color of background for inbound calls.
Public property | InboundForeColor | Gets or sets the color of the text for inbounds calls.
Public property | InternalBackColor | Gets or sets the color of the background for Internals calls.
Public property | InternalForeColor | Gets or sets the color of the text for Internals calls.
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | OutboundBackColor | Gets or sets the color of the background for outbound calls.
Public property | OutboundForeColor | Gets or sets the color of the text for outbounds calls.
Public property | ShowAgentsChannels | Gets or sets a value indicating whether to show agents channels
Public property | ShowInternalChannels | Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.
Public property | ShowOutboundChannels | Gets or sets a value indicating whether the outbound calls are displayed.
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewChannels Class


InboundBackColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..InboundBackColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of background for inbound calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InboundBackColor { get; set; }
Visual Basic
Public Property InboundBackColor As Color
    Get
    Set
Visual C++
public:
property Color InboundBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


InboundForeColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..InboundForeColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of the text for inbounds calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InboundForeColor { get; set; }
Visual Basic
Public Property InboundForeColor As Color
    Get
    Set
Visual C++
public:
property Color InboundForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


InternalBackColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..InternalBackColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of the background for Internals calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InternalBackColor { get; set; }
Visual Basic
Public Property InternalBackColor As Color
    Get
    Set
Visual C++
public:
property Color InternalBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


InternalForeColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..InternalForeColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of the text for Internals calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color InternalForeColor { get; set; }
Visual Basic
Public Property InternalForeColor As Color
    Get
    Set
Visual C++
public:
property Color InternalForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewChannels..::..LargeImages Property
ListViewChannels Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewChannels Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ListViewBackColor Property
ListViewChannels Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ListViewFont Property
ListViewChannels Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewChannels Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ListViewForeColor Property
ListViewChannels Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


OutboundBackColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..OutboundBackColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of the background for outbound calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color OutboundBackColor { get; set; }
Visual Basic
Public Property OutboundBackColor As Color
    Get
    Set
Visual C++
public:
property Color OutboundBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


OutboundForeColor Property

[image]

AMIgo Controls documentation
ListViewChannels..::..OutboundForeColor Property
ListViewChannels Class See Also Send Feedback
Gets or sets the color of the text for outbounds calls.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color OutboundForeColor { get; set; }
Visual Basic
Public Property OutboundForeColor As Color
    Get
    Set
Visual C++
public:
property Color OutboundForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewChannels Class


ShowAgentsChannels Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ShowAgentsChannels Property
ListViewChannels Class See Also Send Feedback
Gets or sets a value indicating whether to show agents channels

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowAgentsChannels { get; set; }
Visual Basic
Public Property ShowAgentsChannels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowAgentsChannels {
    bool get ();
    void set (bool value);
}

Field Value

true if [show agents channels]; otherwise, false

See Also

ListViewChannels Class


ShowInternalChannels Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ShowInternalChannels Property
ListViewChannels Class See Also Send Feedback
Gets or sets a value indicating whether the internal (inter-extensions) calls are displayed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowInternalChannels { get; set; }
Visual Basic
Public Property ShowInternalChannels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInternalChannels {
    bool get ();
    void set (bool value);
}

Field Value

true to show internal calls, otherwise, false.

See Also

ListViewChannels Class


ShowOutboundChannels Property

[image]

AMIgo Controls documentation
ListViewChannels..::..ShowOutboundChannels Property
ListViewChannels Class See Also Send Feedback
Gets or sets a value indicating whether the outbound calls are displayed.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowOutboundChannels { get; set; }
Visual Basic
Public Property ShowOutboundChannels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowOutboundChannels {
    bool get ();
    void set (bool value);
}

Field Value

true to show outbound calls, otherwise, false.

See Also

ListViewChannels Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewChannels..::..SmallImages Property
ListViewChannels Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewChannels Class


View Property

[image]

AMIgo Controls documentation
ListViewChannels..::..View Property
ListViewChannels Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewChannels Class


ListViewConferences Class

[image]

AMIgo Controls documentation
ListViewConferences Class
Members See Also Send Feedback
This control implements a ListView that display the defined conferences.
This class implement a ListView control to display defined conferences and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewConferences : AMIgoListViewControl
Visual Basic
Public Class ListViewConferences _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewConferences : public AMIgoListViewControl

Remarks

This display reflect the content of the AstConferencesList which contains the conferences definitions and current status information. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Click on the 'New' toolbox button to create a new AstConference. This will open a AMIgoSetupConferenceForm object which display a form that allows to set the agent number, name and options. You can also double click on an item to edit the conference.

Context Menu: Right click on an item to open a Context menu with options to Lock / Unlock a conference.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewConferences

See Also

ListViewConferences Members
AMIgo Namespace
AMIgo..::..AstConference
AMI_Client..::..AstConferencesList
AMI_Client..::..ConferenceEvent


ListViewConferences Members

[image] [image]

AMIgo Controls documentation
ListViewConferences Members
ListViewConferences Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewConferences type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewConferences | Initializes a new instance of the ListViewConferences class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the control ListView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the conference SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewConferences Class


ListViewConferences Constructor

[image]

AMIgo Controls documentation
ListViewConferences Constructor
ListViewConferences Class See Also Send Feedback
Initializes a new instance of the ListViewConferences class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewConferences()
Visual Basic
Public Sub New
Visual C++
public:
ListViewConferences()

See Also

ListViewConferences Class


ListViewConferences Fields

[image] [image]

AMIgo Controls documentation
ListViewConferences Fields
ListViewConferences Class See Also Send Feedback

The ListViewConferences type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferences Class


ListViewConferences Methods

[image] [image]

AMIgo Controls documentation
ListViewConferences Methods
ListViewConferences Class See Also Send Feedback

The ListViewConferences type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the control ListView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the conference SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

See Also

ListViewConferences Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewConferences..::..ClearAll Method
ListViewConferences Class See Also Send Feedback
Clears all of the control ListView items.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewConferences Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewConferences..::..Dispose Method
ListViewConferences Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewConferences Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewConferences..::..GetItemIndexByTagKey Method
ListViewConferences Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferences Class
ListViewConferences Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewConferences..::..GetSubItemTextByColumnName Method
ListViewConferences Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferences Class
ListViewConferences Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewConferences..::..ListChangedEventHandler Method
ListViewConferences Class See Also Send Feedback
This event handler is called when the conference SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewConferences Class


VersionEventHandler Method

[image]

AMIgo Controls documentation
ListViewConferences..::..VersionEventHandler Method
ListViewConferences Class See Also Send Feedback
Handle the VersionEvent and sets the control according to the version connected

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void VersionEventHandler(
    Object sender,
    VersionEventArgs ev
)
Visual Basic
Public Sub VersionEventHandler ( _
    sender As Object, _
    ev As VersionEventArgs _
)
Visual C++
public:
void VersionEventHandler(
    Object^ sender,
    VersionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VersionEventArgs
The VersionEventArgs instance containing the event data.

See Also

ListViewConferences Class


ListViewConferences Properties

[image] [image]

AMIgo Controls documentation
ListViewConferences Properties
ListViewConferences Class See Also Send Feedback

The ListViewConferences type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewConferences Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewConferences..::..LargeImages Property
ListViewConferences Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewConferences Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewConferences..::..ListViewBackColor Property
ListViewConferences Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewConferences Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewConferences..::..ListViewFont Property
ListViewConferences Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewConferences Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewConferences..::..ListViewForeColor Property
ListViewConferences Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewConferences Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewConferences..::..SmallImages Property
ListViewConferences Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewConferences Class


View Property

[image]

AMIgo Controls documentation
ListViewConferences..::..View Property
ListViewConferences Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewConferences Class


ListViewConferenceUsers Class

[image]

AMIgo Controls documentation
ListViewConferenceUsers Class
Members See Also Send Feedback
This controls implements a ListView that display users of the conferences.
This class implement a ListView control to display defined conferences users and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewConferenceUsers : AMIgoListViewControl
Visual Basic
Public Class ListViewConferenceUsers _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewConferenceUsers : public AMIgoListViewControl

Remarks

This display reflect the content of the AstConferenceUsersList which contains the conferences definitions and current status information. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Context Menu: Right click on an item to open a Context menu.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewConferenceUsers

See Also

ListViewConferenceUsers Members
AMIgo Namespace
AMIgo..::..AstConferenceUser
AMI_Client..::..AstConferenceUsersList
AMI_Client..::..ConferenceUserEvent


ListViewConferenceUsers Members

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers Members
ListViewConferenceUsers Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewConferenceUsers type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewConferenceUsers | Initializes a new instance of the ListViewConferenceUsers class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the controls ListView tems.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the conference users SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewConferenceUsers Class


ListViewConferenceUsers Constructor

[image]

AMIgo Controls documentation
ListViewConferenceUsers Constructor
ListViewConferenceUsers Class See Also Send Feedback
Initializes a new instance of the ListViewConferenceUsers class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewConferenceUsers()
Visual Basic
Public Sub New
Visual C++
public:
ListViewConferenceUsers()

See Also

ListViewConferenceUsers Class


ListViewConferenceUsers Fields

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers Fields
ListViewConferenceUsers Class See Also Send Feedback

The ListViewConferenceUsers type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferenceUsers Class


ListViewConferenceUsers Methods

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers Methods
ListViewConferenceUsers Class See Also Send Feedback

The ListViewConferenceUsers type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all of the controls ListView tems.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the conference users SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferenceUsers Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..ClearAll Method
ListViewConferenceUsers Class See Also Send Feedback
Clears all of the controls ListView tems.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewConferenceUsers Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..Dispose Method
ListViewConferenceUsers Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewConferenceUsers Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers..::..GetItemIndexByTagKey Method
ListViewConferenceUsers Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferenceUsers Class
ListViewConferenceUsers Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers..::..GetSubItemTextByColumnName Method
ListViewConferenceUsers Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewConferenceUsers Class
ListViewConferenceUsers Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..ListChangedEventHandler Method
ListViewConferenceUsers Class See Also Send Feedback
This event handler is called when the conference users SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewConferenceUsers Class


ListViewConferenceUsers Properties

[image] [image]

AMIgo Controls documentation
ListViewConferenceUsers Properties
ListViewConferenceUsers Class See Also Send Feedback

The ListViewConferenceUsers type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewConferenceUsers Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..LargeImages Property
ListViewConferenceUsers Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewConferenceUsers Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..ListViewBackColor Property
ListViewConferenceUsers Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewConferenceUsers Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..ListViewFont Property
ListViewConferenceUsers Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewConferenceUsers Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..ListViewForeColor Property
ListViewConferenceUsers Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewConferenceUsers Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..SmallImages Property
ListViewConferenceUsers Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewConferenceUsers Class


View Property

[image]

AMIgo Controls documentation
ListViewConferenceUsers..::..View Property
ListViewConferenceUsers Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewConferenceUsers Class


ListViewLines Class

[image]

AMIgo Controls documentation
ListViewLines Class
Members Example See Also Send Feedback
A UserControl used to display and interact with the 'lines' objects that are defined on the system.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewLines : AMIgoListViewControl
Visual Basic
Public Class ListViewLines _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewLines : public AMIgoListViewControl

Remarks

The ListViewLines display show the extensions, trunks and registrations defined on the connected system. This display reflect the content of the AstUsersObjectsList that is populated by sending AMI commands to get information about the SIP/IAX2 peers / users / registration and the defined Zap / DAHDI channels.

The ListViewLines display allows to show the items in differents layouts, in a similar way than the windows file explorer. The state of the item is shown by different Icons colors: Gray: Not available. Red / Yellow: Busy: Green: Idle

Groups: The items ares displayed under two groups: "Extensions" and "Trunks"

Drag / Drop: You can drag an extension and drop it onto another one to originate a call. You can also drag an extension to the AMIgoDropTarget form to originate a call to the selected destination. (Extension, queue, conference, etc). Active channels from the ListViewChannels can be draged and droped on extensions to Transfer an active call.

Context Menu: Right click on an item to open a Context menu.

AstUsersObjectsList

Examples

USAGE: Just drop the ListViewLine control on your project main form which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call GetLinesInfos()()()() after connection and login to fill the control theZap/DAHDI, SIP and IAX objects defined on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewLines

See Also

ListViewLines Members
AMIgo Namespace
AMIgo..::..AstUsersObject
AMI_Client..::..AstUsersObjectEvent
AMI_Client..::..GetLinesInfos()()()()


ListViewLines Members

[image] [image]

AMIgo Controls documentation
ListViewLines Members
ListViewLines Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewLines type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewLines()()()() | Initializes a new instance of the ListViewLines class.
Public method | ListViewLines(AMI_Client) | Initializes a new instance of the ListViewLines class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears the ListView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when changes are made to the AstUsersObjectsList. It updates the ListView so it reflects the AstUsersObjectsLists.
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | SetView | Sets the view.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | ShowInactiveObjects | Show extensions and trunks that are not active (not registered).
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view.(Details/Tile/Large or small Icons).

See Also

ListViewLines Class


ListViewLines Constructor

[image] [image]

AMIgo Controls documentation
ListViewLines Constructor
ListViewLines Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ListViewLines()()()() | Initializes a new instance of the ListViewLines class.
Public method | ListViewLines(AMI_Client) | Initializes a new instance of the ListViewLines class.

See Also

ListViewLines Class
ListViewLines Members


ListViewLines Constructor

[image]

AMIgo Controls documentation
ListViewLines Constructor
ListViewLines Class See Also Send Feedback
Initializes a new instance of the ListViewLines class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewLines()
Visual Basic
Public Sub New
Visual C++
public:
ListViewLines()

See Also

ListViewLines Class
ListViewLines Overload


ListViewLines Constructor (AMI_Client)

[image]

AMIgo Controls documentation
ListViewLines Constructor (AMI_Client)
ListViewLines Class See Also Send Feedback
Initializes a new instance of the ListViewLines class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewLines(
    AMI_Client AMI_ClientInstance
)
Visual Basic
Public Sub New ( _
    AMI_ClientInstance As AMI_Client _
)
Visual C++
public:
ListViewLines(
    AMI_Client^ AMI_ClientInstance
)

Parameters

AMI_ClientInstance
Type: AMIgo..::..AMI_Client
The AMI_ Client instance.

See Also

ListViewLines Class
ListViewLines Overload


ListViewLines Fields

[image] [image]

AMIgo Controls documentation
ListViewLines Fields
ListViewLines Class See Also Send Feedback

The ListViewLines type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewLines Class


ListViewLines Methods

[image] [image]

AMIgo Controls documentation
ListViewLines Methods
ListViewLines Class See Also Send Feedback

The ListViewLines type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears the ListView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when changes are made to the AstUsersObjectsList. It updates the ListView so it reflects the AstUsersObjectsLists.
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | SetView | Sets the view.

See Also

ListViewLines Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewLines..::..ClearAll Method
ListViewLines Class See Also Send Feedback
Clears the ListView items.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewLines Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewLines..::..Dispose Method
ListViewLines Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewLines Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewLines..::..GetItemIndexByTagKey Method
ListViewLines Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewLines Class
ListViewLines Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewLines..::..GetSubItemTextByColumnName Method
ListViewLines Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewLines Class
ListViewLines Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewLines..::..ListChangedEventHandler Method
ListViewLines Class See Also Send Feedback
This event handler is called when changes are made to the AstUsersObjectsList. It updates the ListView so it reflects the AstUsersObjectsLists.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewLines Class


SetView Method

[image]

AMIgo Controls documentation
ListViewLines..::..SetView Method
ListViewLines Class See Also Send Feedback
Sets the view.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void SetView(
    View ViewP
)
Visual Basic
Public Sub SetView ( _
    ViewP As View _
)
Visual C++
public:
void SetView(
    View ViewP
)

Parameters

ViewP
Type: System.Windows.Forms..::..View
The view to set (Details / Tile / LargeIcons / SmallIcons)

See Also

ListViewLines Class


ListViewLines Properties

[image] [image]

AMIgo Controls documentation
ListViewLines Properties
ListViewLines Class See Also Send Feedback

The ListViewLines type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | ShowInactiveObjects | Show extensions and trunks that are not active (not registered).
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view.(Details/Tile/Large or small Icons).

See Also

ListViewLines Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewLines..::..LargeImages Property
ListViewLines Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewLines Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewLines..::..ListViewBackColor Property
ListViewLines Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewLines Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewLines..::..ListViewFont Property
ListViewLines Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewLines Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewLines..::..ListViewForeColor Property
ListViewLines Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewLines Class


ShowInactiveObjects Property

[image]

AMIgo Controls documentation
ListViewLines..::..ShowInactiveObjects Property
ListViewLines Class See Also Send Feedback
Show extensions and trunks that are not active (not registered).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool ShowInactiveObjects { get; set; }
Visual Basic
Public Property ShowInactiveObjects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInactiveObjects {
    bool get ();
    void set (bool value);
}

See Also

ListViewLines Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewLines..::..SmallImages Property
ListViewLines Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewLines Class


View Property

[image]

AMIgo Controls documentation
ListViewLines..::..View Property
ListViewLines Class See Also Send Feedback
Gets or sets the view.(Details/Tile/Large or small Icons).

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The seleted view.

See Also

ListViewLines Class


ListViewQueueEntries Class

[image]

AMIgo Controls documentation
ListViewQueueEntries Class
Members See Also Send Feedback
This class implement a ListView control to display the current calls waiting in the queues.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewQueueEntries : AMIgoListViewControl
Visual Basic
Public Class ListViewQueueEntries _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewQueueEntries : public AMIgoListViewControl

Remarks

This display reflect the content of the AstQueuesEntriesList which contains the list of queue members (agents or lines) and their statuses. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Drag / Drop: You can drag an agent from the ListView and drop it onto the toolbar to Logoff the agent.

Context Menu: Right click on an item to open a Context menu.

Examples

USAGE: Just drop the ListViewQueueEntries control on your project main form which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call QueueGetStatus()()()() after connection and login to fill the control and display the queues entries (call waiting in the queues) on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewQueueEntries

See Also

ListViewQueueEntries Members
AMIgo Namespace
AMIgo..::..AstQueueEntry
AMI_Client..::..AstQueuesEntriesList
AMI_Client..::..QueueEntryEvent


ListViewQueueEntries Members

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries Members
ListViewQueueEntries Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewQueueEntries type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewQueueEntries | Initializes a new instance of the ListViewQueueEntries class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all the items from this control ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue entries SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueueEntries Class


ListViewQueueEntries Constructor

[image]

AMIgo Controls documentation
ListViewQueueEntries Constructor
ListViewQueueEntries Class See Also Send Feedback
Initializes a new instance of the ListViewQueueEntries class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewQueueEntries()
Visual Basic
Public Sub New
Visual C++
public:
ListViewQueueEntries()

See Also

ListViewQueueEntries Class


ListViewQueueEntries Fields

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries Fields
ListViewQueueEntries Class See Also Send Feedback

The ListViewQueueEntries type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueEntries Class


ListViewQueueEntries Methods

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries Methods
ListViewQueueEntries Class See Also Send Feedback

The ListViewQueueEntries type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears all the items from this control ListView
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue entries SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueEntries Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..ClearAll Method
ListViewQueueEntries Class See Also Send Feedback
Clears all the items from this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewQueueEntries Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..Dispose Method
ListViewQueueEntries Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewQueueEntries Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries..::..GetItemIndexByTagKey Method
ListViewQueueEntries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueEntries Class
ListViewQueueEntries Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries..::..GetSubItemTextByColumnName Method
ListViewQueueEntries Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueEntries Class
ListViewQueueEntries Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..ListChangedEventHandler Method
ListViewQueueEntries Class See Also Send Feedback
This event handler is called when the queue entries SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewQueueEntries Class


ListViewQueueEntries Properties

[image] [image]

AMIgo Controls documentation
ListViewQueueEntries Properties
ListViewQueueEntries Class See Also Send Feedback

The ListViewQueueEntries type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueueEntries Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..LargeImages Property
ListViewQueueEntries Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueueEntries Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..ListViewBackColor Property
ListViewQueueEntries Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueueEntries Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..ListViewFont Property
ListViewQueueEntries Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewQueueEntries Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..ListViewForeColor Property
ListViewQueueEntries Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueueEntries Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..SmallImages Property
ListViewQueueEntries Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueueEntries Class


View Property

[image]

AMIgo Controls documentation
ListViewQueueEntries..::..View Property
ListViewQueueEntries Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewQueueEntries Class


ListViewQueueMembers Class

[image]

AMIgo Controls documentation
ListViewQueueMembers Class
Members See Also Send Feedback
This class implement a ListView control to display queue members and their state.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewQueueMembers : AMIgoListViewControl
Visual Basic
Public Class ListViewQueueMembers _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewQueueMembers : public AMIgoListViewControl

Remarks

This display reflect the content of the AstQueuesMembersList which contains the list of queue members (agents or lines) and their statuses. The ListView display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Drag / Drop: You can drag an agent from the ListView and drop it onto the toolbar to Logoff the agent.

Context Menu: Right click on an item to open a Context menu.

Examples

USAGE: Just drop the ListViewQueueMembers control on your project main form which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call QueueGetStatus()()()() after connection and login to fill the control and display the statuses of the members of queues and defined on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewQueueMembers

See Also

ListViewQueueMembers Members
AMIgo Namespace
AMIgo..::..AstQueueMember
AMI_Client..::..AstQueuesMembersList
AMI_Client..::..QueueMemberEvent


ListViewQueueMembers Members

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers Members
ListViewQueueMembers Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewQueueMembers type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewQueueMembers | Initializes a new instance of the ListViewQueueMembers class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears this control LisView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue members SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueueMembers Class


ListViewQueueMembers Constructor

[image]

AMIgo Controls documentation
ListViewQueueMembers Constructor
ListViewQueueMembers Class See Also Send Feedback
Initializes a new instance of the ListViewQueueMembers class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewQueueMembers()
Visual Basic
Public Sub New
Visual C++
public:
ListViewQueueMembers()

See Also

ListViewQueueMembers Class


ListViewQueueMembers Fields

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers Fields
ListViewQueueMembers Class See Also Send Feedback

The ListViewQueueMembers type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueMembers Class


ListViewQueueMembers Methods

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers Methods
ListViewQueueMembers Class See Also Send Feedback

The ListViewQueueMembers type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears this control LisView items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue members SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueMembers Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..ClearAll Method
ListViewQueueMembers Class See Also Send Feedback
Clears this control LisView items.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewQueueMembers Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..Dispose Method
ListViewQueueMembers Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewQueueMembers Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers..::..GetItemIndexByTagKey Method
ListViewQueueMembers Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueMembers Class
ListViewQueueMembers Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers..::..GetSubItemTextByColumnName Method
ListViewQueueMembers Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueueMembers Class
ListViewQueueMembers Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..ListChangedEventHandler Method
ListViewQueueMembers Class See Also Send Feedback
This event handler is called when the queue members SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewQueueMembers Class


ListViewQueueMembers Properties

[image] [image]

AMIgo Controls documentation
ListViewQueueMembers Properties
ListViewQueueMembers Class See Also Send Feedback

The ListViewQueueMembers type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueueMembers Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..LargeImages Property
ListViewQueueMembers Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueueMembers Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..ListViewBackColor Property
ListViewQueueMembers Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueueMembers Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..ListViewFont Property
ListViewQueueMembers Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewQueueMembers Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..ListViewForeColor Property
ListViewQueueMembers Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueueMembers Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..SmallImages Property
ListViewQueueMembers Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueueMembers Class


View Property

[image]

AMIgo Controls documentation
ListViewQueueMembers..::..View Property
ListViewQueueMembers Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewQueueMembers Class


ListViewQueues Class

[image]

AMIgo Controls documentation
ListViewQueues Class
Members See Also Send Feedback
This class implement a ListView control to display the defined Queues details

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ListViewQueues : AMIgoListViewControl
Visual Basic
Public Class ListViewQueues _
    Inherits AMIgoListViewControl
Visual C++
public ref class ListViewQueues : public AMIgoListViewControl

Remarks

This display reflect the content of the AstQueuesList which contains the queues definitions and parameters. The ListViewQueues display allows to show the items in differents layouts, in a similar way than the windows file explorer.

Drag / Drop: You can drag an agent from the ListViewAgents and drop it onto a queue to add the agent as a member of the queue. You can drag and drop an active channel to a queue to Transfer the caller to the queue.

Click on the 'New' toolbox button to create a new queue. This will open a AMIgoSetupQueueForm object which display a form that allows to set the queue extensions, name and options. You can also double click on an item to edit the queue.

Context Menu: Right click on an item to open a Context menu.

Examples

USAGE: Just drop the ListViewQueues control on your project main form which contains an AMI_Client component. Set the AutoLogin property of the AMI_Client (AutoLogin) to true or call QueueGetStatus()()()() after connection and login to fill the control with the defined queues objects defined on the connected system.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AMIgo..::..AMIgoControl
AMIgo..::..AMIgoListViewControl
AMIgo..::..ListViewQueues

See Also

ListViewQueues Members
AMIgo Namespace
AMIgo..::..AstQueue
AMI_Client..::..AstQueuesList
AMI_Client..::..QueueParamsEvent


ListViewQueues Members

[image] [image]

AMIgo Controls documentation
ListViewQueues Members
ListViewQueues Class Constructors Methods Fields Properties See Also Send Feedback

The ListViewQueues type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewQueues | Initializes a new instance of the ListViewQueues class.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears the ListView Items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueues Class


ListViewQueues Constructor

[image]

AMIgo Controls documentation
ListViewQueues Constructor
ListViewQueues Class See Also Send Feedback
Initializes a new instance of the ListViewQueues class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ListViewQueues()
Visual Basic
Public Sub New
Visual C++
public:
ListViewQueues()

See Also

ListViewQueues Class


ListViewQueues Fields

[image] [image]

AMIgo Controls documentation
ListViewQueues Fields
ListViewQueues Class See Also Send Feedback

The ListViewQueues type exposes the following members.

Fields

 | Name | Description
Public field | _InitDone | true after this control has been initialized. (Inherited from AMIgoControl.)
Public field | AlistView | Points to the descendant ListView control. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueues Class


ListViewQueues Methods

[image] [image]

AMIgo Controls documentation
ListViewQueues Methods
ListViewQueues Class See Also Send Feedback

The ListViewQueues type exposes the following members.

Methods

 | Name | Description
Public method | BeginUpdateListView | Begins the update list view. (Inherited from AMIgoListViewControl.)
Public method | ClearAll | Clears the ListView Items.
Protected method | Dispose | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | EndUpdateListView | Ends the update list view. (Inherited from AMIgoListViewControl.)
Protected method | ExtractFromMsg | Extracts the value of a from an event MSG in the form Param: value (Inherited from AMIgoListViewControl.)
Public method | FindControlRecursive | Finds a Control recursively. Note finds the first match and exits (Inherited from AMIgoControl.)
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | ListChangedEventHandler | This event handler is called when the queue SyncList changes. It reflects the change to this control ListView
Public method | RemoveObject | Removes the given item index from the ListView object. (Inherited from AMIgoListViewControl.)
Public method | VersionEventHandler | Handle the VersionEvent and sets the control according to the version connected

See Also

ListViewQueues Class


ClearAll Method

[image]

AMIgo Controls documentation
ListViewQueues..::..ClearAll Method
ListViewQueues Class See Also Send Feedback
Clears the ListView Items.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll
Visual C++
public:
void ClearAll()

See Also

ListViewQueues Class


Dispose Method

[image]

AMIgo Controls documentation
ListViewQueues..::..Dispose Method
ListViewQueues Class See Also Send Feedback
Clean up any resources being used.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ListViewQueues Class


GetItemIndexByTagKey Method

[image] [image]

AMIgo Controls documentation
ListViewQueues..::..GetItemIndexByTagKey Method
ListViewQueues Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItemIndexByTagKey(Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)
Protected method | GetItemIndexByTagKey(ListView, Int32) | Gets the item index by tag key. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueues Class
ListViewQueues Members


GetSubItemTextByColumnName Method

[image] [image]

AMIgo Controls documentation
ListViewQueues..::..GetSubItemTextByColumnName Method
ListViewQueues Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubItemTextByColumnName(ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)
Public method | GetSubItemTextByColumnName(ListView, ListViewItem, String) | Gets the name of the sub item text by column. (Inherited from AMIgoListViewControl.)

See Also

ListViewQueues Class
ListViewQueues Members


ListChangedEventHandler Method

[image]

AMIgo Controls documentation
ListViewQueues..::..ListChangedEventHandler Method
ListViewQueues Class See Also Send Feedback
This event handler is called when the queue SyncList changes. It reflects the change to this control ListView

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs ev
)
Visual Basic
Public Sub ListChangedEventHandler ( _
    sender As Object, _
    ev As ListChangedEventArgs _
)
Visual C++
public:
void ListChangedEventHandler(
    Object^ sender,
    ListChangedEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

ListViewQueues Class


VersionEventHandler Method

[image]

AMIgo Controls documentation
ListViewQueues..::..VersionEventHandler Method
ListViewQueues Class See Also Send Feedback
Handle the VersionEvent and sets the control according to the version connected

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public void VersionEventHandler(
    Object sender,
    VersionEventArgs ev
)
Visual Basic
Public Sub VersionEventHandler ( _
    sender As Object, _
    ev As VersionEventArgs _
)
Visual C++
public:
void VersionEventHandler(
    Object^ sender,
    VersionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VersionEventArgs
The VersionEventArgs instance containing the event data.

See Also

ListViewQueues Class


ListViewQueues Properties

[image] [image]

AMIgo Controls documentation
ListViewQueues Properties
ListViewQueues Class See Also Send Feedback

The ListViewQueues type exposes the following members.

Properties

 | Name | Description
Public property | AMI_ClientInstance | Gets or sets the AMI_Client instance. The AMI_Client component will set this on startup if left blank. (Inherited from AMIgoControl.)
Public property | LargeImages | Get or set the ListViews images
Public property | ListViewBackColor | Get or set the ListView background color
Public property | ListViewFont | Get or set the ListView font
Public property | ListViewForeColor | Get or set the ListView foreground color
Public property | SmallImages | Get or set the ListViews images
Public property | View | Gets or sets the view mode (Details / Tile / Large/Small icons)

See Also

ListViewQueues Class


LargeImages Property

[image]

AMIgo Controls documentation
ListViewQueues..::..LargeImages Property
ListViewQueues Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList LargeImages { get; set; }
Visual Basic
Public Property LargeImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ LargeImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueues Class


ListViewBackColor Property

[image]

AMIgo Controls documentation
ListViewQueues..::..ListViewBackColor Property
ListViewQueues Class See Also Send Feedback
Get or set the ListView background color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewBackColor { get; set; }
Visual Basic
Public Property ListViewBackColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewBackColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueues Class


ListViewFont Property

[image]

AMIgo Controls documentation
ListViewQueues..::..ListViewFont Property
ListViewQueues Class See Also Send Feedback
Get or set the ListView font

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Font ListViewFont { get; set; }
Visual Basic
Public Property ListViewFont As Font
    Get
    Set
Visual C++
public:
property Font^ ListViewFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ListViewQueues Class


ListViewForeColor Property

[image]

AMIgo Controls documentation
ListViewQueues..::..ListViewForeColor Property
ListViewQueues Class See Also Send Feedback
Get or set the ListView foreground color

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Color ListViewForeColor { get; set; }
Visual Basic
Public Property ListViewForeColor As Color
    Get
    Set
Visual C++
public:
property Color ListViewForeColor {
    Color get ();
    void set (Color value);
}

See Also

ListViewQueues Class


SmallImages Property

[image]

AMIgo Controls documentation
ListViewQueues..::..SmallImages Property
ListViewQueues Class See Also Send Feedback
Get or set the ListViews images

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ImageList SmallImages { get; set; }
Visual Basic
Public Property SmallImages As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ SmallImages {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewQueues Class


View Property

[image]

AMIgo Controls documentation
ListViewQueues..::..View Property
ListViewQueues Class See Also Send Feedback
Gets or sets the view mode (Details / Tile / Large/Small icons)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

Field Value

The view. (Details / Tile / Large/Small icons)

See Also

ListViewQueues Class


ListViewUpdateHandler Delegate

[image]

AMIgo Controls documentation
ListViewUpdateHandler Delegate
See Also Send Feedback
delegate for the List View Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ListViewUpdateHandler()
Visual Basic
Public Delegate Sub ListViewUpdateHandler
Visual C++
public delegate void ListViewUpdateHandler()

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ManagerCommandListHandler Delegate

[image]

AMIgo Controls documentation
ManagerCommandListHandler Delegate
See Also Send Feedback
delegate for the Manage Command List Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ManagerCommandListHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Delegate Sub ManagerCommandListHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public delegate void ManagerCommandListHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the list of manager command.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


MbxCountEventArgs Class

[image]

AMIgo Controls documentation
MbxCountEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Mailbox Count events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class MbxCountEventArgs : EventArgs
Visual Basic
Public Class MbxCountEventArgs _
    Inherits EventArgs
Visual C++
public ref class MbxCountEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..MbxCountEventArgs

See Also

MbxCountEventArgs Members


MbxCountEventArgs Members

[image] [image]

AMIgo Controls documentation
MbxCountEventArgs Members
MbxCountEventArgs Class Constructors Fields See Also Send Feedback

The MbxCountEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MbxCountEventArgs | Initializes a new instance of the MbxCountEventArgs class.

Fields

 | Name | Description
Public field | mailbox | The Mailbox number
Public field | new_msgs_count | The new message count
Public field | old_msgs_count | The old message count

See Also

MbxCountEventArgs Class


MbxCountEventArgs Constructor

[image]

AMIgo Controls documentation
MbxCountEventArgs Constructor
MbxCountEventArgs Class See Also Send Feedback
Initializes a new instance of the MbxCountEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public MbxCountEventArgs(
    string Mailbox,
    int NewMsgsCount,
    int OldMsgsCount
)
Visual Basic
Public Sub New ( _
    Mailbox As String, _
    NewMsgsCount As Integer, _
    OldMsgsCount As Integer _
)
Visual C++
public:
MbxCountEventArgs(
    String^ Mailbox,
    int NewMsgsCount,
    int OldMsgsCount
)

Parameters

Mailbox
Type: System..::..String
The Mailbox.
NewMsgsCount
Type: System..::..Int32
The new MSGS count.
OldMsgsCount
Type: System..::..Int32
The old MSGS count.

See Also

MbxCountEventArgs Class


MbxCountEventArgs Fields

[image] [image]

AMIgo Controls documentation
MbxCountEventArgs Fields
MbxCountEventArgs Class See Also Send Feedback

The MbxCountEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | mailbox | The Mailbox number
Public field | new_msgs_count | The new message count
Public field | old_msgs_count | The old message count

See Also

MbxCountEventArgs Class


mailbox Field

[image]

AMIgo Controls documentation
MbxCountEventArgs..::..mailbox Field
MbxCountEventArgs Class See Also Send Feedback
The Mailbox number

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string mailbox
Visual Basic
Public mailbox As String
Visual C++
public:
String^ mailbox

See Also

MbxCountEventArgs Class


new_msgs_count Field

[image]

AMIgo Controls documentation
MbxCountEventArgs..::..new_msgs_count Field
MbxCountEventArgs Class See Also Send Feedback
The new message count

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int new_msgs_count
Visual Basic
Public new_msgs_count As Integer
Visual C++
public:
int new_msgs_count

See Also

MbxCountEventArgs Class


old_msgs_count Field

[image]

AMIgo Controls documentation
MbxCountEventArgs..::..old_msgs_count Field
MbxCountEventArgs Class See Also Send Feedback
The old message count

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int old_msgs_count
Visual Basic
Public old_msgs_count As Integer
Visual C++
public:
int old_msgs_count

See Also

MbxCountEventArgs Class


MbxCountHandler Delegate

[image]

AMIgo Controls documentation
MbxCountHandler Delegate
See Also Send Feedback
delegate for the MailboxCount Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void MbxCountHandler(
    Object sender,
    MbxCountEventArgs ev
)
Visual Basic
Public Delegate Sub MbxCountHandler ( _
    sender As Object, _
    ev As MbxCountEventArgs _
)
Visual C++
public delegate void MbxCountHandler(
    Object^ sender,
    MbxCountEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..MbxCountEventArgs
The MbxCountEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


NewCallEventArgs Class

[image]

AMIgo Controls documentation
NewCallEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Calls events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class NewCallEventArgs : EventArgs
Visual Basic
Public Class NewCallEventArgs _
    Inherits EventArgs
Visual C++
public ref class NewCallEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..NewCallEventArgs

See Also

NewCallEventArgs Members


NewCallEventArgs Members

[image] [image]

AMIgo Controls documentation
NewCallEventArgs Members
NewCallEventArgs Class Constructors Fields See Also Send Feedback

The NewCallEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | NewCallEventArgs | Initializes a new instance of the NewCallEventArgs class.

Fields

 | Name | Description
Public field | call_type | The Call Type: Inbound, Outbound, Internal
Public field | dst_caller_id | Dest CallerID
Public field | dst_channel | Dest Channel
Public field | dst_unique_id | Dest Unique Id
Public field | src_caller_id | Source CallerID
Public field | src_channel | Source Channel
Public field | src_unique_id | Source Unique Id
Public field | timestamp | Unix timestamp

See Also

NewCallEventArgs Class


NewCallEventArgs Constructor

[image]

AMIgo Controls documentation
NewCallEventArgs Constructor
NewCallEventArgs Class See Also Send Feedback
Initializes a new instance of the NewCallEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public NewCallEventArgs(
    CallType CallType,
    string SrcChannel,
    string DstChannel,
    string SrcCallerId,
    string DstCallerId,
    string SrcUniqueId,
    string DstUniqueId,
    string TimeStamp
)
Visual Basic
Public Sub New ( _
    CallType As CallType, _
    SrcChannel As String, _
    DstChannel As String, _
    SrcCallerId As String, _
    DstCallerId As String, _
    SrcUniqueId As String, _
    DstUniqueId As String, _
    TimeStamp As String _
)
Visual C++
public:
NewCallEventArgs(
    CallType CallType,
    String^ SrcChannel,
    String^ DstChannel,
    String^ SrcCallerId,
    String^ DstCallerId,
    String^ SrcUniqueId,
    String^ DstUniqueId,
    String^ TimeStamp
)

Parameters

CallType
Type: AMIgo..::..CallType
The Call Type: Inbound / Outbound / Internal
SrcChannel
Type: System..::..String
The SRC channel.
DstChannel
Type: System..::..String
The DST channel.
SrcCallerId
Type: System..::..String
The SRC caller id.
DstCallerId
Type: System..::..String
The DST caller id.
SrcUniqueId
Type: System..::..String
The SRC unique id.
DstUniqueId
Type: System..::..String
The DST unique id.
TimeStamp
Type: System..::..String
The time stamp.

See Also

NewCallEventArgs Class


NewCallEventArgs Fields

[image] [image]

AMIgo Controls documentation
NewCallEventArgs Fields
NewCallEventArgs Class See Also Send Feedback

The NewCallEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | call_type | The Call Type: Inbound, Outbound, Internal
Public field | dst_caller_id | Dest CallerID
Public field | dst_channel | Dest Channel
Public field | dst_unique_id | Dest Unique Id
Public field | src_caller_id | Source CallerID
Public field | src_channel | Source Channel
Public field | src_unique_id | Source Unique Id
Public field | timestamp | Unix timestamp

See Also

NewCallEventArgs Class


call_type Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..call_type Field
NewCallEventArgs Class See Also Send Feedback
The Call Type: Inbound, Outbound, Internal

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public CallType call_type
Visual Basic
Public call_type As CallType
Visual C++
public:
CallType call_type

See Also

NewCallEventArgs Class


dst_caller_id Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..dst_caller_id Field
NewCallEventArgs Class See Also Send Feedback
Dest CallerID

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string dst_caller_id
Visual Basic
Public dst_caller_id As String
Visual C++
public:
String^ dst_caller_id

See Also

NewCallEventArgs Class


dst_channel Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..dst_channel Field
NewCallEventArgs Class See Also Send Feedback
Dest Channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string dst_channel
Visual Basic
Public dst_channel As String
Visual C++
public:
String^ dst_channel

See Also

NewCallEventArgs Class


dst_unique_id Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..dst_unique_id Field
NewCallEventArgs Class See Also Send Feedback
Dest Unique Id

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string dst_unique_id
Visual Basic
Public dst_unique_id As String
Visual C++
public:
String^ dst_unique_id

See Also

NewCallEventArgs Class


src_caller_id Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..src_caller_id Field
NewCallEventArgs Class See Also Send Feedback
Source CallerID

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string src_caller_id
Visual Basic
Public src_caller_id As String
Visual C++
public:
String^ src_caller_id

See Also

NewCallEventArgs Class


src_channel Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..src_channel Field
NewCallEventArgs Class See Also Send Feedback
Source Channel

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string src_channel
Visual Basic
Public src_channel As String
Visual C++
public:
String^ src_channel

See Also

NewCallEventArgs Class


src_unique_id Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..src_unique_id Field
NewCallEventArgs Class See Also Send Feedback
Source Unique Id

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string src_unique_id
Visual Basic
Public src_unique_id As String
Visual C++
public:
String^ src_unique_id

See Also

NewCallEventArgs Class


timestamp Field

[image]

AMIgo Controls documentation
NewCallEventArgs..::..timestamp Field
NewCallEventArgs Class See Also Send Feedback
Unix timestamp

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string timestamp
Visual Basic
Public timestamp As String
Visual C++
public:
String^ timestamp

See Also

NewCallEventArgs Class


NewCallEventHandler Delegate

[image]

AMIgo Controls documentation
NewCallEventHandler Delegate
See Also Send Feedback
delegate for the NewCall Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void NewCallEventHandler(
    Object sender,
    NewCallEventArgs ev
)
Visual Basic
Public Delegate Sub NewCallEventHandler ( _
    sender As Object, _
    ev As NewCallEventArgs _
)
Visual C++
public delegate void NewCallEventHandler(
    Object^ sender,
    NewCallEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..NewCallEventArgs
The NewCallEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ObjectType Enumeration

[image]

AMIgo Controls documentation
ObjectType Enumeration
See Also Send Feedback
Enums for Object type. Used to define the type of objects in ListViews etc ...

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public enum ObjectType
Visual Basic
Public Enumeration ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Value | Description
AstUsersObject | 0 | An extension (peer), Zap/DAHDI Channel, SIP / IAX regisrtrationAstUsersObject
AstChannel | 1 | An active channel. AstChannel
AstCall | 2 | A call object. CDR
AstQueue | 3 | A Queue Param Object. AstQueue
AstQueueMember | 4 | A Queue Member object AstQueueMember
AstQueueEntry | 5 | A Queue Entry object AstQueueEntry
AstAgent | 6 | An Agent object AstAgent
AstAgentCall | 7 | An Agent AstCall object AstAgentCall
AstConference | 8 | An AstConference object AstConference
AstConferenceUser | 9 | An AstConference User object AstConferenceUser

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


OriginateEventArgs Class

[image]

AMIgo Controls documentation
OriginateEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for the originate response.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class OriginateEventArgs : EventArgs
Visual Basic
Public Class OriginateEventArgs _
    Inherits EventArgs
Visual C++
public ref class OriginateEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..OriginateEventArgs

See Also

OriginateEventArgs Members


OriginateEventArgs Members

[image] [image]

AMIgo Controls documentation
OriginateEventArgs Members
OriginateEventArgs Class Constructors Fields See Also Send Feedback

The OriginateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | OriginateEventArgs | Initializes a new instance of the OriginateEventArgs class.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | response | An OriginateResponse struc containing the originate response

See Also

OriginateEventArgs Class


OriginateEventArgs Constructor

[image]

AMIgo Controls documentation
OriginateEventArgs Constructor
OriginateEventArgs Class See Also Send Feedback
Initializes a new instance of the OriginateEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public OriginateEventArgs(
    string[] EventStrs,
    OriginateResponse Response
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Response As OriginateResponse _
)
Visual C++
public:
OriginateEventArgs(
    array<String^>^ EventStrs,
    OriginateResponse^ Response
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Response
Type: AMIgo..::..OriginateResponse
The response.

See Also

OriginateEventArgs Class


OriginateEventArgs Fields

[image] [image]

AMIgo Controls documentation
OriginateEventArgs Fields
OriginateEventArgs Class See Also Send Feedback

The OriginateEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | response | An OriginateResponse struc containing the originate response

See Also

OriginateEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
OriginateEventArgs..::..event_strs Field
OriginateEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

OriginateEventArgs Class


response Field

[image]

AMIgo Controls documentation
OriginateEventArgs..::..response Field
OriginateEventArgs Class See Also Send Feedback
An OriginateResponse struc containing the originate response

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public OriginateResponse response
Visual Basic
Public response As OriginateResponse
Visual C++
public:
OriginateResponse^ response

See Also

OriginateEventArgs Class


OriginateResponse Class

[image]

AMIgo Controls documentation
OriginateResponse Class
Members See Also Send Feedback
This class is the base for the originate response message

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class OriginateResponse
Visual Basic
Public Class OriginateResponse
Visual C++
public ref class OriginateResponse

Inheritance Hierarchy

System..::..Object
AMIgo..::..OriginateResponse

See Also

OriginateResponse Members


OriginateResponse Members

[image] [image]

AMIgo Controls documentation
OriginateResponse Members
OriginateResponse Class Constructors Fields Properties See Also Send Feedback

The OriginateResponse type exposes the following members.

Constructors

 | Name | Description
Public method | OriginateResponse()()()() | Initializes a new instance of the OriginateResponse class.
Public method | OriginateResponse(String, String, String, String, String, String, String, Int32) | Initializes a new instance of the OriginateResponse class.

Fields

 | Name | Description
Public field | result | The result of the originate operation

Properties

 | Name | Description
Public property | channel | The channel used in the originate call.
Public property | context | The dialplan Context
Public property | extension | The dialplan extension
Public property | reason | A reason text
Public property | response | The response text
Public property | timeStamp | The timestamp for the response
Public property | uniqueid | The unique id for this call

See Also

OriginateResponse Class


OriginateResponse Constructor

[image] [image]

AMIgo Controls documentation
OriginateResponse Constructor
OriginateResponse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OriginateResponse()()()() | Initializes a new instance of the OriginateResponse class.
Public method | OriginateResponse(String, String, String, String, String, String, String, Int32) | Initializes a new instance of the OriginateResponse class.

See Also

OriginateResponse Class
OriginateResponse Members


OriginateResponse Constructor

[image]

AMIgo Controls documentation
OriginateResponse Constructor
OriginateResponse Class See Also Send Feedback
Initializes a new instance of the OriginateResponse class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public OriginateResponse()
Visual Basic
Public Sub New
Visual C++
public:
OriginateResponse()

See Also

OriginateResponse Class
OriginateResponse Overload


OriginateResponse Constructor (String, String, String, String, String, String, String, Int32)

[image]

AMIgo Controls documentation
OriginateResponse Constructor (String, String, String, String, String, String, String, Int32)
OriginateResponse Class See Also Send Feedback
Initializes a new instance of the OriginateResponse class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public OriginateResponse(
    string TimeStamp,
    string Response,
    string Channel,
    string Context,
    string Extension,
    string Reason,
    string Uniqueid,
    int Result
)
Visual Basic
Public Sub New ( _
    TimeStamp As String, _
    Response As String, _
    Channel As String, _
    Context As String, _
    Extension As String, _
    Reason As String, _
    Uniqueid As String, _
    Result As Integer _
)
Visual C++
public:
OriginateResponse(
    String^ TimeStamp,
    String^ Response,
    String^ Channel,
    String^ Context,
    String^ Extension,
    String^ Reason,
    String^ Uniqueid,
    int Result
)

Parameters

TimeStamp
Type: System..::..String
The time stamp.
Response
Type: System..::..String
The response.
Channel
Type: System..::..String
The channel.
Context
Type: System..::..String
The context.
Extension
Type: System..::..String
The extension.
Reason
Type: System..::..String
The reason.
Uniqueid
Type: System..::..String
The uniqueid.
Result
Type: System..::..Int32
The result.

See Also

OriginateResponse Class
OriginateResponse Overload


OriginateResponse Fields

[image] [image]

AMIgo Controls documentation
OriginateResponse Fields
OriginateResponse Class See Also Send Feedback

The OriginateResponse type exposes the following members.

Fields

 | Name | Description
Public field | result | The result of the originate operation

See Also

OriginateResponse Class


result Field

[image]

AMIgo Controls documentation
OriginateResponse..::..result Field
OriginateResponse Class See Also Send Feedback
The result of the originate operation

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int result
Visual Basic
Public result As Integer
Visual C++
public:
int result

See Also

OriginateResponse Class


OriginateResponse Properties

[image] [image]

AMIgo Controls documentation
OriginateResponse Properties
OriginateResponse Class See Also Send Feedback

The OriginateResponse type exposes the following members.

Properties

 | Name | Description
Public property | channel | The channel used in the originate call.
Public property | context | The dialplan Context
Public property | extension | The dialplan extension
Public property | reason | A reason text
Public property | response | The response text
Public property | timeStamp | The timestamp for the response
Public property | uniqueid | The unique id for this call

See Also

OriginateResponse Class


channel Property

[image]

AMIgo Controls documentation
OriginateResponse..::..channel Property
OriginateResponse Class See Also Send Feedback
The channel used in the originate call.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string channel { get; set; }
Visual Basic
Public Property channel As String
    Get
    Set
Visual C++
public:
property String^ channel {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


context Property

[image]

AMIgo Controls documentation
OriginateResponse..::..context Property
OriginateResponse Class See Also Send Feedback
The dialplan Context

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string context { get; set; }
Visual Basic
Public Property context As String
    Get
    Set
Visual C++
public:
property String^ context {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


extension Property

[image]

AMIgo Controls documentation
OriginateResponse..::..extension Property
OriginateResponse Class See Also Send Feedback
The dialplan extension

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string extension { get; set; }
Visual Basic
Public Property extension As String
    Get
    Set
Visual C++
public:
property String^ extension {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


reason Property

[image]

AMIgo Controls documentation
OriginateResponse..::..reason Property
OriginateResponse Class See Also Send Feedback
A reason text

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string reason { get; set; }
Visual Basic
Public Property reason As String
    Get
    Set
Visual C++
public:
property String^ reason {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


response Property

[image]

AMIgo Controls documentation
OriginateResponse..::..response Property
OriginateResponse Class See Also Send Feedback
The response text

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string response { get; set; }
Visual Basic
Public Property response As String
    Get
    Set
Visual C++
public:
property String^ response {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


timeStamp Property

[image]

AMIgo Controls documentation
OriginateResponse..::..timeStamp Property
OriginateResponse Class See Also Send Feedback
The timestamp for the response

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string timeStamp { get; set; }
Visual Basic
Public Property timeStamp As String
    Get
    Set
Visual C++
public:
property String^ timeStamp {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


uniqueid Property

[image]

AMIgo Controls documentation
OriginateResponse..::..uniqueid Property
OriginateResponse Class See Also Send Feedback
The unique id for this call

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string uniqueid { get; set; }
Visual Basic
Public Property uniqueid As String
    Get
    Set
Visual C++
public:
property String^ uniqueid {
    String^ get ();
    void set (String^ value);
}

See Also

OriginateResponse Class


OriginateResultEventHandler Delegate

[image]

AMIgo Controls documentation
OriginateResultEventHandler Delegate
See Also Send Feedback
delegate for the Originate response Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void OriginateResultEventHandler(
    Object sender,
    OriginateEventArgs ev
)
Visual Basic
Public Delegate Sub OriginateResultEventHandler ( _
    sender As Object, _
    ev As OriginateEventArgs _
)
Visual C++
public delegate void OriginateResultEventHandler(
    Object^ sender,
    OriginateEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..OriginateEventArgs
The OriginateEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


QueueEntryEventArgs Class

[image]

AMIgo Controls documentation
QueueEntryEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Queue Entries

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class QueueEntryEventArgs : EventArgs
Visual Basic
Public Class QueueEntryEventArgs _
    Inherits EventArgs
Visual C++
public ref class QueueEntryEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..QueueEntryEventArgs

See Also

QueueEntryEventArgs Members


QueueEntryEventArgs Members

[image] [image]

AMIgo Controls documentation
QueueEntryEventArgs Members
QueueEntryEventArgs Class Constructors Fields See Also Send Feedback

The QueueEntryEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueueEntryEventArgs | Initializes a new instance of the QueueEntryEventArgs class.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_entry | An AstQueueEntry struc containing the queue entry, that is a call waiting in the queue.

See Also

QueueEntryEventArgs Class


QueueEntryEventArgs Constructor

[image]

AMIgo Controls documentation
QueueEntryEventArgs Constructor
QueueEntryEventArgs Class See Also Send Feedback
Initializes a new instance of the QueueEntryEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public QueueEntryEventArgs(
    string[] EventStrs,
    AstQueueEntry Entry
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Entry As AstQueueEntry _
)
Visual C++
public:
QueueEntryEventArgs(
    array<String^>^ EventStrs,
    AstQueueEntry^ Entry
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Entry
Type: AMIgo..::..AstQueueEntry
The entry.

See Also

QueueEntryEventArgs Class


QueueEntryEventArgs Fields

[image] [image]

AMIgo Controls documentation
QueueEntryEventArgs Fields
QueueEntryEventArgs Class See Also Send Feedback

The QueueEntryEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_entry | An AstQueueEntry struc containing the queue entry, that is a call waiting in the queue.

See Also

QueueEntryEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
QueueEntryEventArgs..::..event_strs Field
QueueEntryEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

QueueEntryEventArgs Class


queue_entry Field

[image]

AMIgo Controls documentation
QueueEntryEventArgs..::..queue_entry Field
QueueEntryEventArgs Class See Also Send Feedback
An AstQueueEntry struc containing the queue entry, that is a call waiting in the queue.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueueEntry queue_entry
Visual Basic
Public queue_entry As AstQueueEntry
Visual C++
public:
AstQueueEntry^ queue_entry

See Also

QueueEntryEventArgs Class


QueueEntryEventHandler Delegate

[image]

AMIgo Controls documentation
QueueEntryEventHandler Delegate
See Also Send Feedback
delegate for the Queue Entry Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void QueueEntryEventHandler(
    Object sender,
    QueueEntryEventArgs ev
)
Visual Basic
Public Delegate Sub QueueEntryEventHandler ( _
    sender As Object, _
    ev As QueueEntryEventArgs _
)
Visual C++
public delegate void QueueEntryEventHandler(
    Object^ sender,
    QueueEntryEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..QueueEntryEventArgs
The QueueEntryEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


QueueMemberEventArgs Class

[image]

AMIgo Controls documentation
QueueMemberEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Queue Members events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class QueueMemberEventArgs : EventArgs
Visual Basic
Public Class QueueMemberEventArgs _
    Inherits EventArgs
Visual C++
public ref class QueueMemberEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..QueueMemberEventArgs

See Also

QueueMemberEventArgs Members


QueueMemberEventArgs Members

[image] [image]

AMIgo Controls documentation
QueueMemberEventArgs Members
QueueMemberEventArgs Class Constructors Fields See Also Send Feedback

The QueueMemberEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueueMemberEventArgs | Initializes a new instance of the QueueMemberEventArgs class.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_member | A AstQueueMember struc containing infos about the member.

See Also

QueueMemberEventArgs Class


QueueMemberEventArgs Constructor

[image]

AMIgo Controls documentation
QueueMemberEventArgs Constructor
QueueMemberEventArgs Class See Also Send Feedback
Initializes a new instance of the QueueMemberEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public QueueMemberEventArgs(
    string[] EventStrs,
    AstQueueMember Member
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Member As AstQueueMember _
)
Visual C++
public:
QueueMemberEventArgs(
    array<String^>^ EventStrs,
    AstQueueMember^ Member
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Member
Type: AMIgo..::..AstQueueMember
The member.

See Also

QueueMemberEventArgs Class


QueueMemberEventArgs Fields

[image] [image]

AMIgo Controls documentation
QueueMemberEventArgs Fields
QueueMemberEventArgs Class See Also Send Feedback

The QueueMemberEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_member | A AstQueueMember struc containing infos about the member.

See Also

QueueMemberEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
QueueMemberEventArgs..::..event_strs Field
QueueMemberEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

QueueMemberEventArgs Class


queue_member Field

[image]

AMIgo Controls documentation
QueueMemberEventArgs..::..queue_member Field
QueueMemberEventArgs Class See Also Send Feedback
A AstQueueMember struc containing infos about the member.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueueMember queue_member
Visual Basic
Public queue_member As AstQueueMember
Visual C++
public:
AstQueueMember^ queue_member

See Also

QueueMemberEventArgs Class


QueueMemberEventHandler Delegate

[image]

AMIgo Controls documentation
QueueMemberEventHandler Delegate
See Also Send Feedback
delegate for the Queue Member Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void QueueMemberEventHandler(
    Object sender,
    QueueMemberEventArgs ev
)
Visual Basic
Public Delegate Sub QueueMemberEventHandler ( _
    sender As Object, _
    ev As QueueMemberEventArgs _
)
Visual C++
public delegate void QueueMemberEventHandler(
    Object^ sender,
    QueueMemberEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..QueueMemberEventArgs
The QueueMemberEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


QueueMemberStatus Enumeration

[image]

AMIgo Controls documentation
QueueMemberStatus Enumeration
See Also Send Feedback
Statuses of queue members

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public enum QueueMemberStatus
Visual Basic
Public Enumeration QueueMemberStatus
Visual C++
public enum class QueueMemberStatus

Members

Member name | Value | Description
DEVICE_UNKNOWN | 0 | Device state is unknown
DEVICE_NOT_INUSE | 1 | Device is not used
DEVICE_INUSE | 2 | Device is in use
DEVICE_BUSY | 3 | Device is busy
DEVICE_INVALID | 4 | Device is invalid
DEVICE_UNAVAILABLE | 5 | Device is unavailable
DEVICE_RINGING | 6 | Device is ringing
DEVICE_RINGINUSE | 7 | Device is ringing *and* in use
DEVICE_ONHOLD | 8 | Device is on hold

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


QueueParamsEventArgs Class

[image]

AMIgo Controls documentation
QueueParamsEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Queue events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class QueueParamsEventArgs : EventArgs
Visual Basic
Public Class QueueParamsEventArgs _
    Inherits EventArgs
Visual C++
public ref class QueueParamsEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..QueueParamsEventArgs

See Also

QueueParamsEventArgs Members


QueueParamsEventArgs Members

[image] [image]

AMIgo Controls documentation
QueueParamsEventArgs Members
QueueParamsEventArgs Class Constructors Fields See Also Send Feedback

The QueueParamsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueueParamsEventArgs | Initializes a new instance of the QueueParamsEventArgs class.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_params | A AstQueue struct containing the config. info of the queue

See Also

QueueParamsEventArgs Class


QueueParamsEventArgs Constructor

[image]

AMIgo Controls documentation
QueueParamsEventArgs Constructor
QueueParamsEventArgs Class See Also Send Feedback
Initializes a new instance of the QueueParamsEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public QueueParamsEventArgs(
    string[] EventStrs,
    AstQueue Params
)
Visual Basic
Public Sub New ( _
    EventStrs As String(), _
    Params As AstQueue _
)
Visual C++
public:
QueueParamsEventArgs(
    array<String^>^ EventStrs,
    AstQueue^ Params
)

Parameters

EventStrs
Type: array< System..::..String >[]()[][]
The event STRS.
Params
Type: AMIgo..::..AstQueue
The params.

See Also

QueueParamsEventArgs Class


QueueParamsEventArgs Fields

[image] [image]

AMIgo Controls documentation
QueueParamsEventArgs Fields
QueueParamsEventArgs Class See Also Send Feedback

The QueueParamsEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | event_strs | The raw event strings
Public field | queue_params | A AstQueue struct containing the config. info of the queue

See Also

QueueParamsEventArgs Class


event_strs Field

[image]

AMIgo Controls documentation
QueueParamsEventArgs..::..event_strs Field
QueueParamsEventArgs Class See Also Send Feedback
The raw event strings

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] event_strs
Visual Basic
Public event_strs As String()
Visual C++
public:
array<String^>^ event_strs

See Also

QueueParamsEventArgs Class


queue_params Field

[image]

AMIgo Controls documentation
QueueParamsEventArgs..::..queue_params Field
QueueParamsEventArgs Class See Also Send Feedback
A AstQueue struct containing the config. info of the queue

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AstQueue queue_params
Visual Basic
Public queue_params As AstQueue
Visual C++
public:
AstQueue^ queue_params

See Also

QueueParamsEventArgs Class


QueueParamsEventHandler Delegate

[image]

AMIgo Controls documentation
QueueParamsEventHandler Delegate
See Also Send Feedback
delegate for the Queue Params Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void QueueParamsEventHandler(
    Object sender,
    QueueParamsEventArgs ev
)
Visual Basic
Public Delegate Sub QueueParamsEventHandler ( _
    sender As Object, _
    ev As QueueParamsEventArgs _
)
Visual C++
public delegate void QueueParamsEventHandler(
    Object^ sender,
    QueueParamsEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..QueueParamsEventArgs
The QueueParamsEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


RawMngrMsgEventArgs Class

[image]

AMIgo Controls documentation
RawMngrMsgEventArgs Class
Members See Also Send Feedback
Custom EventArgs used to for 'raw message' events (send the message as received from the AMI)

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class RawMngrMsgEventArgs : EventArgs
Visual Basic
Public Class RawMngrMsgEventArgs _
    Inherits EventArgs
Visual C++
public ref class RawMngrMsgEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..RawMngrMsgEventArgs

See Also

RawMngrMsgEventArgs Members


RawMngrMsgEventArgs Members

[image] [image]

AMIgo Controls documentation
RawMngrMsgEventArgs Members
RawMngrMsgEventArgs Class Constructors Fields See Also Send Feedback

The RawMngrMsgEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RawMngrMsgEventArgs | Initializes a new instance of the RawMngrMsgEventArgs class.

Fields

 | Name | Description
Public field | strings | The AMI response message as an array of strings.

See Also

RawMngrMsgEventArgs Class


RawMngrMsgEventArgs Constructor

[image]

AMIgo Controls documentation
RawMngrMsgEventArgs Constructor
RawMngrMsgEventArgs Class See Also Send Feedback
Initializes a new instance of the RawMngrMsgEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public RawMngrMsgEventArgs(
    string[] Strings
)
Visual Basic
Public Sub New ( _
    Strings As String() _
)
Visual C++
public:
RawMngrMsgEventArgs(
    array<String^>^ Strings
)

Parameters

Strings
Type: array< System..::..String >[]()[][]
The AMI response message as an array of strings.

See Also

RawMngrMsgEventArgs Class


RawMngrMsgEventArgs Fields

[image] [image]

AMIgo Controls documentation
RawMngrMsgEventArgs Fields
RawMngrMsgEventArgs Class See Also Send Feedback

The RawMngrMsgEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | strings | The AMI response message as an array of strings.

See Also

RawMngrMsgEventArgs Class


strings Field

[image]

AMIgo Controls documentation
RawMngrMsgEventArgs..::..strings Field
RawMngrMsgEventArgs Class See Also Send Feedback
The AMI response message as an array of strings.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string[] strings
Visual Basic
Public strings As String()
Visual C++
public:
array<String^>^ strings

See Also

RawMngrMsgEventArgs Class


RawMngrMsgHandler Delegate

[image]

AMIgo Controls documentation
RawMngrMsgHandler Delegate
See Also Send Feedback
delegate for the 'raw message' Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void RawMngrMsgHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Delegate Sub RawMngrMsgHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public delegate void RawMngrMsgHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


ShutdownEventArgs Class

[image]

AMIgo Controls documentation
ShutdownEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for Shutdown events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class ShutdownEventArgs : EventArgs
Visual Basic
Public Class ShutdownEventArgs _
    Inherits EventArgs
Visual C++
public ref class ShutdownEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..ShutdownEventArgs

See Also

ShutdownEventArgs Members


ShutdownEventArgs Members

[image] [image]

AMIgo Controls documentation
ShutdownEventArgs Members
ShutdownEventArgs Class Constructors Fields See Also Send Feedback

The ShutdownEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ShutdownEventArgs | Initializes a new instance of the ShutdownEventArgs class.

Fields

 | Name | Description
Public field | restart | Indication wheter a restart will follow
Public field | shutdown | The shutdown message / cause

See Also

ShutdownEventArgs Class


ShutdownEventArgs Constructor

[image]

AMIgo Controls documentation
ShutdownEventArgs Constructor
ShutdownEventArgs Class See Also Send Feedback
Initializes a new instance of the ShutdownEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ShutdownEventArgs(
    string Shutdown,
    string Restart
)
Visual Basic
Public Sub New ( _
    Shutdown As String, _
    Restart As String _
)
Visual C++
public:
ShutdownEventArgs(
    String^ Shutdown,
    String^ Restart
)

Parameters

Shutdown
Type: System..::..String
The shutdown.
Restart
Type: System..::..String
The restart.

See Also

ShutdownEventArgs Class


ShutdownEventArgs Fields

[image] [image]

AMIgo Controls documentation
ShutdownEventArgs Fields
ShutdownEventArgs Class See Also Send Feedback

The ShutdownEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | restart | Indication wheter a restart will follow
Public field | shutdown | The shutdown message / cause

See Also

ShutdownEventArgs Class


restart Field

[image]

AMIgo Controls documentation
ShutdownEventArgs..::..restart Field
ShutdownEventArgs Class See Also Send Feedback
Indication wheter a restart will follow

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string restart
Visual Basic
Public restart As String
Visual C++
public:
String^ restart

See Also

ShutdownEventArgs Class


shutdown Field

[image]

AMIgo Controls documentation
ShutdownEventArgs..::..shutdown Field
ShutdownEventArgs Class See Also Send Feedback
The shutdown message / cause

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string shutdown
Visual Basic
Public shutdown As String
Visual C++
public:
String^ shutdown

See Also

ShutdownEventArgs Class


ShutdownEventHandler Delegate

[image]

AMIgo Controls documentation
ShutdownEventHandler Delegate
See Also Send Feedback
delegate for the ShutDown Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void ShutdownEventHandler(
    Object sender,
    ShutdownEventArgs ev
)
Visual Basic
Public Delegate Sub ShutdownEventHandler ( _
    sender As Object, _
    ev As ShutdownEventArgs _
)
Visual C++
public delegate void ShutdownEventHandler(
    Object^ sender,
    ShutdownEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..ShutdownEventArgs
The ShutdownEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


StateChangeEventArgs Class

[image]

AMIgo Controls documentation
StateChangeEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for State Changes events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class StateChangeEventArgs : EventArgs
Visual Basic
Public Class StateChangeEventArgs _
    Inherits EventArgs
Visual C++
public ref class StateChangeEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..StateChangeEventArgs

See Also

StateChangeEventArgs Members


StateChangeEventArgs Members

[image] [image]

AMIgo Controls documentation
StateChangeEventArgs Members
StateChangeEventArgs Class Constructors Fields See Also Send Feedback

The StateChangeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StateChangeEventArgs | Initializes a new instance of the StateChangeEventArgs class.

Fields

 | Name | Description
Public field | state | The AMI client state. Ex: "Idle, connected, logged, etc"
Public field | string_msg | A message describing the new state

See Also

StateChangeEventArgs Class


StateChangeEventArgs Constructor

[image]

AMIgo Controls documentation
StateChangeEventArgs Constructor
StateChangeEventArgs Class See Also Send Feedback
Initializes a new instance of the StateChangeEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public StateChangeEventArgs(
    AMI_Client..::..AMI_ClientState State,
    string StatusMsg
)
Visual Basic
Public Sub New ( _
    State As AMI_Client..::..AMI_ClientState, _
    StatusMsg As String _
)
Visual C++
public:
StateChangeEventArgs(
    AMI_Client..::..AMI_ClientState State,
    String^ StatusMsg
)

Parameters

State
Type: AMIgo..::..AMI_Client..::..AMI_ClientState
The state.
StatusMsg
Type: System..::..String
The status MSG.

See Also

StateChangeEventArgs Class


StateChangeEventArgs Fields

[image] [image]

AMIgo Controls documentation
StateChangeEventArgs Fields
StateChangeEventArgs Class See Also Send Feedback

The StateChangeEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | state | The AMI client state. Ex: "Idle, connected, logged, etc"
Public field | string_msg | A message describing the new state

See Also

StateChangeEventArgs Class


state Field

[image]

AMIgo Controls documentation
StateChangeEventArgs..::..state Field
StateChangeEventArgs Class See Also Send Feedback
The AMI client state. Ex: "Idle, connected, logged, etc"

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public AMI_Client..::..AMI_ClientState state
Visual Basic
Public state As AMI_Client..::..AMI_ClientState
Visual C++
public:
AMI_Client..::..AMI_ClientState state

See Also

StateChangeEventArgs Class


string_msg Field

[image]

AMIgo Controls documentation
StateChangeEventArgs..::..string_msg Field
StateChangeEventArgs Class See Also Send Feedback
A message describing the new state

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string string_msg
Visual Basic
Public string_msg As String
Visual C++
public:
String^ string_msg

See Also

StateChangeEventArgs Class


StateChangeEventHandler Delegate

[image]

AMIgo Controls documentation
StateChangeEventHandler Delegate
See Also Send Feedback
delegate for the StateChange Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void StateChangeEventHandler(
    Object sender,
    StateChangeEventArgs ev
)
Visual Basic
Public Delegate Sub StateChangeEventHandler ( _
    sender As Object, _
    ev As StateChangeEventArgs _
)
Visual C++
public delegate void StateChangeEventHandler(
    Object^ sender,
    StateChangeEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StateChangeEventArgs
The StateChangeEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


StatusEventHandler Delegate

[image]

AMIgo Controls documentation
StatusEventHandler Delegate
See Also Send Feedback
delegate for the Status Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void StatusEventHandler(
    Object sender,
    StringMsgEventArgs ev
)
Visual Basic
Public Delegate Sub StatusEventHandler ( _
    sender As Object, _
    ev As StringMsgEventArgs _
)
Visual C++
public delegate void StatusEventHandler(
    Object^ sender,
    StringMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..StringMsgEventArgs
The StringMsgEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


StringMsgEventArgs Class

[image]

AMIgo Controls documentation
StringMsgEventArgs Class
Members See Also Send Feedback
Customs EventArgs for a few events

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class StringMsgEventArgs : EventArgs
Visual Basic
Public Class StringMsgEventArgs _
    Inherits EventArgs
Visual C++
public ref class StringMsgEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..StringMsgEventArgs

See Also

StringMsgEventArgs Members


StringMsgEventArgs Members

[image] [image]

AMIgo Controls documentation
StringMsgEventArgs Members
StringMsgEventArgs Class Constructors Fields See Also Send Feedback

The StringMsgEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StringMsgEventArgs | Initializes a new instance of the StringMsgEventArgs class.

Fields

 | Name | Description
Public field | string_msg | The status messge

See Also

StringMsgEventArgs Class


StringMsgEventArgs Constructor

[image]

AMIgo Controls documentation
StringMsgEventArgs Constructor
StringMsgEventArgs Class See Also Send Feedback
Initializes a new instance of the StringMsgEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public StringMsgEventArgs(
    string StatusMsg
)
Visual Basic
Public Sub New ( _
    StatusMsg As String _
)
Visual C++
public:
StringMsgEventArgs(
    String^ StatusMsg
)

Parameters

StatusMsg
Type: System..::..String
The status MSG.

See Also

StringMsgEventArgs Class


StringMsgEventArgs Fields

[image] [image]

AMIgo Controls documentation
StringMsgEventArgs Fields
StringMsgEventArgs Class See Also Send Feedback

The StringMsgEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | string_msg | The status messge

See Also

StringMsgEventArgs Class


string_msg Field

[image]

AMIgo Controls documentation
StringMsgEventArgs..::..string_msg Field
StringMsgEventArgs Class See Also Send Feedback
The status messge

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public string string_msg
Visual Basic
Public string_msg As String
Visual C++
public:
String^ string_msg

See Also

StringMsgEventArgs Class


SyncList(T) Class

[image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Class
Members See Also Send Feedback
A 'synchronized' descendant of BindingList used to insure that ListView and other UI AMIgo objects are updated from the Main application's thread.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class SyncList<T> : BindingList<T>
Visual Basic
Public Class SyncList(Of T) _
    Inherits BindingList(Of T)
Visual C++
generic<typename T>
public ref class SyncList : public BindingList<T>

Type Parameters

T
The list item type

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
System.ComponentModel..::..BindingList <(Of <(<'T>)>)>
AMIgo..::..SyncList<(Of <(<'T>)>)>

See Also

SyncList<(Of <(<'T>)>)> Members


SyncList(T) Members

[image] [image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Members
SyncList<(Of <(<'T>)>)> Class Constructors Methods Fields See Also Send Feedback

The SyncList<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SyncList<(Of <(<'T>)>)>()()()() | Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.
Public method | SyncList<(Of <(<'T>)>)>(ISynchronizeInvoke) | Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Protected method | OnListChanged | Raises the ListChangedEventArgs event. (Overrides BindingList<(Of <(<'T>)>)>..::..OnListChanged(ListChangedEventArgs).)

Fields

 | Name | Description
Public field | _SyncObject | The object on which to synchronize the events. Usually the main form.

See Also

SyncList<(Of <(<'T>)>)> Class


SyncList(T) Constructor

[image] [image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Constructor
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyncList<(Of <(<'T>)>)>()()()() | Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.
Public method | SyncList<(Of <(<'T>)>)>(ISynchronizeInvoke) | Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.

See Also

SyncList<(Of <(<'T>)>)> Class
SyncList<(Of <(<'T>)>)> Members


SyncList(T) Constructor

[image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Constructor
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList()
Visual Basic
Public Sub New
Visual C++
public:
SyncList()

See Also

SyncList<(Of <(<'T>)>)> Class
SyncList<(Of <(<'T>)>)> Overload


SyncList(T) Constructor (ISynchronizeInvoke)

[image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Constructor (ISynchronizeInvoke)
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SyncList<(Of <(<'T>)>)> class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public SyncList(
    ISynchronizeInvoke syncObject
)
Visual Basic
Public Sub New ( _
    syncObject As ISynchronizeInvoke _
)
Visual C++
public:
SyncList(
    ISynchronizeInvoke^ syncObject
)

Parameters

syncObject
Type: System.ComponentModel..::..ISynchronizeInvoke
The sync object.

See Also

SyncList<(Of <(<'T>)>)> Class
SyncList<(Of <(<'T>)>)> Overload


SyncList(T) Fields

[image] [image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Fields
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback

The SyncList<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Public field | _SyncObject | The object on which to synchronize the events. Usually the main form.

See Also

SyncList<(Of <(<'T>)>)> Class


_SyncObject Field

[image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)>..::.._SyncObject Field
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback
The object on which to synchronize the events. Usually the main form.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public ISynchronizeInvoke _SyncObject
Visual Basic
Public _SyncObject As ISynchronizeInvoke
Visual C++
public:
ISynchronizeInvoke^ _SyncObject

See Also

SyncList<(Of <(<'T>)>)> Class


SyncList(T) Methods

[image] [image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)> Methods
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback

The SyncList<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | OnListChanged | Raises the ListChangedEventArgs event. (Overrides BindingList<(Of <(<'T>)>)>..::..OnListChanged(ListChangedEventArgs).)

See Also

SyncList<(Of <(<'T>)>)> Class


OnListChanged Method

[image]

AMIgo Controls documentation
SyncList<(Of <(<'T>)>)>..::..OnListChanged Method
SyncList<(Of <(<'T>)>)> Class See Also Send Feedback
Raises the ListChangedEventArgs event.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs args
)
Visual Basic
Protected Overrides Sub OnListChanged ( _
    args As ListChangedEventArgs _
)
Visual C++
protected:
virtual void OnListChanged(
    ListChangedEventArgs^ args
) override

Parameters

args
Type: System.ComponentModel..::..ListChangedEventArgs
The ListChangedEventArgs instance containing the event data.

See Also

SyncList<(Of <(<'T>)>)> Class


TransferEventHandler Delegate

[image]

AMIgo Controls documentation
TransferEventHandler Delegate
See Also Send Feedback
delegate for the Transfer Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void TransferEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Delegate Sub TransferEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public delegate void TransferEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


UserEventHandler Delegate

[image]

AMIgo Controls documentation
UserEventHandler Delegate
See Also Send Feedback
delegate for the User Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void UserEventHandler(
    Object sender,
    RawMngrMsgEventArgs ev
)
Visual Basic
Public Delegate Sub UserEventHandler ( _
    sender As Object, _
    ev As RawMngrMsgEventArgs _
)
Visual C++
public delegate void UserEventHandler(
    Object^ sender,
    RawMngrMsgEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..RawMngrMsgEventArgs
The RawMngrMsgEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


VersionEventArgs Class

[image]

AMIgo Controls documentation
VersionEventArgs Class
Members See Also Send Feedback
Custom EventArgs used for VersionEvent

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class VersionEventArgs : EventArgs
Visual Basic
Public Class VersionEventArgs _
    Inherits EventArgs
Visual C++
public ref class VersionEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..VersionEventArgs

See Also

VersionEventArgs Members


VersionEventArgs Members

[image] [image]

AMIgo Controls documentation
VersionEventArgs Members
VersionEventArgs Class Constructors Fields See Also Send Feedback

The VersionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VersionEventArgs | Initializes a new instance of the VersionEventArgs class.

Fields

 | Name | Description
Public field | _version | A Version object that contains the currently connected system version
Public field | _versionMajor | The Major Version. Ex: 1
Public field | _versionMinor | The Minor Version. Ex: 4

See Also

VersionEventArgs Class


VersionEventArgs Constructor

[image]

AMIgo Controls documentation
VersionEventArgs Constructor
VersionEventArgs Class See Also Send Feedback
Initializes a new instance of the VersionEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public VersionEventArgs(
    Version AsteriskVersion,
    int VersionMajor,
    int VersionMinor
)
Visual Basic
Public Sub New ( _
    AsteriskVersion As Version, _
    VersionMajor As Integer, _
    VersionMinor As Integer _
)
Visual C++
public:
VersionEventArgs(
    Version^ AsteriskVersion,
    int VersionMajor,
    int VersionMinor
)

Parameters

AsteriskVersion
Type: System..::..Version
The asterisk version.
VersionMajor
Type: System..::..Int32
The Major version number
VersionMinor
Type: System..::..Int32
The Minor version number

See Also

VersionEventArgs Class


VersionEventArgs Fields

[image] [image]

AMIgo Controls documentation
VersionEventArgs Fields
VersionEventArgs Class See Also Send Feedback

The VersionEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | _version | A Version object that contains the currently connected system version
Public field | _versionMajor | The Major Version. Ex: 1
Public field | _versionMinor | The Minor Version. Ex: 4

See Also

VersionEventArgs Class


_version Field

[image]

AMIgo Controls documentation
VersionEventArgs..::.._version Field
VersionEventArgs Class See Also Send Feedback
A Version object that contains the currently connected system version

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public Version _version
Visual Basic
Public _version As Version
Visual C++
public:
Version^ _version

See Also

VersionEventArgs Class


_versionMajor Field

[image]

AMIgo Controls documentation
VersionEventArgs..::.._versionMajor Field
VersionEventArgs Class See Also Send Feedback
The Major Version. Ex: 1

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int _versionMajor
Visual Basic
Public _versionMajor As Integer
Visual C++
public:
int _versionMajor

See Also

VersionEventArgs Class


_versionMinor Field

[image]

AMIgo Controls documentation
VersionEventArgs..::.._versionMinor Field
VersionEventArgs Class See Also Send Feedback
The Minor Version. Ex: 4

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public int _versionMinor
Visual Basic
Public _versionMinor As Integer
Visual C++
public:
int _versionMinor

See Also

VersionEventArgs Class


VersionEventHandler Delegate

[image]

AMIgo Controls documentation
VersionEventHandler Delegate
See Also Send Feedback
delegate for the Version Event Handler

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public delegate void VersionEventHandler(
    Object sender,
    VersionEventArgs ev
)
Visual Basic
Public Delegate Sub VersionEventHandler ( _
    sender As Object, _
    ev As VersionEventArgs _
)
Visual C++
public delegate void VersionEventHandler(
    Object^ sender,
    VersionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
The sender.
ev
Type: AMIgo..::..VersionEventArgs
The VersionEventArgs instance containing the event data.

See Also

AMIgo Namespace

Send comments on this topic to AMIgo@teledata.qc.ca

Copyright © 2010-2011, Noël Bouchard, TELE DATA Inc., All rights reserved


VisibleChangeEventArgs Class

[image]

AMIgo Controls documentation
VisibleChangeEventArgs Class
Members See Also Send Feedback
A custom EventArgs to use for the Hide Event

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public class VisibleChangeEventArgs : EventArgs
Visual Basic
Public Class VisibleChangeEventArgs _
    Inherits EventArgs
Visual C++
public ref class VisibleChangeEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
AMIgo..::..VisibleChangeEventArgs

See Also

VisibleChangeEventArgs Members


VisibleChangeEventArgs Members

[image] [image]

AMIgo Controls documentation
VisibleChangeEventArgs Members
VisibleChangeEventArgs Class Constructors Fields See Also Send Feedback

The VisibleChangeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VisibleChangeEventArgs | Initializes a new instance of the VisibleChangeEventArgs class.

Fields

 | Name | Description
Public field | Show | Command panel visible status

See Also

VisibleChangeEventArgs Class


VisibleChangeEventArgs Constructor

[image]

AMIgo Controls documentation
VisibleChangeEventArgs Constructor
VisibleChangeEventArgs Class See Also Send Feedback
Initializes a new instance of the VisibleChangeEventArgs class.

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public VisibleChangeEventArgs(
    bool doShow
)
Visual Basic
Public Sub New ( _
    doShow As Boolean _
)
Visual C++
public:
VisibleChangeEventArgs(
    bool doShow
)

Parameters

doShow
Type: System..::..Boolean
if set to true [do show].

See Also

VisibleChangeEventArgs Class


VisibleChangeEventArgs Fields

[image] [image]

AMIgo Controls documentation
VisibleChangeEventArgs Fields
VisibleChangeEventArgs Class See Also Send Feedback

The VisibleChangeEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Show | Command panel visible status

See Also

VisibleChangeEventArgs Class


Show Field

[image]

AMIgo Controls documentation
VisibleChangeEventArgs..::..Show Field
VisibleChangeEventArgs Class See Also Send Feedback
Command panel visible status

Namespace: AMIgo
Assembly: AMIgo (in AMIgo.dll) Version: 1.1.0.1 (1.1.0.1)

Syntax

C#
public bool Show
Visual Basic
Public Show As Boolean
Visual C++
public:
bool Show

See Also

VisibleChangeEventArgs Class